<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1338871095817&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2017/1/27/stuff-the-internet-says-on-scalability-for-january-27th-2017.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://five.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Stuff The Internet Says On Scalability For January 27th,&nbsp;2017 - High Scalability - </title>
    <meta property="og:title" content="Stuff The Internet Says On Scalability For January 27th,&nbsp;2017 - High Scalability - " /> 
  

      <meta property="og:description" content=" Hey, it's HighScalability time:

 
  

 
 Tired of noisy drones? Use the same dedrone tech used at..." />
  

  
      <meta property="og:image" content="https://c1.staticflickr.com/1/471/31638966454_9fce8f0000_o.jpg" />
  

  <!-- End Heading -->

  <script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1044643/SS_HS_Ad1', [125, 125], 'div-gpt-ad-1325175098795-0').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad10', [125, 125], 'div-gpt-ad-1325175098795-1').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad11', [125, 125], 'div-gpt-ad-1325175098795-2').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad12', [125, 125], 'div-gpt-ad-1325175098795-3').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad13', [125, 125], 'div-gpt-ad-1325175098795-4').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad14', [125, 125], 'div-gpt-ad-1325175098795-5').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad15', [125, 125], 'div-gpt-ad-1325175098795-6').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad16', [125, 125], 'div-gpt-ad-1325175098795-7').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad17', [125, 125], 'div-gpt-ad-1325175098795-8').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad2', [125, 125], 'div-gpt-ad-1325175098795-9').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad3', [125, 125], 'div-gpt-ad-1325175098795-10').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad4', [125, 125], 'div-gpt-ad-1325175098795-11').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad5', [125, 125], 'div-gpt-ad-1325175098795-12').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad6', [125, 125], 'div-gpt-ad-1325175098795-13').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_ad7', [125, 125], 'div-gpt-ad-1325175098795-14').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad8', [125, 125], 'div-gpt-ad-1325175098795-15').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad9', [125, 125], 'div-gpt-ad-1325175098795-16').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad18', [125, 125], 'div-gpt-ad-1325175098795-17').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad19', [125, 125], 'div-gpt-ad-1325175098795-18').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad20', [125, 125], 'div-gpt-ad-1325175098795-19').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>


  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId35849532"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2017%2F1%2F27%2Fstuff-the-internet-says-on-scalability-for-january-27th-2017.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2017/1/27/stuff-the-internet-says-on-scalability-for-january-27th-2017.html">Stuff The Internet Says On Scalability For January 27th, 2017</a></li>  <li><a href="/blog/2017/1/23/master-master-replication-and-scaling-of-an-application-betw.html">Master-Master Replication and Scaling of an Application between Each of the IoT Devices and the Cloud</a></li>  <li><a href="/blog/2017/1/20/stuff-the-internet-says-on-scalability-for-january-20th-2017.html">Stuff The Internet Says On Scalability For January 20th, 2017</a></li>  <li><a href="/blog/2017/1/17/sponsored-post-contentful-stream-loupe-new-york-times-scalyr.html">Sponsored Post: Contentful, Stream, Loupe, New York Times, Scalyr, VividCortex, MemSQL, InMemory.Net, Zohocorp</a></li>  <li><a href="/blog/2017/1/17/wouldnt-it-be-nice-if-everyone-knew-a-little-queuing-theory.html">Wouldn't it be nice if everyone knew a little queuing theory?</a></li>  <li><a href="/blog/2017/1/13/stuff-the-internet-says-on-scalability-for-january-13th-2017.html">Stuff The Internet Says On Scalability For January 13th, 2017</a></li>  <li><a href="/blog/2017/1/6/stuff-the-internet-says-on-scalability-for-january-6th-2017.html">Stuff The Internet Says On Scalability For January 6th, 2017</a></li>  <li><a href="/blog/2017/1/4/how-is-writing-lord-of-the-rings-like-writing-software.html">How is Writing Lord of the Rings Like Writing Software?</a></li>  <li><a href="/blog/2017/1/3/sponsored-post-loupe-new-york-times-scalearc-aerospike-scaly.html">Sponsored Post: Loupe, New York Times, ScaleArc, Aerospike, Scalyr, VividCortex, MemSQL, InMemory.Net, Zohocorp</a></li>  <li><a href="/blog/2017/1/2/efficient-storage-how-we-went-down-from-50-pb-to-32-pb.html">Efficient storage: how we went down from 50 PB to 32 PB</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <CENTER>
  <!-- SS_HS_Ad1 -->
  <div id='div-gpt-ad-1325175098795-0' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-0'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad10 -->
  <div id='div-gpt-ad-1325175098795-1' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-1'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad11 -->
  <div id='div-gpt-ad-1325175098795-2' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-2'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad12 -->
  <div id='div-gpt-ad-1325175098795-3' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-3'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad13 -->
  <div id='div-gpt-ad-1325175098795-4' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-4'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad14 -->
  <div id='div-gpt-ad-1325175098795-5' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-5'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad15 -->
  <div id='div-gpt-ad-1325175098795-6' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-6'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad16 
  <div id='div-gpt-ad-1325175098795-7' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-7'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad17 
  <div id='div-gpt-ad-1325175098795-8' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-8'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad2 
  <div id='div-gpt-ad-1325175098795-9' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-9'); });
  </script>
  </div>
  -->
  
  </CENTER>
  
  <center><a href="/advertising">advertise</A></center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2017%2F1%2F27%2Fstuff-the-internet-says-on-scalability-for-january-27th-2017.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178453">

    <div id="moduleContent15178453">

              <a id="moduleLink15178453" class=" " href="http://highscalability.com/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870172">

    <div id="moduleContent4870172">

              <a id="moduleLink4870172" class=" " href="http://highscalability.squarespace.com/blog/category/product" ><span>Useful Products</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870194">

    <div id="moduleContent4870194">

              <a id="moduleLink4870194" class=" " href="http://highscalability.squarespace.com/blog/category/paper" ><span>Useful Papers</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870201">

    <div id="moduleContent4870201">

              <a id="moduleLink4870201" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Useful Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4885586">

    <div id="moduleContent4885586">

              <a id="moduleLink4885586" class=" " href="/blog/category/blog" ><span>Useful Blogs</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4920227">

    <div id="moduleContent4920227">

              <a id="moduleLink4920227" class=" " href="http://highscalability.com/blog/category/book" ><span>Useful Books</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper12001611">

    <div id="moduleContent12001611">

              <a id="moduleLink12001611" class=" " href="http://highscalability.com/blog/2011/9/14/big-list-of-scalabilty-conferences.html" ><span>Useful Conferences</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4878991">

    <div id="moduleContent4878991">

              <a id="moduleLink4878991" class="offsite-link " href="http://astore.amazon.com/possiboutpos-20" onclick="this.target='new';"><span>Book Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2017/1/23/master-master-replication-and-scaling-of-an-application-betw.html">Master-Master Replication and Scaling of an Application between Each of the IoT Devices and the Cloud &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability category-hot-links">
<div id="item35849532" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Friday</span></div><div class="journal-entry-float-date"><span class="month">Jan</span><span class="date">27</span><span class="year">2017</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2017/1/27/stuff-the-internet-says-on-scalability-for-january-27th-2017.html">Stuff The Internet Says On Scalability For January 27th,&nbsp;2017</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Friday, January 27, 2017 at 8:56AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p>Hey, it's HighScalability time:</p>
<div align="center"><img src="https://c1.staticflickr.com/1/471/31638966454_9fce8f0000_o.jpg" alt="" />
<p>&nbsp;</p>
</div>
<div align="center">Tired of noisy drones? Use the same <a href="http://www.dedrone.com/en/">dedrone</a> tech used at Davos. It's the future.</div>
<div align="center"><br /><span style="text-align: start;">If you like this sort of&nbsp;</span><em>Stuff </em><span style="text-align: start;">then please support me&nbsp;</span><a style="text-align: start;" href="https://www.patreon.com/toddhoff">on Patreon</a><span style="text-align: start;">.</span></div>
<div align="center"><span style="text-align: start;"><br /></span></div>
<ul>
<li><a href="https://blog.twitter.com/2017/the-infrastructure-behind-twitter-scale">1+ trillion</a>: messages Twitter handles per day;&nbsp;<a href="https://twitter.com/BenedictEvans/status/823349823084445696">695 million</a>: Internet users in China;&nbsp;<a href="https://arxiv.org/pdf/1701.02405v1.pdf">&gt;350k</a>: Twitter Star Wars bots; <a href="https://www.nimbushosting.co.uk/most-expensive-domains/">$90 million</a>: value of LasVegas.com domain name; <a href="https://arxiv.org/pdf/1701.02528v2.pdf">45%</a>: WiFi connection failure rate; <a href="https://twitter.com/viktorklang/status/823671445578481664">80</a>: threads in Slack Mac OS app; <a href="http://www.slideshare.net/adriancockcroft/microservices-workshop-all-topics-deck-2016">364</a>: slides in Adrian Cockcroft's microservices deck;&nbsp;<a href="https://codeascraft.com/2017/01/25/optimizing-meta-descriptions-h1s-and-title-tags-lessons-from-multivariate-seo-testing-at-etsy/">5180%</a>: increases at Etsy in daily visits to pages related to Donald Trump;&nbsp;<a href="http://www.businessinsider.com/walmart-dives-into-the-car-business-2017-1">465,000</a>: cars sold by Costco last year;&nbsp;<a href="https://www.searchenginejournal.com/duckduckgo-hits-milestone-14-million-searches-single-day/184179/">14 Million</a>: one day of DuckDuckGo searches; <a href="http://sci-hub.cc/">58 million</a>: science papers online; <a href="https://www.cncf.io/blog/2017/01/17/container-management-trends-kubernetes-moves-testing-production">~3x</a>: use of Kubernetes in production settings; <a href="https://redditblog.com/2017/01/17/caching-at-reddit/">54</a>: r3.2xlarge instances used for Reddit caching;&nbsp;<a href="http://www.recode.net/2017/1/26/14402736/microsoft-earnings-azure-cloud-business-almost-doubled">$14 billion</a>: Microsoft&rsquo;s Azure's annual run rate;&nbsp;</li>
<br />
<li>Quotable Quotes:                                                      
<ul>
<li><a href="https://www.edge.org/response-detail/27074">Carlo Rovelli</a>:&nbsp;the basic ingredient is down there in the physical world: physical correlation between distinct variables. The physical world is not a set of self-absorbed entities that do their selfish things. It is a tightly knitted net of relative information, where everybody&rsquo;s state reflects somebody else&rsquo;s state.&nbsp;</li>
<li><a href="https://kindle.amazon.com/work/empire-games-charles-stross-ebook/B01HMO4G5Q/B01HMMYSOW">Charles Stross</a>: There&rsquo;s a saying that goes something like this: &ldquo;Lieutenants study tactics, colonels study strategy, generals study logistics, and field marshals study economics.&rdquo; But economists&mdash;the smart ones&mdash;study education.</li>
<li><a href="https://groups.google.com/d/msg/mechanical-sympathy/QccsH00a-T8/wkkNzAbdFAAJ">Kirk Pepperdine</a>: I would suggest that with 200 JVMs running on 80 core you should consider using the serial collector.</li>
<li><a href="https://twitter.com/alicegoldfuss/status/824436616802373632">@alicegoldfuss</a>: Things containers improve: - testing - deploying Things containers shit on: - security - troubleshooting - managing systems resources &nbsp;<em>Note:&nbsp;this is a long thread of comments, enjoy!</em></li>
<li><a href="https://twitter.com/pewinternet/status/823489464668450816">@pewinternet</a>:&nbsp;In 2005, just 5% of Americans used at least one social media platform. Today, 69% do.&nbsp;</li>
<li><a href="http://www.newyorker.com/tech/elements/why-peter-thiel-fears-star-trek">Manu Saadia</a>: He [Peter Thiel] was a bigger fan of &ldquo;Star Wars&rdquo; or &ldquo;Star Trek,&rdquo; Thiel replied that, as a capitalist, he preferred the former. &ldquo; &lsquo;Star Trek&rsquo; is the communist one,&rdquo; he said. &ldquo;The whole plot of &lsquo;Star Wars&rsquo; starts with Han Solo having this debt that he owes, and so the plot in &lsquo;Star Wars&rsquo; is driven by money.</li>
<li><a href="https://twitter.com/asymco/status/824747120381026305">@asymco</a>:&nbsp;Google's costs-per-click &mdash; essentially its pricing &mdash; fell 16% y/y</li>
<li><a href="https://www.fastly.com/blog/service-workers-pwas-and-whats-next-for-mobile">Anna MacLachlan</a>: In order to follow best practices for performance when building PWAs [progressive web app] and otherwise, the Chrome team goes by the Rail performance model: Respond: 100ms / Animate: &lt; 8ms / Idle work in 50ms chunks / Load: 1,000ms to interactive</li>
<li><a href="https://www.nextplatform.com/2017/01/22/aws-details-fpga-rationale-market-trajectory/">Deepak Singh (AWS)</a>: There is a certain scale where specialized hardware and infrastructure make a lot of sense and for those who need special infrastructure, we think FPGAs are one clear way to go</li>
<li><a href="https://twitter.com/MarcWilczek/status/823290428220993536">@MarcWilczek</a>:&nbsp;Containerization: 19% using it, 15% testing it, 13% considering it; 15% are curious, 38% have no plans or clue.&nbsp;#Cloud #CIO @interop #Docker</li>
<li><a href="http://readwrite.com/2017/01/22/end-of-net-neutrality-demise-of-iot-il1/">Clarke Illmatical</a>: The death of net neutrality will severely impact IoT solutions which rely on an open internet concept.</li>
<li><a href="https://twitter.com/mipearson/status/351539310199189505">@mipearson</a>:&nbsp;OH "I'm the Technical Debt Fairy. If you leave technical debt under your pillowcase at night I hire away your best developers"</li>
<li><a href="https://redditblog.com/2017/01/17/caching-at-reddit/">Reddit</a>:&nbsp;&nbsp;When you vote, your vote isn&rsquo;t instantly processed&mdash;instead, it&rsquo;s placed into a queue. Depending on the backlog of the queue, this can mean if you were to vote and quickly refresh the page, your vote may not have been processed yet, and it would appear that your vote had been reverted.&nbsp;</li>
<li><a href="http://martin.kleppmann.com/2017/01/26/data-loss-in-large-clusters.html">Martin Kleppmann</a>: in a 8,000-node cluster, the chance of permanently losing all three replicas of some piece of data (within the same time period) is about 0.2%. Yes, you read that correctly: the risk of losing all three copies of some data is twice as great as the risk of losing a single node!</li>
<li><a href="https://www.soasta.com/blog/2016-holiday-traffic-trends/">Tammy Everts</a>: Always remember that if you&rsquo;re competing online, you&rsquo;re competing with Amazon.</li>
<li><a href="http://atp.fm/episodes/206">Marco Arment</a>: I'm no spending more on [Apple] search ads than I am servers.</li>
<li><a href="https://news.ycombinator.com/item?id=13465329">dijit</a>: the big issue with databases I've worked with is not how many inserts you do per second, even spinning rust, if properly reasoned can do -serious- inserts per second in append only data structures like myisam, redis even lucene. However the issue comes when you want to read that data or, more horribly, update that data. Updates, by definition are a read and a write to commuted data, this can cause fragmentation and other huge headaches. I'd love to see someone do updates 1,000,000/s</li>
<li><a href="https://twitter.com/m0biusloop/status/824619497113972736">@m0biusloop</a>:&nbsp;things kubernetes can't do: ipv6, multiple host networks, prefix based policy, egress policy.</li>
<li><a href="http://www.bbc.com/news/technology-38724082">Dr Zhou</a>: What is really surprising is our questioning on the whole effort of bot detection in the past years. Suddenly we feel vulnerable and don't know much: how many more are there? What do they want to do?</li>
<li><a href="http://thenewstack.io/happens-use-java-1960-ibm-mainframe/">Marianne Bellotti</a>: 15 years ago, everybody was telling us &lsquo;Get off the mainframe, get on AT&amp;T applications, build these thick clients. Mainframes are out.&rsquo; And now thick clients are out, and everybody&rsquo;s moving to APIs and microservices, which basically are very similar to the thin client that a terminal uses to interact with a mainframe.</li>
<li><a href="https://twitter.com/garybernhardt/status/600783770925420546">@garybernhardt</a>: Consulting service: you bring your big data problems to me, I say "your data set fits in RAM", you pay me $10,000 for saving you $500,000.</li>
<li><a href="https://twitter.com/jennschenker/status/820583525640441861">@jennschenker</a>: #DLD17: BMW says it will evolve from being a car maker to a mobility services company.</li>
<li><a href="https://scaleyourcode.com/interviews/interview/31">Nick Craver (StackOverflow)</a>:&nbsp;We try to be boring. Boring is stable ...scalable. The simpler something is, the higher it scales...We are not against anything. We have loyalty to nothing. If there's a better option that comes along, move to it!</li>
<li><a href="http://www.businessinsider.com/new-organisms-engineered-using-first-ever-6-letter-genetic-code-2017-1">Romesberg</a>: evolution works by starting with something close, and then changing what it can do in small steps</li>
<li><a href="https://news.ycombinator.com/item?id=13439225">bitwiseand</a>:&nbsp;The CAP theorem states that in the event of a network-partition you have to choose one of C or A. More intuitively, any delay between nodes can be modeled as a temporary network partition and in that event you have but two choices either wait to return the latest data at a peer node (C) or return the last available data at a peer node (A).</li>
<li><a href="https://www.reddit.com/r/programming/comments/5puz6g/everything_should_be_microservice/dcu29yt/">Gvaireth</a>:&nbsp;We just had a discussion in the team, and we decided, that we need add-one microservice that would get a number and return the number increased by one. A nice separation of concerns in modern distributed web application :)</li>
<li><a href="https://research.swtch.com/go2017">Russ Cox</a>:&nbsp;When I first started thinking about generics for Go in 2008, the main examples to learn from were C#, Java, Haskell, and ML. None of the approaches in those languages seemed like a perfect fit for Go. Today, there are newer attempts to learn from as well, including Dart, Midori, Rust, and Swift.</li>
<li><a href="https://www.reddit.com/r/programming/comments/5q21ng/paas_false_economics/dcwbr04/">RaptorXP</a>:&nbsp;Do your virtual reality wearables usually connect to deep learning drones on the blockchain?</li>
<li><a href="https://blog.twitter.com/2017/the-infrastructure-behind-twitter-scale">Twitter</a>:&nbsp;Hadoop: We have multiple clusters storing over 500 PB divided in four groups (real time, processing, data warehouse and cold storage). Our biggest cluster is over 10k nodes. We run 150k applications and launch 130M containers per day.</li>
<li><a href="https://news.ycombinator.com/item?id=13426381">arnon</a>:&nbsp;GPUs tend to lend themselves well to analytics, contrary to transactions. Specifically, columnar databases. When the columns are all of the same data type, and the data locality is high, GPUs perform /very/ well.</li>
<li><a href="http://www.beyondvc.com/2017/01/thoughts-on-saas-in-2017.html">Ed Sim</a>:&nbsp;Despite the amazing productivity gains from open source, AWS, microservices and other new technologies, we have seen the time to launch extending and the cost of getting a minimally viable product (MVP) out the door increasing.</li>
<li><a href="https://danielmiessler.com/blog/google-amp-not-good-thing">Daniel Miessler</a>: It&rsquo;s&nbsp;[AMP]&nbsp;poisonous to the underlying concept of an open internet. If this were to become widely adopted, you&rsquo;d search for something, get results, consume the content, and you&rsquo;d never leave Google.</li>
</ul>
</li>
<br />
<li>
<div id="_mcePaste">Great detailed discussion on all things serverless.&nbsp;<a href="https://soundcloud.com/amazon-web-services-306355661/171-serverless-special">AWS Podcast&nbsp;#171: Serverless Special</a>. Serverless is an implementation detail, not an architectural pattern. If you look at serverless as just a way to run existing code then it&rsquo;s an implementation detail. &nbsp;If you take it as an opportunity to think about how your application could be structured then it tends more towards the architectural pattern/microservices conversation; Serverless as a concept is a spectrum not binary. Serverless is an important concept but the boundaries are not clear. Example is compare Redshift and BigQuery. Redshift you have to specify a cluster size and with BigQuery you don&rsquo;t, so BigQuery is more serverless; The more serverless you go the harder it is to inject errors in like with Chaos Monkey; There&rsquo;s no best way to do end-to-end testing in serverless environments;&nbsp;There are two ways things can be serverless: Software as a Services and Functions as a Service. FaaS is often thought of being Serverless itself. FaaS only exists because there&rsquo;s isn&rsquo;t SaaS yet that does your business logic; Easy to get something something done quickly with Serverless, but people underestimate how hard it is to get a large team working on a project with a lot of functions. Serveless gets rid of heavy lifting on instracture side but there&rsquo;s more complexity on the operational side when working with a team;&nbsp;What is the model where a team of developers working together on a logical unit uses a larger pipeline to deliver business functionality? Where do we have visibility as to what&rsquo;s going on? How to go to from development to production? What is the pipeline where developers have their own serverless cluster then it goes to master then we have unit tests the integration tests, load tests, amd canary tests?; Serverless doesn&rsquo;t mean noops. It is lessops. The tradeoff is observability; With Serverless it's easy to get something up and running, but the unit of deployment is not the unit of design. You get serverless sprawl. Pain is conserved, it just moves elsewhere. You are still writing a distributed system.</div>
</li>
<br />
<li>Information wants to be free.&nbsp;<a href="http://sci-hub.cc/">Sci-Hub</a>&nbsp;the first pirate website in the world to provide mass and public access to tens of millions of research papers.</li>
<br />
<li>Nick Craver in an excellent interview&nbsp;<a href="https://scaleyourcode.com/interviews/interview/31">on ScaleYourCode </a>talks about many things, including how StackOverflow works:&nbsp;Primarily, it's a Lisp stack. It's Windows IES SQL .NET code, mostly C# for our programs...We're using HAProxy without exotic configs...&nbsp;We have Elasticsearch for our search on the background running on Linux 3 node cluster...With SQL, there is a primary server for Stack Overflow and a primary server for everything else on the network...There are nine web servers running production. We can run on one...behind that are three service boxes running...<strong>One of the cool things we might be doing on those is buying new ones and sticking GPUs in them...With a GPU, you can take a simple task and put it across thousands of cores, it's an excellent use case.</strong> That is the greatest use case...With the GTX 1080s which have 8GB of RAM on them now ( the old ones were 4), we can take a consumer graphics card for $700 and make a Tag engine 10 to 20 times faster than our CPU rewrite...The simplest thing is to grab something that pre exists and plug it in. A lot of people try to build it the first time. Don't do that. Take an existing tool and learn from it if nothing else for a day, or a week.</li>
<br />
<li>Around and around it goes. Where will it stop? Nobody knows.&nbsp;<a href="https://movio.co/blog/migrate-Scala-to-Go/">Making the move from Scala to Go, and why we&rsquo;re not going back</a>. Why was the bloom off the Scala rose?: slow compilation; slow deployments; poor IDE support; object oriented programming sucks; the future of the language is uncertain; it takes too long to learn. Why all the Go love?: simple to learn; simpler more readable code; channels and goroutines make programming easier; compiles fast; runs fast; code is small; Go microservices are a great fit for distributed systems; good tooling.</li>
<br />
<li><a href="https://blog.twitter.com/2017/the-infrastructure-behind-twitter-scale">The Infrastructure Behind Twitter: Scale</a>. Twitter is a complex beast. Too much to summarize. They cover Network Traffic, Data Center Traffic, Backbone Traffic, Edge Traffic, Storage, Cache, Running Puppet at Scale, Branching, and Monitoring. So there's something for everyone. Good <a href="https://news.ycombinator.com/item?id=13441932">discussion on HN</a> on why Twitter is different than WhatsApp (hint: fanout).</li>
<br />
<li>You know Moore's Law is deadish. Here's interesting reasoning as to why cloud computing is more compatible with the future technologies that will help keep Moore's Law a law.&nbsp;<a href="https://www.theguardian.com/technology/2017/jan/26/vanishing-point-rise-invisible-computer?CMP=Share_iOSApp_Other">Vanishing point: the rise of the invisible computer</a>.&nbsp;Quantum computing and&nbsp;3D chips, two projected next gen technologies, &nbsp;require&nbsp;specialised care and feeding, so the cloud is the perfect zoo for keeping the future sources of compute cycles up and running.</li>
<br />
<li>Some free events that might be of interest:&nbsp;                                 
<ul>
<li><a href="https://www.microservices.com/livestream/">Microservices.com Practitioner Summit livestream</a> in on Jan 31 in the great country of San Francisco.&nbsp;</li>
<li>There's a&nbsp;<a href="https://www.meetup.com/golangsf/events/236673793/">Go v1.8 Release Party &ndash; Thurs, Feb 16th</a>.&nbsp;Talk 1: Go and IronFunctions.&nbsp;Talk 2: Go Context Package.</li>
</ul>
</li>
<br />
<li>Tradeoffs are destiny.&nbsp;<a href="https://www.relay.fm/upgrade/125">Upgrade #125</a>. Concrete example of why Apple's privacy first approach of processing data on device makes the whole personal assistant thing a lot harder when compared to Google's cloud based processing approach. Example is populating calendar from events found in email and suggesting names, addressees and phone numbers. Apple only processes email when it's actually downloaded to the inbox of the mail app on your device. So&nbsp;it doesn't happen&nbsp;if your devices are off or you aren't reading email or you are using a third party interface. Apple does recognize events from some companies (doesn't understand Virgin Atlantic booking info, for example) but far fewer than Google supports. Also Apple doesn't have access to your calendar because it's encrypted. Also there's the problem of should Apple process the same data on all devices?</li>
<br />
<li>You can reduce your WiFi connection failures to under 4% and speed up connection setup times by picking the private network with the best signal.&nbsp;<a href="https://arxiv.org/abs/1701.02528">Why It Takes So Long to Connect to a WiFi Access Point</a>.</li>
<br />
<li>To the chagrin of many, Facebook's <a href="https://code.facebook.com/posts/1241394199239439/the-growing-ecosystem-around-open-networking-hardware/">open networking hardware</a> revolution continues.&nbsp;Cumulus Networks supports Backpack and Wedge 100. Big Switch Networks announced a fully functional network operating system for Wedge 40 and Wedge 100. And so on.&nbsp;</li>
<br />
<li>Ask HN: Why is the community so negative towards blockchain technology? <a href="https://news.ycombinator.com/item?id=13420777">patio11</a> captures it nicely:&nbsp;Blockchain is the world's worst database, created entirely to maintain the reputations of venture capital firms who injected hundreds of millions of dollars into a technology whose core defining insight was "You can improve on a Ponzi scam by making it self-organizing and distributed; that gets vastly more distribution, reduces the single point of failure, and makes it censorship-resistant."...No meaningful applications run on top of "blockchain", because it is a marketing term. You cannot install blockchain just like you cannot install database. (Database sounds much cooler without the definitive article, too.) If you pick a particular instantiation of a blockchain-style database, it is a horrible, horrible database. Can I pick on Bitcoin? Let me pick on Bitcoin. Bitcoin is claimed to be a global financial network and ready for production right now. Bitcoin cannot sustain 5 transactions per second, worldwide.</li>
<br />
<li>Excelling in-depth explanation of&nbsp;<a href="https://redditblog.com/2017/01/17/caching-at-reddit/">Caching at Reddit</a>. Caches are split by workload type rather than having one big pool. Advantages: can scale workload independently based on utilization;&nbsp;make reasonable predictions about what will happen in case of a failure; prevent memory fragmentation because sizes are similar. Caching is also used for rate-limiting and locking. Caches are fronted by &nbsp;<a href="https://github.com/facebook/mcrouter">mcrouter</a>&nbsp;which is a&nbsp;connection pooler and proxy developed at Facebook. It can also route keys to specific pools based on their functionality; warm up caches slowly; manage failover pools. There's lots more too.</li>
<br />
<li>Store images in a database? The answer is usually heck no. But that's just what Walmart is doing.&nbsp;<a href="https://medium.com/walmartlabs/building-object-store-storing-images-in-cassandra-walmart-scale-a6b9c02af593">Building Object Store &mdash; Storing Images in Cassandra at Walmart Scale</a>: "the read/write numbers (95th and 99th percentile) were simply outstanding for 90% of our use cases! Our performance tests involved storing millions of images of different sizes worth terabytes of data. The remaining 10% were all large images with 10&rsquo;s of MB in size and the response times were still acceptable." A CDN is used to cache product images and different sized images will be produced on the fly.&nbsp;</li>
<br />
<li>Like a <em>spaceship finding the best path through a meteoroid belt</em>&nbsp;here's another example of using AI in tuning, this time for NAND. <a href="http://thememoryguy.com/nvmdurance-making-nand-flash-last-longer/">NVMdurance &ndash; Making NAND Flash Last Longer</a>: a machine learning algorithm that determines how best to tune the part. &nbsp;This product has been named the &ldquo;Pathfinder&rdquo; since it works out the best few paths a chip can take to reach maximum endurance. &nbsp;Another algorithm called the &ldquo;Navigator&rdquo; resides in the flash controller chip and manages the flash chip&rsquo;s internal parameters during operation to follow one of the paths recommended by the Pathfinder. The exact set of paths chosen by the Navigator differs from chip to chip and depends on the kind of wear the particular application is causing for the flash.&nbsp;</li>
<br />
<li>When Stack Overflow went down they did something cool, they went into read-only mode. It's not that easy to do. You have to be very careful when accessing the database.&nbsp;<a href="https://www.brentozar.com/archive/2017/01/always-isnt-handling-outages-application/">When Always On Isn&rsquo;t: Handling Outages in Your Application</a>.&nbsp;</li>
<br />
<li><a href="https://blog.discordapp.com/how-discord-stores-billions-of-messages-7fa6ec7ee4c7">How Discord Stores Billions of Messages Using Cassandra</a>. Their requirements:&nbsp;Linear scalability ,&nbsp;Automatic failover,&nbsp;Low maintenance, Proven to Work,&nbsp;Predictable performance, Not a Blob Store, Open Source. Cassandra fit, but not perfectly. Messages had to bucketed by time so as to not createLarge partitions which put a lot of GC pressure on Cassandra during compaction, cluster expansion, and more. The eventual consistency model made for some problems as the last write wins policy caused some data overwrites. Only write non-null values to prevent generating tombstones during deletes. As expected writes were sub-millisecond and reads were under 5 milliseconds. They also had some surprising problems due to GC on deletes. Result:&nbsp;went from over 100 million total messages to more than 120 million messages a day, with performance and stability staying consistent.</li>
<br />
<li><a href="http://arstechnica.com/science/2017/01/rem-sleep-lets-the-brain-cut-and-strengthen-new-connections/">The brain uses REM sleep to cut unneeded connections</a>. Similar tactics in software: timeouts; garbage collection; caches; upgrading by starting a new software load in a new VM; in a primary-secondary pair periodically failing over to the secondary.</li>
<br />
<li>Apparently nature hasn't discovered ransomware yet. Nature is old school, malware is introduced for command and control.&nbsp;<a href="http://www.the-scientist.com/?articles.view/articleNo/48185/title/Study--One-Wasp-Takes-Control-of-Another">One Wasp Takes Control of Another</a>.</li>
<br />
<li><a href="https://dzone.com/articles/why-container-based-deployment-is-preferred-for-mi">Why Container-Based Deployment Is Preferred for Microservices</a>:&nbsp;Ability to Deploy and Undeploy Independently of Other Microservices;&nbsp;Ability to Scale at Each Microservices Level;&nbsp;Ability to Build and Deploy Microservices Quickly.</li>
<br />
<li>Wizard level exploration of different coding approaches.&nbsp;<a href="http://www.dalnefre.com/wp/2017/01/same-fringe-revisited/">&ldquo;Same Fringe&rdquo; Revisited</a>:&nbsp;Both functional closures and actor behaviors capture algorithm fragments that can be passed around as values and invoked (or not) whenever we choose. These mechanisms are related to continuations [5], which have been discovered in various contexts by different people. If you squint, you could view all of these as kinds of coroutine implementations.</li>
<br />
<li>When to expect peak loads?&nbsp;<a href="https://www.soasta.com/blog/2016-holiday-traffic-trends/">Black Friday overtakes Cyber Monday for holiday traffic (and other lessons learned from studying 10B user experiences)</a>: more consumer activity to move online in the not-so-distant future; the week before; be ready for spikes throughout the entire holiday season, especially on Mondays.&nbsp;a 2-second improvement to median load times, they almost doubled mobile conversions.&nbsp;</li>
<br />
<li>Looks good.&nbsp;<a href="http://www.interdb.jp/pg/index.html">The Internals of PostgreSQL</a>:&nbsp;Chapters include: Database cluster, databases and tables;&nbsp;Process and memory architecture;&nbsp;Concurrency Control;&nbsp;VACUUM processing;&nbsp;Buffer Manager;&nbsp;Write Ahead Log (WAL);&nbsp;Base Backup and Point-In-Time Recovery (PITR);&nbsp;Streaming-Replication (SR).</li>
<br />
<li><a href="http://www.silota.com/docs/recipes">Nice list of&nbsp;Advanced SQL Recipes to jump start your Analysis</a>. Recipes like&nbsp;Calculating Running Total;&nbsp;Calculating Running/Moving Average;&nbsp;Calculating Z-Score.</li>
<br />
<li><a href="http://tech.marksblogg.com/billion-nyc-taxi-kdb.html">1.1 Billion Taxi Rides on kdb+/q &amp; 4 Xeon Phi CPUs</a>:&nbsp;Q is a programming language with a built-in, column-oriented, in-memory and on-disk database called kdb+. Q both includes and extends SQL. Q is native to the database engine so, unlike most databases, there is no shipping of data between the client and the server.</li>
<br />
<li><a href="https://hackernoon.com/the-must-know-checklist-for-devops-system-reliability-engineers-f74c1cbf259d">The Must Know Checklist For DevOps &amp; Site Reliability Engineers</a>. Seems reasonable. There's surely a lot to know.</li>
<br />
<li>It's hard to explain why your PaaS is worth the money.&nbsp;<a href="https://www.reddit.com/r/programming/comments/5q21ng/paas_false_economics/">PaaS (false) economics</a>. Good advice from&nbsp;<a href="https://www.reddit.com/r/programming/comments/5q21ng/paas_false_economics/dcwfu6r/">NiteLite</a>:&nbsp;Yeah, you should probably look into displaying your pricing information differently.&nbsp;Your pricing model right now is very similar to how AWS etc do their pricing. By breaking down the pricing in a different way you can probably make it a lot more clear that you are selling a service that lets the customer spend less time configuring servers and more time actually making money...Usually you want to make the customer feel like he is saving money if he uses your service. At the moment your pricing information might come across a little too much like "the cost of doing business" instead of a "simple way for your customer to be more efficient" :D</li>
<br />
<li><a href="http://blog.streamingmedia.com/2017/01/using-multi-cdn-strategy.html">Best Practices For Using A Multi-CDN Strategy: How To Balance, Prioritize and Optimize Traffic</a>:&nbsp;There are three types of strategies, those being balanced, prioritized, and optimized. Using a balanced strategy, one merely distributes traffic with different thresholds (like traffic served or concurrent streams) to spill over into secondary CDNs upon reaching a specified limit. A prioritized schema provides a criteria hierarchy, which may include the platform, ISP, device, or protocol utilized until a certain level.</li>
<br />
<li>randsinrepose on&nbsp;<a href="http://randsinrepose.com/archives/rainbows-and-unicorns/">three rules that define a good game</a>:&nbsp;Do I have a continual healthy sense of progression?;&nbsp;Am I learning and mastering the game via timely and effective feedback?;&nbsp;Do I have the impression that I can win?</li>
<br />
<li>This is different. <a href="http://store.steampowered.com/app/576030">MHRD</a> is a hardware design game, in which you design various hardware circuits in a hardware description language. The hardware circuits you design get more complex as you go until you create a fully functional CPU design.</li>
<br />
<li>Need some Extreme Scale Computing training? Here's a series of 82 videos:&nbsp;<a href="https://www.youtube.com/playlist?list=PLGj2a3KTwhRb6LNVucPkwdpzg9OHd8jli">2016 Argonne Training Program on Extreme Scale Computing</a>.</li>
<br />
<li><a href="http://semiaccurate.com/2017/01/19/amd-infinity-fabric-underpins-everything-will-make/">AMD Infinity Fabric underpins everything they will make</a>:&nbsp;So that is the key to the new Infinity Fabric, the granularity, especially in mesh topologies it should allow bandwidth to scale with nodes. Topology is not protocol defined or restricted and the coherent links will work across sockets, CPUs, GPUs, and more. If the level of granularity is as fine as was intoned, it allows a CPU core to pass info to a shader &lsquo;directly&rsquo; regardless of the two being on the same silicon or across a system. The separate control and data fabrics bring AMD up to modern SoC structures too, and in some ways beyond. Infinity Fabric is a really big deal</li>
<br />
<li><a href="http://fission.io/">fission.io</a>:&nbsp;Designed to be the open source alternative to Lambda. Also tries to make Kubernetes easy to consume. Good coverage on&nbsp;<a href="http://www.thecloudcast.net/2017/01/the-serverlesscast-1-project-fission.html">The ServerlessCast #1 - Project Fission</a>.&nbsp;</li>
<br />
<li><a href="https://github.com/urweb/urweb">urweb/urweb</a>:&nbsp;a domain-specific functional programming language for web applications. Lets web developers completely specify their sites&rsquo; functionality using just one programming language. The Ur/Web compiler then automatically generates all the different types of code required to power a website &mdash; HTML, JavaScript, SQL database queries, and cascading style sheets &mdash; while providing certain performance and security guarantees. More info:&nbsp;<a href="http://news.mit.edu/2017/faster-websites-fewer-bugs-0120">Faster websites with fewer bugs&nbsp;</a>-&nbsp;System that automatically handles database caching in server farms increases speed and reliability.</li>
<br />
<li><a href="https://arxiv.org/abs/1701.03757">Deep Probabilistic Programming</a>:&nbsp;We propose Edward, a Turing-complete probabilistic programming language. Edward builds on two compositional representations---random variables and inference. By treating inference as a first class citizen, on a par with modeling, we show that probabilistic programming can be as flexible and computationally efficient as traditional deep learning.&nbsp;or efficiency, Edward is integrated into TensorFlow, providing significant speedups over existing probabilistic systems. For example, on a benchmark logistic regression task, Edward is at least 35x faster than Stan and PyMC3.</li>
</ul>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2017/1/27/stuff-the-internet-says-on-scalability-for-january-27th-2017.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />Post a Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2017/1/27/stuff-the-internet-says-on-scalability-for-january-27th-2017.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2017%2F1%2F27%2Fstuff-the-internet-says-on-scalability-for-january-27th-2017.html','Stuff%20The%20Internet%20Says%20On%20Scalability%20For%20January%2027th%2C%202017');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2017/1/27/stuff-the-internet-says-on-scalability-for-january-27th-2017.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/35849532"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/hot-links"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />hot links</a></span></span>  <span class="post-snippet-1"><iframe src="http://www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2017/1/27/stuff-the-internet-says-on-scalability-for-january-27th-2017.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2017/1/27/stuff-the-internet-says-on-scalability-for-january-27th-2017.html" data-text="Stuff The Internet Says On Scalability For January 27th,&nbsp;2017" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments </h3>

      
        
          <div class="text">There are no comments for this journal entry.  To create a new comment, use the form below.</div>

        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=35849532"> 

    
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2016, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>