<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1338871095817&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2017/10/20/stuff-the-internet-says-on-scalability-for-october-20th-2017.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://five.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Stuff The Internet Says On Scalability For October 20th,&nbsp;2017 - High Scalability - </title>
    <meta property="og:title" content="Stuff The Internet Says On Scalability For October 20th,&nbsp;2017 - High Scalability - " /> 
  

      <meta property="og:description" content=" Hey, it's HighScalability time: 

 
  

Cassini's last image of Saturn, stitched together from 11 ..." />
  

  
      <meta property="og:image" content="https://c1.staticflickr.com/5/4449/36540388354_18599862be.jpg" />
  

  <!-- End Heading -->

  <script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1044643/SS_HS_Ad1', [125, 125], 'div-gpt-ad-1325175098795-0').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad10', [125, 125], 'div-gpt-ad-1325175098795-1').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad11', [125, 125], 'div-gpt-ad-1325175098795-2').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad12', [125, 125], 'div-gpt-ad-1325175098795-3').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad13', [125, 125], 'div-gpt-ad-1325175098795-4').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad14', [125, 125], 'div-gpt-ad-1325175098795-5').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad15', [125, 125], 'div-gpt-ad-1325175098795-6').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad16', [125, 125], 'div-gpt-ad-1325175098795-7').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad17', [125, 125], 'div-gpt-ad-1325175098795-8').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad2', [125, 125], 'div-gpt-ad-1325175098795-9').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad3', [125, 125], 'div-gpt-ad-1325175098795-10').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad4', [125, 125], 'div-gpt-ad-1325175098795-11').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad5', [125, 125], 'div-gpt-ad-1325175098795-12').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad6', [125, 125], 'div-gpt-ad-1325175098795-13').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_ad7', [125, 125], 'div-gpt-ad-1325175098795-14').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad8', [125, 125], 'div-gpt-ad-1325175098795-15').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad9', [125, 125], 'div-gpt-ad-1325175098795-16').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad18', [125, 125], 'div-gpt-ad-1325175098795-17').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad19', [125, 125], 'div-gpt-ad-1325175098795-18').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad20', [125, 125], 'div-gpt-ad-1325175098795-19').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>


  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId35982302"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2017%2F10%2F20%2Fstuff-the-internet-says-on-scalability-for-october-20th-2017.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2017/10/20/stuff-the-internet-says-on-scalability-for-october-20th-2017.html">Stuff The Internet Says On Scalability For October 20th, 2017</a></li>  <li><a href="/blog/2017/10/16/buttercms-architecture-a-mission-critical-api-serving-millio.html">ButterCMS Architecture: a Mission-Critical API Serving Millions of Requests per Month</a></li>  <li><a href="/blog/2017/10/13/stuff-the-internet-says-on-scalability-for-october-13th-2017.html">Stuff The Internet Says On Scalability For October 13th, 2017</a></li>  <li><a href="/blog/2017/10/10/sponsored-post-loupe-etleap-aerospike-stream-scalyr-vividcor.html">Sponsored Post: Loupe, Etleap, Aerospike, Stream, Scalyr, VividCortex, Domino Data Lab, MemSQL, InMemory.Net, Zohocorp</a></li>  <li><a href="/blog/2017/10/9/what-will-programming-look-like-in-the-future.html">What will programming look like in the future?</a></li>  <li><a href="/blog/2017/10/6/stuff-the-internet-says-on-scalability-for-october-6th-2017.html">Stuff The Internet Says On Scalability For October 6th, 2017</a></li>  <li><a href="/blog/2017/10/2/ripple-the-most-demonstrably-scalable-blockchain.html">Ripple: The Most (Demonstrably) Scalable Blockchain</a></li>  <li><a href="/blog/2017/9/29/stuff-the-internet-says-on-scalability-for-september-29th-20.html">Stuff The Internet Says On Scalability For September 29th, 2017</a></li>  <li><a href="/blog/2017/9/27/aligning-your-team-around-microservices-when-theres-no-preci.html">Aligning Your Team around Microservices When There's No Precise Definition</a></li>  <li><a href="/blog/2017/9/26/sponsored-post-loupe-etleap-aerospike-stream-scalyr-vividcor.html">Sponsored Post: Loupe, Etleap, Aerospike, Stream, Scalyr, VividCortex, Domino Data Lab, MemSQL, InMemory.Net, Zohocorp</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <CENTER>
  <!-- SS_HS_Ad1 -->
  <div id='div-gpt-ad-1325175098795-0' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-0'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad10 -->
  <div id='div-gpt-ad-1325175098795-1' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-1'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad11 -->
  <div id='div-gpt-ad-1325175098795-2' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-2'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad12 -->
  <div id='div-gpt-ad-1325175098795-3' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-3'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad13 -->
  <div id='div-gpt-ad-1325175098795-4' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-4'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad14 -->
  <div id='div-gpt-ad-1325175098795-5' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-5'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad15 -->
  <div id='div-gpt-ad-1325175098795-6' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-6'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad16 -->
  <div id='div-gpt-ad-1325175098795-7' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-7'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad17 
  <div id='div-gpt-ad-1325175098795-8' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-8'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad2 
  <div id='div-gpt-ad-1325175098795-9' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-9'); });
  </script>
  </div>
  -->
  
  </CENTER>
  
  <center><a href="/advertising">advertise</A></center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2017%2F10%2F20%2Fstuff-the-internet-says-on-scalability-for-october-20th-2017.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178453">

    <div id="moduleContent15178453">

              <a id="moduleLink15178453" class=" " href="http://highscalability.com/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870172">

    <div id="moduleContent4870172">

              <a id="moduleLink4870172" class=" " href="http://highscalability.squarespace.com/blog/category/product" ><span>Useful Products</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870194">

    <div id="moduleContent4870194">

              <a id="moduleLink4870194" class=" " href="http://highscalability.squarespace.com/blog/category/paper" ><span>Useful Papers</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870201">

    <div id="moduleContent4870201">

              <a id="moduleLink4870201" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Useful Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4885586">

    <div id="moduleContent4885586">

              <a id="moduleLink4885586" class=" " href="/blog/category/blog" ><span>Useful Blogs</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4920227">

    <div id="moduleContent4920227">

              <a id="moduleLink4920227" class=" " href="http://highscalability.com/blog/category/book" ><span>Useful Books</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper12001611">

    <div id="moduleContent12001611">

              <a id="moduleLink12001611" class=" " href="http://highscalability.com/blog/2011/9/14/big-list-of-scalabilty-conferences.html" ><span>Useful Conferences</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4878991">

    <div id="moduleContent4878991">

              <a id="moduleLink4878991" class="offsite-link " href="http://astore.amazon.com/possiboutpos-20" onclick="this.target='new';"><span>Book Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2017/10/16/buttercms-architecture-a-mission-critical-api-serving-millio.html">ButterCMS Architecture: a Mission-Critical API Serving Millions of Requests per Month &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability category-hot-links">
<div id="item35982302" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Friday</span></div><div class="journal-entry-float-date"><span class="month">Oct</span><span class="date">20</span><span class="year">2017</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2017/10/20/stuff-the-internet-says-on-scalability-for-october-20th-2017.html">Stuff The Internet Says On Scalability For October 20th,&nbsp;2017</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Friday, October 20, 2017 at 8:59AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p>Hey, it's HighScalability time:&nbsp;</p>
<div align="center"><img src="https://c1.staticflickr.com/5/4449/36540388354_18599862be.jpg" alt="" />
<p>&nbsp;</p>
Cassini's last image of Saturn, stitched together from 11 color composites, each a stack of three images taken in red, green, and blue channels. <span style="font-size: 80%;">(<a href="https://www.flickr.com/photos/lightsinthedark/37163572171/">Jason Major</a>)</span></div>
<div align="center">
<p>&nbsp;</p>
<p>If you like this sort of <em>Stuff</em> then please support me <a href="https://www.patreon.com/toddhoff">on Patreon</a>.</p>
</div>
<ul>
<li><a href="https://www.amazon.com/dp/B073CPP581">21 billion</a>: max bitcoins ever; <a href="http://www.barrons.com/articles/alibaba-cloud-biz-may-be-2-globally-1508248278?mod=hp_pop&amp;">#2</a>: Alibaba's cloud?;&nbsp;<a href="https://twitter.com/werner/status/921108949801222145">1M MWh</a>:&nbsp;Amazon Wind Farm Texas with 100 Turbines is live; <a href="https://www.wired.com/story/track-location-with-mobile-ads-1000-dollars-study/">$1000</a>: cost to track someone with mobile ads; <a href="https://twitter.com/amcafee/status/920046822164451329">20%</a>: ebook sales of total; <a href="https://spectrum.ieee.org/tech-talk/computing/hardware/intel-accelerates-its-quantum-computing-efforts-with-17qubit-chip">17</a>: qubit chip; <a href="https://eng.uber.com/horovod/">30%</a>: Uber deep learning speedup using RDMA;&nbsp;</li>
<br />
<li>Quoteable Quotes:                                                              
<ul>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://www.amazon.com/dp/B01N34IDU6">Tim O'Reilly</a>: So what makes a real unicorn of this amazing kind? 1. &nbsp;It seems unbelievable at first. 2. &nbsp;It changes the way the world works. 3. &nbsp;It results in an ecosystem of new services, jobs, business models, and industries.</div>
</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/rajivpant/status/920892665285115906">@rajivpant</a>:&nbsp;AlphaGo has already beaten two of the world's best players. But the new AlphaGo Zero began with a blank Go board and no data apart from the rules, and then played itself. Within 72 hours it was good enough to beat the original AlphaGo by 100 games to zero!</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://twitter.com/swardley/status/919533312498192384">@swardley</a>:&nbsp;Containers aka winning battle but losing the war. AMZN joining CNCF is misdirection. Lambda is given a free pass to entire software industry</div>
</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15452828">vlucas</a>: Event-Driven architecture sounds like somewhat of a panacea with no worries about hard-coded or circular dependencies, more de-coupling with no hard contracts, etc. but in practice it ends up being your worst debugging nightmare. I would much rather have a hard dependency fail fast and loudly than trigger an event that goes off into the ether silently.</div>
</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/xaprb/status/921004656402321408">@xaprb</a>:&nbsp;Monitoring tells you whether the system works. Observability lets you ask why it's not working.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://blogs.the451group.com/techdeals/investment-banking/stuck-startups-and-a-billion-dollar-backlog/">Brenon Daly</a>: Startups are increasingly stuck. The well-worn path to riches &ndash; selling to an established tech giant &ndash; isn&rsquo;t providing nearly as many exits as it once did. In fact, based on 451 Research calculations, 2017 will see roughly 100 fewer exits for VC-backed companies than any year over the past half-decade. This current crimp in startup deal flow, which is costing billions of dollars in VC distributions, could have implications well beyond Silicon Valley.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/krishnan/status/920320609048936450">@krishnan</a>:&nbsp;The battle lines are IaaS+ with Kubernetes vs Platforms like OpenShift or Pivotal CF Vs Serverless. No one is a winner yet</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://twitter.com/fredwilson/status/919809817220222976">@fredwilson</a>:&nbsp;"We now have 30,000 data scientists .... 100x more than any other hedge fund ... we are not yet two years old"</div>
</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.reddit.com/r/space/comments/76e79c/i_am_elon_musk_ask_me_anything_about_bfr/">Elon Musk</a>:&nbsp;Our goal is get you there and ensure the basic infrastructure for propellant production and survival is in place. A rough analogy is that we are trying to build the equivalent of the transcontinental railway. A vast amount of industry will need to be built on Mars by many other companies and millions of people.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.cryptocoinsnews.com/100-dubai-put-entire-land-registry-blockchain/">Samburaj Das</a>: &lsquo;Dubai Blockchain Strategy&rsquo;, which aims to record and process 100% of all documents and transactions on a blockchain by the year 2020. The sweeping blockchain mandate was announced by Hamdan bin Mohammed, the crown prince of Dubai, in October 2016.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/danielbryantuk/status/920241710336303104">@danielbryantuk</a>:&nbsp;"Defence in depth can add 15% to dev cost. Some think this is a lot, but does it compare to data being exposed?" @eoinwoodz #OReillySACon</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/cmeik/status/919581177790586880">@cmeik</a>:&nbsp;It's solving the issues around gossip floods, it's providing a more reliable infrastructure, it's alleviating head of line blocking. &nbsp;These are the problems that when solved *enable* large clusters.</div>
</li>
<li>
<div id="_mcePaste"><a href="http://ben-evans.com/benedictevans/2017/10/12/scale-wetxp">Benedict Evans</a>: the four leading tech companies of the current cycle (outside China), Google, Apple, Facebook and Amazon, or &lsquo;GAFA&rsquo;, have together over three times the revenue of Microsoft and Intel combined (&lsquo;Wintel&rsquo;, the dominant partnership of the previous cycle), and close to six times that of IBM. They have far more employees, and they invest far more.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://medium.com/@alanderr/good-article-e5cbdf47a1d7">Alan Andersen</a>: At Canopy Tax we have been using dockerized micro-serviced Java containers using vertx with RxJava and have found it to be highly performant and memory efficient.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.amazon.com/dp/B073CPP581">David Gerard</a>: as of June 2017 the Bitcoin network was running 5,500,000,000,000,000,000 (5.5&times;1018, or 5.5 quintillion) hashes per second, or 3.3&times;1021 (3.3 sextillion) per ten minutes</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/codewisdom/status/920414873498112000">@CodeWisdom</a>:&nbsp;"One accurate measurement is worth a thousand expert opinions." - Grace Hopper</div>
</li>
<li>
<div id="_mcePaste"><a href="https://blog.usejournal.com/why-trello-failed-to-build-a-1-billion-business-e1579511d5dc">Hiten Shah</a>: if you wan&rsquo;t to build the next $1B+ SaaS app, you have to remember to constantly evolve on top of your product. Don&rsquo;t build around any one single feature that the competition can rip out. Alternatively, make that one single feature so deeply integrated into everyone else&rsquo;s product that it&rsquo;s pointless for anyone else to copycat it.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/fmanjoo/status/920137534184681472">@fmanjoo</a>:&nbsp;Every number in Netflix&rsquo;s earnings report is just extraordinary. $8 billion on content, 80 movies by next year!</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.bloomberg.com/news/articles/2017-10-11/driverless-cars-are-giving-engineers-a-fuel-economy-headache">Bloomberg</a>: self-driving technology is a huge power drain. Some of today&rsquo;s prototypes for fully autonomous systems consume two to four kilowatts of electricity -- the equivalent of having 50 to 100 laptops continuously running in the trunk</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/swardley/status/920442768257900544">@swardley</a>:&nbsp;I view that once again, Amazon has been given too long to freely invade a space .. and Lambda is gunning for the entire software industry.</div>
</li>
<li>
<div id="_mcePaste"><a href="http://etherealmind.com/response-oracles-chides-us-govt-believing-devops-open-source/">Greg Ferro</a>: First, Just about everything in this submission [from Oracle] sounds self serving and protecting their own revenue. Its hard to see this as a genuine attempt to add value to the process. Second, the author of the letter has adopted a tone that is approximately like a father berating a child for uppity behaviour.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://lemire.me/blog/2017/10/13/bee-level-intelligence/">Daniel Lemire</a>: What I am really looking forward, as the next step, is not human-level intelligence but bee-level intelligence. We are not there yet, I think.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.virgin.com/richard-branson/two-million-dollar-heist">Richard Branson</a>: People used to raid banks and trains for smaller amounts - it&rsquo;s frightening to think how easy it is becoming to pull off these crimes for larger amounts.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://lobste.rs/s/zsbrjy/why_we_switched_from_python_go#c_ea61kn">tbarbugli</a>: Disclaimer: CTO of Stream here. We experimented writing Cython code to remove bottlenecks, it worked for some (eg. make UUID generation and parsing faster) and think that&rsquo;s indeed good advice to try that before moving to a different language. We still decided to drop Python and use Go for some parts of our infrastructure&nbsp;</div>
</li>
<li>
<div id="_mcePaste"><a href="https://medium.com/@PaulDJohnston/serverlessconf-nyc-2017-shifting-serverless-from-faas-to-analytics-and-monitoring-from-technical-10fe482470ca">Paul Johnston</a>: The Serverless conversation is shifting from Functions to Analytics and Monitoring.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://spectrum.ieee.org/automaton/robotics/humanoids/watch-the-worlds-first-giant-robot-fight">Gui Cavalcanti</a>: Eagle Prime has modular weapons systems. The chainsaw is absolutely my favorite. I had no idea it could do as much damage as it does</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/sheeshee/status/919614656561500162">@sheeshee</a>:&nbsp;I have a web app with a postgres database running in a kubernetes cluster. I am very hip now.</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15458976">otakucode</a>:&nbsp;Why stop with microwaves? Why not make platters out of pure gold and the read/write heads out of synthetic diamond? Maybe integrate a cryogenic cooling system and store the data in a Bose-Einstein condensate? At this point it seems people will believe even that is cheaper than some NAND chips run off a line like printouts.</div>
</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/adrianhosey/status/920657574982291457">@adrianhosey</a>: Swagger/WSDL/CORBA IDL/ONC RPC ... They all come out the same color in the end.</div>
</li>
<li>
<div id="_mcePaste"><a href="http://250bpm.com/blog:107">@sustrik</a>: do we have an equivalent of embryonic development in software, something that could serve as a window to software product's history?</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15492122">hosh</a>: Someone said it. ... K8S, not Docker, is the Linux of the cloud native platform.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.wired.com/story/new-theory-deep-learning/">Natalie Wolchover</a>: The scientists found that, layer by layer, the networks converged to the information bottleneck theoretical bound: a theoretical limit derived in Tishby, Pereira and Bialek&rsquo;s original paper that represents the absolute best the system can do at extracting relevant information. At the bound, the network has compressed the input as much as possible without sacrificing the ability to accurately predict its label.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15461092">Narew</a>:&nbsp;Unlike Keras and Tensorflow, Gluon is Define-by-run Deeplearning framework like Pytorch, Chainer. Network definition/debugging/flexibility are really better with dynamic network (define-by-run). That's why Facebook seem to use Pytorch for research and caffe2 for deployment. Gluon/Mxnet can do both define-by-run with Gluon API and "standard" define-and-run with it's Module API.</div>
</li>
<li>
<div id="_mcePaste"><a href="http://r6.ca/blog/20171010T001746Z.html">Russell O&rsquo;Connor</a>:&nbsp;By dividing data structures up into layers of functors, one can create a separation of concerns that does not occur in traditional functional programming. With functor oriented programming, polymorphism is not necessarily about using functions polymorphically. Instead, polymorphism provides correctness guarantees by ensuring that a particular function can only touch the specific layers of functors in its type signature and is independent of the rest of the data structure. One benefits from polymorphism even when a function is only ever invoked at a single type.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.reddit.com/r/programming/comments/76q3n2/standardising_microservices_at_scale/dofwl9q/">Gotebe</a>: attention: unsubstantiated, poorly thought-out babbling ahead. The need for standards in microservices... And here goes another standardization cycle... Yes, we need the way to describe interfaces (IDL of some sort, with a proxy (client) generation tooling for various languages). Yes, we need a way to discover services (WSDL of some sort). Yes, we need a way to handle authentication and authorization (OAuth something something). Some people will want to secure the conversation. Some will want transactions. Some will want... Nineties called, they want their CORBA back!</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15489679">tw1010</a>:&nbsp;Man, software engineering at the cutting edge is getting harder and harder by the day. Not only are you expected to master coding but also math heavy ML and economics. I guess a consequence of software eating the world is that more and more fields of human knowledge is folded into the engineering world. The consequence being that engineers really aught to be very broad in their reading if they want to take advantage of all the low hanging fruit the octopus arms stumbles into.</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://www.amazon.com/dp/B073CPP581">David Gerard</a>: The ensuing evolutionary arms race, as miners desperately try for enough of an edge to turn a profit, is such that Bitcoin&rsquo;s power usage is on the order of the entire power consumption of Ireland. This electricity is literally wasted for the sake of decentralisation; the power cost to confirm the transactions and add them to the blockchain is around $10-20 per transaction. That&rsquo;s not imaginary money &ndash; those are actual dollars, or these days mostly Chinese yuan, coming from people buying the new coins and going to pay for the electricity. An ordinary centralised database could calculate an equally tamper-evident block of transactions on a 2007 smartphone running off USB power. Even if Bitcoin could replace conventional currencies, it would be an ecological disaster.</div>
</div>
</li>
<li>
<div id="_mcePaste"><a href="http://blog.dshr.org/2017/10/will-hamr-happen.html">David Rosenthal</a>: I've been writing abut the slowing of Kryder's Law from 30-40%/yr to 10-20%/yr since at least 2014, and that projection has been verified. Remembering that industry projections have a history of optimism, WDC's projection of a 15% Kryder rate going forward on the assumption that they can get a new recording technology into the market in 2020 should be treated skeptically. I would expect that the future Kryder rate will be more like 10% than 15%. I would also expect that the cost factor between disk and flash in the 2020s would be less than 10x rather than greater than 10x, but still more than enough to maintain hard disk's dominance of the bulk storage market.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.mappingthejourney.com/single-post/2017/10/12/episode-11-interview-with-don-chamberlin-designer-of-sql-database-language/">Don Chamberlin</a>: It&rsquo;s very gratifying to me that, 43 years after Ray Boyce and I published the first SEQUEL paper, SQL is still the world&rsquo;s most widely used database query language. I&rsquo;m also very gratified to see that SQL is being used in a vast variety of exciting applications, far more than Ray and I ever anticipated. When we started work on SQL, the internet did not exist, but nevertheless, SQL has turned out to be an essential tool for commerce on the internet. Several open-source SQL systems are available, so anyone who wants to can use SQL for free.</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15477426">richie5um</a>: I liken software methodologies to cooking recipes. On one end of the scale you have a highly skilled and experienced chef, who can craft a great (requested) dish with a variety of ingredients and equipment. Knowing how to adapt and what to add and when. This works well, but requires a heavy cost (experience) and is, from the outside, difficult to follow and control. On the other end of the scale you have fast food. A strict process and fixed ingredients that &lsquo;just works&rsquo;. Those involved in cooking have very little knowledge of why, and are almost certainly not able to adapt. This works well for scenarios where you exactly know and control both the input and output.</div>
</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15476586">whipoodle</a>: I work for one of those fancy startups. Everything is chaos all the time, you have all these extremely smart people in the small doing actually kinda dumb things in the large. This worked better when the company was small and is causing more and more problems as we grow. Anyway, the point being that there&rsquo;s lots of smart individuals and little process. I mentioned this during a meeting with my team, and so a process was devised for the next project we embarked upon. The process was waterfall, except nobody referred to it that way (most of the people are like 25, and weren&rsquo;t working back when it was the norm). Everything old is new again. It wasn&rsquo;t important anyway; we didn&rsquo;t follow the process.</div>
</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15486533">jhgg</a>:&nbsp;It's worth noting that the instance migration basically null-routed the redis VM for a good 30 minutes, until we manually intervened and restarted it. The instance was completely disconnected from the internal network immediately following the migration. From what we could gather from instance logs, the routing table on the VM was completely dropped and it could not even connect to the magic metadata service (metadata.internal - we saw "no route to host" errors for that). This is a pretty serious bug within GCP and we've already opened a case with them hoping they can get a fix. I think this is the 4th or 5th major bug we've encountered with their live migration system that could have, or has led to an outage or internal service degradation. GCP team has seriously investigated and fixed every bug we've reported to them so far, so props to them for that! Live migration is incredibly difficult to get right.</div>
</li>
</ul>
</li>
<br />
<li>Seeing some creative internet style thinking in the movie business. <a href="https://www.moviepass.com/">Movie Pass</a> let's you see one movie a day, at a theatre, for a flat fee of $10 a month. Theatres have tons of unused inventory in empty seats. They make money selling crappy popcorn and sugary treats. Packing theatres should be the goal, shouldn't it? Maybe put theatre seats on Airbnb?</li>
<br />
<li>Here's everything that happened at Facebook's&nbsp;<a href="https://code.facebook.com/posts/1113992258742201/mobile-scale-2017-recap/">Mobile @Scale 2017</a>. Topics include:&nbsp;The future of multi-modal interfaces;&nbsp;Evolution of WhatsApp within Facebook's data centers; Modern server-side rendering with React;&nbsp;Runkeeper: Scaling to get the whole world running.</li>
<br />
<li><a href="https://medium.com/@elliot_f/microservices-in-java-never-a7f3a2540dbb">Microservices in Java? Never.</a> &amp;&amp;&nbsp;<a href="https://hackernoon.com/microservices-in-java-a-second-look-460ba3909c44">Microservices in Java &mdash; A Second Look</a>. The idea is if you run a lot of microservices, which one tends to do, if they use a lot of RAM you're wasting money. In this example, the Java 8 + SpringBoot version cost $5K more per year to run than the go version. Pushback included SpringBoot is a kitchen sink framework so the comparison is unfair. Use Java 9 and include only what you need. $5K is nothing, what are you worried about? Will go really save RAM in the full application? SpringBoot isn't your only option.</li>
<br />
<li>So, you think formally verified means bug free? Nah.&nbsp;<a href="https://blog.cryptographyengineering.com/2017/10/16/falling-through-the-kracks/">Falling through the KRACKs</a>:&nbsp;how did this attack slip through, despite the fact that the 802.11i handshake was formally proven secure?...One of the problems with IEEE is that the standards are highly complex and get made via a closed-door process of private meetings...The second problem is that the IEEE standards are poorly specified. As the KRACK paper points out, there is no formal description of the 802.11i handshake state machine...The critical problem is that while people looked closely at the two components &mdash; handshake and encryption protocol &mdash; in isolation, apparently nobody looked closely at the two components as they were connected together. I&rsquo;m pretty sure there&rsquo;s an entire geek meme about this.</li>
<br />
<li><a href="http://www.craigkerstiens.com/2017/10/12/dear-postgres/">Dear Postgres</a>. A love letter.&nbsp;</li>
<br />
<li>Insightful interview with <a href="https://www.linkedin.com/in/cmcmanis/">Chuck McManis</a> on&nbsp;<a href="https://mesosphere.com/blog/containers-distributed-systems/">Containers and Distributed Systems: Where They Came From and Where They&rsquo;re Going</a>:&nbsp;Early on there was a war between multiprocessing and distributing processing, supercomputing versus network computing, and this has been an ongoing battle even to today. A distributed system requires a network fabric between nodes and this is always much, much less bandwidth than what&rsquo;s internal to a single node...We ran into a lot of problems that plague distributed systems even today, about naming, time synchronization, logging, and making new transactions...battle between parallel processing systems and distributed systems. Within Sun Microsystems there were two efforts: Beowulf clusters and typical multiprocessing machines...The key needs were better resource utilization, process isolation, and the need to prevent information leakage. It turned out that about twenty years earlier IBM did sort of solve that problem with partition isolation, but they did that on custom mainframe hardware and architecture. It turned out that everyone wanted that too, but on low-cost commodity hardware. And it was at that particular insight that Google had internalized in early 2000 and gotten really good at...Google was very famous for having a policy where every node was uniformly the same, so that you could just schedule things on top of them. I brought in a somewhat heretical notion that perhaps storage can be a first-class service running on equipment that did nothing but provided a storage API to the network...Computers are so fast today, disks are so dense, memory is so cheap, that it takes a fairly big problem for you to actually want to partition it...Much of this revolves around how cheap processors have gotten. We can build clouds of cheap processors connected to very inexpensive sensors and readers at the edge. They&rsquo;ll be a self-contained cloud. You could have tens of thousands of these in a single location. They may not even need to be connected to the Internet as they can function on their own. They&rsquo;re their own cloud. It&rsquo;s similar to the technology we were building at the very beginning of distributed computing.</li>
<br />
<li>It's as cool as you think it would be.&nbsp;<a href="https://spectrum.ieee.org/automaton/robotics/humanoids/watch-the-worlds-first-giant-robot-fight">Watch the World&rsquo;s First Giant Robot Fight</a>: The only way this project was possible was by using as many COTS [commercial off-the-shelf] parts as possible, and by verifying each part&rsquo;s functionality as it came in. As best we could, we tested each part as it arrived, made sure it worked, and tested each subsystem before it was assembled into the full system. This let us catch errors like suppliers sending us the wrong part, suppliers sending us parts that didn&rsquo;t work as advertised (for example, we lost a month of controls work by debugging a firmware issue with one of our sensors), and manufacturing errors. If I had to pass on a piece of advice, it would be to assemble in small pieces and test early and often.</li>
<br />
<li><a href="https://www.cockroachlabs.com/customers/baidu/">Baidu: Supporting 50M Inserts a Day with CockroachDB in Production</a>:&nbsp;Baidu&rsquo;s DBA team is now running CockroachDB in production to support two new applications that would have previously used MySQL. These applications access 2TB of data with 50M inserts a day, taking advantage of SQL features like secondary indexes and distributed SQL queries. Baidu&rsquo;s deployment of CockroachDB is simple with ten nodes installed on bare metal servers. A load balancer sits above the ten nodes to distribute traffic.&nbsp;</li>
<br />
<li><a href="https://blog.2ndquadrant.com/postgresql-better-mysql-1/">Why PostgreSQL is better than MySQL</a>. Reason: a MySQL bug took 14.5 years to fix. In the highly unlikely event you haven't already developed a position on this issue that you'll defend to the boredom of anyone who will listen, some good comments <a href="https://news.ycombinator.com/item?id=15478027">on HackerNews</a>.</li>
<br />
<li><a href="https://arstechnica.com/cars/2017/10/5-things-we-learned-from-waymos-big-self-driving-car-report/">5 things we learned from Waymo&rsquo;s big self-driving car report</a>. Interesting that they are pitching safety. What does that mean for software?&nbsp;Waymo is sandboxing safety-critical systems and building in a lot of redundancy...Waymo says it has done extensive work to make sure that computer crashes don't lead to car crashes. All of the key systems on its cars&mdash;the computer, brakes, steering systems, and batteries&mdash;have backups ready to take over if the main system fails...A secondary computer in the vehicle is always running in the background and is designed to bring the vehicle to a safe stop if it detects a failure of the primary system...all of these systems have separate power sources, so the failure of power to the main computer won't knock out the backup computer or other critical systems...Safety-critical aspects of Waymo's vehicles&mdash;e.g. steering, braking, controllers&mdash;are isolated from outside communication...both the safety-critical computing that determines vehicle movements and the onboard 3D maps are shielded from, and inaccessible from, the vehicle's wireless connections and systems.</li>
<br />
<li>Adding a dash of parallelism and a pinch of math makes everything faster. <a href="https://www.reddit.com/r/Dentistry/comments/6mg3ep/dear_dentist_what_is_your_professional_opinion_on/dk1bump/">Wundawuzi</a>: Amabrush can brush your teeth in just 10 seconds, because all your teeth are cleaned simultaneously. Even in this 10 seconds, every tooth surface is cleaned longer compared with common toothbrushes. If you brush your teeth for the recommended 120 seconds with a regular toothbrush (manual or electric), every surface gets brushed for just 1.25 seconds (given the fact that you have 32 teeth and every teeth has three surfaces). Amabrush brushes all your surfaces for whole 10 seconds. This means: every tooth surface gets brushed 8x longer and the total toothbrushing duration is 12x quicker.</li>
<br />
<li><a href="https://medium.com/@eranhammer/when-500-faster-is-garbage-553121a088c3">When 500% Faster is Garbage</a>:&nbsp;On my local machine, hapi v16 handled 3,500 requests/second when using the Fastify benchmark scripts. A recent build of v17 handled 17,800 requests/second. That&rsquo;s a 508% improvement. Almost a tie with a bare Express benchmark at 18,500 requests/second. Garbage...It might be a nice number to brag about but it still means nothing.</li>
<br />
<li><a href="https://www.docker.com/kubernetes">Adding Kubernetes support in the Docker platform</a>:&nbsp;The Docker platform is getting support for Kubernetes. This means that developers and operators can build apps with Docker and seamlessly test and deploy them using both Docker Swarm and Kubernetes.&nbsp;<a href="https://news.ycombinator.com/item?id=15489833">amouat</a>:&nbsp;This really helps with the dev-to-production story for containers.&nbsp;<a href="https://news.ycombinator.com/item?id=15492122">hosh</a>:&nbsp;I see the same thing too: a struggle for relevance. The center of gravity has already moved onto k8s, even if it will takw a while for the rest of the developer community to catch up. <a href="https://news.ycombinator.com/item?id=15490549">InTheArena</a>:&nbsp;Great news for everyone except for VMWare (this is a simple compelling operating system for data centers that spans both windows and mac) and Openshift (which was one of the few viable ways of actually purchasing Kubernetes support). A lot of egos on both sides had to be suppressed to make this happen.&nbsp;<a href="https://news.ycombinator.com/item?id=15489747">grabcocque</a>:&nbsp;This seems a lot to me like Docker Inc. caving in to what has been painfully obvious for a while: K8s won and Swarm/Mesos lost the battle for hearts and minds in container orchestration. We can argue about why it happened, but I got the impression Docker Inc. were desperately trying to wish it away. <a href="https://news.ycombinator.com/item?id=15489694">ealexhudson</a>:&nbsp;Have to say, I don't see the value in being able to have Swarm and k8s in the same cluster.&nbsp;<a href="https://news.ycombinator.com/item?id=15493342">erikb</a>:&nbsp;Kubernetes currently has a lot of traction in Enterprise world. Even the CEOs of the big corps currently know what Kubernetes is. That's why you need to support it in some way if you want to continue to compete. At least for the time being.</li>
<br />
<li>Actually thoughtful and balanced.&nbsp;<a href="https://getstream.io/blog/switched-python-go/">Why we switched from Python to Go</a>:&nbsp;Reason 1 &ndash; Performance:&nbsp;Go is typically 30 times faster than Python.&nbsp;Reason 2 &ndash; Language Performance Matters:&nbsp;Python is a great language but its performance is pretty sluggish for use cases such as serialization/deserialization, ranking and aggregation. We frequently ran into performance issues where Cassandra would take 1ms to retrieve the data and Python would spend the next 10ms turning it into objects.&nbsp;Reason 3 &ndash; Developer Productivity &amp; Not Getting Too Creative:&nbsp;Go forces you to stick to the basics. This makes it very easy to read anyone&rsquo;s code and immediately understand what&rsquo;s going on.&nbsp;Reason 4 &ndash; Concurrency &amp; Channels:&nbsp;Go&rsquo;s approach to concurrency is very easy to work with.&nbsp;Reason 5 &ndash; Fast Compile Time:&nbsp;Our largest micro service written in Go currently takes 6 seconds to compile.&nbsp;Reason 6 &ndash; The Ability to Build a Team:&nbsp;We&rsquo;ve found it easier to build a team of Go developers compared to many other languages.&nbsp;Reason 7 &ndash; Strong Ecosystem:&nbsp;Go has great support for the tools we use. Solid libraries were already available for Redis, RabbitMQ, PostgreSQL, Template parsing, Task scheduling, Expression parsing and RocksDB.&nbsp;Reason 8 &ndash; Gofmt, Enforced Code Formatting:&nbsp;Gofmt avoids all of this discussion by having one official way to format your code.&nbsp;Reason 9 &ndash; gRPC and Protocol Buffers:&nbsp;Go has first-class support for protocol buffers and gRPC.&nbsp;So, no more ambiguous REST endpoints for internal traffic, that you have to write almost the same client and server code for every time. Lots of good comments <a href="https://lobste.rs/s/zsbrjy/why_we_switched_from_python_go">on Lobsters</a>&nbsp;and <a href="https://www.reddit.com/r/programming/comments/776onv/why_we_switched_from_python_to_go/">on reddit</a>. Needless to say, there's lots of disagreement.</li>
<br />
<li>There's always a push to move computation down to be as close as possible to the data. We've seen this same proposal for disk drives, NICs, ASICs, etc.&nbsp;<a href="https://www.cs.utah.edu/~rajeev/pubs/issc16.pdf">Making the Case for Feature-Rich Memory Systems</a>: this article has made the argument that memory devices can be much more than &ldquo;dumb&rdquo; units that store rows of bits. They can be augmented to perform parts of the application or other auxiliary system-level features. This can directly impact overall system performance and energy. While this approach will no doubt increase the cost per bit for memory devices, it offers an opportunity for value addition in an era where customers will likely pay more for specialized systems.</li>
<br />
<li>Nice code example.&nbsp;<a href="https://cloudonaut.io/engaging-your-users-with-aws-step-functions">Engaging your users with AWS Step Functions</a>.&nbsp;</li>
<br />
<li>How does Apple recognize "Hey, Siri?" They have millions of people listening to every word you say, waiting for the right key word phrase. Nah, it's ML of course.&nbsp;<a href="https://machinelearning.apple.com/2017/10/01/hey-siri.html">Hey Siri: An On-device DNN-powered Voice Trigger for Apple&rsquo;s Personal Assistant</a>:&nbsp;The &ldquo;Hey Siri&rdquo; detector uses a Deep Neural Network (DNN) to convert the acoustic pattern of your voice at each instant into a probability distribution over speech sounds. It then uses a temporal integration process to compute a confidence score that the phrase you uttered was &ldquo;Hey Siri&rdquo;. If the score is high enough, Siri wakes up...Most of the implementation of Siri is &ldquo;in the Cloud&rdquo;, including the main automatic speech recognition...The microphone in an iPhone or Apple Watch turns your voice into a stream of instantaneous waveform samples, at a rate of 16000 per second. A spectrum analysis stage converts the waveform sample stream to a sequence of frames, each describing the sound spectrum of approximately 0.01 sec. About twenty of these frames at a time (0.2 sec of audio) are fed to the acoustic model, a Deep Neural Network (DNN) which converts each of these acoustic patterns into a probability distribution over a set of speech sound classes: those used in the &ldquo;Hey Siri&rdquo; phrase, plus silence and other speech, for a total of about 20 sound classes...On iPhone we use two networks&mdash;one for initial detection and another as a secondary checker. The initial detector uses fewer units than the secondary checker...To avoid running the main processor all day just to listen for the trigger phrase, the iPhone&rsquo;s Always On Processor (AOP) (a small, low-power auxiliary processor, that is, the embedded Motion Coprocessor) has access to the microphone signal (on 6S and later). We use a small proportion of the AOP&rsquo;s limited processing power to run a detector with a small version of the acoustic model (DNN). When the score exceeds a threshold the motion coprocessor wakes up the main processor, which analyzes the signal using a larger DNN. In the first versions with AOP support, the first detector used a DNN with 5 layers of 32 hidden units and the second detector had 5 layers of 192 hidden units.</li>
<br />
<li>Good&nbsp;<a href="https://read.acloud.guru/what-you-missed-at-serverlessconf-nyc-3ab02398ebe6">Breaking down ServerlessConf NYC 2017</a>.</li>
<br />
<li>Lots of great insight on syncing time in a game. Managing time always sucks.&nbsp;<a href="https://engineering.riotgames.com/news/determinism-league-legends-unified-clock">Determinism in League of Legends: Unified Clock</a>. But that's not the hard part.&nbsp;<a href="https://engineering.riotgames.com/news/determinism-league-legends-unified-clock#comment-3561276806">Rick Hoskinson</a>:&nbsp;Probably the scariest part of the process is actually rolling out the changes themselves. There were many subtleties and edge cases to deal with. The full roll-out happened over the course of months, gradually adding in more environments/regions and adjusting or fixing bugs as necessary. We had a really excellent team of Quality Assurance experts working with us though, which definitely was the secret ingredient for mitigating player pain.</li>
<br />
<li><a href="http://go.heptio.com/becoming-cloud-native">Free eBook: Becoming a Cloud Native Organization</a>. 25 pages. Joe Beda knows his stuff. Requires sign-up, but it's a good overview, so it's worth it.</li>
<br />
<li>An unusual combination.&nbsp;<a href="https://medium.com/@romain.beauxis/scalable-and-serverless-media-processing-using-bucklescript-ocaml-and-aws-lambda-api-gateway-4efe39331f33">Scalable and serverless media processing using BuckleScript/OCaml and AWS Lambda/API Gateway</a>:&nbsp;In order to make Javascript more suitable for large-scale industrial applications, the BuckleScript framework has recently emerged, originally supported by Bloomberg. BuckleScript interfaces Javascript native code with OCaml. You start by defining bindings from Javascript to OCaml, then write OCaml code using those bindings. Finally, the BuckleScript compiler creates Javascript code from your OCaml code that you can deploy as native Javascript.</li>
<br />
<li>Not a lot of details.&nbsp;<a href="https://githubengineering.com/evolution-of-our-data-centers/">Evolution of GitHub's data centers</a>:&nbsp;We&rsquo;ve got four facilities, two of which are transit hotels which we call points of presence (POPs) and two of which are data centers. To give an idea of our scale, we&rsquo;ve got petabytes of Git data stored for users of GitHub.com and do around 100Gb/s across transit, internet exchanges, and private network interfaces in order to serve thousands of requests per second. Our network and facilities are built using a hub and spoke design. We operate our own backbone between Seattle and northern Virginia POPs which provides more consistent latencies and throughput via protected fiber.</li>
<br />
<li>Wisdom from Guerrilla Capacity Planning's&nbsp;<a href="https://groups.google.com/forum/#!forum/guerrilla-capacity-planning">DrQ</a>: By "trade-off," I'm referring to the notion that proper performance analysis is about optimization of one kind or another. &nbsp;Basically, you are varying one performance metric against another, or several others, to achieve an optimal goal. Identifying the <a href="http://www.perfdynamics.com/Tools/PDQ.html">appropriate performance metrics</a> to vary is one thing, but not the most important thing. The more important point is that all performance metrics are related ... and related nonlinearly. That's what makes performance analysis both interesting and difficult. Queueing theory provides an appropriate rigorous framework by which to characterize those nonlinearities: including Little's law and <a href="http://www.perfdynamics.com/Manifesto/USLscalability.html">the USL</a>. By way of a very simple example, if you are more concerned about user impatience when they're interacting with an application, you might tend to focus on optimizing the user waiting-time metric as a (nonlinear) function of message queue-lengths or resource utilization or whatever other metrics. Conversely, if you were a weather forecaster and needed to crunch a lot of simulation data on a supercomputer, you might tend to focus on optimizing the throughput metric as a function of the number of cores or memory size or whatever other relevant metrics. All the metric relationships are nonlinear. Those two performance goals, represented respectively by the waiting time and throughput, can be thought of as being at opposite ends of the performance spectrum. And then there's the matter of the cost of your selected performance solution. The "best" (optimal) choice mathematically might not be affordable so, you have to fall back to a goal that may be technically sub-optimal but less expensive. In general, there is no single "right way" or one size fits all. It depends on your performance goals.</li>
<br />
<li>Don't be caught with your S3 pants down. Here's your belt and suspenders.&nbsp;<a href="https://www.secplicity.org/2017/10/13/s3-bucket-security-acls-policies/amp/">S3 Bucket Security: More Than ACLs and Policies.</a></li>
<br />
<li><a href="https://blog.wallaroolabs.com/2017/10/how-wallaroo-scales-distributed-state/">How Wallaroo Scales Distributed State</a>:&nbsp;Wallaroo provides in-memory application state. That means that in our word count example, you don&rsquo;t need to make calls out to an external system...Wallaroo breaks down application state into discrete state entities that act as boundaries for atomic transactions (see Pat Helland&rsquo;s paper, which inspired our work in this area)...When a Wallaroo application starts up, state entities are distributed over the workers in the cluster. Each worker has routing information that allows us to route data to the correct state, whether that state exists locally or on another worker.</li>
<br />
<li>A great role for AI would be in maintenance. All the glory and easy stuff for humans. Kurt Vonnegut:&nbsp;Another flaw in human character is that everybody wants to build and nobody wants to do maintenance.&nbsp;</li>
<br />
<li>Excellent overview of <a href="https://herbertograca.com/2017/10/05/event-driven-architecture/">Event-Driven Architecture</a>&nbsp;and&nbsp;<a href="https://herbertograca.com/2017/10/19/from-cqs-to-cqrs/">From CQS to CQRS</a>. There are three cases in which to use events: To decouple components. To perform async tasks. To keep track of state changes (audit log).&nbsp;Command Query Separation:&nbsp;asking a question should not change the answer and doing something should not give back an answer.&nbsp;Command Pattern:&nbsp;instead of having a user execute a &ldquo;CreateUser&rdquo; action, followed by an &ldquo;ActivateUser&rdquo; action, and a &ldquo;SendUserCreatedEmail&rdquo; action, we would have the user simply execute a &ldquo;RegisterUser&rdquo; command which would execute the previously mentioned three actions as an encapsulated business process.&nbsp;Command Bus:&nbsp;evolve the Command Invoker into something capable of receiving a Command and figure out what handler can handle it.&nbsp;Command Query Responsibility Segregation:&nbsp;By putting together the concepts of CQS, Command, Query and CommandBus we finally reach CQRS. By using CQRS we can completely separate the read model from the write model, allowing us to have optimised read and write operations. This adds to performance, but also to the clarity and simplicity of the codebase, to the ability of the codebase to reflect the domain, and to the maintainability of the codebase. Again, it&rsquo;s all about encapsulation, low coupling, high cohesion, and the Single Responsibility Principle.</li>
<br />
<li><a href="https://github.com/makerbot/labs">makerbot/labs</a>:&nbsp;Documentation and utilities for experimental usage of MakerBot 3D printing solutions&nbsp;</li>
<br />
<li><a href="https://github.com/Grafeas">github.com/Grafeas</a>:&nbsp;A Component Metadata API. Also,&nbsp;<a href="https://shopifyengineering.myshopify.com/blogs/engineering/how-shopify-governs-containers-at-scale-with-grafeas-and-kritis">How Shopify Governs Containers at Scale with Grafeas and Kritis</a>,&nbsp;<a href="https://cloudplatform.googleblog.com/2017/10/introducing-grafeas-open-source-api-.html">Introducing Grafeas: An open-source API to audit and govern your software supply chain</a>.&nbsp;</li>
<br />
<li><a href="https://github.com/haydenjameslee/networked-aframe#deepstream">haydenjameslee/networked-aframe</a>:&nbsp;A web framework for building multi-user virtual reality experiences.&nbsp;Write full-featured multi-user VR experiences entirely in HTML.</li>
<br />
<li><a href="https://github.com/twitter/torch-decisiontree">twitter/torch-decisiontree</a>:&nbsp;This project implements random forests and gradient boosted decision trees (GBDT). The latter uses gradient tree boosting. Both use ensemble learning to produce ensembles of decision trees (that is, forests).</li>
<br />
<li>Facebook's&nbsp;<a href="http://fbinfer.com/docs/racerd.html">Infer : RacerD</a>&nbsp;(<a href="https://code.facebook.com/posts/293371094514305/open-sourcing-racerd-fast-static-race-detection-at-scale">article</a>):&nbsp;RacerD statically analyzes Java code to detect potential concurrency bugs. This analysis does not attempt to prove the absence of concurrency issues, rather, it searches for a high-confidence class of data races.</li>
<br />
<li><a href="https://purl.stanford.edu/qf934gh3708">Efficient Methods and Hardware for Deep Learning</a>: to efficiently implement "Deep Compression" in hardware, we developed EIE, the "Efficient Inference Engine", a domain-specific hardware accelerator that performs inference directly on the compressed model which significantly saves memory bandwidth. Taking advantage of the compressed model, and being able to deal with the irregular computation pattern efficiently, EIE improves the speed by 13x and energy efficiency by 3,400x over GPU.</li>
<br />
<li><a href="https://arxiv.org/pdf/1701.03980v1.pdf">DyNet: The Dynamic Neural Network Toolkit</a>: a toolkit for implementing neural network models based on dynamic declaration of network structure. In the static declaration strategy that is used in toolkits like Theano, CNTK, and TensorFlow, the user first defines a computation graph (a symbolic representation of the computation), and then examples are fed into an engine that executes this computation and computes its derivatives. In DyNet&rsquo;s dynamic declaration strategy, computation graph construction is mostly transparent, being implicitly constructed by executing procedural code that computes the network outputs, and the user is free to use different network structures for each input. Dynamic declaration thus facilitates the implementation of more complicated network architectures</li>
<br />
<li><a href="https://www.kernel.org/pub/linux/kernel/people/paulmck/perfbook/perfbook.html">Is Parallel Programming Hard, And, If So, What Can You Do About It?</a>: The purpose of this book is to help you program sharedmemory parallel machines without risking your sanity. We hope that this book&rsquo;s design principles will help you avoid at least some parallel-programming pitfalls. That </li>
<br />
<li>said, you should think of this book as a foundation on which to build, rather than as a completed cathedral. Your mission, if you choose to accept, is to help make further progress in the exciting field of parallel programming&mdash;progress that will in time render this book obsolete</li>
<br />
<li><a href="http://www.cs.virginia.edu/~evans/cs655/readings/steele.pdf">Growing a Language</a>: A language design can no longer be a thing. It must be a pattern&mdash;a pattern for growth&mdash;a pattern for growing the pattern for defining the patterns that programmers can use for their real work and their main goal. My point is that a good programmer in these times does not just write programs. A good programmer builds a working vocabulary. In other words, a good programmer does language design, though not from scratch, but by building on the frame of a base language.</li>
<br />
<li><a href="https://blog.acolyer.org/2017/10/19/serverless-computing-economic-and-architectural-impact/">Serverless computing: economic and architectural impact</a>:&nbsp;It&rsquo;s a case study on how serverless computing changes the shape of the systems that we build, and the (dramatic) impact it can have on the cost of running those systems. There&rsquo;s also a nice section at the end of the paper summarising some of the current limitations of the serverless approach.</li>
</ul>
<p>&nbsp;</p>
<p>Hey, just letting you know I've written a new book:&nbsp;<a href="https://www.amazon.com/dp/B0765C4SNR">Explain the Cloud Like I'm 10</a>. It's&nbsp;pretty much exactly what the title says it is. If you've ever tried to explain the cloud to someone, but had no idea what to say, send them this book.</p>
<p>I've also written a novella: <a href="https://smile.amazon.com/Strange-Trial-Ciri-First-Sentient-ebook/dp/B073GCWG6M">The Strange Trial of Ciri: The First Sentient AI</a>. It explores the idea of how a sentient AI might arise as ripped from the headlines deep learning techniques are applied to large social networks. Anyway, I like the story. If you do too please consider giving it a review on Amazon.</p>
<p>Thanks for your support!</p>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2017/10/20/stuff-the-internet-says-on-scalability-for-october-20th-2017.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />Post a Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2017/10/20/stuff-the-internet-says-on-scalability-for-october-20th-2017.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2017%2F10%2F20%2Fstuff-the-internet-says-on-scalability-for-october-20th-2017.html','Stuff%20The%20Internet%20Says%20On%20Scalability%20For%20October%2020th%2C%202017');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2017/10/20/stuff-the-internet-says-on-scalability-for-october-20th-2017.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/35982302"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/hot-links"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />hot links</a></span></span>  <span class="post-snippet-1"><iframe src="http://www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2017/10/20/stuff-the-internet-says-on-scalability-for-october-20th-2017.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2017/10/20/stuff-the-internet-says-on-scalability-for-october-20th-2017.html" data-text="Stuff The Internet Says On Scalability For October 20th,&nbsp;2017" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments </h3>

      
        
          <div class="text">There are no comments for this journal entry.  To create a new comment, use the form below.</div>

        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=35982302"> 

    
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2016, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>