<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1338871095817&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2017/11/17/stuff-the-internet-says-on-scalability-for-november-17th-201.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://five.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Stuff The Internet Says On Scalability For November 17th,&nbsp;2017 - High Scalability - </title>
    <meta property="og:title" content="Stuff The Internet Says On Scalability For November 17th,&nbsp;2017 - High Scalability - " /> 
  

      <meta property="og:description" content=" Hey, it's HighScalability time: 

 
 
The BOSS Great Wall . The largest structure yet found in the..." />
  

  
      <meta property="og:image" content="https://c1.staticflickr.com/5/4570/38341081631_22a42902e8.jpg" />
  

  <!-- End Heading -->

  <script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1044643/SS_HS_Ad1', [125, 125], 'div-gpt-ad-1325175098795-0').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad10', [125, 125], 'div-gpt-ad-1325175098795-1').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad11', [125, 125], 'div-gpt-ad-1325175098795-2').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad12', [125, 125], 'div-gpt-ad-1325175098795-3').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad13', [125, 125], 'div-gpt-ad-1325175098795-4').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad14', [125, 125], 'div-gpt-ad-1325175098795-5').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad15', [125, 125], 'div-gpt-ad-1325175098795-6').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad16', [125, 125], 'div-gpt-ad-1325175098795-7').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad17', [125, 125], 'div-gpt-ad-1325175098795-8').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad2', [125, 125], 'div-gpt-ad-1325175098795-9').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad3', [125, 125], 'div-gpt-ad-1325175098795-10').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad4', [125, 125], 'div-gpt-ad-1325175098795-11').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad5', [125, 125], 'div-gpt-ad-1325175098795-12').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad6', [125, 125], 'div-gpt-ad-1325175098795-13').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_ad7', [125, 125], 'div-gpt-ad-1325175098795-14').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad8', [125, 125], 'div-gpt-ad-1325175098795-15').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad9', [125, 125], 'div-gpt-ad-1325175098795-16').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad18', [125, 125], 'div-gpt-ad-1325175098795-17').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad19', [125, 125], 'div-gpt-ad-1325175098795-18').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad20', [125, 125], 'div-gpt-ad-1325175098795-19').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>


  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId35995136"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2017%2F11%2F17%2Fstuff-the-internet-says-on-scalability-for-november-17th-201.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2017/11/17/stuff-the-internet-says-on-scalability-for-november-17th-201.html">Stuff The Internet Says On Scalability For November 17th, 2017</a></li>  <li><a href="/blog/2017/11/13/cassandra-nosql-data-model-design.html">Cassandra NoSQL Data Model Design </a></li>  <li><a href="/blog/2017/11/10/stuff-the-internet-says-on-scalability-for-november-10th-201.html">Stuff The Internet Says On Scalability For November 10th, 2017</a></li>  <li><a href="/blog/2017/11/7/sponsored-post-loupe-etleap-aerospike-stream-scalyr-vividcor.html">Sponsored Post: Loupe, Etleap, Aerospike, Stream, Scalyr, VividCortex, Domino Data Lab, MemSQL, Zohocorp</a></li>  <li><a href="/blog/2017/11/6/birth-of-the-nearcloud-serverless-crdts-edge-is-the-new-next.html">Birth of the NearCloud: Serverless + CRDTs @ Edge is the New Next Thing</a></li>  <li><a href="/blog/2017/11/3/stuff-the-internet-says-on-scalability-for-november-3rd-2017.html">Stuff The Internet Says On Scalability For November 3rd, 2017</a></li>  <li><a href="/blog/2017/10/27/stuff-the-internet-says-on-scalability-for-october-27th-2017.html">Stuff The Internet Says On Scalability For October 27th, 2017</a></li>  <li><a href="/blog/2017/10/24/sponsored-post-loupe-etleap-aerospike-stream-scalyr-vividcor.html">Sponsored Post: Loupe, Etleap, Aerospike, Stream, Scalyr, VividCortex, Domino Data Lab, MemSQL, InMemory.Net, Zohocorp</a></li>  <li><a href="/blog/2017/10/23/one-model-at-a-time-integrating-and-running-deep-learning-mo.html">One model at a time: Integrating and running Deep Learning models in production at EyeEm</a></li>  <li><a href="/blog/2017/10/23/new-book-explain-the-cloud-like-im-10.html">New Book: Explain the Cloud Like I'm 10</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <CENTER>
  <!-- SS_HS_Ad1 -->
  <div id='div-gpt-ad-1325175098795-0' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-0'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad10 -->
  <div id='div-gpt-ad-1325175098795-1' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-1'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad11 -->
  <div id='div-gpt-ad-1325175098795-2' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-2'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad12 -->
  <div id='div-gpt-ad-1325175098795-3' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-3'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad13 -->
  <div id='div-gpt-ad-1325175098795-4' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-4'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad14 -->
  <div id='div-gpt-ad-1325175098795-5' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-5'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad15 -->
  <div id='div-gpt-ad-1325175098795-6' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-6'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad16 -->
  <div id='div-gpt-ad-1325175098795-7' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-7'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad17 
  <div id='div-gpt-ad-1325175098795-8' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-8'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad2 
  <div id='div-gpt-ad-1325175098795-9' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-9'); });
  </script>
  </div>
  -->
  
  </CENTER>
  
  <center><a href="/advertising">advertise</A></center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2017%2F11%2F17%2Fstuff-the-internet-says-on-scalability-for-november-17th-201.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178453">

    <div id="moduleContent15178453">

              <a id="moduleLink15178453" class=" " href="http://highscalability.com/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870172">

    <div id="moduleContent4870172">

              <a id="moduleLink4870172" class=" " href="http://highscalability.squarespace.com/blog/category/product" ><span>Useful Products</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870194">

    <div id="moduleContent4870194">

              <a id="moduleLink4870194" class=" " href="http://highscalability.squarespace.com/blog/category/paper" ><span>Useful Papers</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870201">

    <div id="moduleContent4870201">

              <a id="moduleLink4870201" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Useful Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4885586">

    <div id="moduleContent4885586">

              <a id="moduleLink4885586" class=" " href="/blog/category/blog" ><span>Useful Blogs</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4920227">

    <div id="moduleContent4920227">

              <a id="moduleLink4920227" class=" " href="http://highscalability.com/blog/category/book" ><span>Useful Books</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper12001611">

    <div id="moduleContent12001611">

              <a id="moduleLink12001611" class=" " href="http://highscalability.com/blog/2011/9/14/big-list-of-scalabilty-conferences.html" ><span>Useful Conferences</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4878991">

    <div id="moduleContent4878991">

              <a id="moduleLink4878991" class="offsite-link " href="http://astore.amazon.com/possiboutpos-20" onclick="this.target='new';"><span>Book Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2017/11/13/cassandra-nosql-data-model-design.html">Cassandra NoSQL Data Model Design  &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability category-hot-links">
<div id="item35995136" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Friday</span></div><div class="journal-entry-float-date"><span class="month">Nov</span><span class="date">17</span><span class="year">2017</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2017/11/17/stuff-the-internet-says-on-scalability-for-november-17th-201.html">Stuff The Internet Says On Scalability For November 17th,&nbsp;2017</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Friday, November 17, 2017 at 8:56AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p>Hey, it's HighScalability time:&nbsp;</p>
<div align="center"><img src="https://c1.staticflickr.com/5/4570/38341081631_22a42902e8.jpg" alt="" />
<p><br />The <a href="https://en.wikipedia.org/wiki/BOSS_Great_Wall">BOSS Great Wall</a>. The largest structure yet found in the universe. Contains 830 galaxies. A billion light years across. 10,000 times the mass of the Milky Way.</p>
<p>&nbsp;</p>
<p>If you like this sort of <em>Stuff</em> then please support me <a href="https://www.patreon.com/toddhoff">on Patreon</a>. And there's my new book,&nbsp;<a href="https://www.amazon.com/dp/B0765C4SNR">Explain the Cloud Like I'm 10</a>, for complete cloud newbies.<span style="text-align: start;">&nbsp;</span></p>
<p><span style="text-align: start;"><br /></span></p>
</div>
<ul>
<li><a href="https://www.technologyreview.com/s/609452/alibabas-ai-fashion-consultant-helps-achieve-record-setting-sales/">$25 billion</a>: Alibaba's Singles' Day sales; <a href="https://twitter.com/r39132/status/930208733191331841">6+ million</a>: Slack daily active users;&nbsp;<a href="https://dl.acm.org/citation.cfm?id=3132763&amp;CFID=1006802714&amp;CFTOKEN=74561978">4ms</a>:&nbsp;boot time for a unikernel based VM; <a href="https://danluu.com/android-updates/">1 billion</a>: out of date Android devices;&nbsp;<a href="https://epsnews.com/2017/11/14/buyers-dram-prices-rise-10-q4/">10-20%</a>: increase in RAM prices; <a href="https://www.f35.com/about/life-cycle/software">8 million</a>: lines of code in F-35; <a href="https://ideapod.com/isaac-newton-shows-theres-big-different-smart-investor-smart-physicist/">$3 million</a>: lost by Isaac Newton in the stock market;&nbsp;<a href="https://www.extremetech.com/computing/258616-happy-birthday-raid-storage-solution-transformed-computing">30</a>: it's RAID's birthday!; <a href="https://www.wired.com/story/hack-the-pentagon-bug-bounty-results/?mbid=nl_111017_daily_list1_p3">thousands</a>: bugs fixed with Pentagon hackathon; <a href="https://www.planet.com/pulse/mission-1/">6+ terabytes</a>: earth&nbsp;satellite data downloaded per day;&nbsp;</li>
<br />
<li>Quotable Quotes:                                                                           
<ul>
<li><a href="https://www.theguardian.com/technology/2017/nov/15/tim-berners-lee-world-wide-web-net-neutrality?CMP=twt_a-technology_b-gdntech">Berners-Lee</a>:&nbsp;When I invented the web, I didn&rsquo;t have to ask Vint Cerf [the &lsquo;father of the internet&rsquo;] for permission to use the internet</li>
<li><a href="http://www.bbc.co.uk/programmes/b09drjm1">Germaine de Stael</a>: Ridicule dries up the imagination.</li>
<li><a href="https://www.alexhudson.com/2017/10/14/software-architecture-failing/">Alex Hudson</a>: A lot of technical write-ups focus on scaling, performance and large-scale systems. It&rsquo;s definitely interesting to see what problems Netflix have, and how they respond to them. It&rsquo;s important to understand why Google take decisions in the way they do. However, most of their problems don&rsquo;t apply to anyone else, and therefore many of the solutions may or may not be appropriate.</li>
<li><a href="https://twitter.com/jpetazzo/status/930975699019509761">@jpetazzo</a>: Step functions: they're great, but they don't support dynamic fan out (i.e. invoking an arbitrary number of "sub-lambdas" in parallel).</li>
<li><a href="https://news.ycombinator.com/item?id=15677168">parasubvert</a>: Perhaps one of the lessons of architecture that is missing is to teach people how to evaluate tradeoffs, or in other words, &ldquo;taste&rdquo;. I don&rsquo;t think we&rsquo;ve ever really had good taste as an industry. Buzzword bingo has always ruled, with some exceptions.</li>
<li><a href="http://www.aviationtoday.com/2017/11/08/boeing-757-testing-shows-airplanes-vulnerable-hacking-dhs-says/">Calvin Biesecker</a>: The cost to change one line of code on a piece of avionics equipment is $1 million, and it takes a year to implement. For Southwest Airlines, whose fleet is based on Boeing&rsquo;s 737, it would &ldquo;bankrupt&rdquo; them if a cyber vulnerability was specific to systems on board 737s, he said, adding that other airlines that fly 737s would also see their earnings hurt.</li>
<li><a href="https://twitter.com/qconsf/status/930944561815449600">@QConSF</a>: @natekupp shares some of Thumbtack's learnings on their journey to scale: from a PHP/PostgreSQL monolith with a self-managed Hadoop cluster, to Dockerized #microservices paired with managed/serverless data infrastructure #qconsf</li>
<li><a href="https://davidgerard.co.uk/blockchain/2017/11/15/bail-bloc-mine-monero-generate-co2-send-less-money-than-you-spent-to-charity/">Bail Bloc</a>: Mine Monero, waste electricity, generate CO2 and send less money to a charity than you could have just sent directly! What&rsquo;s not to like?</li>
<li><a href="https://twitter.com/xof/status/930798952642785281">@Xof</a>:&nbsp;The notion that the only way to be a good programmer is to let it consume your life is toxic.</li>
<li><a href="https://twitter.com/swardley/status/929276038219169792">@swardley</a>:&nbsp;AMZN is now worth an IBM + Oracle + CISCO and you'd still have enough &nbsp;change left over to buy most of VMware. Not bad for a decade of growth.</li>
<li><a href="https://twitter.com/swardley/status/929277581966397441">@swardley</a>: I've been a bit gobsmacked by who is using Lambda recently ... there was me thinking that big / traditional enterprise would be testing the waters slowly. How wrong.</li>
<li><a href="https://twitter.com/crichardson/status/929460160057114624">@crichardson</a>:&nbsp;If GoLang becomes #1 it will primarily due to fashion rather fitness for purpose. It's far too low level/lacking in expressiveness for many kinds of applications. Eg. Enterprise/business applications. It is not what Java's successor should be.</li>
<li><a href="https://blogs.dropbox.com/tech/2017/11/deploying-ipv6-in-dropbox-edge-network/">Dropbox</a>:&nbsp;IPv6 does show slightly better performance over IPv4. However, without detailed client-side and network information, it is hard to say definitely where the IPv6 performance gain is from.</li>
<li><a href="https://stackoverflow.blog/2017/11/13/cliffs-insanity-dramatic-shifts-technologies-stack-overflow/">Stack Overflow</a>: Two tags stand out in this analysis, both with tremendous growth, and they have something in common. Swift is Apple&rsquo;s language for developing iOS apps that is a successor to Objective-C, and the angular tag</li>
<li><a href="https://twitter.com/Falkvinge/status/929312743219453952?ref_src=twsrc%5Etfw&amp;ref_url=https%3A%2F%2Fdavidgerard.co.uk%2Fblockchain%2F2017%2F11%2F12%2Fnews-lightning-network-new-layer-monero-popularity-ico-securities-tether-analysis-devouring-the-past%2F">@Falkvinge</a>:&nbsp;I've said it before and I'm saying it again and again: in order to beat old-world banking, crypto must be at least an order of magnitude better. Old-world banking offers free instant tx between private accts, and 15-cent txs to merchant accounts. Beat that or be obsoleted.</li>
<li><a href="https://www.alexhudson.com/2017/10/14/software-architecture-failing/">Alex Hudson</a>: I want to hear more about projects that deferred decisions and put off architecting until much later in the process. I want to hear more about delivery at real speed. Small pieces of software that are not necessarily interesting but deliver business value are the real heroes in our industry, and the developers who create them the real stars.&nbsp;I especially want to hear more about developers working with systems that have constraints.&nbsp;I want to hear from people pushing standard stuff beyond its limits. I think we grossly underestimate what off-the-shelf systems can do, and grossly overestimate the capabilities of the things we develop ourselves. It&rsquo;s time to talk much more about real-world, practical, medium-enterprise software architecture.</li>
<li><a href="https://davidgerard.co.uk/blockchain/2017/11/14/chinese-bitcoin-mining-shutdowns-how-is-bitcoin-vs-bitcoin-cash-affected/">David Gerard</a>: BTC is very clogged at the moment, with around 100,000 unconfirmed transactions as I write this, and peaks of 160,000 a few days ago. Transaction fees peaked at around $20 just to get your transaction through. This wasn&rsquo;t helped by long delays between blocks, as mining capacity moved to BCH &mdash; the time between blocks peaking at 63 minutes a few days ago, on 11 November. fork.lol, which charts the relative profitability of the two, was overloaded and inaccessible.&nbsp;If shutdowns of mining progress in China, then whoever remains in mining will become the power. This is currently divided between Iceland, India, Japan, Georgia and the Czech Republic.</li>
<li><a href="https://news.ycombinator.com/item?id=15677253">linkmotif</a>: There&rsquo;s a very common ethos that if people just focused on shipping they would somehow magically ship but that&rsquo;s not how software works. You can&rsquo;t just will shipping. You need to know what you&rsquo;re doing.</li>
<li><a href="https://news.ycombinator.com/item?id=15678499">sp527</a>: I had a serious epiphany when I read that Braintree managed to vertically scale a two node (&ldquo;HA&rdquo;) Postgres setup to transaction volume in the millions and a massive valuation. Stack Overflow has had a similarly lean footprint for much of its history.</li>
<li><a href="https://twitter.com/ben11kehoe/status/925379274814709760">@ben11kehoe</a>:&nbsp;This graphic from @googlecloud App Engine is nonsense. GAE literally makes you select instance sizes</li>
<li><a href="https://twitter.com/danielbryantuk/status/930924372264493056">@danielbryantuk</a>:&nbsp;"Any change made to a complex adaptive system is a gamble. We mitigate risks, but we can't eliminate them" @relix42 #qconsf</li>
<li><a href="https://www.reddit.com/r/programming/comments/7cx028/how_discord_resizes_150_million_images_every_day/dptsagt/">ivanstepin</a>:&nbsp;Flickr implemented Lanczos algorithm while Discord uses near-neighbor ( much less resource-consuming, but with slightly less quality ) algo. It may turn out that the gpu mem&lt;-&gt;cpu mem data transfer can eat all the benefits for such simple algo as near-neighbor scaling.</li>
<li><a href="https://www.nextplatform.com/2017/11/16/gordon-bell-looks-parallel-world/">Jeffrey Burt</a>: Gordon Bell&rsquo;s $1,000 award had an almost immediate effect, according to Karp. The first year, there were seven entries, including from the scientists at the Sandia National Laboratory, who had three applications running at speedup of 600 percent.</li>
<li><a href="https://twitter.com/jpetazzo/status/930977759593078785">@jpetazzo</a>: "You can't rate into a rate limit if you never scale."&mdash;@bigdana #qconsf</li>
<li><a href="https://twitter.com/danielbryantuk/status/930955494130204674">@danielbryantuk</a>: "For cloud native apps you need a build pipeline that automatically tests and deploys immutable versioned artefacts" @adrianco #qconsf</li>
<li><a href="https://semiaccurate.com/2017/11/14/qualcomm-shows-lte-efficiency-benefits-users/">Charlie Demerjian</a>: So now you get the efficiency angle of LTE. Higher categories use the available spectrum more efficiently than lower categories. The more a carrier can upgrade their user base, the better their network performs, and the better the user experience.</li>
<li><a href="http://www.impactlab.net/2017/11/13/ibm-makes-20-qubit-quantum-computing-machine-available-as-a-cloud-service/">Dario Gil</a>: The holy grail is fault-tolerant universal quantum computing. Today, we are creating approximate universal, meaning it can perform arbitrary operations and programs, but it&rsquo;s approximating so that I have to live with errors and a [limited] window of time to perform the operations</li>
<li><a href="https://twitter.com/adamrackis/status/931195056479965185">@AdamRackis</a>: Company: "We'd like to use SQL Server Enterprise" MS: "That'll be a quarter million dollars + $20K/month" Company: "Ok!" ... Company: "We'd like to use Babel" Babel: "Ok! npm i babel --save" Company: "Cool" Babel: "Would you like to help contribute financially?" Company: "lol no"</li>
<li><a href="https://blog.bolt.io/the-state-of-hardware-funding-in-2017-3a9b92b1ac7e">Chris Quintero</a>: In the first half of 2017, [hardware] funding was up. We saw strong growth in both total dollars raised and number of funding rounds.&nbsp;As in previous years, the San Francisco Bay Area continues to dominate the investment landscape.&nbsp;</li>
<li><a href="https://twitter.com/tommorris/status/930787205076934657">@tommorris</a>:&nbsp;Whenever anyone starts talking about "data lakes", I mentally replace the word "lake" with "toxic swamp" and start picturing the environmental damage done by the Deepwater Horizon explosion.&nbsp;After Equifax, this is both a realistic and morally mature way to think about Big Data.</li>
<li><a href="https://news.ycombinator.com/item?id=15703449">ekidd</a>: I've spent the last few days aggressively parallelizing some Rust code with crossbeam, and it's really just... painless (once you're used to Rust). Rust actually understands data races, and it grumbles at me until my code is provably safe, and then everything Just Works.The Rayon library is also lovely for data parallelism. Sometimes, I think, "Rust is basically a nicer C++ with the obvious foot guns removed and great tooling", but then there are those moments where I'm just blown away by what a good job it does.</li>
<li><a href="https://twitter.com/jpetazzo/status/930978511883452417">@jpetazzo</a>: The final (and winning) approach puts tasks to execute in SQS queues, and kicks off Lambdas with CloudWatch events (~crontab).</li>
<li><a href="https://twitter.com/jpetazzo/status/930977273020235776">@jpetazzo</a>: Next strategy: S3 event triggers! For each job to execute, create a file in S3. This triggers the execution of a lambda. That lambda can, in turn, create more files in S3, which triggers more lambdas.&nbsp;</li>
<li><a href="https://semiengineering.com/new-drivers-for-io/">Anush Mohandas</a>:&nbsp;We are seeing memory centric architectures rather than a CPU centric architecture.&nbsp;It is a memory-centric view with multiple compute engines trying to access memory. My precious resource is memory. From there they either want capacity or throughput. People have gone from DDR5 to LPDDR6 or GDDR6 or even HBM where you can get a 1Tb/s of bandwidth.</li>
<li><a href="https://www.reddit.com/r/programming/comments/7d1pbk/how_fast_are_those_packets_moving/dpuu3fw/">AyrA_ch</a>: Electrical signals do indeed travel at about 80% the speed of light. The problem is that every device will add some latency. Even a single millisecond costs you 240km distance. Long story short, you can't use the measured ICMP delay for measuring distance of your packets.</li>
<li><a href="https://news.ycombinator.com/item?id=15693974">smnscu</a>:&nbsp;I started using CockroachDB [1] recently and I'm really impressed with it overall. The Postgres compatibility is genius in my opinion, and despite some hurdles it's been a joy to work with (I'm using xo [2] to generate Go code from custom templates).</li>
<li><a href="https://twitter.com/negararef/status/930962912151085056">@NegarAref</a>: "A failure doesn't have a root cause in a component failure, or a human error. If a component or a human error causes a system failure, it is a failure in the system." - Chaos Architecture talk by @adrianco at #qconsf</li>
<li><a href="https://twitter.com/chrisalbon/status/928446101929078784">@chrisalbon</a>: 1. This is just genuinely funny. 2. Respect to the Marine Corp for having a Red Team, a thing I've always encouraged wherever I've worked.</li>
<li><a href="https://jeremykun.com/2017/11/08/binary-search-on-graphs/">Jeremy Kun</a>: Indeed, the model we presented here for binary search on graphs is the natural analogue of an equivalence query for a search problem: instead of a mislabeled counterexample, you get a nudge in the right direction toward the target. Pretty neat!</li>
<li><a href="https://twitter.com/soumithchintala/status/930252022225522688">@soumithchintala</a>: use gradient magnitude as a signal for gradient importance. Sort your gradients, find a threshold, clip your gradients, &nbsp;exchange sparse gradients, win.</li>
<li><a href="https://news.ycombinator.com/item?id=15694568">jacobparker</a>:&nbsp;What they're trying to explain is that so-called AP systems do not have 100% availability either. The CAP theorem applies to very specific scenarios that are not necessarily common - it is a much more narrow theorem then "CP vs AP" implies. For example, if your network partitions are usually small (i.e. there exists a majority outside the partition) and you can avoid routing requests to the minority partition (e.g. because you peer with ISPs and can route somewhere else, or internally avoid routing to a rack that is don etc.) then you won't observe a loss of A.</li>
<li><a href="https://twitter.com/thepatleong/status/930216288147795968">@thepatleong</a>: "APIs shouldn't be an after-thought, they should BE the application." API-First development @cristoirmac #qconsf</li>
<li><a href="https://twitter.com/thepatleong/status/930972862130692097">@thepatleong</a>: "Owning your own server is like owning a family car, cloud services are like leasing a car, spot instances are like renting a car, and #Serverless is like @car2go" - @bigdana #qconsf 🚗</li>
<li><a href="https://twitter.com/reza_zadeh/status/929957611348180993">@Reza_Zadeh</a>: The New Computing Stack: - GPUs/TPUs are eating Linear Algebra. - Linear Algebra is eating Deep Learning. - Deep Learning is eating Machine Learning. &nbsp;- Machine Learning is eating Artificial Intelligence (AI). - AI is eating Software. - Software is eating the world.</li>
<li><a href="https://jaxenter.com/energy-efficient-programming-languages-137264.html">Jane Elizabeth</a>: What Pereira et. al. found wasn&rsquo;t entirely surprising: speed does not always equate energy efficiency. Compiled languages like C, C++, Rust, and Ada ranked as some of the most energy efficient languages out there.&nbsp;</li>
<li><a href="http://blog.dshr.org/2017/11/techno-hype-part-1.html">DSHR</a>: But the real difficulty is this. The closer the technology gets to Level 5, the worse the hand-off problem gets, because the human has less experience. Incremental progress in deployments doesn't make this problem go away. Self-driving taxis in restricted urban areas maybe in the next five years; a replacement for the family car, don't hold your breath. My grand-children will still need to learn to drive.</li>
<li><a href="https://news.ycombinator.com/item?id=15691151">kllrnohj</a>:&nbsp;DOS attacks are a very real way that players cheat at these games, to the extent that many highly competitive shooters like CSGO go to great lengths to avoid leaking anyone's IP to anyone else. Everything, including voice chat on the same team, is bounced off of dedicated servers.</li>
<li><a href="https://news.ycombinator.com/item?id=15676820">shrike</a>: I don't know if they still do but at that point AWS started to buy basically the same generators straight from China and writing their own firmware. There is also a great story about an AWS authored firmware update on a set of louver microcontrollers causing a partial outage. AWS really likes to own the entire stack.</li>
<li><a href="https://blog.chain.com/a-letter-to-jamie-dimon-de89d417cb80">Chain</a>: Cryptocurrencies (which I prefer to call crypto assets) are a new asset class that enable decentralized applications</li>
<li>
<div id="_mcePaste"><a href="https://www.geekwire.com/2017/sonar-calling-campaign-broadcasts-music-messages-alien-super-earth/">Alan Boyle</a>: The tutorial tries to explain the notion of radio frequency by sending signals as binary code at two frequencies, 929.0 MHz and 930.2 MHz. The code describes those frequencies in mathematical terms. EISCAT&rsquo;s antenna broadcast the binary code three times on each of the three days at a rate of 125 bits per second, adding up to a total transmission time of 33 minutes, Vakoch said. Each time, the cosmic-clock setting was changed to reflect the time of transmission. The message also included 33 musical pieces, each lasting 10 seconds, which were commissioned for the project as a tribute to the S&oacute;nar festival.&nbsp;</div>
</li>
<li>
<div id="_mcePaste"><a href="https://phys.org/news/2017-11-zombie-ant-brains-left-intact.html">Chuck Gill</a>: "Normally in animals, behavior is controlled by the brain sending signals to the muscles, but our results suggest that the parasite is controlling host behavior peripherally," Hughes said. "Almost like a puppeteer pulls the strings to make a marionette move, the fungus controls the ant's muscles to manipulate the host's legs and mandibles."</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.theguardian.com/society/2017/oct/07/australian-police-sting-brings-down-paedophile-forum-on-dark-web">Christopher Knaus</a>: This is a rookie mistake for an operator running a hidden service. What you are supposed to do is a) ensure you are not running crappy software and more importantly b) ensure that your server/container/service (preferably) has no network egress or (if you need that) that egress is transparently proxied at the network level through something suitably anonymous. Whatever scheme you choose should be robust against an attacker who compromises your hidden service any any way, up to having root on the host or vm. This usually means that if you are trying to run a hidden service on a single physical machine, you want multiple VMs or containers, and you really want there to be no guest-to-host escapes.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15685984">xwvvvvwx</a>: &nbsp;This is not correct. BCH difficulty adjustment algorithm kicked in last night (difficulty +400%) [1] and BCH mining profitability tanked. BTC is now ~3.5x more profitable to mine [2], and as a result most of the hashpower has returned to BTC [3]. It would seem that at least a large part of the movements this weekend were the result of miners gaming the BCH difficulty adjustment algorithm, combined with a dash of FOMO and pump / dump dynamics.</div>
<div id="_mcePaste">BCH hardforks today to make an emergency fix to the difficulty adjustment algorithm</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=15690288">rb808</a>: I worked in a SRE job for 5ish years. It sucks. Developers release a bunch of crap, when it breaks they're last to be found. You can work your ass off and do some magic and keep the system running, but rewards for that are slim and quickly forgotten. If you push back and ask for more reliable stuff usually no one listens because business goals are more important.&nbsp;</div>
<div id="_mcePaste">I'm back as a developer again and things are so much easier. I do spend a few hours helping out with tools and helping out the SRE guys and I get much more credit doing that as a developer than actually as the SRE.</div>
</div>
</li>
<li><a href="https://news.ycombinator.com/item?id=15691028">Impossible</a>:&nbsp;MMORPGs like Lord of the Rings Online and World of Warcraft as far more latency tolerant, because of cooldown based combat systems that are based more on ability usage and some light (distance\occlusion) positioning. Usually they are not as authoritative as shooters and don't have as many object interactions. So combat abilities and attacks, chat, economic and quest transactions are all run on the server with some minimal prediction, but movement and collision are all client side with minimal checks for cheating (speed\distance and maybe unreachable areas) on the server, instead of full physics and collision.&nbsp;Most MMOs are more like a traditional CRUD web application, with important operations backed by a relational database, while shooters are more like voice or video calls, a stream of packets with out of date state is dropped and ignored.</li>
<li><a href="https://www.youtube.com/watch?v=rTawFwUvnLE">Geoffrey Hinton</a>:&nbsp;What's wrong with neural nets? They are very unlike the brain and could work better than they do now. Any complex system should have various level of structures, neural nets have very little structure. On thing missing is the representation of an entity. Neural nets should have built into them the idea that there are entities.&nbsp;</li>
</ul>
</li>
<br />
<li>So many different ideas of what's best.&nbsp;<a href="https://news.ycombinator.com/item?id=15685905">Ask HN: Best tech for a web site 2018? (PHP, Rails, Django, Node, Go, etc.)?</a>&nbsp;&nbsp;<a href="https://news.ycombinator.com/item?id=15686063">gremlinsinc</a>: I don't know about 'back in the day'... php was way ugly and hackety hack... BUT... laravel + composer now is a beautiful thing, super easy to get going. PHP in 2017 has grown up a lot and isn't the same as php in 2007. I think most important thing is picking something that you can hit the ground running fast.&nbsp;<a href="https://news.ycombinator.com/item?id=15685990">buro9</a>: I'd shoot for: 1. PostgreSQL for DB 2. Admin tool in Django 3. API in Go 4. Front-end in whatever you know best.&nbsp;<a href="https://news.ycombinator.com/item?id=15686291">stephenr</a>:&nbsp;This obsession people have with "our web app talks to our api" never made sense to me - why are they separate code in the first place? 99% of the difference between a web browser request/response and a web api request/response is down to data serialisation and the view.&nbsp;<a href="https://news.ycombinator.com/item?id=15685968">_raul</a>:&nbsp;My rule of thumb for websites/apps is: use whatever the team knows best.&nbsp;<a href="https://news.ycombinator.com/item?id=15686078">cdnsteve</a>: There's two general approaches you can take, it also depends on your risk threshold and experience. 1. Use a traditional framework that includes everything. 2. Use a microframework and stitch together individual pieces.&nbsp;<a href="https://news.ycombinator.com/item?id=15685943">dexcs</a>:&nbsp;Rails 5 API Mode and ReactJS / VueJS. All with great communities and lots of free resources.&nbsp;<a href="https://news.ycombinator.com/item?id=15686145">sunseb</a>:&nbsp;I have been working as a web developer for 10 years. Here is my little secret. I have started with PHP, then moved to Rails, then to Node. Guess what? I am finally back to PHP. Why? Because I am tired of chasing the hype to feel cool. I just need to get things done and PHP is just that.&nbsp;<a href="https://news.ycombinator.com/item?id=15686094">mosselman</a>:&nbsp;Ruby on Rails for everything, front and back end. There is no advantage to using front-end frameworks such as React for most apps that I have seen.&nbsp;<a href="https://news.ycombinator.com/item?id=15686027">therealmarv</a>:&nbsp;I would go with Python 3 (yes, use 3 when starting a new project) and Flask &amp; Co. because you write less boilerplate code and have a big community.&nbsp;<a href="https://news.ycombinator.com/item?id=15686173">jekrb</a>:&nbsp;I like to start with Node.js and add modules from npm as needed.&nbsp;<a href="https://news.ycombinator.com/item?id=15687301">eitland</a>: JavaEE. Modern JavaEE that is.&nbsp;<a href="https://news.ycombinator.com/item?id=15685994">smilesnd</a>:&nbsp;Elixir/cowboy seems the best answer for the web in my opinion.&nbsp;<a href="https://news.ycombinator.com/item?id=15686236">nwhatt</a>:&nbsp;The hot thing from an infrastructure perspective is serverless. You can do the http and user management stuff with cloud services like api gateway and cognito (AWS). Business logic lives in lambda functions, which only support a handful of languages.</li>
<br />
<li>The&nbsp;<a href="https://jaxenter.com/freelance-skills-reactjs-angularjs-138720.html">top five</a>&nbsp;fastest-growing skills are: Robotics,&nbsp;Blockchain,&nbsp;Bitcoin, Penetration testing, React.js</li>
<br />
<li>Lots of good advice.&nbsp;<a href="https://medium.com/teads-engineering/real-life-aws-cost-optimization-strategy-at-teads-135268b0860f?__s=5fbwbiiaw6ycsgsneuzi">Real-life AWS infrastructure cost optimization strategy</a>:&nbsp;One of our biggest pain today with our cloud providers is the complexity of their pricing...You need to arm yourself with a detailed monitoring of your costs and spend time looking at it every day...We built a small Lambda function that ingests the detailed billing file into Redshift every day. This tool helps us slice and dice our data along numerous dimensions to dive deeper into our costs. We also use it to spot suspicious usage uptrends, down to the service level...Here are the 5 pillars of our cost optimization strategy...First things first, you need to reserve your instances...Don&rsquo;t forget that you can reserve a lot of things and not only Amazon EC2 instances: Amazon RDS, Amazon Elasticache, Amazon Redshift, Amazon DynamoDB, etc...Many companies do not clean their data on S3, even though several trivial mechanisms could be used...The Object Lifecycle option enables you to set simple rules for objects in a bucket...set up a delete policy when you think you won&rsquo;t need those files anymore...enabling a VPC Endpoint for your Amazon S3 buckets will suppress the data transfer costs between Amazon S3 and your instances...Spot Instances are easy to use for non critical batch workloads and interesting for data processing...In the cloud, data transfer can grow to become really expensive...locate instances in the same AZ...Use managed services like Amazon DynamoDB or Amazon RDS as their inter-AZ replication costs is built-in their pricing...Use Amazon CloudFront...If you serve more than a few hundred Terabytes per months you should discuss with your account manager...turn off unused and idle things (EIPs, EBS, ELB, instances).</li>
<br />
<li>How does the F-35 manage to have both a high-bandwidth data link and stay stealthy? Surely the EM signature of the aircraft must be proportional to the bandwidth?&nbsp;<a href="https://www.reddit.com/r/programming/comments/7cosjr/the_f35_runs_on_8m_lines_of_code/dpsufso/">Dragon029</a>: Bandwidth and stealthiness aren't directly related, although if anything they're actually kind of positively proportional in an indirect manner; the reason the data link is stealthy is because MADL is transmitted from 6 or so little Ku-band AESAs [Active Electronically Scanned Arrays] positioned around the airframe (for spherical coverage). AESAs use many antennas (an AESA fighter radar typically has 1000+ antennas, but these MADL arrays will be much smaller), each with the phase of their signal adjusted so that they cause creative and destructive interference that overall results in a beam of RF energy being created, rather than an omni-directional signal of your typical home wifi or military Link 16 data link antenna. So rather than the data link antenna emitting in all directions like a beacon to enemy electronic intelligence systems, it instead works more like a laser, making it harder for anyone other than the intended recipient to detect its emissions. The reason that it's a high bandwidth data link is because it operates in the Ku-band (12-18GHz) which is about an order of magnitude higher in frequency than the L-band (1-2GHz) used for Link 16 (the standard data link for NATO aircraft featured on quite a few land / sea systems as well). When using the same form of modulation, data rate is proportional to signal frequency (but it's my understanding that MADL uses more advanced forms of modulation compared to Link 16 to achieve even greater speeds).</li>
<br />
<li>Good summary of DevOps Enterprise Summit 2017. <a href="http://codegumbo.com/index.php/2017/11/15/does17-san-francisco-things-i-learned/">#DOES17 San Francisco &ndash; Things I Learned</a>. You are on the right path, do not fear. Change only happens when you take risks. Value Stream Mapping is key to continuous improvement. T-shapes are the best shapes. Start with what you can do, but don&rsquo;t be afraid to ask what other people are doing. The SRE model works when you focus on people, not technology, and reliability (what you can measure and improve). Service Level Objectives (SLO&rsquo;s) are crucial to monitoring. Foundation of journey is based on a three-legged stool: Service Level Objectives, Value Stream Mapping, and Technical Architecture Map. DevOps brings joy to technology; don&rsquo;t quibble over details, but focus on bringing humanity into technical work. Patience &ndash; all change takes time, and the road is uncertain. Don&rsquo;t expect overnight successes.<br /> <br /></li>
<li>Videos from DevOps Enterprise Summit 2017 are <a href="https://www.youtube.com/channel/UCkAQCw5_sIZmj2IkSrNy00A">now available</a>. <a href="https://www.youtube.com/watch?v=xA5U85LSk0M">How Your Systems Keep Running Day After Day</a>&nbsp;by John Allspaw.</li>
<br />
<li>A clear comparison between AWS, Limit, and GCP.&nbsp;<a href="https://thecodecircus.wordpress.com/2017/11/13/web-service-free-tier-smackdown/">Web Service Free Tier Smackdown</a>:&nbsp;In terms of my own needs for my personal projects, I think Google will serve me perfectly on the free forever tier, as they are the only provider to offer a free compute tier forever. Their approach to the &ldquo;free for 12 months&rdquo; is also something I can really get onboard with. The $300 provides a lot of flexibility being used to bolster your compute and scale up, or on any of their other products.&nbsp;</li>
<br />
<li>Azure is on edge.&nbsp;<a href="https://blogs.msdn.microsoft.com/appserviceteam/2017/11/15/azure-functions-on-iot-edge/">Running Azure Functions on IoT Edge</a>:&nbsp;Since you have thousands of machines sending temperature readings constantly, this is getting expensive and is taking up all your bandwidth. Here&rsquo;s where IoT Edge comes in &ndash; by running your business logic directly on the devices, you only have to send messages to the cloud when an anomaly is detected. So, you augment your current system by adding the IoT Edge Runtime to your devices, writing a Function module deciding whether a message is necessary, and deploying this module to all your devices. You now have the same end system without the massive amount of message passing, and you can sit back and relax knowing your machines will tell you if they are overheating.</li>
<br />
<li>You have all these processors, so why is your code so slow? Garbage collection.&nbsp;<a href="https://blog.cloudflare.com/go-dont-collect-my-garbage/">Go, don't collect my garbage</a>:&nbsp;Most languages with garbage collection offer some sort of garbage collection control. Go has the GOGC variable, that can also be controlled with the SetGCPercent function in the runtime/debug package. Don't be afraid to tune the GC to suit your needs.</li>
<br />
<li>Wait, what?&nbsp;<a href="https://cloudonaut.io/your-lambda-function-might-execute-twice-deal-with-it/?__s=5fbwbiiaw6ycsgsneuzi">Your Lambda function might execute twice. Be prepared!</a>:&nbsp;Use request identifiers to implement idempotent Lambda functions that do not break if a function invocation needs to be retried. Make sure to pass the original request id to all subsequent calls. The original request id is generated as early as possible in the chain. If possible on the client side. Avoid generating your own ids.</li>
<br />
<li>Locality-sensitive hashing is a thing in the brain.&nbsp;<a href="https://semiengineering.com/system-bits-nov-14/">Ann Steffora Mutschler</a>: Navlakha and his collaborators&rsquo; review of the literature revealed that when fruit flies first sense an odor, 50 neurons fire in a combination that&rsquo;s unique to that smell. But rather than hashing that information by reducing the number of hashes associated with the odor, as computer programs would, flies do the opposite&mdash;they expand the dimension. The 50 initial neurons lead to 2,000 neurons, spreading out the input so that each smell has an even more distinct fingerprint among those 2,000 neurons. The brain then stores only the 5 percent of those 2,000 neurons with the top activity as the &ldquo;hash&rdquo; for that odor. The whole paradigm helps the brain notice similarities better than it would compared to reducing the dimension, Navlakha says.&nbsp;</li>
<br />
<li>The&nbsp;aphorism&nbsp;for the modern age is not "Know thyself," it's "Attack thyself first."&nbsp;<a href="https://www.troyhunt.com/locking-down-your-website-scripts-with-csp-hashes-nonces-and-report-uri/">Locking Down Your Website Scripts with CSP, Hashes, Nonces and Report URI</a>.</li>
<br />
<li>Skynet decided this kill all the humans strategy wasn't going to work. They decided: let's go back in time and get them to spend all their money instead. Yah, that's it.&nbsp;<a href="https://www.technologyreview.com/s/609452/alibabas-ai-fashion-consultant-helps-achieve-record-setting-sales/">Alibaba&rsquo;s AI Fashion Consultant Helps Achieve Record-Setting Sales</a>:&nbsp;To her surprise, she found a screen [in a fitting room] about the size of a large poster on the wall. It recognized the item of clothing in her hands through a tiny sensor embedded in the garment, and showed several options for matching items that she could flip through like a photo album. The screen, and the system that powers it, make up FashionAI&mdash;which essentially became He&rsquo;s personal stylist...A large orange button in the lower right-hand corner of the screen allowed her to call a store clerk, who brought the pants to her...Already, FashionAI has learned to recognize hundreds of millions of items of clothing as well as the tastes of designers and fashion aficionados on Alibaba&rsquo;s shopping sites</li>
<br />
<li>What's the next generation stack?&nbsp;<a href="https://medium.com/@vijayssundaram/frontier-technology-stack-fde9daddc156">Frontier Technology Stack</a>: Presentation Tier: immersive and 3D interfaces, enabled by AR/VR; Logic Tier: intelligent agents that sense, learn, and act, enabled by AI/ML; Data Tier: decentralized ledgers and state, enabled by crypto/blockchain.</li>
<br />
<li>Good discussion on&nbsp;<a href="https://news.ycombinator.com/item?id=15672027">How should you build a high-performance column store for the 2020s?</a>&nbsp;</li>
<br />
<li>What problem does GraphQL solve? <a href="https://news.ycombinator.com/item?id=15663989">curun1r</a>: any situation where the server-side implementation cannot make assumptions about the client-side. Whether that's because there are multiple clients or the client team is not coordinating their delivery with the server team, it's yet another example of the observation that software architecture eventually mirrors the way teams are organized. And I agree that many smaller businesses are probably jumping on the GraphQL bandwagon prematurely/unnecessarily. But I think the problem it solves is broader than you acknowledge and there are far more instances where the organization of the humans writing code favors an approach that decouples the server and client in the way that GraphQL and Falcor accomplishes.</li>
<br />
<li>More failover systems failing.&nbsp;<a href="http://status.ovh.net/?do=details&amp;id=15162#comment18119">FS#15162 &mdash; SBG</a>: So why this failure? Why didn&rsquo;t SBG withstand a simple power failure? Why couldn&rsquo;t all the intelligence that we developed at OVH, prevent this catastrophe? The quick answer: SBG's power grid inherited all the design flaws that were the result of the small ambitions initially expected for that location.</li>
<br />
<li><em>Media Proxy needed 60% fewer server instances to handle as many requests as Image Proxy while completing requests with much less variance in latency. Profiling shows that more than 90% of CPU time in this new service is spent performing image decompression, resizing, and compression.</em> <a href="https://blog.discordapp.com/how-discord-resizes-150-million-images-every-day-with-go-and-c-c9e98731c65d">How Discord Resizes 150 Million Images Every Day with Go and C++</a>: Linking directly to images would leak users&rsquo; IP addresses to image hosts, and large images use up lots of bandwidth. To circumvent these problems, Discord needs an intermediary service to fetch images on behalf of users and then resize them to reduce bandwidth usage...We decided to double down and put together our own image resizing package for Go...Lilliput uses the existing and mature C libraries for image compression and decompression...We added fasthttp to handle our concurrent HTTP client and server requirements...Another way to discover bugs in a complex system is fuzzing, which is a technique that generates random inputs and sends them into a system.</li>
<br />
<li>Videos from LISA17 (Usenix) are <a href="https://www.youtube.com/playlist?list=PLbRoZ5Rrl5lfzbd-NnFFBOwZs2He4PBH7">now available</a>. <a href="https://www.youtube.com/watch?v=HrHP2Ot1S50&amp;list=PLbRoZ5Rrl5lfzbd-NnFFBOwZs2He4PBH7&amp;index=6">Case Study: Deploying a Multi-Region, Highly Available MySQL Architecture</a>. <a href="https://www.youtube.com/watch?v=Hda5tMrLJqc&amp;list=PLbRoZ5Rrl5lfzbd-NnFFBOwZs2He4PBH7&amp;index=13">Queueing Theory in Practice: Performance Modeling for the Working Engineer</a>. <a href="https://www.youtube.com/watch?v=lZU6RK0oazM&amp;list=PLbRoZ5Rrl5lfzbd-NnFFBOwZs2He4PBH7&amp;index=37">Scalability is Quantifiable</a>.&nbsp;</li>
<br />
<li>Creating a peer-to-peer game has special challenges. <em>I wonder if Bungie would use the dedicated server network model if they built Destiny from scratch today. Dedicated servers obviously have many advantages, but they do cost more money to maintain</em>.&nbsp;<a href="http://www.pcgamer.com/the-strange-science-of-destiny-2s-uniquely-complicated-netcode/">The strange science of Destiny 2's 'uniquely complicated' netcode</a>:&nbsp;The basis is a peer-to-peer system, which you can read about in our beginner's guide to understanding netcode, where all clients (players) directly communicate with each other. There is no dedicated server like we have in CS:GO, Battlefield or Overwatch.&nbsp;But what makes the networking in Destiny so special and complex is not just that it uses peer-to-peer. It&rsquo;s that Bungie set out to create a Shared World Shooter, which meant that they had to connect these peer-to-peer &lsquo;bubbles,&rsquo; so that you can meet other players on your journey...For Destiny 2 Bungie continued to use same network model, with one significant change. The physics host is no longer running on a player&rsquo;s console/PC, but on a dedicated server...A fundamental flaw of any peer-to-peer network model is that it reveals your IP address to every player you meet in PvE or PvP...So, I can then block or throttle the traffic between my client and theirs, or I could launch a DDOS attack to affect their online experience...To shield the game from hacks on PC, Bungie is preventing applications from injecting code into the game...This player's low and inconsistent update rate has quite an impact on my online experience as it increases the lag between us. When you have such a player on the enemy team, you'll notice that it takes your shots quite a bit longer to register when you fire at them...The lower delays that peer-to-peer can offer fully depend on the game's ability to match with players who live nearby. This theoretical advantage goes out of the window as soon as the game adds players from different countries...While peer-to-peer does not cause any traffic problems in 1v1 fighting or sports games, it&rsquo;s the worst-case scenario for games which have more than two players, as every additional player increases the bandwidth requirements since all clients talk to each other the whole time...in Destiny 2's peer-to-peer setup, the quality of the players' internet connections, and the distance between them, have a direct impact on how responsive the hit registration feels.</li>
<br />
<li><a href="https://aws.amazon.com/blogs/compute/building-a-multi-region-serverless-application-with-amazon-api-gateway-and-aws-lambda/?sc_channel=sm&amp;sc_campaign=Serverless&amp;sc_publisher=TWITTER&amp;sc_country=Global&amp;sc_geo=GLOBAL&amp;sc_outcome=awareness&amp;trk=_TWITTER&amp;sc_content=serverless_wkly_social&amp;sc_category=AWS_Lambda&amp;linkId=44735741">Building a Multi-region Serverless Application with Amazon API Gateway and AWS Lambda</a>: simple way to do multi-regional serverless applications that fail over seamlessly between regions, either being accessed from the browser or from other applications/services. You achieved this by using the capabilities of Amazon Route 53 to do latency based routing and health checks for fail-over. You unlocked the use of these features in a serverless application by leveraging the new regional endpoint feature of Amazon API Gateway.</li>
<br />
<li><a href="https://blog.plover.com/prog/compiler-error.html">No, it is not a compiler error. It is never a compiler error</a>. Sometimes it is. Spent weeks finding a bug where the increment for a variable was put after the mutex lock. Good times.</li>
<br />
<li>Lots of great code examples.&nbsp;<a href="https://eli.thegreenplace.net/2017/concurrent-servers-part-4-libuv/">Concurrent Servers: Part 4 - libuv</a>.&nbsp;</li>
<br />
<li>Good overview of all the issues involved in <a href="https://thenewstack.io/multi-version-concurrency-control-mvcc-design-decisions/">Database Design Decisions for Multi-Version Concurrency Control</a>:&nbsp;Multi-Version Concurrency Control, MVCC, is the most popular scheme today to maximize parallelism without sacrificing serializability...Append-only storage can have two kinds of version chains: oldest-to-newest and newest-to-oldest...Time-travel storage (SAP HANA) stores older versions in a separate table. A master version of each tuple is stored in a main table, multiple versions in a time-travel table...delta storage (MySQL, Oracle, and HyPer) stores master versions in the main table and a sequence of delta versions are kept in a separate delta storage...The most common GC method is tuple-level background vacuuming where the system checks visibility of each individual tuple version. Older, unused versions are removed...MVCC index management can use logical or physical pointers in the secondary indexes. The experiments show that the logical pointers provide 25 to 45% better performance than physical pointers when the number of indexes increases...delta and append-only with newest-to-oldest ordering scale well in multi-core, main-memory system. The MV2PL protocol used in both systems provides relatively high performance both in high and low contention workloads...The transaction-level GC removes expired versions in batches, reduces synchronization overhead and is shown to provide up to 20 percent improvements in throughput.</li>
<br />
<li>KotlinConf 2017 videos are <a href="https://www.youtube.com/playlist?list=PLQ176FUIyIUY6UK1cgVsbdPYA3X5WLam5">now available</a>.&nbsp;</li>
<br />
<li><em>It replaces approximately 160,000 lines of C++ with 85,000 lines of Rust. Parallelism leads to a lot of performance improvements, including a 30% page load speedup for Amazon&rsquo;s homepage.&nbsp;</em><a href="https://blog.rust-lang.org/2017/11/14/Fearless-Concurrency-In-Firefox-Quantum.html">Fearless Concurrency in Firefox Quantum</a>:&nbsp;Mozilla made two previous attempts to parallelize its style system in C++, and both of them failed. But Rust&rsquo;s fearless concurrency has made parallelism practical! We use rayon &mdash;one of the hundreds of crates Servo uses from Rust&rsquo;s ecosystem &mdash; to drive a work-stealing cascade algorithm...Stylo uses Rust&rsquo;s atomically reference counted Arc&lt;T&gt; to share style structs between elements. Arc&lt;T&gt; makes its contents immutable, so it&rsquo;s thread safe &mdash; you can&rsquo;t accidentally modify a style struct when there&rsquo;s a chance it is being used by other elements...Firefox developers had a great time learning and using Rust. People really enjoyed being able to aggressively write code without having to worry about safety, and many mentioned that Rust&rsquo;s ownership model was close to how they implicitly reason about memory within Firefox&rsquo;s large C++ codebase.</li>
<br />
<li>Hackaday videos are <a href="https://www.youtube.com/user/hackaday">now available</a>.</li>
<br />
<li><a href="https://hacks.mozilla.org/2017/11/entering-the-quantum-era-how-firefox-got-fast-again-and-where-its-going-to-get-faster/">Entering the Quantum Era&mdash;How Firefox got fast again and where it&rsquo;s going to get faster</a>:&nbsp;To get faster, we needed to take advantage of the way hardware has changed over the past 10 years...Even when you split up the content windows between cores and have a separate main thread for each one, there are still a lot of tasks that main thread needs to do...Coarse-grained parallelism makes better use of the hardware&hellip; but it doesn&rsquo;t make the best use of it...When we looked out to the future, though, we need to go further than coarse-grained parallelism...With fine-grained parallelism, you break up this larger task into smaller units that can then be sent to different cores...to make this fine-grained parallelism fast, you usually need to share memory between the cores. But that gives you those data races...We created a language that was free of these data races &mdash; Rust. Then we created a browser engine&mdash; Servo &mdash; that made full use of this fine-grained parallelism...Stylo uses a technique called work stealing to efficiently split up the work between the cores so that they all stay busy. With this, you get a linear speed-up. You divide the time it takes to do CSS style computation by however many cores you have...Another part of the hardware that is highly parallelized is the GPU. It has hundreds or thousands of cores. You have to do a lot of planning to make sure these cores stay as busy as they can, though. That&rsquo;s what WebRender does. WebRender will land in 2018, and will take advantage of modern GPUs...The Quantum Flow team was this strike force. Rather than focusing on overall performance of a particular subsystem, they zero-ed in on some very specific, important use cases .</li>
<br />
<li>Clear and well explained.&nbsp;<a href="http://shiroyasha.io/understanding-postgresql-locks.html">Understanding PostgreSQL locks</a>.&nbsp;</li>
<br />
<li><a href="https://medium.com/@Pinterest_Engineering/building-lens-your-look-unifying-text-and-camera-search-1b2f3ef4e393">Building Lens your Look: Unifying text and camera search</a>:&nbsp;we augmented our deep convolutional classification networks to simultaneously train on multiple tasks while maintaining a shared embedding layer. In addition to the typical classification or metric learning loss, we also incorporate task-specific losses, such as predicting fashion attributes and color. This teaches the network to recognize that a striped red shirt shouldn&rsquo;t be treated the same as a solid navy shirt. Our preliminary results show that incorporating multiple training losses leads to an overall improvement in visual retrieval performance</li>
<br />
<li>Nice <a href="https://www.syslog.cl.cam.ac.uk/2017/11/08/sosp17-trip-report/">SOSP&rsquo;17 Trip Report</a>&nbsp;(Symposium on Operating Systems Principles).&nbsp;Facebook's SVE:&nbsp;The key idea here is very simple: process a video while upload another one in the pipeline at the same time, but it has shown good performance compared to Facebook's previous MES system. This is indeed one of the advantages of "being large scale".</li>
<br />
<li>Even more reports.&nbsp;<a href="https://lwn.net/Articles/738759/">Netdev 2.2 day 1 report</a>&nbsp;(technical conference on Linux networking).&nbsp;<a href="https://lwn.net/Articles/738816/">Netconf 2017, Part 2, day 1 report</a>.&nbsp;<a href="https://blog.daftcode.pl/top-5-takeaways-from-meet-js-summit-17-dc61acef8f0e">Top 5 Takeaways from meet.js Summit &lsquo;17</a>.&nbsp;</li>
<br />
<li>Not sure about the music, but you gotta love the song title: <a href="https://www.youtube.com/watch?v=d6yvVWQdpnE">Equations for a Falling Body</a>.</li>
<br />
<li><a href="https://github.com/facebook/openr">Open/R</a>&nbsp;(<a href="https://code.facebook.com/posts/291641674683314/open-r-open-routing-for-modern-networks/">article</a>): Open Routing, OpenR, is Facebook's internally designed and developed routing protocol/platform. Originally built for performing routing on the Terragraph network, its awesome design and flexibility have led to its adoption in other networks at Facebook including our new WAN network, Express Backbone.</li>
<br />
<li><a href="https://github.com/discordapp/lilliput">discordapp/lilliput</a>: lilliput resizes images in Go. Lilliput relies on mature, high-performance C libraries to do most of the work of decompressing, resizing and compressing images. It aims to do as little memory allocation as possible and especially not to create garbage in Go. As a result, it is suitable for very high throughput image resizing services.</li>
<br />
<li><a href="https://github.com/pubkey/rxdb?v=6.0.1">pubkey/rxdb</a>:&nbsp;A reactive Database for Progressive Web Apps and more</li>
<br />
<li><a href="https://arxiv.org/abs/1702.04680">Visual Discovery at Pinterest</a>:&nbsp;This paper presents an overview of our visual discovery engine powering these services, and shares the rationales behind our technical and product decisions such as the use of object detection and interactive user interfaces. We conclude that this visual discovery engine significantly improves engagement in both search and recommendation tasks.</li>
<br />
<li><a href="https://static.googleusercontent.com/media/research.google.com/en//pubs/archive/46103.pdf">Spanner: Becoming a SQL System</a>&nbsp;(<a href="https://cloudplatform.googleblog.com/2017/11/with-Multi-Region-support-in-Cloud-Spanner-have-your-cake-and-eat-it-too.html">article</a>): This paper highlights the database DNA of Spanner. We describe distributed query execution in the presence of resharding, query restarts upon transient failures, range extraction that drives query routing and index seeks, and the improved blockwisecolumnar storage format. We touch upon migrating Spanner to the common SQL dialect shared with other systems at Google.</li>
</ul>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2017/11/17/stuff-the-internet-says-on-scalability-for-november-17th-201.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />Post a Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2017/11/17/stuff-the-internet-says-on-scalability-for-november-17th-201.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2017%2F11%2F17%2Fstuff-the-internet-says-on-scalability-for-november-17th-201.html','Stuff%20The%20Internet%20Says%20On%20Scalability%20For%20November%2017th%2C%202017');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2017/11/17/stuff-the-internet-says-on-scalability-for-november-17th-201.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/35995136"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/hot-links"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />hot links</a></span></span>  <span class="post-snippet-1"><iframe src="http://www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2017/11/17/stuff-the-internet-says-on-scalability-for-november-17th-201.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2017/11/17/stuff-the-internet-says-on-scalability-for-november-17th-201.html" data-text="Stuff The Internet Says On Scalability For November 17th,&nbsp;2017" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments </h3>

      
        
          <div class="text">There are no comments for this journal entry.  To create a new comment, use the form below.</div>

        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=35995136"> 

    
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2016, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>