<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1338871095817&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2017/8/18/stuff-the-internet-says-on-scalability-for-august-18th-2017.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://five.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Stuff The Internet Says On Scalability For August 18th,&nbsp;2017 - High Scalability - </title>
    <meta property="og:title" content="Stuff The Internet Says On Scalability For August 18th,&nbsp;2017 - High Scalability - " /> 
  

      <meta property="og:description" content=" Sorry about missing last week, but my birthday won out over working: 

 
  

 Ouch!  @john_overhol..." />
  

  
      <meta property="og:image" content="https://c1.staticflickr.com/5/4374/36013670130_91760fec5e.jpg" />
  

  <!-- End Heading -->

  <script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1044643/SS_HS_Ad1', [125, 125], 'div-gpt-ad-1325175098795-0').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad10', [125, 125], 'div-gpt-ad-1325175098795-1').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad11', [125, 125], 'div-gpt-ad-1325175098795-2').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad12', [125, 125], 'div-gpt-ad-1325175098795-3').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad13', [125, 125], 'div-gpt-ad-1325175098795-4').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad14', [125, 125], 'div-gpt-ad-1325175098795-5').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad15', [125, 125], 'div-gpt-ad-1325175098795-6').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad16', [125, 125], 'div-gpt-ad-1325175098795-7').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad17', [125, 125], 'div-gpt-ad-1325175098795-8').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad2', [125, 125], 'div-gpt-ad-1325175098795-9').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad3', [125, 125], 'div-gpt-ad-1325175098795-10').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad4', [125, 125], 'div-gpt-ad-1325175098795-11').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad5', [125, 125], 'div-gpt-ad-1325175098795-12').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad6', [125, 125], 'div-gpt-ad-1325175098795-13').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_ad7', [125, 125], 'div-gpt-ad-1325175098795-14').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad8', [125, 125], 'div-gpt-ad-1325175098795-15').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad9', [125, 125], 'div-gpt-ad-1325175098795-16').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad18', [125, 125], 'div-gpt-ad-1325175098795-17').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad19', [125, 125], 'div-gpt-ad-1325175098795-18').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad20', [125, 125], 'div-gpt-ad-1325175098795-19').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>


  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId35951472"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2017%2F8%2F18%2Fstuff-the-internet-says-on-scalability-for-august-18th-2017.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class=" " href="http://astore.amazon.com/possiboutpos-20" ><span>Book Store</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2017/8/18/stuff-the-internet-says-on-scalability-for-august-18th-2017.html">Stuff The Internet Says On Scalability For August 18th, 2017</a></li>  <li><a href="/blog/2017/8/15/sponsored-post-domino-data-lab-etleap-aerospike-clubhouse-st.html">Sponsored Post: Domino Data Lab, Etleap, Aerospike, Clubhouse, Stream, Scalyr, VividCortex, MemSQL, InMemory.Net, Zohocorp</a></li>  <li><a href="/blog/2017/8/14/why-morningstar-moved-to-the-cloud-97-cost-reduction.html">Why Morningstar Moved to the Cloud: 97% Cost Reduction</a></li>  <li><a href="/blog/2017/8/4/stuff-the-internet-says-on-scalability-for-august-4th-2017.html">Stuff The Internet Says On Scalability For August 4th, 2017</a></li>  <li><a href="/blog/2017/8/2/the-next-scalability-hurdle-massively-multiplayer-mobile-ar.html">The Next Scalability Hurdle: Massively Multiplayer Mobile AR</a></li>  <li><a href="/blog/2017/8/1/sponsored-post-apple-domino-data-lab-etleap-aerospike-clubho.html">Sponsored Post: Apple, Domino Data Lab, Etleap, Aerospike, Clubhouse, Stream, Scalyr, VividCortex, MemSQL, InMemory.Net, Zohocorp</a></li>  <li><a href="/blog/2017/7/28/stuff-the-internet-says-on-scalability-for-july-28th-2017s.html">Stuff The Internet Says On Scalability For July 28th, 2017s</a></li>  <li><a href="/blog/2017/7/25/7-interesting-parallels-between-the-invention-of-tiny-satell.html">7 Interesting Parallels Between the Invention of Tiny Satellites and Cloud Computing </a></li>  <li><a href="/blog/2017/7/21/stuff-the-internet-says-on-scalability-for-july-21st-2017.html">Stuff The Internet Says On Scalability For July 21st, 2017</a></li>  <li><a href="/blog/2017/7/17/youll-never-believe-the-big-hairy-audacious-startup-john-jac.html">You'll Never Believe the Big Hairy Audacious Startup John Jacob Astor Created in 1808</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <CENTER>
  <!-- SS_HS_Ad1 -->
  <div id='div-gpt-ad-1325175098795-0' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-0'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad10 -->
  <div id='div-gpt-ad-1325175098795-1' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-1'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad11 -->
  <div id='div-gpt-ad-1325175098795-2' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-2'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad12 -->
  <div id='div-gpt-ad-1325175098795-3' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-3'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad13 -->
  <div id='div-gpt-ad-1325175098795-4' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-4'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad14 -->
  <div id='div-gpt-ad-1325175098795-5' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-5'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad15 -->
  <div id='div-gpt-ad-1325175098795-6' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-6'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad16 -->
  <div id='div-gpt-ad-1325175098795-7' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-7'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad17 
  <div id='div-gpt-ad-1325175098795-8' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-8'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad2 
  <div id='div-gpt-ad-1325175098795-9' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-9'); });
  </script>
  </div>
  -->
  
  </CENTER>
  
  <center><a href="/advertising">advertise</A></center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2017%2F8%2F18%2Fstuff-the-internet-says-on-scalability-for-august-18th-2017.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178453">

    <div id="moduleContent15178453">

              <a id="moduleLink15178453" class=" " href="http://highscalability.com/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870172">

    <div id="moduleContent4870172">

              <a id="moduleLink4870172" class=" " href="http://highscalability.squarespace.com/blog/category/product" ><span>Useful Products</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870194">

    <div id="moduleContent4870194">

              <a id="moduleLink4870194" class=" " href="http://highscalability.squarespace.com/blog/category/paper" ><span>Useful Papers</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4870201">

    <div id="moduleContent4870201">

              <a id="moduleLink4870201" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Useful Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4885586">

    <div id="moduleContent4885586">

              <a id="moduleLink4885586" class=" " href="/blog/category/blog" ><span>Useful Blogs</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4920227">

    <div id="moduleContent4920227">

              <a id="moduleLink4920227" class=" " href="http://highscalability.com/blog/category/book" ><span>Useful Books</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper12001611">

    <div id="moduleContent12001611">

              <a id="moduleLink12001611" class=" " href="http://highscalability.com/blog/2011/9/14/big-list-of-scalabilty-conferences.html" ><span>Useful Conferences</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4878991">

    <div id="moduleContent4878991">

              <a id="moduleLink4878991" class="offsite-link " href="http://astore.amazon.com/possiboutpos-20" onclick="this.target='new';"><span>Book Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2017/8/15/sponsored-post-domino-data-lab-etleap-aerospike-clubhouse-st.html">Sponsored Post: Domino Data Lab, Etleap, Aerospike, Clubhouse, Stream, Scalyr, VividCortex, MemSQL, InMemory.Net, Zohocorp &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability category-hot-links">
<div id="item35951472" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Friday</span></div><div class="journal-entry-float-date"><span class="month">Aug</span><span class="date">18</span><span class="year">2017</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2017/8/18/stuff-the-internet-says-on-scalability-for-august-18th-2017.html">Stuff The Internet Says On Scalability For August 18th,&nbsp;2017</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Friday, August 18, 2017 at 9:03AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p>Sorry about missing last week, but my birthday won out over working:&nbsp;</p>
<div align="center"><img src="https://c1.staticflickr.com/5/4374/36013670130_91760fec5e.jpg" alt="" />
<p>&nbsp;</p>
<p>Ouch!&nbsp;<a href="https://twitter.com/john_overholt/status/881951639904690176">@john_overholt</a>: My actual life is now a science exhibit about the primitive conditions of the past.</p>
</div>
<div align="center"><span style="text-align: start;">If you like this sort of&nbsp;</span><em>Stuff </em><span style="text-align: start;">then please support me&nbsp;</span><a style="text-align: start;" href="https://www.patreon.com/toddhoff">on Patreon</a><span style="text-align: start;">.</span></div>
<p>&nbsp;</p>
<ul>
<li><a href="https://www.pcper.com/news/Storage/FMS-2017-Intels-EDSFF-Ruler-SSD-Form-Factor-Details-Emerge-1-Petabyte-1U-Chassis">1PB</a>: SSD in 1U chassis; <a href="https://www.youtube.com/watch?v=yLpDczIRJSQ">90%</a>: savings using EC2 Spot for containers; <a href="https://twitter.com/swardley/status/898085035072466944">16</a>: forms of inertia; <a href="https://techcrunch.com/2017/08/17/alibaba-profit-doubles-to-2-1b/">$2.1B</a>:&nbsp;Alibaba&rsquo;s profit; <a href="https://dazeinfo.com/2017/08/15/app-downloads-worldwideq-app-store-google-play-q2-2017/">22.6B</a>: app downloads in Q2; <a href="https://thestack.com/cloud/2017/04/05/google-unveils-espresso-for-the-peering-edge/">25%</a>: Google generated internet traffic;&nbsp;<a href="http://spectrum.ieee.org/nanoclast/computing/hardware/a-true-random-number-generator-built-from-carbon-nanotubes-promises-better-security-for-flexible-electronics">20 by 20 micrometers</a>:&nbsp;quantum random number generators; <a href="https://www.youtube.com/playlist?list=PL3FW7Lu3i5JvHM8ljYj-zLfQRF3EO8sYv">16</a>: lectures on&nbsp;Convolutional Neural Networks for Visual Recognition; <a href="https://archive.org/details/georgeblood">25,000</a>: digitized gramophone records;&nbsp;<a href="a">280%</a>: increase in IoT attacks;&nbsp;<a href="https://twitter.com/billmckibben/status/894542512580423680">6.5%</a>: world's GDP goes to subsidizing fossil fuel;&nbsp;<a href="http://www.jonkensy.com/832-tb-zfs-on-linux-project-cheap-and-deep-part-1/">832 TB</a>: ZFS on Linux;&nbsp;&nbsp;<a href="https://www.wired.com/story/meet-alex-the-russian-casino-hacker-who-makes-millions-targeting-slot-machines">$250,000</a>: weekly take from breaking slot machines; <a href="http://surprizingfacts.com/advanced-civilizations-can-build-a-galactic-internet-using-the-passage-of-planets-translation/">30</a>: galatic message exchanges using artificial megastructures in 100,000 years;&nbsp;</li>
<br />
<li>Quotable Quotes:                            
<ul>
<li>
<div id="_mcePaste"><a href="https://twitter.com/chris__martin/status/893951453269766144">@chris__martin</a>: ALIENS: we bring you a gift of reliable computing technol--</div>
<div id="_mcePaste">HUMANS: oh no we have that already but JS is easier to hire for</div>
</li>
<li><a href="https://twitter.com/rakyll/status/895132157630226432">@rakyll</a>:&nbsp;"You woman, you like intern." I interned on F-16's flight computer. Even my internship was 100x more legit than any job you will have.</li>
<li><a href="https://twitter.com/codewisdom/status/897911593878511617">@CodeWisdom</a>: "Debugging is like being the detective in a crime movie where you are also the murderer." - Filipe Fortes</li>
<li><a href="http://www.vulture.com/2017/08/william-gibson-archangel-apocalypses-dystopias.html">William Gibson</a>: what I find far more ominous is how seldom, today, we see the phrase &ldquo;the 22nd century.&rdquo; Almost never. Compare this with the frequency with which the 21st century was evoked in popular culture during, say, the 1920s.</li>
<li><a href="https://www.arador.com/ridiculous-bandwidth-costs-amazon-google-microsoft/">Arador</a>: Amazon EC2, Microsoft Azure and Google Gloud Platform are all seriously screwing their customers over when it comes to bandwidth charges.&nbsp;Every one of the big three has massive buying power yet between them their average bandwidth price is 3.4x higher than colocation facilities.</li>
<li><a href="https://twitter.com/mattklein123/status/896586512757805058">@mattklein123</a>: Good thread: my view: 1) most infra startups will fail. It's an awful business to be in (sorry all, much ❤️).</li>
<li><a href="https://mondaynote.com/misunderstanding-apple-services-58b1aa248590">Jean-Louis Gass&eacute;e</a>:&nbsp;With Services, Apple enjoys the benefits of a virtuous circle: Hardware sales create Services revenue opportunities; Services makes hardware more attractive and &ldquo;stickier&rdquo;. Like Apple Stores, Services are part of the ecosystem. Such is the satisfying simplicity and robustness of Apple&rsquo;s business model.</li>
<li><a href="https://news.ycombinator.com/item?id=14929128">cardine</a>:&nbsp;The price difference between Hetzner and AWS is large enough that it could pay for 4x as much computational power (as much redundancy as you'd ever need), three full time system admins (not that you'd ever need them), and our office lease... with plenty of money left over!</li>
<li><a href="https://hackernoon.com/moving-on-9f1bb1e42331">Brujo Benavides</a>: Communication is Key: Have you ever watched a movie or a soap opera and thought &ldquo;If you would&rsquo;ve just told her that, we would&rsquo;ve avoided 3 entire episodes, you moron!&rdquo;. Happens to me all the time. At Inaka we learned that the hard way.</li>
<li><a href="https://twitter.com/f3ew/status/897245414537256961">@f3ew</a>: Doesn't matter how many layers of stateless services you have in the middle, the interesting ends have state.</li>
<li><a href="https://news.ycombinator.com/item?id=14928750">brianwawok</a>: My cloud cost is less than 5% of my bussiness costs using GCE. Would be foolish to move it to lower my costs 2%.</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/f3ew/status/897245609400442880">@f3ew</a>:&nbsp;Stateless services are as relevant as routers. Pattern match, compute, push to next layer.</div>
</li>
<li>
<div id="_mcePaste"><a href="http://5by5.tv/asymcar/40">Horace Dediu</a>~ when you outsource you're taking knowledge out of your company, which ends up gutting it in terms of the value that is added&nbsp;</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://www.amazon.com/dp/B01M9C1Y3S">Jason Calacanis</a>: Google was the twelfth search engine. Facebook was the tenth social network. iPad was the twentieth tablet. It&rsquo;s not who gets there first. It&rsquo;s who gets there first when the market&rsquo;s ready.</div>
</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=14039755">puzzle</a>:&nbsp;The B4 paper states multiple times that Google runs links at almost 100% saturation, versus the standard 30-40%. That's accomplished through the use of SDN technology and, even before that, through strict application of QoS.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://siliconangle.com/blog/2017/08/14/serverless-buzz-has-eclipsed-containers-say-analysts-awssummit/">@stu</a>:&nbsp;Serverless has in many ways eclipsed the containers discussion for the hot buzz in the industry</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/mjpt777/status/894540931042553856">@mjpt777</a>:&nbsp;GC is a wonderful thing but I cannot help but feel it leaves the typical developer even less prepared for distributed resource management.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=14987617">joaodlf</a>: Spark works and does a good job, it has many features that I can see us use in the future too. With that said, it's yet another piece of tech that bloats our stack. I would love to reduce our tech debt: We are much more familiar with relational databases like MySQL and Postgres, but we fear they won't answer the analytics problems we have, hence Cassandra and Spark. We use these technologies out of necessity, not love for them.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=14983047">tobyjsullivan</a>:&nbsp;No, dear author. Setting up the AWS billing alarm was the smartest thing you ever did. It probably saved you tens of thousands of dollars (or at least the headache associated with fighting Amazon over the bill).&nbsp;Developers make mistakes. It's part of the job. It's not unusual or bad in any way. A bad developer is one who denies that fact and fails to prepare for it. A great developer is one like the author.</div>
</li>
<li>
<div id="_mcePaste"><a href="http://woz.posthaven.com/what-orms-have-taught-me-just-learn-sql">Geoff Wozniak</a>: Regardless of whether I find that stored procedures aren't actually that evil or whether I keep using templated SQL, I do know one thing: I won't fall into the "ORMs make it easy" trap.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/BenedictEvans/status/893870187090386945">@BenedictEvans</a>:&nbsp;Part of what distinguishes today&rsquo;s big tech companies is a continual push against complacency. They saw the last 20 years and read the books</div>
</li>
<li>
<div id="_mcePaste"><a href="http://fortune.com/2017/08/03/game-of-thrones-sophie-turner-role-social-media/">John Patrick Pullen</a>: In the upcoming fall issue of Porter magazine, the 21-yer-old X-Men: Apocalypse star said, "I auditioned for a project and it was between me and another girl who is a far better actress than I am, far better, but I had the followers, so I got the job," according to The Telegraph. "It&rsquo;s not right, but it is part of the movie industry now."</div>
</li>
<li>
<div id="_mcePaste"><a href="http://www.slate.com/articles/technology/future_tense/2017/08/the_19th_century_moral_panic_over_paper_technology.html">Rachel Adler</a>: Naturally, faster prints drove up demand for paper, and soon traditional methods of paper production couldn&rsquo;t keep up. The paper machine, invented in France in 1799 at the Didot family&rsquo;s paper mill, could make 40 times as much paper per day as the traditional method, which involved pounding rags into pulp by hand using a mortar and pestle.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=14990373">pawelkomarnicki</a>: As a person that can get the product from scratch to production and scale it, I can say I'm a full-stack developer. Can I feel mythical now?</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.deekit.com/braintree-to-stripe/">Risto</a>:&nbsp;Before integrating any payment flow make sure you understand the whole flow and the different payment states trialing -&gt; active -&gt; unpaid -&gt; cancelled. For Braintree there is a flow chart. For Stripe there is one too. Both payment providers have REST API&rsquo;s so make sure to play through the payment flows before starting actual coding.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://hackernoon.com/swarming-the-power-of-1m-evs-teslas-on-our-roads-cab1bfa1615">Seyi Fabode</a>: I have 3 neighbors in close proximity who also have solar panels on their roofs. And a couple of other neighbors with electric cars. What says we can&rsquo;t start our own mini-grid system between ourselves?</div>
</li>
<li>
<div id="_mcePaste">
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=14981592">pixl97</a>:&nbsp;Muscles/limbs are only 'vastly' more efficient if you consider they have large numbers of nano scale support systems constantly rebuilding them. Since we don't have nanobots, gears will be better for machines. Also, nature didn't naturally develop a axle.</div>
</div>
</li>
<li>
<div id="_mcePaste"><a href="http://bravenewgeek.com/are-we-there-yet-the-go-generics-debate/">Brave New Greek</a>:&nbsp;I sympathize with the Go team&rsquo;s desire to keep the overall surface area of the language small and the complexity low, but I have a hard time reconciling this with the existing built-in generics and continued use of interface{} in the standard library.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/jeffhollan/status/897837651339784192">@jeffhollan</a>:&nbsp;Agree to a point. But where does PaaS become &ldquo;serverless&rdquo;? Feel should be &lsquo;infinite&rsquo; scale of dynamic allocation of resources + micro bill</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/kcimc/status/893849886529003524">@kcimc</a>:&nbsp;common tempos in 1M songs, 1959-2011: 120 bpm takes over in the late 80s, and bpms at multiples of 10 emerge in the mid 90s</div>
</li>
<li>
<div id="_mcePaste"><a href="http://www.nature.com/news/how-to-map-the-circuits-that-define-us-1.22437">How to Map the Circuits That Define Us</a>: If neural circuits can teach one lesson, it is that no network is too small to yield surprises &mdash; or to frustrate attempts at comprehension.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/orskov/status/895882341674926080">@orskov</a>:&nbsp;In Q2, The Wall Street Journal had 1,270,000 daily digital-only subscribers, a 34% increase compared to last year</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.youtube.com/watch?v=h0962biiZa4&amp;lc=z120tpvy2zqujnszd04chtaxdnybcv5ppoo0k">Thrust Zone</a>: A panel including tech billionaire Elon Musk is discussing the fact that technology has progressed so much that it may soon destroy us and they have to pass microphones to talk.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/damonedwards/status/897928039480217600">@damonedwards</a>:&nbsp;When we are all running containers in public clouds, I&rsquo;m really going to miss datacenter folks one-upping each other on hardware specs.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://twitter.com/benedictevans/status/896970740288724992">@BenedictEvans</a>:&nbsp;186 page telecoms report from 1994. 5 pages on &lsquo;videophones&rsquo;: no mention of internet. 10 pages saying web will lose to VR. Nothing on mobile</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.edge.org/conversation/thomas_metzinger-benevolent-artificial-anti-natalism-baan">Thomas Metzinger</a>: The superintelligence concludes that non-existence is in the own best interest of all future self-conscious beings on this planet. Empirically, it knows that naturally evolved biological creatures are unable to realize this fact because of their firmly anchored existence bias. The superintelligence decides to act benevolently.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://jeremyeder.com/2017/07/25/docker-operations-slowing-down-on-aws-this-time-its-not-dns/">Jeremy Eder</a>: As with all public cloud, you can do whatever you want&hellip;for a price. &nbsp;BurstBalance is the creation of folks who want you to get hooked on great performance (gp2 can run at 3000+ IOPS), but then when you start doing something more than dev/test and run into these weird issues, you&rsquo;re already hooked and you have no choice but to pay more for a service that is actually usable.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.bloomberg.com/news/features/2017-08-03/a-baccarat-binge-helped-launder-the-world-s-biggest-cyberheist">Katz and Fan</a>: After all, the important thing for anyone looking to launder money through a casino isn&rsquo;t to win. It&rsquo;s to exchange millions of dollars for chips you can swap for cool, untraceable cash at the end of the night.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://cacm.acm.org/magazines/2016/2/197420-the-verification-of-a-distributed-system/fulltext">Caitie McCaffrey</a>: Verification in industry generally consists of unit tests, monitoring, and canaries. While this provides some confidence in the system's correctness, it is not sufficient. More exhaustive unit and integration tests should be written. Tools such as random model checkers should be used to test a large subset of the state space. In addition, forcing a system to fail via fault injection should be more widely used. Even simple tests such as running kill &minus;9 on a primary node have found catastrophic bugs.</div>
</li>
<li>
<div id="_mcePaste"><a href="http://zupa.hu/thoughts/fpga-the-future-of-computing">Zupa</a>: FPGAs give you most of the benefits of special-purpose processors, for a fraction of the cost. They are about 10x slower, but that means an FPGA based bitcoin miner is still 100k times faster than a processor based one</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.reddit.com/r/programming/comments/6se3lu/fpga_the_future_of_computing/dldlnb3/">menge101work</a>: I'm not sure if the implication is that our CPUs will have gate arrays on chip with the generic CPU, that is an interesting idea. But if they are not on chip, the gate array will never be doing anything in a few clock cycles. It'll be more akin to going out to memory, the latency between a real memory load and an L1 or L2 cache hit is huge. (reference)</div>
<div id="_mcePaste">Not to say that being able to do complex work on dedicated hardware won't still be fast, but the difference between on-die and off-die is a huge difference in how big of a change this could be.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=14945033">Animats</a>: This article [<a href="https://www.coindesk.com/three-smart-contract-misconceptions/">Why Many Smart Contract Use Cases Are Simply Impossible</a>] outlines the basic problem. If you want smart contracts that do anything off chain, there have to be connections to trusted services that provide information and take actions. If you have trusted services available, you may not need a blockchain.The article points out that you can't construct an ordinary loan on chain, because you have no way to enforce paying it back short of tying up the loaned funds tor the duration of the loan. Useful credit fundamentally requires some way of making debtors pay up later. It's possible to construct various speculative financial products entirely on chain, and that's been done, but it's mostly useful for gambling, broadly defined.</div>
</li>
<li>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=14931441">curun1r</a>: Your characterization of startup cloud costs is laughably outdated. With credits for startups and the ability to go serverless, I've known startups that didn't pay a dime for hosting their entire first year despite reaching the threshold of hundreds of customers and over $1m ARR. One of my friends actually started doing some ML stuff on AWS because he wanted to use his remaining credits before they expired and his production and staging workloads weren't going to get him there.&nbsp;I'd say it makes no sense to buy your 32gb, 16-core single point of fail, waste $40/mo and half a day setting it up and then have to keep it running yourself when you can easily spin up an API in API Gateway/Lambda that dumps data into dynamo/simpledb and front it with a static site in S3. That setup scales well enough to be mentioned on HN without getting hugged to death and is kept running by someone else. And if it is, literally, free for the first year, how is that not a no brainer?</div>
</li>
<li>
<div id="_mcePaste"><a href="https://www.nytimes.com/2017/07/25/upshot/maybe-weve-been-thinking-about-the-productivity-slump-all-wrong.html">Neil Irwin</a>: In this way of thinking about productivity, inventors and business innovators are always cooking up better ways to do things, but it takes a labor shortage and high wages to coax firms to deploy the investment it takes to actually put those innovations into widespread use. In other words, instead of worrying so much about robots taking away jobs, maybe we should worry more about wages being too low for the robots to even get a chance.</div>
</li>
</ul>
</li>
<br />
<li>The best introduction to Azure Stack&mdash;Microsoft's on-prem cloud solution&mdash;out there.&nbsp;<a href="http://packetpushers.net/podcast/podcasts/datanauts-97-unpacking-azure-stack-hybrid-clouds/">Datanauts 097: Unpacking Azure Stack For Hybrid Clouds</a>. Not a white box solution, it's all black box baby. You must buy expensive hardware from certified vendors who will do the install for you. It's "your" cloud, yet Azure Stack uses a subscription based model. With Windows licensing in place, spinning up a VM costs $6 per VM's VCPU per month. In Azure you would pay $30-$60 per month for the same VM. Window's licensing costs more if you don't have it. There's still a Window's strategy tax to pay.&nbsp;Suggestion is to buy datacenter licensing. It's closed source, everything is done through an admin portal. It's not even clear if you get admin on the VMs. This is the first release, so the largest configuration is a 12 node system in one region. You get the same API endpoints as you do in Azure, so your tooling works in both environments. You don't get all of Azure. You get VMs, Azure Storage, Azure App Service, Azure Functions, Azure Backup, and Azure Site Recovery. Your don't get: hardware specific VMs, like with GPU accelerators, Azure Data Lake, Azure Data Warehouse, Cognitive services. Base hypervisor runs Server Core 2016 and Hyper-V. Storage platform is Storage Spaces Direct. No centralized SAN, uses Microsoft's&nbsp;SDN to NAT,&nbsp;BGP and segment subnets. Has an app store type of marketplace for buying 3rd party software. Supports IT utilization charge back to tenants. Do not have to change Active Directory.</li>
<br />
<li>Irony: the automatic update mechanism for distributing software upgrades, the number one hope for quickly propagating security fixes, is also one giant gaping maw of a security risk. <a href="http://www.express.co.uk/news/world/842200/China-hackers-cyber-spying-attack-UK-business">Chinese hackers 'built back door hack into software to spy on Britain&rsquo;s top businesses</a>: A legitimate software update from NetSarang was highjacked by the hackers in a &ldquo;supply chain&rdquo; attack...Companies at risk from this latest attack include American weapons firm Lockheed Martin, Russian energy supplier Gazprom and French bank Soci&eacute;t&eacute; G&eacute;n&eacute;rale.</li>
<br />
<li>Who would have thunk it, Napoleon was into BigData. <a href="https://www.amazon.com/dp/B00INIXLPW">Napoleon: A Life</a>: He insisted that his prefects provide him with systematic statistical data, ordering them to make extensive annual tours of their departments to glean first-hand information.</li>
<br />
<li>Looks like Ford is trying hard to avoid being disrupted. It makes no sense for Ford, as an OEM, not to own core AI technology. It's not a sustaining technology, it's not something you should outsource to your supply chain, it's an existential level bet.&nbsp;<a href="https://www.theverge.com/2017/8/16/16155254/argo-ai-ford-self-driving-car-autonomous">An inside look at Ford&rsquo;s $1 billion bet on Argo AI</a>:&nbsp;Argo is developing self-driving technology that Ford can use to deploy fully autonomous Level 4-capable vehicles for commercial on-demand service. In other words: something like a self-driving taxi service. Level 4 is a designation by SAE International that means the car takes over all of the driving in certain conditions.</li>
<br />
<li>This is a huge downside, but AWS really should detect infinite loops.&nbsp;<a href="https://sourcebox.be/blog/2017/08/07/serverless-a-lesson-learned-the-hard-way/">Serverless: A lesson learned. The hard way</a>:&nbsp;The actual cost is now $206 and over $1000 forecasted, it makes me think twice about using pay-per-use services in the future. One little mistake can cost a lot of money, the budget notifications were very late so there was very little I could do against it...This is probably the most stupid thing I ever did. One missing return; ended up costing me $206.</li>
<br />
<li><a href="https://blog.timescale.com/timescaledb-vs-6a696248104e">TimescaleDB vs. Postgres for time-series: 20x higher inserts, 2000x faster deletes, 1.2x-14,000x faster queries</a>:&nbsp;a new, open-source time-series database architected for fast ingest, complex queries, and ease of use. It looks like PostgreSQL to the outside world...users can scale to billions of rows on PostgreSQL, while maintaining high, constant insert rates...TimescaleDB solves this [update the indexes]&nbsp;through its heavily utilization and automation of time-space partitioning, even when running ​on a single machine​. Essentially, all writes to recent time intervals are only to tables that remain in memory. This results in a consistent 20x insert performance improvement over PostgreSQL when inserting data at scale.</li>
<br />
<li>LinkedIn lost their data-scraping case. So scraping data from websites, seems to be legal...for the moment. <a href="http://online.wsj.com/public/resources/documents/2017_0814_hiq_order.pdf">UNITED STATES DISTRICT COURT NORTHERN DISTRICT OF CALIFORNIA</a>.&nbsp;LinkedIn must allow a company to scrape users' public profiles and must remove technical barriers within 24 hours.</li>
<br />
<li>As you scale work needs to move from the center to the edge (and back again :-). That's what Google is doing with routing.&nbsp;<a href="https://thestack.com/cloud/2017/04/05/google-unveils-espresso-for-the-peering-edge/">Google unveils Espresso for the peering-edge</a>.&nbsp;<a href="https://www.blog.google/topics/google-cloud/making-google-cloud-faster-more-available-and-cost-effective-extending-sdn-public-internet-espresso/">Espresso makes Google cloud faster, more available and cost effective by extending SDN to the public internet</a>: "Espresso delivers two key pieces of innovation. First, it allows us to dynamically choose from where to serve individual users based on measurements of how end-to-end network connections are performing in real time. Second, we separate the logic and control of traffic management from the confines of individual router 'boxes.'" If you want to understand why edge computing is more than a buzz word, Google makes the point that being at the edge is necessary to provide today and tomorrow's low-latency services: Answering the question &ldquo;What&rsquo;s the latest news?&rdquo; with Google Assistant requires a fast, low-latency connection from a user&rsquo;s device to the edge of Google&rsquo;s network, and from the edge of our network to one of our data centers. Once inside a data center, hundreds&mdash;or even thousands&mdash;of individual servers must consult vast amounts of data to score the mapping of an audio recording to possible phrases in one of many languages and dialects. The resulting phrase is then passed to another cluster to perform a web search, consulting a real-time index of internet content. The results are then gathered, scored and returned to the edge of Google&rsquo;s network back to the end user. Answering queries in real-time involves coordinating dozens of internet routers and thousands of computers across the globe, often in the space of less than a second! Further, the system must scale to a worldwide audience that generates thousands of queries every second.</li>
<br />
<li>Move over mobile, AI is the new hotness.&nbsp;<a href="https://www.cnbc.com/2017/08/02/microsoft-2017-annual-report-lists-ai-as-top-priority.html">Microsoft just officially listed AI as one of its top priorities, replacing mobile</a>. Internet looks on longingly, remembering when it was the new hotness. Microprocessors nod, knowingly. Combustion engines, fart carbon tears. Electricity, is not shocked at all. Guns, want another shot. Wheels say, what comes around goes around. Fire, burns with envy.</li>
<br />
<li><a href="https://blog.acolyer.org/2017/08/11/automatic-database-management-system-tuning-through-large-scale-machine-learning/">Automatic database management system tuning through large-scale machine learning</a>:&nbsp;Our results show that OtterTune produces configurations that achieve up to 94% lower latency compared to [the DBMS] default settings or configurations generated by other tuning advisors. We also show that OtterTune generates configurations in under 60 minutes that are comparable to ones created by human experts.</li>
<br />
<li>Microsoft continues to extend its cloud service offerings.&nbsp;<a href="https://azure.microsoft.com/en-us/blog/introducing-azure-event-grid-an-event-service-for-modern-applications">Introducing Azure Event Grid &ndash; an event service for modern applications</a>:&nbsp;Azure Event Grid manages all routing of events from any source, to any destination, for any application...makes an event a first-class object...create your own custom events to publish directly to the service...supporting custom web hooks to publish events to any service, even 3rd-party services outside of Azure. It's general eventing model looks to be more flexibile than Lambda's restricted set of event sources. Events can terminate at many different endpoints, like VMs. Not sure how usefule that is. There's also smart filtering on events, not sure how useful that is either. Didn't see anything on rate limiting, batching, etc. How is it different than Service Bus, MSs' enterprise messaging product?&nbsp;<a href="https://azure.microsoft.com/en-us/blog/introducing-azure-event-grid-an-event-service-for-modern-applications/?utm_content=buffer3cbf6&amp;utm_medium=social&amp;utm_source=twitter.com&amp;utm_campaign=buffer#comment-3471628905">Ben Coleman</a>:&nbsp;Service Bus requires polling, this is an asynchronous push to you, rather than you having some code checking in a loop.&nbsp;</li>
<br />
<li><a href="https://twitter.com/patrickdebois/status/897041518216839168">@patrickdebois</a> asks Why NOT serverless? And gets some not very convincing answers: <a href="https://twitter.com/jtopper/status/897046667429638144">@jtopper</a>: Why make yourself a distributed systems problem when you didn&rsquo;t need to? <a href="https://twitter.com/samnewman/status/897052789234257921">@samnewman</a>: In sort, hybrid apps especially have challenges, and there are gaps that need to be addressed. <a href="https://twitter.com/PaulDJohnston/status/897049573289598976">@PaulDJohnston</a>: Hiring - fewer people in the pool and no fixed idea of "serverless" means your hiring is harder. <a href="https://twitter.com/Clausewitz45/status/897172622454247429">@Clausewitz45</a>: The app trace level never going to reach the expected depth. You can't setup an identical environment for testing - latency differs somehow. <a href="https://twitter.com/jon95016161/status/897047126018019328">@jon95016161</a>: Network isolation <a href="https://twitter.com/sethvargo/status/897446152844566528">@sethvargo</a>: Unclear isolation barriers (how do I "promote" something from stage to prod reliably?&nbsp;</li>
<br />
<li>A classic&nbsp;Brendan Gregg investigative expose.&nbsp;<a href="http://www.brendangregg.com/blog/2017-08-08/linux-load-averages.html">Linux Load Averages: Solving the Mystery</a>:&nbsp;In 1993, a Linux engineer found a nonintuitive case with load averages, and with a three-line patch changed them forever from "CPU load averages" to what one might call "system load averages." His change included tasks in the uninterruptible state, so that load averages reflected demand for disk resources and not just CPUs. These system load averages count the number of threads working and waiting to work, and are summarized as a triplet of exponentially-damped moving sum averages that use 1, 5, and 15 minutes as constants in an equation. This triplet of numbers lets you see if load is increasing or decreasing, and their greatest value may be for relative comparisons with themselves.</li>
<br />
<li>Nice summary of patterns.&nbsp;<a href="https://hackernoon.com/designing-a-microservices-architecture-for-failure-a57f34ded646">Designing a Microservices Architecture for Failure</a>: apply configuration changes to a subset of your instances gradually;&nbsp;run two production environments;&nbsp;load balancer should skip unhealthy instances;&nbsp;an application can do the necessary steps to recover from a broken state;&nbsp;use two different expiration dates, a shorter that tells how long you can use the cache in a normal situation, and a longer one that says how long can you use the cached data during failure;&nbsp;retry our action as we can expect that the resource will recover after some time;&nbsp;define how many requests can be received or processed by a particular customer or application during a timeframe;&nbsp;hold back lower-priority traffic to give enough resources to critical transactions;&nbsp;using timeouts is an anti-pattern and you should avoid it;&nbsp;applying the bulkheads pattern, we can protect limited resources from being exhausted;&nbsp;a circuit breaker opens when a particular type of error occurs multiple times in a short period;&nbsp;test your system against common issues to make sure that your services can survive various failures</li>
<br />
<li>An incredible story. Amazing people. Deeply moving.&nbsp;<a href="https://mobile.nytimes.com/2017/08/03/magazine/the-loyal-engineers-steering-nasas-voyager-probes-across-the-universe.html">The Loyal Engineers Steering NASA&rsquo;s Voyager Probes Across the Universe</a>.&nbsp;Doug:&nbsp;Entire generations of consumer telecom have been swept aside while Voyager headed through then out of the Solar system. All the while beaming data back to Earth with the same radio technology that existed when TV stations used to sign off at the end of the broadcast day, and calling your mom actually routed your voice across a chain of copper wires spanning the nation.</li>
<br />
<li>I'm shocked I tell you.&nbsp;<a href="https://hackernoon.com/meet-spoofy-how-a-single-entity-dominates-the-price-of-bitcoin-39c711d28eb4">Meet &lsquo;Spoofy&rsquo;. How a Single entity dominates the price of Bitcoin</a>: The exchange rate of Bitcoin has been heavily manipulated as a result of spoofing, wash trading, and other shenanigans. This is not healthy long term for the price of bitcoin and the possible future collapse of Tether and Bitfinex will cause a dramatic effect on future Bitcoin prices because we will no longer have these false signals coming out from Bitfinex...I believe that a significant amount of the trading on Bitfinex is likely wash trading, and this could be wash trading in both directions up and down. I believe Spoofy is playing on multiple exchanges, but his orders are usually much smaller on the other exchanges.</li>
<br />
<li>If you are considering Firebase for your BaaS then&nbsp;<a href="https://lugassy.net/why-im-dumping-firebase-for-web-cd64a78cb43e">Why I&rsquo;m dumping Firebase for Web?</a>&nbsp;rips through a lot of different problems. Good discussion <a href="https://news.ycombinator.com/item?id=14962567">on HackerNews</a> and <a href="https://www.reddit.com/r/programming/comments/6sk6cx/why_im_dumping_firebase_for_web_michael_lugassy/">on Reddit</a>. As always, there's agreement and disagreement. The authors current stack:&nbsp;Google Compute running pm2; otherwise Google App Engine Flexible Env; Monolith Node.js application running Express;&nbsp;Home-brewed REST middleware;&nbsp;MySQL for metadata;&nbsp;In-process (a.k.a RAM) cache for stuff I read a lot;&nbsp;Redis for real-time counters;&nbsp;JWT for user sessions;&nbsp;JSON event/log files rotated directly to BigQuery;&nbsp;Some PWA practices but not SPA;&nbsp;ES5 client-side JavaScript, CDN includes;&nbsp;Some Vue.js.</li>
<br />
<li>Theadripper reviews are in. <a href="https://www.pcper.com/reviews/Processors/AMD-Ryzen-Threadripper-1950X-and-1920X-Review">The AMD Ryzen Threadripper 1950X and 1920X Review</a>. <a href="https://twit.tv/shows/this-week-in-computer-hardware/episodes/427">This Week in Computer Hardware 427</a>. <a href="http://www.anandtech.com/show/11697/the-amd-ryzen-threadripper-1950x-and-1920x-review">The AMD Ryzen Threadripper 1950X and 1920X Review: CPUs on Steroids</a>.&nbsp;<a href="https://news.ycombinator.com/item?id=14983699">Instructor</a>:&nbsp;TL;DR: clear winner in multithread productivity, intel better in single-thread productivity, around Ryzen 1800X in gaming (in game mode, which tries to pin threads to one die at a time and disables SMT), great TDP (stays under 180w at full load), has some teething issues with the NUMA nature of two-dies, but is overall a great processor.</li>
<br />
<li>Like something nerdy and interesting to read? This is very well written.&nbsp;<a href="https://www.teamten.com/lawrence/writings/coding-machines/">Coding Machines</a>.&nbsp;<a href="https://news.ycombinator.com/item?id=15005590">nickpsecurity</a>: The story shows what people typically do if there&rsquo;s a Karger/Thompson attack.</li>
<br />
<li>Technology changes how society structures itself. <a href="http://99percentinvisible.org/episode/the-stethoscope/">The Stethoscope</a>.&nbsp;Invention of the stethoscope changed the relationship of patients to their doctor. Instead of the doctor listening to the patient to form a diagnosis, patients became a source of data. This shifted the balance of power in the relationship to doctors, who became more distant and authoritarian. Welcome to the future.</li>
<br />
<li><a href="https://www.youtube.com/watch?v=Q5cTT0M0YXg">Uber Mobility: RIB (Router Interactor Builder)</a>.&nbsp;Uber spent 6 months looking at MVC, MVVM, VIPER before creating RIB. Their Rider app was boken into 500 RIBs, less 300 lines per class.</li>
<br />
<li>Jibes with the thought I've always had that programming is explaining something to yourself in code.&nbsp;<a href="https://www.edge.org/conversation/tania_lombrozo-learning-by-thinking">Learning By Thinking</a>:&nbsp;something about the process of explanation, the process of trying to get an understanding of something, is crucial to how we're able to then predict and intervene in the future...learning by thinking...is the experience of coming to understand something better as a result of explaining it to yourself...you gain new insight or understanding, it isn't driven by that new information that they've provided. In some way, you've rearranged what was already in your head in order to get new insight...The process of trying to explain to yourself is a lot like a thought experiment in science...if you engage in the process of asking yourself why something happened, part of what you're doing is trying to relate the concrete particulars of that story to a more general principle or generalization</li>
<br />
<li><a href="http://blog.backand.com/serverless-shootout">Serverless Performance Shootout</a>:&nbsp;Google Cloud Functions had the best UI;&nbsp;Microsoft Azure Functions had the largest number of configuration options;&nbsp;AWS Lambda had the most complex configuration setup;&nbsp;Most obscure logs also goes to AWS with its CloudWatch integration;&nbsp;Microsoft clearly comes out the winner here, with a median round trip time that is just about half that of both AWS and Google;&nbsp;Google Cloud Functions has about a 40 millisecond lead time on AWS Lambda when it comes to comparing the machine instance ramp-up time;&nbsp;Microsoft Azure Functions had the best average runtime performance, there was also a higher error rate.</li>
<br />
<li>Binary is so old school, we're going beyond binary, to quaternary.&nbsp;<a href="http://www.networkworld.com/article/3210745/storage/radical-innovation-could-reduce-data-density-by-50.html">A radical innovation that could reduce data density by 50%</a>:&nbsp;Their radical solution is to use polymer films containing colored dyes to optically store data. What&rsquo;s more, binary ones and zeroes&mdash;the classic method we use for writing data&mdash;should be junked, and we must move over to a space-saving quaternary, or four-symbol code...The four symbols are the absence of color and three colors&mdash;fluorescent green, ultramarine and cyan.</li>
<br />
<li>Apparently when you let a 1000 flowers bloom, most of them wither and die.&nbsp;<a href="https://dazeinfo.com/2017/08/15/app-downloads-worldwideq-app-store-google-play-q2-2017/">Worldwide App Downloads Q2 2017: Games Eclipsing Social Media</a>: Another feature worth noting is the fact that all apps in the top 5 fall under the social media and messaging category. However, despite this, the social networking and communication app downloads actually went down compared to Q1 2016. This means users are consolidating around a few select platforms. While the established social media apps are seeing more and more interest, fringe players and upstarts are falling by the wayside.</li>
<br />
<li>Looks like a giant game of tetris that never completes.&nbsp;Robot army! Based on AI Algorithm, <a href="https://twitter.com/xhnews/status/898087421782446080">100+ robots deliver goods</a> at China's largest "smart warehouse" in Guangdong</li>
<br />
<li>Love this kind of find the bug style detective story.&nbsp;<a href="https://jeremyeder.com/2017/07/25/docker-operations-slowing-down-on-aws-this-time-its-not-dns/">Docker operations slowing down on AWS (this time it&rsquo;s not DNS)</a>. Also love lessons drawn from experience based cynicism:&nbsp;Regardless of cloud provider, you pay a premium for both performance and determinism;&nbsp;If you think you are saving money up front, just wait until the production issues start rolling in which, conveniently, can easily be solved by simply clicking a little button and upgrading to the next tier.</li>
<br />
<li><a href="https://www.newscientist.com/article/2143499-ships-fooled-in-gps-spoofing-attack-suggest-russian-cyberweapon/">Ships fooled in GPS spoofing attack suggest Russian cyberweapon</a>. <a href="https://news.ycombinator.com/item?id=15003878">Nokinside</a>: There are several types of spoofing attacks and it's possible to use spoofing as type of jamming attack against military GPS units from a distance where pure jamming is not effective. Older receivers require lock into C/A code before moving to encrypted P(Y). The new M-code attempts to solve some of these issues. The simplest form of GPS spoofing sends made up signals that misdirects the GPS receiver. Military equipment is protected against these kinds of attacks with authenticated signals. Carry-off attacks (satellite-lock takeover) start with broadcasting perfectly synced repeat of the original signal. This kind of attack can be used to make munitions and missiles to lose their signal lock in critical time. It's also possible that there are multiple weaknesses and bugs in the military receivers that can be exploited. Iranians were somehow able to trick RQ-170 drone to land on Iran. When Iranians captured U.S. Navy patrol boat it was because there was mysterious navigation error.</li>
<br />
<li>GitHub had a problem releasing new product in production. New services took months to deploy. When that happens you need a better underlying development platform, so&nbsp;<a href="https://thenewstack.io/github-goes-kubernetes-tells">GitHub Goes All in on Kubernetes</a>. The article says the SRE team became the bottleneck, which is odd, because at Google SRE involvement is not necessary for a service to go live. They took an evolutionary approach and eventually were able to make a metal cluster pass acceptance tests. They routed test traffic into the cluster,&nbsp;starting with 100 requests-per-second and expanding later to 10 percent of the requests to github.com and api.github.com. They went with multiple clusters to reduce risk. Result:&nbsp;I can already see how the move to Kubernetes is creating an environment at GitHub for more rapid innovation</li>
<br />
<li>The content wars have begun they have. <a href="http://variety.com/2017/digital/news/disney-netflix-end-acquires-bamtech-espn-ott-services-1202519917/">Disney to End Netflix Deal, Sets Launch of ESPN and Disney-Branded Streaming Services</a>. Everyone wants to be a streaming service with unique content to lock-in users. Disney wants to be Netflix and Netflix wants to be Disney. Even&nbsp;<a href="https://www.engadget.com/2017/08/16/apple-sets-1-billion-budget-for-original-tv-shows/">Apple sets $1 billion budget for original TV shows</a>. Though, so far, whatever taste level Apple has in designing nice shiny objects, hasn't rubbed off on their original content.&nbsp;</li>
<br />
<li><a href="http://www.datacenterjournal.com/nvme-change-agent-next-gen-data-centers/">NVMe: The Change Agent for Next-Gen Data Centers</a>:&nbsp;Non-Volatile Memory Express is a standard protocol and driver for SSDs based on NAND flash memory...NVMe-compliant SSDs can deliver up to 10 times the sequential read performance of SATA-based SSDs...Compared with SATA, the NVMe standard delivers better bandwidth and IOPS performance, plus lower latencies. It also provides scalability to main storage devices without the cost or complexities of battery-backed RAID or HBA cards...Replacing SATA-based SSDs or HDDs with NVMe SSDs can reduce the I/O wait time by 50 percent, enabling both database workloads to run on a single server and requiring only one license.</li>
<br />
<li>Looks good.&nbsp;<a href="https://www.amazon.com/Kubernetes-Running-Dive-Future-Infrastructure/dp/1491935677">Kubernetes: Up and Running: Dive into the Future of Infrastructure</a>.&nbsp;</li>
<br />
<li><a href="https://groups.google.com/d/msg/mechanical-sympathy/sljzehnCNZU/iiUyqbP9AwAJ">Alexandr Nikitin</a>: I played with Transparent Hugepages some time ago and I want to share some numbers based on real world high-load applications. We have a JVM application: high-load tcp server based on netty. No clear bottleneck, CPU, memory and network are equally highly loaded. The amount of work depends on request content...As you can see THP performance impact is measurable and too significant to ignore. 4.1 ms vs 3.2 ms 99%% and 100M vs 25M TLB misses. I also used SytemTap to measure few kernel functions like collapse_huge_page, clear_huge_page, split_huge_page. There were no significant spikes using THP.&nbsp;</li>
<br />
<li>Well done.&nbsp;<a href="http://www.geek-programmer.com/java-blocking-queues-explained/">Java Blocking Queues Explained!</a>: A computational problem can be decomposed in to pieces. Why? Because we can solve those pieces separately and get the final solution. There are several cores in most of the computer&rsquo;s processors nowadays so we can share the pieces among the cores.</li>
<br />
<li>Send this to someone if they are wondering how to start building a web site.&nbsp;<a href="https://medium.com/ladies-storm-hackathons/how-we-built-our-first-full-stack-javascript-web-app-in-three-weeks-8a4668dbd67c">How we built our first full-stack JavaScript web app in three weeks</a>:&nbsp;Step 1: Ideate;&nbsp;Step 2: Wireframe UX/UI;&nbsp;Step 3: Choose a data structure and type of database;&nbsp;Step 4: Set up Github and an agile workflow;&nbsp;Step 5: Choose &amp; download a boilerplate;&nbsp;Step 6: Write back-end API routes (or Firebase listeners);&nbsp;Step 7: Build a &ldquo;Proof Of Concept&rdquo;;&nbsp;Step 8: Code out the features;&nbsp;Step 9: Choose and code the design scheme;&nbsp;Step 10: Find and squash bugs;&nbsp;Step 11: Deploy the live app.</li>
<br />
<li><a href="https://github.com/novarto-oss/sane-dbc">novarto-oss/sane-dbc</a>:&nbsp;A sane approach to interacting with an RDBMS in Java</li>
<br />
<li><a href="https://equalit.ie/introducing-n1sec-a-protocol-for-distributed-multiparty-chat-encryption/">Introducing (n+1)sec &ndash; a protocol for distributed multiparty chat encryption</a>:&nbsp;&nbsp;end-to-end secure, synchronous protocol for group chat developed by eQualit.ie with support from the Open Technology Fund. After 2 years of design, development and testing, we are releasing the (n+1)sec protocol and library for securing group conversations on various messaging systems, like Jabber/XMPP or IRC.</li>
<br />
<li><a href="https://michael.steindorfer.name/publications/phd-thesis-efficient-immutable-collections.pdf">Efficient Immutable Collections</a>: In this thesis we introduce data structures that are more performant than comparable state-of-the-art standard library data structures &mdash;in terms of operation runtimes and memory footprints&mdash; and more general by supporting storage and retrieval of type-heterogeneous data&Dagger; where parametric polymorphism [OW97] on the language level falls short. We specifically target immutable, unordered and hashed data types, such as widely-used hash-sets and hash-maps; we will specify the concepts just mentioned as well as the characteristics of the proposed data structures throughout the remainder of this chapter</li>
<br />
<li><a href="http://dnasec.cs.washington.edu/dnasec.pdf">Computer Security, Privacy, and DNA Sequencing: Compromising Computers with Synthesized DNA, Privacy Leaks, and More</a>: We demonstrate, for the first time, the synthesis of DNA which &mdash; when sequenced and processed&mdash; gives an attacker arbitrary remote code execution. To study the feasibility of creating and synthesizing a DNA-based exploit, we performed our attack on a modified downstream sequencing utility with a deliberately introduced vulnerability. After sequencing, we observed information leakage in our data due to sample bleeding</li>
<br />
<li>Papers from <a href="https://research.googleblog.com/2017/08/google-at-icml-2017.html">Google at ICML 2017</a>.&nbsp;</li>
<br />
<li><a href="http://www.sciencedirect.com/science/article/pii/S1877050914007042">Engineering Antifragile Systems</a>: A Change In Design Philosophy (<a href="https://hackernoon.com/swarming-the-power-of-1m-evs-teslas-on-our-roads-cab1bfa1615">article</a>):&nbsp;NASA is working to infuse concepts from Complexity Science into the engineering process. Some of these problems may be solved by a change in design philosophy. Instead of designing systems to meet known requirements that will always lead to fragile systems at some degree, systems should be designed wherever possible to be antifragile: designing cognitive cyber-physical systems that can learn from their experience, adapt to unforeseen events they face in their environment, and grow stronger in the face of adversity. Several examples are presented of on ongoing research efforts to employ this philosophy.</li>
</ul>
<p>&nbsp;</p>
<p>Hey, just letting you know I've written a novella: <a href="https://smile.amazon.com/Strange-Trial-Ciri-First-Sentient-ebook/dp/B073GCWG6M">The Strange Trial of Ciri: The First Sentient AI</a>. It explores the idea of how a sentient AI might arise as ripped from the headlines deep learning techniques are applied to large social networks. Anyway, I like the story. If you do too please consider giving it a review on Amazon. Thanks for your support!</p>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2017/8/18/stuff-the-internet-says-on-scalability-for-august-18th-2017.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />1 Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2017/8/18/stuff-the-internet-says-on-scalability-for-august-18th-2017.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2017%2F8%2F18%2Fstuff-the-internet-says-on-scalability-for-august-18th-2017.html','Stuff%20The%20Internet%20Says%20On%20Scalability%20For%20August%2018th%2C%202017');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2017/8/18/stuff-the-internet-says-on-scalability-for-august-18th-2017.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/35951472"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/hot-links"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />hot links</a></span></span>  <span class="post-snippet-1"><iframe src="http://www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2017/8/18/stuff-the-internet-says-on-scalability-for-august-18th-2017.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2017/8/18/stuff-the-internet-says-on-scalability-for-august-18th-2017.html" data-text="Stuff The Internet Says On Scalability For August 18th,&nbsp;2017" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments  (1) </h3>

      
        
  <div class="comment-wrapper authored-by-None">
  <div class="comment" id="comment21772646">

    <div id="item21772646" class="body">

      <p>No problem on missing last week...and happy belated birthday :)</p>

    </div>
    <div class="signature">

      August 18, 2017 | 
  <a href="/contributor/29909687" title="Unregistered Commenter">
  <img title="Unregistered Commenter" alt="Unregistered Commenter" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/user-unregistered.png) top left no-repeat;"/>Joel Williams
  
  </a>



      
        

        

      

    </div>

  </div>
  </div>



        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=35951472"> 

     <input type="hidden" name="currentPage" value="1"/> 
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2016, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>