<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1338871095817&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2018/1/12/stuff-the-internet-says-on-scalability-for-january-12th-2017.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://five.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Stuff The Internet Says On Scalability For January 12th,&nbsp;2017 - High Scalability - </title>
    <meta property="og:title" content="Stuff The Internet Says On Scalability For January 12th,&nbsp;2017 - High Scalability - " /> 
  

      <meta property="og:description" content=" Hey, it's HighScalability time:  

 

 
 
Whiskey still? Chandelier? Sky city? Nope, it's IBM's 50..." />
  

  
      <meta property="og:image" content="https://c1.staticflickr.com/5/4656/39615468701_0af4129ccd.jpg" />
  

  <!-- End Heading -->

  <script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1044643/SS_HS_Ad1', [125, 125], 'div-gpt-ad-1325175098795-0').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad10', [125, 125], 'div-gpt-ad-1325175098795-1').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad11', [125, 125], 'div-gpt-ad-1325175098795-2').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad12', [125, 125], 'div-gpt-ad-1325175098795-3').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad13', [125, 125], 'div-gpt-ad-1325175098795-4').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad14', [125, 125], 'div-gpt-ad-1325175098795-5').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad15', [125, 125], 'div-gpt-ad-1325175098795-6').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad16', [125, 125], 'div-gpt-ad-1325175098795-7').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad17', [125, 125], 'div-gpt-ad-1325175098795-8').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad2', [125, 125], 'div-gpt-ad-1325175098795-9').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad3', [125, 125], 'div-gpt-ad-1325175098795-10').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad4', [125, 125], 'div-gpt-ad-1325175098795-11').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad5', [125, 125], 'div-gpt-ad-1325175098795-12').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad6', [125, 125], 'div-gpt-ad-1325175098795-13').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_ad7', [125, 125], 'div-gpt-ad-1325175098795-14').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad8', [125, 125], 'div-gpt-ad-1325175098795-15').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad9', [125, 125], 'div-gpt-ad-1325175098795-16').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad18', [125, 125], 'div-gpt-ad-1325175098795-17').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad19', [125, 125], 'div-gpt-ad-1325175098795-18').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad20', [125, 125], 'div-gpt-ad-1325175098795-19').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>


  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId36018251"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2018%2F1%2F12%2Fstuff-the-internet-says-on-scalability-for-january-12th-2017.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19697312">

    <div id="navigationTop-moduleContent19697312">

              <a id="navigationTop-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19697312">

    <div id="navigationBottom-moduleContent19697312">

              <a id="navigationBottom-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19697312">

    <div id="moduleContent19697312">

              <a id="moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2018/1/12/stuff-the-internet-says-on-scalability-for-january-12th-2017.html">Stuff The Internet Says On Scalability For January 12th, 2017</a></li>  <li><a href="/blog/2018/1/9/how-technology-is-changing-music-to-fit-inside-streamings-ne.html">How Technology is Changing Music to fit Inside Streaming's New Box</a></li>  <li><a href="/blog/2018/1/5/stuff-the-internet-says-on-scalability-for-january-5th-2017.html">Stuff The Internet Says On Scalability For January 5th, 2017</a></li>  <li><a href="/blog/2017/12/18/explain-the-cloud-like-im-10.html">Explain the Cloud Like I'm 10</a></li>  <li><a href="/blog/2017/12/15/stuff-the-internet-says-on-scalability-for-december-15th-201.html">Stuff The Internet Says On Scalability For December 15th, 2017</a></li>  <li><a href="/blog/2017/12/11/netflix-what-happens-when-you-press-play.html">Netflix: What Happens When You Press Play?</a></li>  <li><a href="/blog/2017/12/8/stuff-the-internet-says-on-scalability-for-december-8th-2017.html">Stuff The Internet Says On Scalability For December 8th, 2017</a></li>  <li><a href="/blog/2017/12/5/sponsored-post-symbiont-loupe-etleap-aerospike-stream-scalyr.html">Sponsored Post: Symbiont, Loupe, Etleap, Aerospike, Stream, Scalyr, VividCortex, Domino Data Lab, MemSQL, Zohocorp</a></li>  <li><a href="/blog/2017/12/4/the-eternal-cost-savings-of-netflixs-internal-spot-market.html">The Eternal Cost Savings of Netflix's Internal Spot Market</a></li>  <li><a href="/blog/2017/12/1/stuff-the-internet-says-on-scalability-for-december-1st-2017.html">Stuff The Internet Says On Scalability For December 1st, 2017</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <CENTER>
  <!-- SS_HS_Ad1 -->
  <div id='div-gpt-ad-1325175098795-0' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-0'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad10 -->
  <div id='div-gpt-ad-1325175098795-1' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-1'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad11 -->
  <div id='div-gpt-ad-1325175098795-2' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-2'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad12 -->
  <div id='div-gpt-ad-1325175098795-3' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-3'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad13 -->
  <div id='div-gpt-ad-1325175098795-4' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-4'); });
  </script>
  </div>
  
  
  <!-- SS_HS_Ad14 
  <div id='div-gpt-ad-1325175098795-5' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-5'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad15 
  <div id='div-gpt-ad-1325175098795-6' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-6'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad16 
  <div id='div-gpt-ad-1325175098795-7' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-7'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad17 
  <div id='div-gpt-ad-1325175098795-8' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-8'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad2 
  <div id='div-gpt-ad-1325175098795-9' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-9'); });
  </script>
  </div>
  -->
  
  </CENTER>
  
  <center><a href="/advertising">advertise</A></center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2018%2F1%2F12%2Fstuff-the-internet-says-on-scalability-for-january-12th-2017.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2018/1/9/how-technology-is-changing-music-to-fit-inside-streamings-ne.html">How Technology is Changing Music to fit Inside Streaming's New Box &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability category-hot-links">
<div id="item36018251" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Friday</span></div><div class="journal-entry-float-date"><span class="month">Jan</span><span class="date">12</span><span class="year">2018</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2018/1/12/stuff-the-internet-says-on-scalability-for-january-12th-2017.html">Stuff The Internet Says On Scalability For January 12th,&nbsp;2017</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Friday, January 12, 2018 at 8:58AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p><span>Hey, it's <span>HighScalability</span> time:&nbsp;</span></p>
<p style="text-align: center;"><img src="https://c1.staticflickr.com/5/4656/39615468701_0af4129ccd.jpg" alt="" /></p>
<div align="center">
<p><br />Whiskey still? Chandelier? Sky city? Nope, it's IBM's <a href="https://spectrum.ieee.org/tech-talk/computing/hardware/ibm-edges-closer-to-quantum-supremacy-with-50qubit-processor">50-qubit</a> quantum computer. (<a href="https://www.engadget.com/2018/01/09/this-is-what-a-50-qubit-quantum-computer-looks-like/">engadget</a>)</p>
<p>&nbsp;</p>
<p>If you like this sort of <em>Stuff</em> then please support me <a href="https://www.patreon.com/toddhoff"><span>on <span>Patreon</span></span></a>. And I'd appreciate your recommending my new book&mdash;<a href="https://www.amazon.com/dp/B0765C4SNR">Explain the Cloud Like I'm 10</a>&mdash;to anyone who needs to understand the cloud (who doesn't?). I think they'll like it. Now with twice the brightness and new chapters on Netflix and Cloud Computing.</p>
<p>&nbsp;</p>
</div>
<ul>
<li><a href="https://www.pornhub.com/insights/2017-year-in-review">28.5 billion</a>: PornHub visitors;&nbsp;<a href="https://www.technologyreview.com/s/609891/at-least-3-billion-computer-chips-have-the-spectre-security-hole/">3 billion</a>: computer chips&nbsp;have Spectre security hole;&nbsp;<a href="https://duckduckgo.com/download/Private_Browsing.pdf">75.8%</a>: people incorrectly think private browsing is actually private;&nbsp;<a href="https://webcache.googleusercontent.com/search?q=cache%3AAaLrQwumVT8J%3Ahttps%3A%2F%2Fwww.huffingtonpost.com%2Fentry%2Fspotifys-fatal-flaw-exposed-how-my-closed-door-meeting_us_5a512262e4b0cd114bdb33cd+&amp;cd=1&amp;hl=en&amp;ct=clnk%E2%89%B7%3Dus">380,000</a>: streams needed to make minimum wage on Spotify;&nbsp;<a href="https://www.theregister.co.uk/2018/01/08/azure_fpga_nics/">30Gbps</a>:&nbsp;throughput for servers in Azure using&nbsp;new network interface cards packing field-programmable gate arrays;&nbsp;<a href="http://www.noaa.gov/media-release/noaa-kicks-off-2018-with-massive-supercomputer-upgrade">8 quadrillion calculations per second</a>: new NOAA supercomputer;&nbsp;<a href="https://www.cnbc.com/2018/01/08/a-parody-cryptocurrency-just-broke-2-billion-for-its-market-cap.html">$2 billion</a>:&nbsp;market cap for&nbsp;parody cryptocurrency dogecoin; <a href="https://community.arm.com/cfs-file/__key/telligent-evolution-components-attachments/01-1996-00-00-00-01-30-09/Arm-_2D00_-The-route-to-a-trillion-devices-_2D00_-June-2017.pdf">$1 trillion</a>: IoT spending by 2035;&nbsp;<a href="https://spectrum.ieee.org/tech-talk/telecom/internet/a-massive-iot-sensor-network-keeps-watch-over-a-1400kilometer-canal">100,000</a>: IoT sensors monitor canal in China;&nbsp;<a href="https://www.technologyreview.com/s/609871/the-anatomy-of-the-urban-dictionary/">1,204</a>: definitions for emo; <a href="https://www.newscientist.com/article/2157773-largest-prime-number-ever-found-has-over-23-million-digits/">23 million</a>: digits in largest prime number;&nbsp;<a href="https://www.gartner.com/newsroom/id/3844572">2.8%</a>: decline in PC shipments;&nbsp;</li>
<br />
<li>Quoteable Quotes:                                
<ul>
<li><a href="https://twitter.com/lee_holmes/status/948954287165489153">@Lee_Holmes</a>:&nbsp;We owe a debt of gratitude to the unsung heroes of Spectre and Meltdown: the thousands of engineers that spent their holidays working on OS patches, browser patches, cloud roll-outs, and more. Thank you.</li>
<li><a href="http://www.potaroo.net/ispcol/2018-01/bgp2017.html">Geoff Huston</a>: While a small number of providers have made significant progress in public IPv6 deployments for their respective customer base, the overall majority of the Internet is still exclusively using IPv4. This is despite the fact that among that small set of networks that have deployed IPv6 are some of the largest ISPs in the Internet!&nbsp;</li>
<li><a href="https://www.amazon.com/dp/B01IAUGC5S">Robert Sapolsky</a>: But our frequent human tragedy is that the more we consume, the hungrier we get. More and faster and stronger. What was an unexpected pleasure yesterday is what we feel entitled to today, and what won&rsquo;t be enough tomorrow.</li>
<li><a href="https://read.acloud.guru/simon-wardley-is-a-big-fan-of-containers-despite-what-you-might-think-18c9f5352147">Simon Wardley</a>: As for losers &mdash; I&rsquo;m sorry to say that one set of losers will be those who hold on to DevOps practices.</li>
<li><a href="https://stackoverflow.blog/2018/01/11/brutal-lifecycle-javascript-frameworks/">StackOverflow</a>:&nbsp;Angular and React are by far the most popular across the board, no matter the technology used. It makes sense that they are the clear frontrunners, supported by two of the biggest and most influential companies in tech. Just looking at those two frameworks, Angular is more visited amongst C#, Java, and (to a degree) PHP developers, whereas React is more popular with Rails, Node.js, and Python developers.</li>
<li><a href="https://blog.cryptographyengineering.com/2018/01/10/attack-of-the-week-group-messaging-in-whatsapp-and-signal/">Matthew Green</a>: due to flaws in both Signal and WhatsApp (which I single out because I use them), it&rsquo;s theoretically possible for strangers to add themselves to an encrypted group chat. However, the caveat is that these attacks are extremely difficult to pull off in practice, so nobody needs to panic. But both issues are very avoidable, and tend to undermine the logic of having an end-to-end encryption protocol in the first place.&nbsp;</li>
<li><a href="https://www.thedailybeast.com/author/taylor-lorenz">Taylor Lorenz</a>: The data shows that despite its perception as a nascent social platform, Snapchat is much more of a chat app. And key features like Snap Maps have yet to gain widespread adoption among the app&rsquo;s user base. </li>
<li><a href="https://www.fittedcloud.com/blog/upgrading-aws-ec2-c5m5-instances-reduce-cost-caveats/">FittedCloud</a>: In summary, converting C4/M4 instances may not be a trial task. But for those that are able to go through the analysis and convert could save significantly and improve application performance. At the pace with which AWS moves it is likely that next generation instances will continue to be available in the coming years so the sooner you upgrade the better prepared you are for the future generation instances.</li>
<li><a href="https://cloudplatform.googleblog.com/2018/01/how-moving-Apigee-Sense-to-GCP-reduced-our-data-litter-and-decreased-our-costs.html">Sridhar Rajagopalan</a>: When we moved the Sense analytics chain to GCP, the data coverage metric went from below 80% to roughly 99.8% for one of our toughest customer use cases. Put another way, our data litter decreased from over 20%, or one in five, to approximately one in five hundred. That&rsquo;s a decrease of a factor of approximately 100, or two orders of magnitude!</li>
<li><a href="https://read.acloud.guru/simon-wardley-is-a-big-fan-of-containers-despite-what-you-might-think-18c9f5352147">Simon Wardley</a>: We have to be very, very careful on this point. Because people think &ldquo;reduced waste&rdquo; means &ldquo;reduced IT spend&rdquo;. And it certainly does not. We&rsquo;ll see more efficiency and rapid development of higher order systems. But in terms of reducing IT spend, people said the same thing about EC2 in 2007, 2008. And they quickly learned about something called Jevons&rsquo; Paradox. What happens is that as we make something more efficient, we wind up consuming vastly more of that thing. So when people say &ldquo;Oh, we&rsquo;re going to spend so much less money with serverless!&rdquo; nah &mdash; forget it. We&rsquo;re just going to do more stuff.</li>
<li><a href="https://spectrum.ieee.org/tech-talk/telecom/wireless/ces-2018-what-happens-to-your-phone-is-going-to-be-the-least-interesting-thing-about-5g">Stephen Cass</a>: 5G is likely to become the glue that binds many of our critical technologies together, which will put mobile carriers at the center of modern global civilization in a big way.</li>
<li><a href="https://twitter.com/sggrc/status/950501739454636032">@SGgrc</a>: The General Law of Cross-Task Information Leakage: &ldquo;In any setting where short-term performance optimizations have global effect, a sufficiently clever task can infer the recent history of other tasks by observing its own performance.&rdquo;</li>
<li><a href="https://medium.freecodecamp.org/stories-from-300-developers-who-got-their-first-tech-job-in-their-30s-40s-and-50s-64306eb6bb27">Quincy Larson</a>: It turns out a LOT of developers got their first tech job in their 30s, 40s, and 50s.</li>
<li><a href="https://twitter.com/mjpt777/status/951161217791463424">@mjpt777</a>:&nbsp;The approach of not caring about software performance because processors keep getting faster seems to be a bit broken right now.</li>
<li><a href="https://www.washingtonpost.com/news/theworldpost/wp/2017/10/31/technology-environment">Bill Joy</a>:&nbsp;We sought &ldquo;grand challenge&rdquo; breakthroughs because they can lead to a cascade of positive effects and transformations far beyond their initial applications. The grand challenge approach works &mdash; dramatic improvements reducing energy, materials and food impact are possible. If we widely deploy such breakthrough innovations, we will take big steps toward a sustainable future.</li>
<li><a href="https://twitter.com/cocoaphony/status/950883388575174658">@cocoaphony</a>:&nbsp;I have made some snarky comments about "serverless" (since it&hellip;you know&hellip;runs on servers). And I have flailed around quite a bit trying to understand that world. But as it comes into focus, wow, oh my goodness, it really is quite amazing what I'm able to do with so little code.</li>
<li><a href="https://twitter.com/thelastpickle/status/951157056718843904">@TheLastPickle</a>:&nbsp;Running cassandra-stress on a mixed load showed 20%+ latency increase, over every percentile, when upgrading to the patched ubuntu kernel 4.13.0-25 #Cassandra #meltdown</li>
<li><a href="https://twitter.com/PWAStats/status/951633915286114305">@PWAStats</a>:&nbsp;Tinder cut load times from 11.91 seconds to 4.69 seconds with their new PWA. The PWA is 90% smaller than Tinder&rsquo;s native Android app. User engagement is up across the board on the PWA.</li>
<li><a href="https://twitter.com/Nick_Craver/status/951831239320899584">@Nick_Craver</a>:&nbsp;Here's what happened last night to one of our busier redis servers before and after patching for meltdown. Using the same 200k/12 minute axes on both: down from ~145k ops/sec to ~95ks ops/sec, or about 35% slower.</li>
<li><a href="https://discuss.httparchive.org/t/cache-control-immutable-a-year-later/1195">paulcalvano</a>: In a year since Facebook&rsquo;s blog post200 about Cache-Control Immutable, we can see that it&rsquo;s usage has spread beyond Facebook and is being used by a handful of large 3rd parties and ~4150 additional domains. Across all of the pages in the HTTP Archive, 2% of requests and 30% of sites appear to include at least 1 immutable response. Additionally, most of the sites that are using it have the directive set on assets that have a long freshness lifetime.</li>
<li><a href="https://www.bloomberg.com/news/articles/2018-01-08/-it-can-t-be-true-inside-the-semiconductor-industry-s-meltdown">Bloomberg</a>: "It makes you shudder," said Paul Kocher, who helped find Spectre and started studying trade-offs between security and performance after leaving chip company Rambus Inc. last year. "The processor people were looking at performance and not looking at security."</li>
<li><a href="https://twitter.com/quora/status/949837380470673408">@Quora</a>:&nbsp;Quora is facing a slowdown due to the patch applied by AWS for Intel's Meltdown and Spectre issues. We are currently working on fixing it and appreciate your patience during this.</li>
<li><a href="http://queue.acm.org/detail.cfm?id=3178371">Theo Schlossnagle</a>:&nbsp;the ground has shifted under the monitoring industry. This seismic change has caused existing tools to change and new tools to emerge in the monitoring space, but that alone will not deliver us into the low-risk world of DevOps&mdash;not without new and updated thinking. Why? Change.</li>
<li><a href="https://www.epicgames.com/fortnite/forums/news/announcements/132642-epic-services-stability-update">Epic Games</a>:&nbsp;We wanted to provide a bit more context for the most recent login issues and service instability. All of our cloud services are affected by updates required to mitigate the Meltdown vulnerability. We heavily rely on cloud services to run our back-end and we may experience further service issues due to ongoing updates.</li>
<li><a href="https://news.ycombinator.com/item?id=16082907">scrollaway</a>:&nbsp;Yep, seeing a much more severe hit on all our elasticache instances than anywhere else. CPU graph from two underused ones</li>
<li><a href="https://news.ycombinator.com/item?id=16083766">necubi</a>:&nbsp;We also saw a huge hit on our memcached elasticache nodes. Eyeballing from our CPU graph, seems ~30%.</li>
<li><a href="http://brooker.co.za/blog/2018/01/01/balls-into-bins">Marc Brooker</a>: the conclusion of all of this is that random load balancing (and random shuffle-sharding, and random consistent hashing) distributed load rather poorly when 𝑀 is small. Load-sensitive load-balancing, either stateful or stateless with an algorithm like best-of-two is still very much interesting and relevant. The world would be simpler and more convenient if that wasn't the case, but it is.</li>
<li><a href="https://twitter.com/joeerl/status/949657413963210753">@joeerl</a>: Quite - right. One process = one CPU. Shared nothing. Pure message passing. The fact this is inefficient on conventional hardware is because conventional hardware has been optimised for something completely different.</li>
<li><a href="https://twitter.com/kelseyhightower/status/950886344959635456">@kelseyhightower</a>:&nbsp;Serverless is going to DRY up software development. Look beyond FaaS and you'll find better platforms that help you avoid rebuilding the same subsystems over and over again.</li>
<li><a href="http://ampletter.org/">ampletter</a>: We don&rsquo;t want to stop Google&rsquo;s development of AMP, and these changes do not require that. We also applaud search engines that give ranking preference to fast-loading pages. AMP can remain one of a range of technologies that give publishers high quality options for delivering Web pages quickly and making users happy. However, publishers should not be compelled by Google&rsquo;s search dominance to put their content under a Google umbrella. The Web is not Google, and should not be just Google.</li>
<li><a href="https://twitter.com/mnewswanger/status/951540572799602690">@mnewswanger</a>: Breaking down requests for @StackOverflow web servers: Pre-Meltdown Patch -&gt; Post Meltdown Patch (Increase %) Response time: 18ms -&gt; 22ms (22%) Avg SQL Call: .73ms -&gt; .83ms (13%) Avg Elastic Call: 12.56ms -&gt; 19.71ms (57%) #Meltdown</li>
<li><a href="https://twitter.com/swardley/status/950890655827550208">@swardley</a>:&nbsp;One of the biggest arguments for "bad" hybrid cloud (as in public + private) is the sunk cost fallacy of an existing data centre.&nbsp; In practice, this is hiding a truth - loss of political capital. Execs just don't want to admit they've spent billions on the obviously wrong thing.</li>
<li><a href="https://www.epicgames.com/fortnite/forums/news/announcements/132642-epic-services-stability-update">Epic Games</a>: We wanted to provide a bit more context for the most recent login issues and service instability. All of our cloud services are affected by updates required to mitigate the Meltdown vulnerability. We heavily rely on cloud services to run our back-end and we may experience further service issues due to ongoing updates.</li>
<li><a href="https://www.reddit.com/r/programming/comments/7ok5ty/cloudflare_golang_sucks/dsakvpd/">kl0nos</a>: I see Rust Evangelic Strike Force in Action again. Bashing Go and everything else whenever you can and prising Rust without seeing its obvious flaws.
<div id="_mcePaste"></div>
<div id="_mcePaste">Every programming language has flaws, period. Go also has its flaws, same goes for Rust, C++, Java etc.</div>
</li>
<li>
<div id="_mcePaste"><a href="http://thememoryguy.com/how-3d-nand-shrinks-ecc-requirements/">Memory Guy</a>:&nbsp;Why is ECC necessary on NAND flash, yet it&rsquo;s not used for other memory technologies?&nbsp; The simple answer is that NAND&rsquo;s purpose is to be the absolute cheapest memory on the market, and one way to achieve the lowest-possible cost is to relax the standards for data integrity &mdash; to allow bit errors every so often.&nbsp;</div>
</li>
<li><a href="https://twitter.com/aionescu/status/948817335980142592">@aionescu</a>:The mitigations poor OS vendors have to do for "Variant 2: branch target injection (CVE-2017-5715)" aka #Spectre make me cry/die a little inside.
<div></div>
The mitigations poor OS vendors have to do for "Variant 2: branch target injection (CVE-2017-5715)" aka #Spectre make me cry/die a little inside.</li>
<li><a href="https://twitter.com/parismarx/status/946598080522137601">@parismarx</a>: &ldquo;Prior to artificial regulatory supply caps, the unregulated taxi industry was unprofitable and subject to growing concerns over negative externalities. #Uber is now facing the same relentless drag on its P&amp;L.&rdquo;</li>
<li><a href="https://twitter.com/bitfield/status/949602601624055808">@bitfield</a>: This isn't a patch, this is like cutting your leg off to prevent someone stealing your toes.</li>
<li><a href="https://blog.siftscience.com/2018/travel-fraud-challenges/">Sift Science</a>: The window of time between booking and traveling is shrinking for all travelers. One-third of millennials make travel plans at the last minute, and 72% of mobile hotel bookings are made within one day of a stay.&nbsp;</li>
<li><a href="https://twitter.com/brendangregg/status/949455222497161216">@brendangregg</a>:&nbsp;2018 will be the year of Transparent Huge Pages. KPTI patches for #spectre/#meltdown do a TLB flush on syscalls. Can be better to reload by 2M instead of 4k.</li>
<li><a href="https://twitter.com/lukego/status/949661982042488832">@lukego</a>:&nbsp;One core Per process is actually becoming popular in some domains e.g. network data planes. We setup CPU+NIC pairs that seldom talk to the kernel and we don&rsquo;t seem to be particularly impacted (afaik.) Stay in ring3 and be merry...?</li>
<li><a href="https://twitter.com/jxxf/status/949291438701010944">@jxxf</a>: How to avoid 80% of all software problems: * store all times as UTC ISO8601 * only do datetime math with libraries * more processes &gt; more threads * avoid building a distributed system * ... or if you can't, avoid requiring coordination * shun whiteboard coding interviews</li>
<li><a href="https://semiengineering.com/getting-serious-about-chiplets/">Ann Steffora Mutschler</a>:&nbsp;The idea of using chiplets, with or without a package, has been circulating for at least a half-dozen years, and they can trace their origin back to IBM&rsquo;s packaging scheme in the 1960s. It is now picking up steam, both commercially and for military purposes, as the need for low-cost semi-customized solutions spreads across a number of new market opportunities.</li>
<li><a href="https://twitter.com/chris__martin/status/950206403813273600">@chris__martin</a>: The "overly-verbose programming language" problem: When you translate your idea into code, a bunch of extra detail has to be added. The "insufficiently-typed programming language" problem: when you translate your idea into code, a bunch of valuable detail has to be removed.</li>
<li><a href="https://medium.com/@jameshorrox/the-science-of-hiking-53e8260ab46d">James Horrox</a>: In a 2012 study, psychologists David L. Strayer and Ruth and Paul Atchley sent a group of participants on a four-day wilderness hike, completely cut off from technology, and subsequently asked them to carry out tasks requiring creative thinking and complex problem solving. The study found that participants&rsquo; performance on these tasks improved by 50%, leading the authors to conclude that &ldquo;[t]here is a real, measurable cognitive advantage to be realized if we spend time truly immersed in a natural setting&rdquo;.</li>
<li><a href="http://blog.appliedmaterials.com/materials-engineering-key-unlocking-commercial-value-ai">Dr. Welser</a>~&nbsp;Beyond the current trend of using GPUs as accelerators, future advances in computing logic architecture for AI will be driven by a shift toward reduced-precision analog devices, which will be followed by mainstream applications of quantum computing. Neural network algorithms that GPUs are commonly used for are inherently designed to tolerate reduced precision. Reducing the size of the data path would allow more computing elements to be packed together inside a GPU, a dynamic that in the past was taken for granted as an outcome of Moore's Law technology scaling. Whether it is integration of analog computing elements or solving complex chemistry problems for quantum computing, materials engineering will play a critical enabling role.</li>
<li><a href="http://www.potaroo.net/ispcol/2018-01/bgp2017.html">Geoff Huston</a>: The density of inter-AS interconnection continues to increase. The growth of the Internet is not "outward growth from the edge" as the network is not getting any larger in terms of average AS path change. Instead, the growth is happening by increasing the density of the network by attaching new networks into the existing transit structure and peering at established exchange points. This makes for a network whose diameter, measured in AS hops, is essentially static, yet whose density, measured in terms of prefix count, AS interconnectivity and AS Path diversity, continues to increase. This denser mesh of interconnectivity could be potentially problematical in terms of convergence times if the BGP routing system used a dense mesh of peer connectivity, but the topology of the network continues along a clustered hub and spoke model, where a small number of transit ASs directly service a large number of stub edge networks. This implies that the performance of BGP in terms of time and updates required to reach convergence continues to be relatively static.</li>
<li><a href="https://www.grc.com/sn/SN-645-Notes.pdf">Steve Gibson</a>: Speculative execution is a technique used by high speed processors in order to increase performance by guessing likely future execution paths and prematurely executing the instructions in them. For example when the program&rsquo;s control flow depends on an uncached value located in the physical memory, it may take several hundred clock cycles before the value becomes known. Rather than wasting these cycles by idling, the processor guesses the direction of control flow, saves a checkpoint of its register state, and proceeds to speculatively execute the program on the guessed path. When the value eventually arrives from memory the processor checks the correctness of its initial guess. If the guess was wrong, the processor discards the (incorrect) speculative execution by reverting the register state back to the stored checkpoint, resulting in performance comparable to idling. In case the guess was correct, however, the speculative execution results are committed, yielding a significant performance gain as useful work was accomplished during the delay.</li>
</ul>
</li>
<br />
<li>Google solved Spectre in a very googly way.&nbsp;<a href="https://www.blog.google/topics/google-cloud/protecting-our-google-cloud-customers-new-vulnerabilities-without-impacting-performance/">Protecting our Google Cloud customers from new vulnerabilities without impacting performance</a>: With the performance characteristics uncertain, we started looking for a &ldquo;moonshot&rdquo;&mdash;a way to mitigate Variant 2 without hardware support. Finally, inspiration struck in the form of &ldquo;Retpoline&rdquo;&mdash;a novel software binary modification technique that prevents branch-target-injection, created by Paul Turner, a software engineer who is part of our Technical Infrastructure group. With Retpoline, we didn't need to disable speculative execution or other hardware features. Instead, this solution modifies programs to ensure that execution cannot be influenced by an attacker.&nbsp;By December, all Google Cloud Platform (GCP) services had protections in place for all known variants of the vulnerability. During the entire update process, nobody noticed: we received no customer support tickets related to the updates. This confirmed our internal assessment that in real-world use, the performance-optimized updates Google deployed do not have a material effect on workloads. With Retpoline, we could protect our infrastructure at compile-time, with no source-code modifications. Furthermore, testing this feature, particularly when combined with optimizations such as software branch prediction hints, demonstrated that this protection came with almost no performance loss.</li>
<br />
<li>Azure has some work to do.&nbsp;<a href="https://www.azurefromthetrenches.com/azure-functions-vs-aws-lambda-scaling-face-off/">Azure Functions vs AWS Lambda &ndash; Scaling Face Off</a>:&nbsp;The results are, frankly, pretty damning when it comes to Azure Functions ability to scale dynamically and so let&rsquo;s get into the data and then look at why...Add 2 Users per Second...We can see from this test that AWS matches the growth in user load almost exactly, it has no issue dealing with the growing demand and page requests time hover around the 100ms mark. Contrast this with Azure which always lags a little behind the demand, is spikier, and has a much higher response time hovering around the 700ms mark...Constant Load of 400 Concurrent Users...[AWS]&nbsp;quickly absorbs the load and hits a steady response time of around 80ms again in under a minute...Azure, on the other hand, is more complex. Average response time doesn&rsquo;t fall under a second until the test has been running for 7 minutes and it&rsquo;s only around then that the system is able to get near the throughput AWS put out in a minute...Same scenario as the last test but this time 1000 users...Again we can see a similar pattern with Azure slow to scale up to meet the demand while with AWS it is business as usual in under a minute...I don&rsquo;t think there&rsquo;s much point dancing around the issue: the above numbers are disappointing. Azure is slow to scale it&rsquo;s HTTP triggered functions and once we get beyond the 100 concurrent users point the response times are never great and the experience is generally uneven</li>
<br />
<li>PornHub&mdash;2017 <a href="https://www.pornhub.com/insights/2017-year-in-review">by the numbers</a>:&nbsp;28.5 billion visitors...81 million people per day...24.7 billion searches...this translates to about 50,000 searches per minute and 800 searches per second.&nbsp;This is also incidentally the same number of hamburgers that McDonalds sells every second...users and content partners uploaded over 4 million videos...In total, 595,482 hours of video were uploaded, which is 68 YEARS of porn if watched continuously...3,732 Petabytes of data was streamed&nbsp;for 7,101 GB per minutes and 118 GB per second...every 5 minutes Pornhub transmits more data than the entire contents of the New York Public library&rsquo;s 50 million books...people are more interested than ever before in &lsquo;Porn for Women&rsquo;, making this the top trending search throughout the year, increasing by over 1400%.</li>
<br />
<li>Gil does his usual masterful job explaining&nbsp;Meltdown. This is only part of his long and detailed post. You'll want to read the whole thing.&nbsp;<a href="https://groups.google.com/forum/m/#!msg/mechanical-sympathy/L9mHTbeQLNU/2NEif-GIAAAJ">Gil Tene</a>: I'm sure people here have heard enough about the Meltdown vulnerability and the rush of Linux fixes that have to do with addressing it. So I won't get into how the vulnerability works here. My one word reaction to the simple code snippets showing "remote sensing" of protected data values was "Wow". However, in examining both the various fixes rolled out in actual Linux distros over the past few days and doing some very informal surveying of environments I have access to, I discovered that the PCID processor feature, which used to be a virtual no-op, is now a performance AND security critical item. In the spirit of [mechanically] sympathizing with the many systems that now use PCID for a new purpose, as well was with the gap between the haves/have-nots in the PCID world, let me explain why: The PCID (Processor-Context ID) feature on x86-64 works much like the more generic ASID (Address Space IDs) available on many hardware platforms for decades. Simplistically, it allows TLB-cached page table contents to be tagged with a context identifier, and limits the lookups in the TLB to only match within the currently allowed context. TLB cached entires with a different PCID will be ignored. Without this feature, a context switch that would involve switching to a different page table (e.g. a process-to-process context switch) would require a flush of the entire TLB. With the feature, it only requires a change to the context id designated as "currently allowed". The benefit of this comes up when a back-and-forth set of context switches (e.g. from process 1 to process 2 and back to process 1) occurs "quickly enough" that TLB entries of the newly-switched-into context still reside in the TLB cache. With modern x86 CPUs holding &gt;1K entries in their L2 TLB caches (sometimes referred to as STLB), and each entry mapping 2MB or 4KB virtual regions to physical pages, the possibility of such reuse becomes interesting on heavily loaded systems that do a lot of process-to-process context switching. It's important to note that in virtually all modern operating systems, thread-to-thread context switches do not require TLB flushing, and remain within the same PCID because they do not require switching the page table. In addition, UNTIL NOW, most modern operating systems implemented user-to-kernel and kernel-to-user context switching without switching page tables, so no TLB flushing or switching or ASID/PCID was required in system calls or interrupts. The PCID feature has been a "cool, interesting, but not critical" feature to know about in most Linux/x86 environments for these main reasons: 1. Linux kernels did not make use of PCID until 4.14. So even tho it's been around and available in hardware, it didn't make any difference. 2. It's been around and supported in hardware "forever", since 2010 (apparently added with Westmere), so it's not new or exciting. 3. The benefits of PCID-based retention of TLB entries in the TLB cache, once supported by the OS, would only show up when process-to-process context switching is rapid enough to matter. While heavily loaded systems with lots of active processes (not threads) that rapidly switch would benefit, systems with a reasonable number of &nbsp;of [potentially heavily] multi-threaded processes wouldn't really be affected or see a benefit. This all changed with Meltdown.&nbsp;</li>
<br />
<li>Here's a thorough EC2 network benchmark in the form of an&nbsp;<a href="https://cloudonaut.io/ec2-network-performance-cheat-sheet/">EC2 Network Performance Cheat Sheet</a>. Fastest was&nbsp;m5.24xlarge at 24.597&nbsp;Gbit/s. Slowest was&nbsp;t1.micro at 0.094&nbsp;Gbit/s.</li>
<br />
<li><a href="https://dbahire.com/finding-out-the-mysql-performance-regression-due-to-kernel-mitigation-for-meltdown-cpu-vulnerability/">Finding out the MySQL performance regression due to kernel mitigation for Meltdown CPU vulnerability</a>:&nbsp;In this case we can observe around a 4-7% regression in throughput if pcid is enabled. If pcid is disabled, they increase up to 9-10% bad, but not as bad as the warned by some &ldquo;up to 20%&rdquo;. If you are in my situation, and upgrade to stretch would be worth to get the pcid support.</li>
<br />
<li>RedHat on&nbsp;<a href="https://access.redhat.com/articles/3307751">Speculative Execution Exploit Performance Impacts - Describing the performance impacts to security patches for CVE-2017-5754 CVE-2017-5753 and CVE-2017-5715</a>. They see a&nbsp;1-20% performance reduction.</li>
<br />
<li>How long can a BBC reporter stay hidden from CCTV cameras in China? 7 minutes. @TheJohnSudworth has been given rare access to put the world's largest surveillance system to the test.&nbsp;<a href="https://twitter.com/BBCWorld/status/939832896604565505">Chilling</a>.</li>
<br />
<li><em>RSM (real systems monitoring) is coming, and we will, just as with RUM, be recording and analyzing systems-level interactions&mdash;every one of them</em>.&nbsp;<a href="http://queue.acm.org/detail.cfm?id=3178371">Monitoring in a DevOps World</a>:&nbsp;Long dead are the systems that age like fine wine. Today's systems are born in an agile world and remain fluid to accommodate changes in both the supplier and the consumer landscape...In this new world, you not only have fluid development processes that can introduce change on a continual basis, you also have adopted a microservices-systems architecture pattern...Many monitoring companies have been struggling to keep up with the nature of ephemeral architecture. Nodes come and go, and architectures dynamically resize from one minute to the next in an attempt to meet growing and shrinking demand. As nodes spin up and subsequently disappear, monitoring solutions must accommodate...The first thing to remember is that all the tools in the world will not help you detect bad behavior if you are looking at the wrong things. Be wary of tools that come with prescribed monitoring for complex assembled systems...When it comes to monitoring the "right thing," always look at your business from the top down...Second, embrace mathematics. In modern times, functionality is table stakes; it isn't enough that the system is working, it must be working well...Circonus has experienced an increase in data volume of almost seven orders of magnitude. Some people still monitor systems by taking a measurement from them every minute or so, but more and more people are actually observing what their systems are doing. This results in millions or tens of millions of measurements per second on standard servers...A third important characteristic of successful monitoring systems is data retention...At the pace we move, it is undeniable that your organization will develop intelligent questions regarding a failure that were missed immediately after past failures. Those new questions are crucial to the development of your organization, but they become absolutely precious if you can travel back in time and ask those questions about past incidents...The final piece of advice for a successful monitoring system is to be specific about what success looks like...The art of the SLI (service-level indicator), SLO (service-level objective), and SLA (service-level agreement) reigns here.</li>
<br />
<li>SSITH, really? Dear DARPA, should your new program developing a framework for designing security against cyberintruders right into chips&rsquo; microarchitecture really be called System Security Integrated Through Hardware and Firmware? May the force be with you.&nbsp;<a href="https://www.darpa.mil/news-events/2017-04-10">Baking Hack Resistance Directly into Hardware</a>.&nbsp;</li>
<br />
<li>Geoff Huston's flawless one paragraph <a href="http://www.potaroo.net/ispcol/2018-01/bgp2017.html">summary of BGP</a>:&nbsp;BGP is an instance of a Bellman-Ford distance vector routing algorithm. This algorithm allows a collection of connected devices (BGP speakers) to each learn the relative topology of the connecting network. The basic approach of this algorithm is very simple: each BGP speaker tells all its other neighbours about what it has learned if the new learned information alters the local view of the network. This is a lot like a social rumour network, where every individual who hears a new rumour immediately informs all their friends. BGP works in a very similar fashion: each time a neighbour informs a BGP speaker about reachability to an IP address prefix, the BGP speaker compares this new reachability information against its stored knowledge that was gained from previous announcements from other neighbours. If this new information provides a better path to the prefix then the local speaker moves this prefix and associated next hop forwarding decision to the local forwarding table and informs all its immediate neighbours of a new path to a prefix, implicitly citing itself as the next hop. In addition, there is a withdrawal mechanism, where a BGP speaker determines that it no longer has a viable path to a given prefix, in which case it announces a "withdrawal" to all its neighbours. When a BGP speaker receives a withdrawal, it stores the withdrawal against this neighbour. If the withdrawn neighbour happened to be the currently preferred next hop for this prefix, then the BGP speaker will examine its per-neighbour data sets to determine which stored announcement represents the best path from those that are still extant. If it can find such an alternative path, it will copy this into its local forwarding table and announce this new preferred path to all its BGP neighbours. If there is no such alternative path, it will announce a withdrawal to its neighbors, indicating that it no longer can reach this prefix.</li>
<br />
<li>People being badly burned by superheating water in a microwave is a thing. Here's a demonstration&nbsp;<a href="https://www.youtube.com/watch?v=1_OXM4mr_i0">on Mythbuster</a>s. Maybe some microwave oven makers can use some of the smart learnin' to recognize when a cup of liquid and too long of a timer period has been entered?</li>
<br />
<li><a href="https://spectrum.ieee.org/nanoclast/semiconductors/devices/stochastic-computing-in-a-single-device">Stochastic Computing in a Single Device</a>:&nbsp;Researchers at the University of Minnesota say they&rsquo;ve made a big leap in a strange but growing field of computing. Called stochastic computing, the method uses random bits to calculate via simpler circuits, at lower power, and with greater tolerance for errors...Their device, similar to an MRAM memory cell, can perform the stochastic computing versions of both addition and multiplication on four logical inputs...Instead of suppressing this random aspect of the magnetic tunnel junction&rsquo;s nature, Wang and&nbsp; Lv put it to use. They designed a cell that produces random strings of bits that carry and compute information...They demonstrated that the tunnel junction&rsquo;s randomness could be tuned by four independent values: the amplitude and width of a pulse of current fed into the junction, a bias current running through the junction, and a biasing magnetic field. Stochastic data can easily be converted to any of these with some simple circuitry. When Wang and Lv did that, they found that the device summed whatever values were input as pulse amplitude, bias current, and the bias magnetic field. The result of that triple summation was then multiplied by the value represented by the pulse width to produce an answer in the stochastic computing form&mdash;a string of random bits with a particular probability of ones occurring.</li>
<br />
<li>How might&nbsp;Tesla's car security work? Fascinating look at how a hardware-based Root of Trust works and why it&rsquo;s necessary.&nbsp;<a href="https://semiengineering.com/protecting-automotive-systems-with-a-root-of-trust/">Protecting Automotive Systems With A Root Of Trust</a>.&nbsp;</li>
<br />
<li><a href="https://engblog.nextdoor.com/summary-of-22-product-engineering-patterns-that-college-didnt-teach-me-77790331d8fa">Summary of 22 product-engineering patterns that college didn&rsquo;t teach me</a>:&nbsp;Know your short/mid/long-term solutions;&nbsp;Doing the right thing should be easy;&nbsp;Add monitoring &amp; alerting early on;&nbsp;Limiting the stack / Leveraging the existing stack;&nbsp;Use the right tools for the job;&nbsp;Time-boxing;&nbsp;Separation of responsibilities;&nbsp;Pain of failures ought to be felt by those who can fix it (and those who caused it);&nbsp;Cleanup should be easy;&nbsp;Solutions via Engineering or via People;&nbsp;Write Testable Code;&nbsp;Develop for debug-ability (or self-teaching failures);&nbsp;Understand when some extra work can become a slippery slope;&nbsp;No worse than before;&nbsp;All or nothing;&nbsp;Use time correlation to notice changes;&nbsp;Going from alert to failure should be fast;&nbsp;Bring in all the right people;&nbsp;Bad alerts are evil alerts.&nbsp;</li>
<br />
<li>What does the code to exploit Metdown look like? Here you go.&nbsp;<a href="http://funwithbits.net/blog/programmers-guide-to-meltdown/">Programmer's Guide to Meltdown</a>.</li>
<br />
<li><a href="https://www.gamasutra.com/blogs/JoostVanDongen/20180109/312693/The_limitations_of_matchmaking_without_server_logic.php">The limitations of matchmaking without server logic</a>: we came up with was to add a league system to Awesomenauts and limit matchmaking based on that. The idea is that we divide the leaderboards into 9 leagues, based on player skill. These leagues weren't just intended for matchmaking, but also for the player experience: it's cooler to be in league 2 than to be in place 4735, even though that might actually be the same thing...While leagues were an improvement, this approach didn't fix the big problem that there's no logic running on the servers. Each client decides for themselves based on incomplete information. This is very limiting to how clever your matchmaking can be. There are lots of situations in which this algorithm will fail to produce optimal match-ups...So we started developing our own matchmaking system (called Galactron) with our own servers.&nbsp;</li>
<br />
<li><em>Overall, we&rsquo;ve been impressed with Envoy and will continue to explore its features as we build out and expand Bugsnag</em>.&nbsp;<a href="https://blog.bugsnag.com/envoy/">Using Envoy to Load Balance gRPC Traffic</a>:&nbsp;Behind the scenes, Bugsnag has a pipeline of microservices responsible for processing the errors we receive from our customers that are later displayed on the dashboard. This pipeline currently handles hundreds of millions of events per day...Bugsnag&rsquo;s microservices are deployed as Docker containers in the cloud using Google&rsquo;s excellent Kubernetes orchestration tool. Kubernetes has built in load balancing via its kube-proxy which works perfectly with HTTP/1.1 traffic, but things get interesting when you throw HTTP/2 into the mix...gRPC uses the performance boosted HTTP/2 protocol. One of the many ways HTTP/2 achieves lower latency than its predecessor is by leveraging a single long-lived TCP connection and to multiplex request/responses across it. This causes a problem for layer 4 (L4) load balancers as they operate at too low a level to be able to make routing decisions based on the type of traffic received...One of the options we explored was using gRPCs client load balancer which is baked into the gRPC client libraries. That way each client microservice could perform its own load balancing. However, the resulting clients were ultimately brittle and required a heavy amount of custom code to provide any form of resilience, metrification, or logging...We needed a layer 7 (L7) load balancer because they operate at the application layer and can inspect traffic in order to make routing decisions...our ultimate decision came down to the footprint of the proxy. For this, there was one clear winner. Envoy is tiny. Written in C++11, it has none of the enterprise weight that comes with Java based Linkerd.</li>
<br />
<li>Lots of good advice.&nbsp;<a href="https://www.ebayinc.com/stories/blogs/tech/elasticsearch-performance-tuning-practice-at-ebay/">Elasticsearch Performance Tuning Practice at eBay</a>:&nbsp;Split your data into multiple indices if your query has a filter field and its value is enumerable;&nbsp;Use routing if your query has a filter field and its value is not enumerable;&nbsp;Organize data by date if your query has a date range filter;&nbsp;Set mapping explicitly;&nbsp;Avoid imbalanced sharding if documents are indexed with user-defined ID or routing;&nbsp;Make shards distributed evenly across nodes;&nbsp;Use bulk requests;&nbsp;Use multiple threads/works to send requests;&nbsp;Increase the refresh interval;&nbsp;Reduce replica number;&nbsp;Use auto generated IDs if possible;&nbsp;Use filter context instead of query context if possible;&nbsp;Increase refresh interval;&nbsp;Increase replica number;&nbsp;Try different shard numbers;&nbsp;Node query cache;&nbsp;Retrieve only necessary fields;&nbsp;Avoid searching stop words;&nbsp;Sort by _doc if you don&rsquo;t care about the order in which documents are returned;&nbsp;Avoid using a script query to calculate hits in flight. Store the calculated fields when indexing;&nbsp;Avoid wildcard queries.&nbsp;</li>
<br />
<li>Which is the <a href="https://github.com/tbrand/which_is_the_fastest">fastest web framework</a>?&nbsp;router_cr (crystal);&nbsp;raze (crystal);&nbsp;nickel (rust);&nbsp;japronto (python);&nbsp;iron (rust);&nbsp;fasthttprouter (go);&nbsp;kemal (crystal). Rails is last at 25. My first question was what the heck is crystal? <a href="https://crystal-lang.org/">Crystal</a>: fast as C, slick as Ruby. Crystal&rsquo;s syntax is heavily inspired by Ruby&rsquo;s, so it feels natural to read and easy to write, and has the added benefit of a lower learning curve for experienced Ruby devs. Crystal is statically type checked, so any type errors will be caught early by the compiler rather than fail on runtime. Moreover, and to keep the language clean, Crystal has built-in type inference, so most type annotations are unneeded.</li>
<br />
<li>Robohub Podcast with a fascinating episode on building an <a href="http://robohub.org/open-source-prosthetic-leg/">Open Source Prosthetic Leg</a>:&nbsp;goal is to provide an inexpensive and capable platform for researchers to use so that they can work on prostheses without developing their own hardware, which is both time-consuming and expensive.&nbsp;</li>
<br />
<li><a href="http://www.michaelnygard.com/blog/2018/01/services-by-lifecycle/">Services by Lifecycle</a>: Avoid the Entity Service;&nbsp;Focus on Behavior Instead of Data;&nbsp;Tell, Don&rsquo;t Ask;&nbsp;Divide Services by Lifecycle in a Business Process.</li>
<br />
<li><a href="https://github.com/nikoladimitroff/Game-Engine-Architecture">nikoladimitroff/Game-Engine-Architecture</a>:&nbsp;A repo containing the learning materials for the course 'Game Engine Architecture with UE4' taught at Univeristy of Sofia.</li>
<br />
<li><a href="https://github.com/ray-project/ray">ray-project/ray</a>&nbsp;(<a href="http://bair.berkeley.edu/blog/2018/01/09/ray/">article</a>): a flexible, high-performance distributed execution framework. Ray comes with libraries that accelerate deep learning and reinforcement learning development</li>
<br />
<li><a href="https://support.google.com/faqs/answer/7625886">Retpoline: a software construct for preventing branch-target-injection</a>:&nbsp;Retpoline&rdquo; sequences are a software construct which allow indirect branches to be isolated from speculative execution.&nbsp; This may be applied to protect sensitive binaries (such as operating system or hypervisor implementations) from branch target injection attacks against their indirect branches.</li>
<br />
<li><a href="https://cloud.google.com/files/Lift-and-Shift-onto-Google-Cloud.pdf">How to Lift-and-Shift a Line of Business Application onto Google Cloud Platform</a>: Phase one &ndash; Migrate the application to the cloud using Google&rsquo;s Infrastructure-as-a-Service (IaaS) offering, Google Compute Engine;&nbsp;Phase two &ndash; Leverage the cloud for high availability (HA);&nbsp;Phase three &ndash; Leverage the cloud for disaster recovery (DR).</li>
<br />
<li><a href="file:///Users/toddhoffious/Downloads/5g-mobile-disrupting-the-automotive-sector%20(1).pdf">5G Mobile: Disrupting the Automotive Sector</a>: One does not need to postulate that 5G will be as important as railroads in the 19th century or indeed ICTs in the 1990s to appreciate that it will have a very sizable economic impact&mdash;even a fraction of the impact of these past GPTs would still be enough to make 5G a significant enabler of growth in the coming two decades. The automotive sector provides a good showcase of the role and effects of 5G, particularly the manner in which it can serve as a platform around which other innovation can occur.</li>
</ul>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2018/1/12/stuff-the-internet-says-on-scalability-for-january-12th-2017.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />Post a Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2018/1/12/stuff-the-internet-says-on-scalability-for-january-12th-2017.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2018%2F1%2F12%2Fstuff-the-internet-says-on-scalability-for-january-12th-2017.html','Stuff%20The%20Internet%20Says%20On%20Scalability%20For%20January%2012th%2C%202017');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2018/1/12/stuff-the-internet-says-on-scalability-for-january-12th-2017.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/36018251"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/hot-links"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />hot links</a></span></span>  <span class="post-snippet-1"><iframe src="http://www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2018/1/12/stuff-the-internet-says-on-scalability-for-january-12th-2017.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2018/1/12/stuff-the-internet-says-on-scalability-for-january-12th-2017.html" data-text="Stuff The Internet Says On Scalability For January 12th,&nbsp;2017" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments </h3>

      
        
          <div class="text">There are no comments for this journal entry.  To create a new comment, use the form below.</div>

        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=36018251"> 

    
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2018, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>