<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1338871095817&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2018/12/5/how-shiftleft-uses-postgresql-extension-timescaledb.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://www.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>How ShiftLeft Uses PostgreSQL Extension&nbsp;TimescaleDB - High Scalability - </title>
    <meta property="og:title" content="How ShiftLeft Uses PostgreSQL Extension&nbsp;TimescaleDB - High Scalability - " /> 
  

      <meta property="og:description" content=" 
  

 
 This article is written by Preetam Jinka , Senior Infrastructure Engineer at ShiftLeft. Or..." />
  

  
      <meta property="og:image" content="https://c1.staticflickr.com/5/4898/45467501044_1f268519e4.jpg" />
  
      <meta property="og:image" content="https://cdn-images-1.medium.com/max/800/1*EFvFeNemC5zawA1_DCAwyQ.png" />
  
      <meta property="og:image" content="https://c1.staticflickr.com/5/4902/45467573094_a7ae540028.jpg" />
  
      <meta property="og:image" content="https://c1.staticflickr.com/5/4917/46191768081_a791a1bdea_b.jpg" />
  
      <meta property="og:image" content="https://cdn-images-1.medium.com/max/800/1*V7E5IXQVoJT68cSvH-XfUQ.png" />
  
      <meta property="og:image" content="https://cdn-images-1.medium.com/max/800/1*ff_wo9q5QDgO3FnbyLMTHg.png" />
  
      <meta property="og:image" content="https://cdn-images-1.medium.com/max/800/1*YVPsHrt3SmdpmL5GLjR-Ig.png" />
  
      <meta property="og:image" content="https://cdn-images-1.medium.com/max/800/0*wtDFCXx90IXF1xOy" />
  
      <meta property="og:image" content="https://c1.staticflickr.com/5/4835/45467620614_7064f5833e_b.jpg" />
  
      <meta property="og:image" content="https://cdn-images-1.medium.com/max/800/0*CWkAHaYbLswR_Gvk" />
  
      <meta property="og:image" content="https://cdn-images-1.medium.com/max/800/0*byrCUUBLhexoyI8Z" />
  

  <!-- End Heading -->

  <script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src ='https:' + '//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1044643/SS_HS_Ad1', [125, 125], 'div-gpt-ad-1325175098795-0').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad10', [125, 125], 'div-gpt-ad-1325175098795-1').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad11', [125, 125], 'div-gpt-ad-1325175098795-2').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad12', [125, 125], 'div-gpt-ad-1325175098795-3').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad13', [125, 125], 'div-gpt-ad-1325175098795-4').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad14', [125, 125], 'div-gpt-ad-1325175098795-5').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad15', [125, 125], 'div-gpt-ad-1325175098795-6').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad16', [125, 125], 'div-gpt-ad-1325175098795-7').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad17', [125, 125], 'div-gpt-ad-1325175098795-8').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad2', [125, 125], 'div-gpt-ad-1325175098795-9').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad3', [125, 125], 'div-gpt-ad-1325175098795-10').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad4', [125, 125], 'div-gpt-ad-1325175098795-11').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad5', [125, 125], 'div-gpt-ad-1325175098795-12').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad6', [125, 125], 'div-gpt-ad-1325175098795-13').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_ad7', [125, 125], 'div-gpt-ad-1325175098795-14').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad8', [125, 125], 'div-gpt-ad-1325175098795-15').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad9', [125, 125], 'div-gpt-ad-1325175098795-16').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad18', [125, 125], 'div-gpt-ad-1325175098795-17').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad19', [125, 125], 'div-gpt-ad-1325175098795-18').addService(googletag.pubads());
googletag.defineSlot('/1044643/SS_HS_Ad20', [125, 125], 'div-gpt-ad-1325175098795-19').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>


  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId36136948"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2018%2F12%2F5%2Fhow-shiftleft-uses-postgresql-extension-timescaledb.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19697312">

    <div id="navigationTop-moduleContent19697312">

              <a id="navigationTop-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19700860">

    <div id="navigationTop-moduleContent19700860">

              <a id="navigationTop-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19697312">

    <div id="navigationBottom-moduleContent19697312">

              <a id="navigationBottom-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19700860">

    <div id="navigationBottom-moduleContent19700860">

              <a id="navigationBottom-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19697312">

    <div id="moduleContent19697312">

              <a id="moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19700860">

    <div id="moduleContent19700860">

              <a id="moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2018/12/5/how-shiftleft-uses-postgresql-extension-timescaledb.html">How ShiftLeft Uses PostgreSQL Extension TimescaleDB</a></li>  <li><a href="/blog/2018/12/4/sponsored-post-inmemorynet-triplebyte-etleap-stream-scalyr.html">Sponsored Post: InMemory.Net, Triplebyte, Etleap, Stream, Scalyr</a></li>  <li><a href="/blog/2018/11/30/stuff-the-internet-says-on-scalability-for-november-30th-201.html">Stuff The Internet Says On Scalability For November 30th, 2018</a></li>  <li><a href="/blog/2018/11/23/stuff-the-internet-says-on-scalability-for-november-23rd-201.html">Stuff The Internet Says On Scalability For November 23rd, 2018</a></li>  <li><a href="/blog/2018/11/16/stuff-the-internet-says-on-scalability-for-november-16th-201.html">Stuff The Internet Says On Scalability For November 16th, 2018</a></li>  <li><a href="/blog/2018/11/14/new-the-datacenter-as-a-computer-designing-warehouse-scale-m.html">New: The Datacenter as a Computer: Designing Warehouse-Scale Machines, Third Edition</a></li>  <li><a href="/blog/2018/11/13/sponsored-post-twitch-inmemorynet-triplebyte-etleap-stream-s.html">Sponsored Post: Twitch, InMemory.Net, Triplebyte, Etleap, Stream, Scalyr</a></li>  <li><a href="/blog/2018/11/9/stuff-the-internet-says-on-scalability-for-november-9th-2018.html">Stuff The Internet Says On Scalability For November 9th, 2018</a></li>  <li><a href="/blog/2018/11/7/fighting-the-ecosystem-wars-in-the-proactive-cloud.html">Fighting the Ecosystem Wars in the Proactive Cloud</a></li>  <li><a href="/blog/2018/11/2/stuff-the-internet-says-on-scalability-for-november-2nd-2018.html">Stuff The Internet Says On Scalability For November 2nd, 2018</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <CENTER>
  <!-- SS_HS_Ad1 -->
  <div id='div-gpt-ad-1325175098795-0' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-0'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad10 -->
  <div id='div-gpt-ad-1325175098795-1' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-1'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad11 -->
  <div id='div-gpt-ad-1325175098795-2' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-2'); });
  </script>
  </div>
   
  <!-- SS_HS_Ad12
  <div id='div-gpt-ad-1325175098795-3' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-3'); });
  </script>
  </div>
   -->
  
  <!-- SS_HS_Ad13 
  <div id='div-gpt-ad-1325175098795-4' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-4'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad14 
  <div id='div-gpt-ad-1325175098795-5' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-5'); });
  </script>
  </div>
  --> 
  
  <!-- SS_HS_Ad15 
  <div id='div-gpt-ad-1325175098795-6' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-6'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad16
  <div id='div-gpt-ad-1325175098795-7' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-7'); });
  </script>
  </div>
  -->
  
  <!-- SS_HS_Ad17
  <div id='div-gpt-ad-1325175098795-8' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-8'); });
  </script>
  </div>
   -->
  
  <!-- SS_HS_Ad2  --
  <div id='div-gpt-ad-1325175098795-9' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-9'); });
  </script>
  </div>
   -->
  
  <!-- SS_HS_Ad2
  <div id='div-gpt-ad-1325175098795-10' style='width:125px; height:125px; margin: 3px;'>
  <script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1325175098795-10'); });
  </script>
  </div>
   -->
  
  </CENTER>
  
  <center><a href="/advertising">advertise</A></center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2018%2F12%2F5%2Fhow-shiftleft-uses-postgresql-extension-timescaledb.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2018/12/4/sponsored-post-inmemorynet-triplebyte-etleap-stream-scalyr.html">Sponsored Post: InMemory.Net, Triplebyte, Etleap, Stream, Scalyr &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability ">
<div id="item36136948" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Wednesday</span></div><div class="journal-entry-float-date"><span class="month">Dec</span><span class="date">05</span><span class="year">2018</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2018/12/5/how-shiftleft-uses-postgresql-extension-timescaledb.html">How ShiftLeft Uses PostgreSQL Extension&nbsp;TimescaleDB</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Wednesday, December 5, 2018 at 8:21AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <div align="center"><img src="https://c1.staticflickr.com/5/4898/45467501044_1f268519e4.jpg" alt="" />
<p>&nbsp;</p>
</div>
<p><em>This article is written by <a href="https://www.linkedin.com/in/preetamjinka/">Preetam Jinka</a>,  Senior Infrastructure Engineer at ShiftLeft. Originially published as <a href="https://medium.com/@preetam_27821/e1f98196909b">Time Series at ShiftLeft</a>.&nbsp;</em></p>
<p class="graf-after--h3 graf--p graf">&nbsp;</p>
<p class="graf-after--h3 graf--p graf">Time series are a major component of the ShiftLeft runtime experience. This is true for many other products and organizations too, but each case involves different characteristics and requirements. This post describes the requirements that we have to work with, how we use&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=http%3A%2F%2Fbit.ly%2F2RCYjIF" target="_blank">TimescaleDB</a>&nbsp;to store and retrieve time series data, and the tooling we&rsquo;ve developed to manage our infrastructure.</p>
<p id="5d4a" class="graf-after--p graf--p graf">We have two types of time series data: metrics and vulnerability events. Metrics represent application events, and a subset of those that involve security issues are vulnerability events. In both cases, these time series have some sort of ID, a timestamp, and a count. Vulnerability events can also have an event sample that contains detailed information about the request that exercised a security vulnerability. In addition to those attributes, time series are also keyed by an internal ID we call an SP ID, which essentially represents a customer project at a certain version.</p>
<p id="d0a1" class="graf-after--p graf--p graf">The data model for metrics is closely tied to the source-sink model of the&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=https%3A%2F%2Fblog.shiftleft.io%2Fsemantic-code-property-graphs-and-security-profiles-b3b5933517c1" target="_blank">Code Property Graph</a>&nbsp;such that, for a given application, its methods, and I/O and data flows are organized into triggers, inputs, and outputs. This has been illustrated in the figure below which summarizes a few typical endpoints acting as&nbsp;<em>trigger</em>s and the flows through which&nbsp;<em>input</em>&nbsp;data received at those endpoints eventually reach an&nbsp;<em>output&nbsp;</em>such as a log.We rarely query time series data for a single metric; usually we need to query for lots of metrics that are related according to this data model.</p>
<div class="is-locked aspectRatioPlaceholder">
<div class="aspectRatioPlaceholder-fill"></div>
<div class="is-imageLoaded is-canvasLoaded graf-image js-progressiveMedia progressiveMedia"><img class="js-progressiveMedia-image progressiveMedia-image" src="https://cdn-images-1.medium.com/max/800/1*EFvFeNemC5zawA1_DCAwyQ.png" alt="" /></div>
</div>
<p>Visualization of a flow and its trigger, input, and output&nbsp;ends</p>
<p id="bcb9" class="graf-after--figure graf--p graf">Here are the requirements that we&rsquo;ve had to work with for the implementation:</p>
<ul class="postList">
<li id="a98c" class="graf-after--p graf--li graf">Needs to work with Go because almost all of the runtime infrastructure is written in Go.</li>
<li id="8266" class="graf-after--li graf--li graf">Needs to fit in well with the rest of our development and testing environment. For example, our end-to-end (E2E) testing environment is implemented using&nbsp;<a class="markup--li-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=https%3A%2F%2Fdocs.docker.com%2Fcompose%2F" target="_blank">Docker Compose</a>&nbsp;so all databases need to be available as a Docker image.</li>
<li id="1c67" class="graf-after--li graf--li graf">Has to support our rapid iteration workflow. We can&rsquo;t be too tied down to a single data model as new features can change requirements.</li>
<li id="ae66" class="graf-after--li graf--li graf">Needs to be manageable by a small team. We&rsquo;re a startup with limited resources so it would be best to choose a technology that is familiar to a lot of people.</li>
<li id="c145" class="graf-after--li graf--li graf">Multiple granularity support and retention management so we can keep queries fast and costs low.</li>
</ul>
<p id="51b0" class="graf-after--li graf--p graf">So far we&rsquo;ve found that TimescaleDB is the best suited for these requirements.&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=http%3A%2F%2Fbit.ly%2F2RxN4RF" target="_blank">TimescaleDB</a>&nbsp;is an open-source PostgreSQL extension that provides special tables called&nbsp;<em>hypertables</em>&nbsp;that behave like regular PostgreSQL tables but are partitioned into&nbsp;<em>chunks</em>&nbsp;under the hood. These chunks can be partitions of time as well as user-defined attributes. In our case we use SP ID as a partitioning column. This results in the the fast update and querying benefits of using several tables without the hassle of handling partitioning logic in your queries.</p>
<p id="a045" class="graf-after--p graf--p graf">Our hypertables can have thousands of chunks. When we query for metrics for a given SP ID and time range, TimescaleDB filters out unnecessary chunks and only queries a small subset to execute the query. The other benefit of hypertables is we&rsquo;re able to purge old data quickly by&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=http%3A%2F%2Fbit.ly%2F2Ryjg7g" target="_blank">dropping chunks</a>&nbsp;instead of running expensive DELETEs on large tables.</p>
<p id="4c31" class="graf-after--p graf--p graf">Finally, because we&rsquo;re still working with PostgreSQL, we can leverage the development and operational experience we already have. We use other instances of PostgreSQL for some of our other SaaS data storage needs so we benefit from code reuse like&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=https%3A%2F%2Fblog.shiftleft.io%2Fintroducing-gaum-an-open-source-o-rm-that-isnt-an-o-rm-e7fd2880396e" target="_blank">Gaum</a>. There are also plenty of monitoring solutions that support PostgreSQL out-of-the-box.</p>
<h3 id="5d85" class="graf-after--p graf--h3 graf">Infrastructure</h3>
<p id="0e1b" class="graf-after--h3 graf--p graf">Almost all of ShiftLeft is deployed with Docker containers on an orchestration system. This includes TimescaleDB. We also use the Docker image for testing, and have a comprehensive E2E testing suite that uses Docker Compose.</p>
<p id="2aa4" class="graf-after--p graf--p graf">Most of the ShiftLeft runtime infrastructure is written in Go. Runtime metrics data from agents ends up at gateway instances which publish into a Kafka topic. On the other side, we have consumer instances which ingest and aggregate the metrics data and occasionally write to TimescaleDB in batches. The minimum granularity is 2s, and we also have 1m and 5m aggregation in the consumers. ShiftLeft also has 1h and 1d granularity, but this is handled with a batch process instead.</p>
<h3 id="2555" class="graf-after--p graf--h3 graf">Rollups / Downsampling</h3>
<p id="2f56" class="graf-after--h3 graf--p graf">We created a period downsampling job to support larger granularities without aggregating in memory. On ingest, we periodically update a&nbsp;<code class="markup--p-code markup--code">metrics_downsampling_status</code>&nbsp;table which stores downsampling tasks.</p>
<p id="c8f0" class="graf-after--p graf--p graf">Example data in the&nbsp;<code class="markup--p-code markup--code">metrics_downsampling_status</code>&nbsp;table:</p>
<p><img src="https://c1.staticflickr.com/5/4902/45467573094_a7ae540028.jpg" alt="" /></p>
<p id="ecd0" class="graf-after--pre graf--p graf">Entries get updated in this table at the same time as our 5m aggregation flush. When the downsampling task runs, which happens once an hour, it looks for unprocessed rows in the status table, aggregates 5m data into 1h and 1d granularity, and then updates the status table again.</p>
<h3 id="4d2f" class="graf-after--p graf--h3 graf">Querying</h3>
<p id="0e9e" class="graf-after--h3 graf--p graf">Our metrics API is written in Go, and it has logic to use the best granularity (or several) depending on the request. For example, requesting 60 points for a 5 hour interval means each point would be 5 minutes, so we can use our 5m granularity data. Anything smaller than a 5 hour range for 60 points means we have to use either 1m or 2s granularity. Aggregate counts (everything except charts) behave like charts but with 1 point.</p>
<p id="2701" class="graf-after--p graf--p graf">Example of the granularity logic:</p>
<p><img src="https://c1.staticflickr.com/5/4917/46191768081_a791a1bdea_b.jpg" alt="" /> One issue we had with queries was that sometimes a lot of time was spent on planning. In one case, we saw a query take 17 seconds for planning but only 250 ms on execution. This problem went away with&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=https%3A%2F%2Fgithub.com%2Ftimescale%2Ftimescaledb%2Fblob%2Fmaster%2FCHANGELOG.md%230100-2018-06-27" target="_blank">v0.10</a>&nbsp;which significantly improved chunk interaction for queries. You can read more about Timescale&rsquo;s work on this improvement&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=https%3A%2F%2Fblog.timescale.com%2Foptimizing-queries-timescaledb-hypertables-with-partitions-postgresql-6366873a995d" target="_blank">here</a>.</p>
<h4 id="2104" class="graf-after--p graf--h4 graf">Samples</h4>
<p id="d5a2" class="graf-after--h4 graf--p graf">Vulnerability events can have details about requests like the HTTP path and headers. Some of these events are sampled and stored as JSON using a JSONB column in a hypertable. This way we get the flexibility of using JSON and unstructured data and the operational benefits of hypertables.</p>
<h3 id="e2dd" class="graf-after--p graf--h3 graf">Monitoring</h3>
<p id="9007" class="graf-after--h3 graf--p graf">We monitor requests, TimescaleDB, and related components in several ways. To monitor query performance, we use a mix of&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=https%3A%2F%2Fgithub.com%2Fankane%2Fpghero" target="_blank">PgHero</a>&nbsp;and application metrics. PgHero uses&nbsp;<code class="markup--p-code markup--code">pg_stat_statements</code>&nbsp;and provides a rough view of the top queries. In practice we usually don&rsquo;t find it helpful because our queries tend to be fast and our request latency mainly comes from executing&nbsp;<em>lots</em>&nbsp;of these queries, not a single slow one. The majority of the time series metrics request monitoring is done with&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=https%3A%2F%2Fprometheus.io%2F" target="_blank">Prometheus</a>&nbsp;metrics exposed by the API and&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=https%3A%2F%2Fgrafana.com%2F" target="_blank">Grafana</a>&nbsp;for visualization.</p>
<div class="is-locked aspectRatioPlaceholder">
<div class="aspectRatioPlaceholder-fill"></div>
<div class="is-imageLoaded is-canvasLoaded graf-image js-progressiveMedia progressiveMedia"><img class="js-progressiveMedia-image progressiveMedia-image" src="https://cdn-images-1.medium.com/max/800/1*V7E5IXQVoJT68cSvH-XfUQ.png" alt="" /></div>
</div>
<p>Average metrics latencies</p>
<p id="115e" class="graf-after--figure graf--p graf">In terms of ingest monitoring, we keep a close eye on DB write rates and latencies.</p>
<div class="is-locked aspectRatioPlaceholder">
<div class="aspectRatioPlaceholder-fill"></div>
<div class="is-imageLoaded is-canvasLoaded graf-image js-progressiveMedia progressiveMedia"><img class="js-progressiveMedia-image progressiveMedia-image" src="https://cdn-images-1.medium.com/max/800/1*ff_wo9q5QDgO3FnbyLMTHg.png" alt="" /></div>
</div>
<p>Database write&nbsp;rates</p>
<div class="is-locked aspectRatioPlaceholder">
<div class="aspectRatioPlaceholder-fill"></div>
<div class="is-imageLoaded is-canvasLoaded graf-image js-progressiveMedia progressiveMedia"><img class="js-progressiveMedia-image progressiveMedia-image" src="https://cdn-images-1.medium.com/max/800/1*YVPsHrt3SmdpmL5GLjR-Ig.png" alt="" /></div>
</div>
<p>Average latency to flush metrics to TimescaleDB</p>
<p id="1faf" class="graf-after--figure graf--p graf">We also use Grafana extensively with PostgreSQL, but for operational purposes and not extracting time series from hypertables. Using the&nbsp;<a class="markup--p-anchor markup--anchor" rel="nofollow" href="https://medium.com/r/?url=http%3A%2F%2Fdocs.grafana.org%2Ffeatures%2Fdatasources%2Fpostgres%2F" target="_blank">PostgreSQL data source</a>&nbsp;option in Grafana, we can create visualizations based on queries against any PostgreSQL database. A couple of great examples are our downsampling charts. These use the&nbsp;<code class="markup--p-code markup--code">metrics_downsampling_status</code>&nbsp;table described earlier and let us keep an eye on pending work and processing times.</p>
<div class="is-locked aspectRatioPlaceholder">
<div class="aspectRatioPlaceholder-fill"></div>
<div class="is-imageLoaded is-canvasLoaded graf-image js-progressiveMe&fnof;dia progressiveMedia"><img class="js-progressiveMedia-image progressiveMedia-image" src="https://cdn-images-1.medium.com/max/800/0*wtDFCXx90IXF1xOy" alt="" /></div>
</div>
<p>Monitoring the status of downsampling jobs using&nbsp;Grafana</p>
<p id="a4a8" class="graf-after--figure graf--p graf">Here&rsquo;s what one of the SQL queries looks like for that Grafana chart:</p>
<p><img src="https://c1.staticflickr.com/5/4835/45467620614_7064f5833e_b.jpg" alt="" /></p>
<p><br /><span class="markup--pre-strong markup--strong">&nbsp;</span><span class="markup--pre-strong markup--strong">&nbsp;</span><span class="markup--pre-strong markup--strong">&nbsp;</span><span class="markup--pre-strong markup--strong">&nbsp;</span><br /><br /><span class="markup--pre-strong markup--strong">&nbsp;</span></p>
<div class="is-locked aspectRatioPlaceholder">
<div class="aspectRatioPlaceholder-fill"></div>
<div class="is-imageLoaded is-canvasLoaded graf-image js-progressiveMedia progressiveMedia"><img class="js-progressiveMedia-image progressiveMedia-image" src="https://cdn-images-1.medium.com/max/800/0*CWkAHaYbLswR_Gvk" alt="" /></div>
</div>
<p>Average downsampling job&nbsp;latency</p>
<p id="c89e" class="graf-after--figure graf--p graf">When you zoom out to a longer time period like 90 days, you can clearly see some interesting trends. In our case, our downsampling tasks are starting to take longer and longer. They&rsquo;re still around 2 sec on average so we don&rsquo;t have any problems (yet).</p>
<div class="is-locked aspectRatioPlaceholder">
<div class="aspectRatioPlaceholder-fill"></div>
<div class="is-imageLoaded is-canvasLoaded graf-image js-progressiveMedia progressiveMedia"><img class="js-progressiveMedia-image progressiveMedia-image" src="https://cdn-images-1.medium.com/max/800/0*byrCUUBLhexoyI8Z" alt="" /></div>
</div>
<p>Long-term downsampling latency&nbsp;trend</p>
<h3 id="0102" class="graf-after--figure graf--h3 graf">What&rsquo;s next</h3>
<p id="d588" class="graf-after--h3 graf--p graf">We&rsquo;ve been running this architecture using Kafka and TimescaleDB in production for a while and have done lots of different things with it in terms of feature use and monitoring. That said, there are still areas where we&rsquo;re hoping to see improvement, both in how we manage our infrastructure and features that TimescaleDB can implement.</p>
<h4 id="2ac1" class="graf-after--p graf--h4 graf">How we can improve our infrastructure</h4>
<p id="e3aa" class="graf-after--h4 graf--p graf"><span class="markup--p-strong markup--strong"><strong>Optimal chunk size:</strong></span>&nbsp;We haven&rsquo;t determined what the optimal chunk size is, and we haven&rsquo;t tried out adaptive chunking.</p>
<p id="f37f" class="graf-after--p graf--p graf"><span class="markup--p-strong markup--strong"><strong>Read replicas</strong>:</span>&nbsp;We don&rsquo;t use read replicas yet. We can easily improve our read query performance by adding a read replica and parallelizing requests.</p>
<p id="6735" class="graf-after--p graf--p graf"><span class="markup--p-strong markup--strong"><strong>PostgreSQL 10</strong>:</span>&nbsp;We&rsquo;re still on PostgreSQL 9.6. PostgreSQL 10 introduces JIT compilation and evaluation of WHERE clauses which can really improve queries that have to filter lots of rows.</p>
<p id="c437" class="graf-after--p graf--p graf"><span class="markup--p-strong markup--strong"><strong>Better ingest monitoring</strong>:</span>&nbsp;We have a lot of visibility into PostgreSQL, but we don&rsquo;t have visibility into what happens to metrics before PostgreSQL. For example, we&rsquo;d like to have better metrics on how long it takes for a metric message to be accepted at the API until it makes it into TimescaleDB.</p>
<h4 id="cb31" class="graf-after--p graf--h4 graf">What we&rsquo;d like to see from TimescaleDB</h4>
<p id="ba62" class="graf-after--h4 graf--p graf"><span class="markup--p-strong markup--strong"><strong>RDS support</strong>:</span>&nbsp;TimescaleDB is the only database we host ourselves. Our other PostgreSQL instances are hosted on RDS. We&rsquo;d probably use RDS for everything if TimescaleDB was a supported extension.</p>
<p id="f674" class="graf--trailing graf-after--p graf--p graf"><span class="markup--p-strong markup--strong"><strong>Compression</strong>:</span>&nbsp;We could use ZFS for compression but we haven&rsquo;t tried that yet. Compression is not a major requirement yet. It would be great if TimescaleDB supported that out-of-the-box.</p>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2018/12/5/how-shiftleft-uses-postgresql-extension-timescaledb.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />1 Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2018/12/5/how-shiftleft-uses-postgresql-extension-timescaledb.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2018%2F12%2F5%2Fhow-shiftleft-uses-postgresql-extension-timescaledb.html','How%20ShiftLeft%20Uses%20PostgreSQL%20Extension%20TimescaleDB');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2018/12/5/how-shiftleft-uses-postgresql-extension-timescaledb.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/36136948"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="post-snippet-1"><iframe src="//www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2018/12/5/how-shiftleft-uses-postgresql-extension-timescaledb.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="//twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2018/12/5/how-shiftleft-uses-postgresql-extension-timescaledb.html" data-text="How ShiftLeft Uses PostgreSQL Extension&nbsp;TimescaleDB" data-count="horizontal">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments  (1) </h3>

      
        
  <div class="comment-wrapper authored-by-None">
  <div class="comment" id="comment21886090">

    <div id="item21886090" class="body">

      <p>&quot;PostgreSQL 10 introduces JIT compilation &quot;, no, JIT appears in 11 ;)</p>

    </div>
    <div class="signature">

      December 5, 2018 | 
  <a href="/contributor/30745542" title="Unregistered Commenter">
  <img title="Unregistered Commenter" alt="Unregistered Commenter" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/user-unregistered.png) top left no-repeat;"/>Adrien Nayrat
  
  </a>



      
        

        

      

    </div>

  </div>
  </div>



        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=36136948"> 

     <input type="hidden" name="currentPage" value="1"/> 
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2018, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>