<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1338871095817&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2019/3/8/stuff-the-internet-says-on-scalability-for-march-8th-2019.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://www.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Stuff The Internet Says On Scalability For March 8th,&nbsp;2019 - High Scalability - </title>
    <meta property="og:title" content="Stuff The Internet Says On Scalability For March 8th,&nbsp;2019 - High Scalability - " /> 
  

      <meta property="og:description" content=" Wake up! It's HighScalability time:

 
  

 A highly simplified diagram of serverless. ( @jbesw )
..." />
  

  
      <meta property="og:image" content="https://farm8.staticflickr.com/7907/46546925104_d494c94ef7.jpg" />
  

  <!-- End Heading -->

  <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1044643/SS_HS_Ad1', [125, 125], 'div-gpt-ad-1552063564428-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId36162863"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2019%2F3%2F8%2Fstuff-the-internet-says-on-scalability-for-march-8th-2019.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19697312">

    <div id="navigationTop-moduleContent19697312">

              <a id="navigationTop-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19700860">

    <div id="navigationTop-moduleContent19700860">

              <a id="navigationTop-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19697312">

    <div id="navigationBottom-moduleContent19697312">

              <a id="navigationBottom-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19700860">

    <div id="navigationBottom-moduleContent19700860">

              <a id="navigationBottom-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19697312">

    <div id="moduleContent19697312">

              <a id="moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19700860">

    <div id="moduleContent19700860">

              <a id="moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2019/3/8/stuff-the-internet-says-on-scalability-for-march-8th-2019.html">Stuff The Internet Says On Scalability For March 8th, 2019</a></li>  <li><a href="/blog/2019/3/6/2019-database-trends-sql-vs-nosql-top-databases-single-vs-mu.html">2019 Database Trends – SQL vs. NoSQL, Top Databases, Single vs. Multiple Database Use</a></li>  <li><a href="/blog/2019/3/5/sponsored-post-software-buyers-council-inmemorynet-triplebyt.html">Sponsored Post: Software Buyers Council, InMemory.Net, Triplebyte, Etleap, Stream, Scalyr</a></li>  <li><a href="/blog/2019/3/4/how-is-software-developed-at-amazon.html">How is software developed at Amazon? </a></li>  <li><a href="/blog/2019/3/1/stuff-the-internet-says-on-scalability-for-march-1st-2019.html">Stuff The Internet Says On Scalability For March 1st, 2019</a></li>  <li><a href="/blog/2019/2/27/give-meaning-to-100-billion-events-a-day-the-shift-to-redshi.html">Give Meaning to 100 Billion Events a Day — The Shift to Redshift</a></li>  <li><a href="/blog/2019/2/25/design-of-a-modern-cachepart-deux.html">Design Of A Modern Cache—Part Deux</a></li>  <li><a href="/blog/2019/2/22/stuff-the-internet-says-on-scalability-for-february-22nd-201.html">Stuff The Internet Says On Scalability For February 22nd, 2019</a></li>  <li><a href="/blog/2019/2/19/sponsored-post-software-buyers-council-inmemorynet-triplebyt.html">Sponsored Post: Software Buyers Council, InMemory.Net, Triplebyte, Etleap, Stream, Scalyr</a></li>  <li><a href="/blog/2019/2/19/intro-to-redis-cluster-sharding-advantages-limitations-deplo.html">Intro to Redis Cluster Sharding – Advantages, Limitations, Deploying & Client Connections</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <!-- /1044643/SS_HS_Ad1 -->
  <div id='div-gpt-ad-1552063564428-0' style='height:125px; width:125px;'>
  <script>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1552063564428-0'); });
  </script>
  </div>
  
  <center><a href="/advertising">advertise</A></center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2019%2F3%2F8%2Fstuff-the-internet-says-on-scalability-for-march-8th-2019.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2019/3/6/2019-database-trends-sql-vs-nosql-top-databases-single-vs-mu.html">2019 Database Trends – SQL vs. NoSQL, Top Databases, Single vs. Multiple Database Use &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability category-hot-links">
<div id="item36162863" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Friday</span></div><div class="journal-entry-float-date"><span class="month">Mar</span><span class="date">08</span><span class="year">2019</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2019/3/8/stuff-the-internet-says-on-scalability-for-march-8th-2019.html">Stuff The Internet Says On Scalability For March 8th,&nbsp;2019</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Friday, March 8, 2019 at 9:05AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p>Wake up! It's HighScalability time:</p>
<div align="center"><img src="https://farm8.staticflickr.com/7907/46546925104_d494c94ef7.jpg" alt="" height="400" />
<p>&nbsp;</p>
<p>A highly simplified diagram of serverless. (<a href="https://twitter.com/wolfejosh/status/1101615757153263617">@jbesw</a>)</p>
</div>
<p style="text-align: center;">&nbsp;</p>
<p style="text-align: center;">Do you like this sort of Stuff? I'd greatly appreciate your <a href="https://www.patreon.com/toddhoff">support on Patreon</a>. Know anyone who needs cloud? I wrote <a href="https://www.amazon.com/dp/B0765C4SNR">Explain the Cloud Like I'm 10</a> just for them. It has 40 mostly 5 star reviews. They'll learn a lot and love you even more.</p>
<p>&nbsp;</p>
<ul>
<li><a href="https://www.bloomberg.com/news/articles/2019-03-03/france-plans-5-digital-tax-as-governments-chase-internet-giants">5%</a>: France's new digital tax revolution; <a href="https://seekingalpha.com/article/4244316-ai-will-add-15-trillion-world-economy-2030">$15 trillion</a>: AI contribution to global GDP by 2030; <a href="https://theburningmonk.com/2019/02/lambda-optimization-tip-enable-http-keep-alive/">70%</a>: better response time using HTTP keep-alive in lambda; <a href="https://www.akamai.com/us/en/multimedia/documents/state-of-the-internet/state-of-the-internet-security-retail-attacks-and-api-traffic-report-2019.pdf">115 million</a>:&nbsp;Akamai found bots (per day) compromising user accounts by credential stuffing; <a href="https://www.akamai.com/us/en/multimedia/documents/state-of-the-internet/state-of-the-internet-security-retail-attacks-and-api-traffic-report-2019.pdf">83%</a>: of all internet traffic is API calls, not HTML; <a href="https://twitter.com/santi_lopezz99">$1 million</a>: first millionaire bug-bounty hacker is 19 years old; <a href="https://cordcutting.com/research/subscription-mooching/">15%</a>: mooch their Netflix account; <a href="https://blogs.windows.com/buildingapps/2019/03/06/updated-microsoft-store-app-developer-agreement-new-revenue-share/">5%</a>: Microsoft's app store take; <a href="https://petewarden.com/2019/03/07/launching-tensorflow-lite-for-microcontrollers/">$15</a>: Tensorflow at the edge; <a href="https://www.eetimes.com/document.asp?doc_id=1334411#">30%</a>: first quarter drop in DRAM prices;&nbsp;<a href="https://tedium.co/2019/02/28/ibm-workplace-os-taligent-history/">$2 billion</a>: IBM's microkernel folly; <a href="https://twitter.com/ramez/status/1103905730627657728">~1TWh</a>: lithium-ion batteries production per year by 2030; <a href="https://twitter.com/elonmusk/status/1103765550461681664">25%</a>: Tesla supercharger time improvement by a software update;&nbsp;</li>
<br />
<li>Quoteable Quotes:                                                                
<ul>
<li><a href="https://www.businessinsider.com/jeff-bezos-blue-origin-wings-club-presentation-transcript-2019-2">Jeff Bezos</a>: I've witnessed this incredible thing happen on the internet over the last two decades. I started Amazon in my garage 24 years ago &mdash; drove packages to the post office myself. Today we have 600,000-plus people, millions and millions of customers, a very large company. How did that happen in such a short period of time? It happened because we didn't have to do any of the heavy lifting. All of the heavy-lifting infrastructure was already in place for it. There was already a telecommunication network, which became the backbone of the internet. There was already a payment system &mdash; it was called the credit card. There was already a transportation network called the US Postal Service, and Royal Mail, and Deutsche Post, all over the world, that could deliver our packages. We didn't have to build any of that heavy infrastructure. An even more stark example is Facebook. Here's a guy who literally, in his dorm room, started a company &mdash; Mark Zuckerberg started a company in his dorm room, which is now worth half a trillion dollars &mdash; less than two decades ago.</li>
<li><a href="https://twitter.com/paul_snively/status/1101944717619748864">@paul_snively</a>: You say "convention over configuration;" I hear "ambient information stuck in someone's head." You say "configuration over hardcoding;" I hear "information in a different language that must be parsed, can be malformed, or not exist."</li>
<li><a href="https://news.ycombinator.com/item?id=19295919">lget</a>: A common phrase you often hear when people try to explain the impressive technological leaps made in the 20th century is "war is the father of all things", meaning of course that WWII was a major catalyst for technological advancement. I always wondered if it shouldn't be phrased as "John von Neumann is the father of all things."</li>
<li><a href="https://twitter.com/joeemison/status/1102877307059007488">@JoeEmison</a>: It&rsquo;s possible for (serviceful) serverless to be the optimal greenfield architecture for 95%+ of all applications without it being the solution for even 5% of all problems actually given to software developers today.</li>
<li><a href="https://www2.eecs.berkeley.edu/Pubs/TechRpts/2019/EECS-2019-3.pdf">Berkeley</a>: Serverless computing will become the default computing paradigm of the Cloud Era, largely replacing serverful computing and thereby bringing closure to the Client-Server Era.</li>
<li><a href="https://twitter.com/Cycling_Embassy/status/1101483299388751873">@Cycling_Embassy</a>:&nbsp;This just in: the Dutch #bicycle sales figures are reporting over 1 million bicycles sold in the Netherlands in 2018: 40% of them e-bikes, passing regular bicycles at 34%</li>
<li><a href="https://www.anandtech.com/comments/14059/amd-3rd-gen-ryzen-threadripper-in-2019/636397">Marlin1975</a>: Threadripper is not just about core count but also PCIe lanes and Memory bandwith/channels. 8 cores have shown to be memory limited in some cases. So 12/16 would also show weakness that a threadripper system would over come.</li>
<li><a href="https://www.reddit.com/r/programming/comments/axyi2p/why_you_should_use_kubernetes_in_your_projects/ehxeto5/">jiffier</a>:&nbsp;In fact, I don't even use Docker. As someone said on twitter, Kubernetes is the Websphere of the millenials, which I have to admit was quite hilarious.</li>
<li><a href="https://www.wired.com/story/no-data-is-not-the-new-oil">Antonio Garc&iacute;a Mart&iacute;nez</a>: No, data isn&rsquo;t the new oil. And it never will be, because the biggest data repositories don&rsquo;t want it to be.</li>
<li><a href="https://www.youtube.com/watch?v=OYDrJAd-iuw">Cliff Click</a>:&nbsp;Hire for enthusiasm not experience.</li>
<li><a href="https://www.nytimes.com/2019/03/04/technology/google-chronicle-alphabet.html">Nicole Perlroth</a>: The hack on Google, called Operation Aurora, was historic for an unusual reason: It was the first time a Chinese government hacking victim confronted its attacker. Inside the company, Sergey Brin, one of Google&rsquo;s co-founders, made it his personal mission to make sure something like Aurora never happened again. Google, known for its motto &ldquo;Don&rsquo;t Be Evil,&rdquo; had a new motto about its cybersecurity: &ldquo;Never again.&rdquo;&nbsp;Google poached cyberexperts from the National Security Agency and Silicon Valley. It built a threat analysis group on a par with those at the top intelligence agencies and designed a new security infrastructure. It also created a new team, called Google Project Zero, to hunt for critical security flaws in technology outside Google.</li>
<li><a href="https://twitter.com/quinnypig/status/1103019127873069057">@QuinnyPig</a>: What the blue hell is this byzantine GCP pricing model?! $120K a year, use whatever you want, at the end of the year you either pay for overages and then walk away, or re-up your contract and the cycle repeats, UNLESS you master the wolf, in which case</li>
<li>
<div id="_mcePaste"><a href="https://www.amazon.com/dp/B07FC5BZYV">Roger McNamee</a>: The man they chose was Dan Rose, a member of their inner circle with whom I was friendly. I spoke with Dan at least twice before the election. Each time, he listened patiently and repeated what Zuck and Sheryl had said, with one important addition: he asserted that Facebook was technically a platform, not a media company, which meant it was not responsible for the actions of third parties. He said it like that should have been enough to settle the matter.</div>
</li>
<li><a href="https://news.ycombinator.com/item?id=19289844">c61</a>: The two key takeaways for me are: (1) "Contrary to the common belief that message passing is less error-prone, more blocking bugs in our studied Go applications are caused by wrong message passing than by wrong shared memory protection." (2) "Shared memory synchronization operations are used more often than message passing, ..." So basically, (1) people have more trouble writing correct multithreaded routines using message passing, and (2) in large production applications people tend to fall back to using shared-memory primitives rather than message-passing anyway.</li>
<li><a href="https://www.percona.com/blog/2019/03/06/settling-the-myth-of-transparent-hugepages-for-databases/">Percona</a>: The results clearly indicate that for these workloads, THP [Transparent Huge Pages] has a negative impact on the overall database performance. Although the performance degradation is negligible, it is, however, clear that there is no performance gain as one might expect. This is very much in line with all the different databases&rsquo; recommendation which suggests disabling the THP.</li>
<li><a href="https://hbr.org/2019/01/how-mindfulness-can-help-engineers-solve-problems">HBR</a>: Both types of thinking [convergent and divergent] are important to finding the best final solution, but divergent thinking is particularly important for developing innovative solutions. However, divergent thinking skills are largely ignored in engineering courses, which tend to focus on a linear progression of narrow, discipline-focused technical information. This leads engineering students to become experts at working individually and applying a series of formulas and rules to structured problems with a &ldquo;right&rdquo; answer.</li>
<li><a href="https://www.technologyreview.com/s/613054/cybersecurity-critical-infrastructure-triton-malware/">Martin Giles</a>:&nbsp;In attacking the plant [Triton], the hackers crossed a terrifying Rubicon. This was the first time the cybersecurity world had seen code deliberately designed to put lives at risk. Safety instrumented systems aren&rsquo;t just found in petrochemical plants; they&rsquo;re also the last line of defense in everything from transportation systems to water treatment facilities to nuclear power stations.</li>
<li><a href="https://twitter.com/pessimistsarc/status/1103702877011349504">@PessimistsArc</a>: In 1872 telegrams were criticized for allowing instant publication of criticisms without context often with malicious additions. Writer said mischief caused couldn't be overstated. Remind you of anything?&nbsp;</li>
<li><a href="https://twitter.com/fintanr/status/1103244723538616320">@fintanr</a>:&nbsp;If you want to do #CloudNative development at any scale - start with #ContinuousIntegration . If you don't have CI in place the rest will fail. Even if you don't want to use containers, put CI in place. It remains, by far, the best tooling decision you will make for your SDLC.</li>
<li><a href="https://twitter.com/airmovingdevice/status/1103158712900833280">@AirMovingDevice</a>:&nbsp;I will be deleting all of my tweets and will no longer be tweeting or responding to DMs. All of my tweets were entirely based on my personal analysis using publicly available data, and did not involve other individuals. It is not my intention to subvert state or Party authority.</li>
<li><a href="https://www.theregister.co.uk/2019/03/06/uk_police_cautious_on_cloud/">Richard Speed</a>: Just over half of UK's 43 police forces responded to a Freedom of Information (FoI) request, and 13 per cent stated that none of their data and applications were "in the cloud". 71 per cent had sent anywhere between 1 and 25 per cent of workloads cloudwards, while only 4 per cent were in the 26 to 50 per cent bracket.</li>
<li><a href="https://twitter.com/ctoadvisor/status/1103034794781429761">@CTOAdvisor</a>: Me: Why do you want multi-cloud? CTO: I want to put the workload on the cheapest compute platform. Me: Multi-cloud for workload mobility is really hard. What value is the savings going to bring the business? CTO: Reduced IT costs. Me: 🤨</li>
<li><a href="https://news.ycombinator.com/item?id=19311750">kureikain</a>: I have zero on-call for Go. I had very few for Elixir. But the bug were in logic code. Same with Ruby. But it's a disaster with Node. We used TypeScript so it catch lot of type issue. However, the Node runtime is weird. We run into DNS issue(like yo have to bump the libuv thread pool, cache DNS). JSON parsing issue and block the event loop etc...max memory...</li>
<li><a href="https://packetpushers.net/podcast/heavy-networking-433-an-insiders-guide-to-aws-transit-gateways/">Nick Matthews</a>~&nbsp;There's a lot of operational problems with how people build DMZs. If you rebuild your DMZ in AWS and don't change your operations...I firmly believe tons of developers came to AWS because the DMZ was so effective at getting nothing done.&nbsp;</li>
<li><a href="https://twitter.com/carnage4life/status/1102228118029316096">@Carnage4Life</a>: Economics of shared scooter economics (e.g. Bird, Lime) is wild. I thought Uber &amp; Lyft losing $1.13-$1.40 per ride was steep but surmountable by raising prices. Shared scooters last only a month and they lose $300 on each one. Closer to $3 per ride loss😱</li>
<li><a href="https://www.youtube.com/watch?v=qOTYgcdNrXE">4 star General Brown</a>:&nbsp;We're in a hyper competition now, always.&nbsp;</li>
<li><a href="https://www.scriptcrafty.com/2019/02/sensible-software-engineering/">Undrinkable Kool-Aid</a>: Whenever I&rsquo;ve approached a new system the bottleneck has never been writing more code. The bottleneck has always been in understanding all the implicit assumptions baked into the system that for one reason or another are essential to its correctness. Pretending that the system and the runtime traces of the system are the specification is why there is always a shortage of programmers. It takes a particular kind of masochist to enjoy reverse engineering a black box from just poking at it with simple linear impulses. If these systems had more formal foundations then there would be no shortage because we could teach people the general formalism and let them figure out the runtime mappings</li>
<li><a href="https://www.ebayinc.com/stories/blogs/tech/how-ebay-uses-microinteractions-to-delight-customers-in-china/">eBay</a>: users who saw the animated percentage off badge were more likely to click an item as compared to those who saw the static percentage off badge. This helps show that animations and microinteractions not only have numerous qualitative benefits, but also strong quantitative ones. This data has empowered us to spend time integrating microinteractions as part of our design system, and we continually look at how to bring these moments to other parts of the customer experience.</li>
<li><a href="https://www.cnbc.com/2019/03/01/lyft-plans-to-spend-300-million-on-aws-through-2021.html">Lyft</a>: It may become increasingly difficult to maintain and improve our performance, especially during peak usage times, as we expand and the usage of our offerings increases</li>
<li><a href="https://twitter.com/copyconstruct/status/1102331673016918016">@copyconstruct</a>: My own hype curve with WebAssembly: &nbsp;Oct 2018: zomg WASM is the future we all need Dec 2018: zomg it really is the future Jan 2019: let me do a bit of research and see what the state of security is and if linear memory is all that ...Feb 2018: oh dear 👀 &nbsp;March 2019: 😧 </li>
<li><a href="https://twitter.com/seldo/status/1101703274300825600">@seldo</a>:&nbsp;At some dumb point in the dumb future Lyft and Uber will declare that they can never be profitable but that they are essential to city transportation and will demand that cities subsidize them and we will have finally closed the circle of stupid.</li>
<li><a href="https://www.infoq.com/presentations/webassembly-intro">Jay Phelps</a>:&nbsp;Let's just dive right in. The question, the ultimate question: what is WebAssembly? Well, it's also known as Wasm, or Wasm, depending on how you want to pronounce it, where you live. I pronounce it Wasm personally. And the quick spiel is that it's an efficient and safe low-level byte code for the web. And that sounds great, but we kind of need to unpact that. Really, what do I mean by efficient? Well, I mean the goal of it is to be fast to load and fast to execute. So fast to load meaning fast to send over the internet, because the primary purpose of WebAssembly is for the browser, but we'll talk about that a little bit later. So fast to load over the internet, small binary sizes are critical, compact format is critical, fast to load meaning fast to parse. And then fast to execute, meaning fast to actually run once it's compiled. So it's going to be just in time compiled.</li>
<li><a href="https://blog.dshr.org/2019/03/it-isnt-just-cryptocurrency-mining.html">David Rosenthal</a>: Perhaps once people figure out that Moore's Law is dead, and Kryder's Law is dying they will insist on keeping their equipment longer. IT manufacturers, like US automakers in the 60s and 70s, have become hooked on planned obsolescence, so they are likely to respond by adding fins and chrome to their hardware rather than making it last longer.</li>
<li><a href="https://segment.com/blog/the-growth-stacks-of-2019/">Segment</a>: If you run a B2B business, you typically have to make a hard choice. You can track data on the individual user level, but then you may have a hard time combining it later (how do I understand what a 2,000 person organization is doing?). On the other hand, you can track the health and actions of overall &lsquo;accounts&rsquo;, but possibly miss data from individual users</li>
<li><a href="https://www.reddit.com/r/DataHoarder/comments/9zxvf2/please_stop_posting_pictures_of_your_hard_drives/">510TBaguettes</a>: It's not because you have 100TB free of storage on your server that you are a data hoarder, and there is no "good way to do this". Data hoarding isn't about just buying $3000 worth of hard drives just for posting them here. What's interesting is what you do with your storage. If you just have 1TB of storage but you do something freakin' cool with it, what you can share here is way more important than someone buying 30TB of storage and never post again here. Please, focus on what we love, the DATA, not the storage medium, please focus on projects, on archiving, on digital preservation.</li>
<li><a href="http://nautil.us/blog/heres-how-well-know-an-ai-is-conscious">Joel Frohlich</a>: Of course, it&rsquo;s possible that an artificial consciousness might possess qualia vastly different than our own. In this scenario, questions about specific qualia, such as color qualia, might not click with the AI. But more abstract questions about qualia themselves should filter out zombies. For this reason, the best question of all would likely be that of the hard problem itself: Why does consciousness even exist? Why do you experience qualia while processing input from the world around you? If this question makes any sense to the AI, then we&rsquo;ve likely found artificial consciousness. But if the AI clearly doesn&rsquo;t understand concepts such as &ldquo;consciousness&rdquo; and &ldquo;qualia,&rdquo; then evidence for an inner mental life is lacking.</li>
</ul>
</li>
<br />
<li>Lyft reportedly pays AWS <a href="https://www.cnbc.com/2019/03/01/lyft-plans-to-spend-300-million-on-aws-through-2021.html">$80 million</a> a year. Is that a lot? Snap reportedly spends <a href="https://www.cnbc.com/2019/03/01/lyft-plans-to-spend-300-million-on-aws-through-2021.html">$600 million</a> a year on GCP and Azure. Is that a lot? One esitmate for Netflix is that they spend <a href="https://www.intricately.com/articles/netflix-aws-spend">$25 millio</a>n per month on AWS. Is that a lot?&nbsp;                                                                      
<ul>
<li>Netflix <a href="http://highscalability.com/blog/2017/12/11/netflix-what-happens-when-you-press-play.html">says</a> they actually save money in AWS. Their cloud costs per streaming view ended up being a fraction of the cost of its old datacenters. Why? The elasticity of the cloud.&nbsp;</li>
<li>Many seem to think they could do the same job a lot cheaper on a couple of laptops in their mom's basement, which is pretty much the same as saying all the people working at these companies don't know what they're doing.&nbsp;</li>
<li>Which is more likely, that people working at these companies don't know what they're doing or people don't know what these companies are doing? Ed Boyden <a href="https://after-on.com/episodes-31-60/043">calls this</a> <em>The illusion of reductionism</em>. Pretending a problem is simple doesn't make it simple.</li>
<li>If you want to know what Netflix is doing:&nbsp;<a href="http://highscalability.com/blog/2017/12/11/netflix-what-happens-when-you-press-play.html">Netflix: What Happens When You Press Play?</a>&nbsp;If you want to know what Lyft <a href="https://press.aboutamazon.com/news-releases/news-release-details/lyft-goes-all-aws">is doing</a> there's a short video by their CTO:&nbsp;<a href="https://aws.amazon.com/solutions/case-studies/lyft/">Lyft Saves Infrastructure Costs, Enables Massive Growth of Ridesharing Platform Using AWS</a>.</li>
<li>Ever think Netflix's infrastructure was a bit of overkill just to watch video? Me too. But that's because I was shortsighted. The big picture became clear in 2016 when Netflix <a href="https://media.netflix.com/en/press-releases/netflix-is-now-available-around-the-world">went live</a> in 130 new countries&mdash;simultaneously! All the work Netflix has been doing up to that point made that possible. Would it be possible if they had to build out their own datacenters? Sure, but how long would it have taken and how much would it have cost? More...a lot more.&nbsp;</li>
<li>Lyft faces a similar problem. Since 2012 Lyft has experienced exponential growth. In 2014 they launched 24 new cities in 24 hours. They rolled out autoscaling and doubled their footprint overnight. They can also scale down, the same feature Netflix found so valuable. The Saturday night peak is 8x Sunday morning. Lyft could IPO for <a href="https://jalopnik.com/lyft-files-for-ipo-valuing-it-as-much-as-25-billion-1832990994">$25 billion</a>. Without the clould could they expanded so fast, so reliably? Unlikely. $80 million a year sounds like a smart investment. </li>
<li><a href="https://twitter.com/quinnypig/status/1101616132681752576">@QuinnyPig</a>: I have these conversations with clients constantly. "We would save money if we built our own datacenters." Yes, until you staff up to maintain them, and ensure that the communications patterns between teams worked, and... (4/16) Does anyone honestly believe that "losing focus" for a company like Lyft at $20-25 billion is worth whatever cost savings they could realize? It simply isn't. &nbsp;(7/16)</li>
<li><a href="https://twitter.com/samkottler/status/1102276201958256643">@samkottler</a>: Lyft&rsquo;s AWS spend is ~1.2% of bookings, which seems pretty normal? Not sure why everyone is so surprised by those numbers. The most interesting part of the Lyft S-1 is not their AWS spend. It&rsquo;s that they are sinking a boatload of money into autonomous driving, the delta of which largely explains increased losses.</li>
<li><a href="https://twitter.com/adrianco/status/1102641707718389761">@adrianco</a>: The $ commitment from Lyft to AWS is part of an enterprise discount plan. Bigger the commitment, bigger the discount. They are big and growing fast and already increased their commitment once. Key thing is that the $ can be spent on any service, it's not like datacenter spend. The most important thing to understand is that your AWS spend depends on your own efficiency. Cleaning up underused stuff, increasing utilization, tuning code, optimizing instance types, spot, reservations etc. makes a big difference to next month's bill, and AWS will help.</li>
<li><a href="https://twitter.com/stevesi/status/1102365674410631170">@stevesi</a>: 1/ Fascinated by discussions of size of cloud hosting bills. At massive scale two things are true: &bull; Someone always says they can run servers on-prem more cheaply &bull; Someone is always under-estimating how much burdened servers cost to run and cost of running them more cheaply 2/ I know everyone "knows" this but it has been so long for many since running on-prem that we forget just how expensive, time, and labor consuming (and rigid) running anything of any scale on-prem (or CoLo) can be. Not to mention unreliable and hard to scale (to more customers).</li>
<li><a href="https://twitter.com/mohapatrahemant/status/1102401615263223809">@MohapatraHemant</a>: So @lyft is paying $8m/mo to @AWS -- almost $100m/yr! Each ride costs $.14 in AWS rent. I keep hearing they could build their own DC &amp; save. My early days at @Google cloud, heard the same from customers: "at scale, owning is cheaper". It wasn't - they all came around. Here's why: Construction of a mid-sized Enterprise DC (just 5000sqft), at just "tier3" availability (3 9s) will cost around 40m. If you want 5 9s redundancy you will need 1-2 failovers, so 3x that. Incld racks, cooling, power, construction and land. Using a colo @Equinix will likely save 20%.&nbsp;<span>But your DC costs will amortize over 10 years, correct? Yes. But there's more. Construction will take 12-24mos. For that time, company loses focus, hires non-core engg, vendors, and planners that understand bldg codes, fire safety, env rules, security, maintenance etc. Then for 10 years you have: ongoing support, maintenance &amp; repair, costs of power, heating/cooling, and biometric security of physical assets. Power bills alone run in xxMs that's why Google DCs are so remote and near Geo/hydro/solar power sources. Moreover, you need to build for 10yrs out, not today, so you'll likely either keep building more and more, or overbuild capacity by 50-100%. Your initial estimate of 40m (x3) is now 60-80m (x3).</span></li>
</ul>
</li>
<br />
<li>The wisdom is knowing what you need to do and when you need to do it.&nbsp;<a href="https://blog.usejournal.com/you-dont-need-all-that-complex-expensive-distracting-infrastructure-a70dbe0dbccb">You Don&rsquo;t Need All That Complex/Expensive/Distracting Infrastructure</a>:&nbsp;Kubernetes clusters? Load balancers across multiple cloud regions? Zero-click, Blue-Green deployment based on real-time metrics from a continuous deployment pipeline?&nbsp;The good news? You don&rsquo;t need any of it*.&nbsp;Your goal, when launching a product, is to build a product that solves a problem for your users. Not build the fanciest deployment pipelines, or multi-zone, multi-region, multi-cloud Nuclear Winter proof high availability setup. I&rsquo;ve seen the idea that every minute spent on infrastructure is a minute less spent shipping features.&nbsp;</li>
<br />
<li>Freetrade and why they ended up&nbsp;<a href="https://blog.freetrade.io/killing-kubernetes-7f8b61c701aa">Killing Kubernetes</a>: &ldquo;do less of everything &gt; do more of the right things &gt; ship faster.&rdquo; This is why we killed our Kubernetes stack. Here&rsquo;s what our setup roughly looked like in June: Kubernetes configuration, Docker images, Kotlin services, Custom Gradle build scripts, Hazelcast, Cloud endpoints configuration, A deployment orchestration tool. In the end, here&rsquo;s what our launch stack looked like. Firebase functions. That the second implementation was: Immediately cheaper (even at 20k users its still cheaper!), Able to scale more quickly, Easier to debug, Easier to replicate for testing/disaster recovery, Has built-in logging support, Has built-in autoscaling.</li>
<br />
<li>Storage demand isn't as high as everyone thinks.&nbsp;<a href="https://blog.dshr.org/2019/03/demand-is-far-from-insatiable.html">Demand Is Far From Insatiable</a>:&nbsp;Seagate was caught out by an unexpectedly deep drop in disk drive demand and saw its revenues fall 7 per cent...Western Digital is about to go into cost cutting mode to carve out $800m in savings, after reporting shrinking revenues of $4.23bn for its second fiscal 2019 quarter, down by a fifth compared to the year ago period</li>
<br />
<li>Last week we had an entry on how serverless might incent creating more specialized hardware (perhaps like <a href="https://www.azul.com/">Azul for Java</a>). In&nbsp;<a href="https://blog.bitsrc.io/how-might-serverless-impact-node-js-ecosystem-b0e312036fcf">How Might Serverless Impact Node.js Ecosystem?</a>&nbsp;it's made clear how better software packing can save money by reducing load times (from 2 seconds to a hundred milliseconds) and ideally could reduce memory foot prints. Related to both these ideas is the fact that cloud providers totally control the backend. We just upload code. Cloud providers could transform our code base into anything, as long as functionality is preserved. So it would be possible to transparently develop specialized representations and hardware that are much faster to load and use less memory. </li>
<br />
<li>Once you've built a solid platform you can quickly build high value services in response to customer demand. Here's an AWS example of that philosophy in action.&nbsp;                                              
<ul>
<li>Nick Matthews,&nbsp;Principal Solutions Architect at AWS, in&nbsp;<a href="https://packetpushers.net/podcast/heavy-networking-433-an-insiders-guide-to-aws-transit-gateways/">Heavy Networking 433: An Insider&rsquo;s Guide To AWS Transit Gateways</a>&nbsp;mentions HyperPlane. HyperPlane is a distributed state system. Think of lots of EC2 instances sharing state with each other. It runs NAT gateway, NLB, EFS mounts, and PrivateLink. It works by running a very large fleet of instances, using a technique called shuffle sharding. Each customer can be given a piece of multiple instances simultaneously. If any instance has an issue a very small percentage of traffic might be impacted.&nbsp;</li>
<li>Following HyperPlane leads to&nbsp;<a href="https://twitter.com/colmmacc/status/1034492508808474625">@colmmacc</a>:&nbsp;Ever wonder how we manage multi-tenancy at AWS? or why we want you to use the personal health dashboard instead of the AWS status dashboard? are you pining for a bonus content section with probabilistic math? These slides on Shuffle Sharding are for you!! ... Again think about, we can build a huge big multi-tenant system with lots of customers on it, and still guarantee that there is *no* full overlap between those customers. Just using math. This still blows my mind...</li>
<li>The key idea being:&nbsp;Our Cloud gives us this agility because we all pool our resources. So a much bigger, and better than me, team can build much bigger, and better than mine, data centers, which we all share. 10 years in, pretty much everyone understands that this is awesome.</li>
<li>Which leads this video&nbsp;<a href="https://atscaleconference.com/videos/networking-scale-2018-load-balancing-at-hyperscale/">Load Balancing at Hyperscale</a>.&nbsp;</li>
<li>Which leads to Cindy Sridharan's gloss of <a href="https://medium.com/@copyconstruct/best-of-2018-in-tech-talks-2970eb3097af">the video</a>: I especially enjoyed learning about the SHOCK principle proposed (Self Healing or Constant Work), which suggests that when you build a system, it should be resilient to even large shocks. Or put differently, &ldquo;if something big changes, the system should be able to carry on as normal&rdquo;. The talk proposes that: 1. Constant effort and recovery from failure are the natural states 2. Always operate in repair mode. When a node fails, Hyperplane actually does less work! 3. When designing large scale systems, we don&rsquo;t want them to be complex. We want them to be as simple as possible. To this end, we want as few modes of operation as possible (Hyperplane has no retry mode, for example. It piggybanks on TCP&rsquo;s innate retry mechanism).&nbsp;4. The talk also introduces the idea of shuffle sharding, a DDoS mitigation technique (where isolation is the primary mitigation technique) that&rsquo;s now widely deployed across many AWS services.</li>
</ul>
</li>
<br />
<li>A bold vision for future discovery.<em> Can we do on purpose for biology what for other fields happened accidentally.</em> <a href="https://after-on.com/episodes-31-60/043">Episode 43: Ed Boyden | New Tools for Neuroscience</a>. Rather than doing moon shots where we try to address unknowns without getting down to the ground truth first maybe we should try to get down to the ground truth. What's the right way to do a moon hot? On one extreme you have extreme translational science where the goal is let's just try to get something into humans quickly. The other extreme is science that might very curiosity driven, but doesn't connect with an application. I propose a third way of doing science where we think backwards from the goal, but the goal is not just to do a moon hot without the knowledge of the underlying mechanisms. Let's&nbsp;accelerate&nbsp;the basic science of those underlying mechanisms to understand what the heck we're doing. It's kind of fusing the two old models. Build new technologies that let you&nbsp;accelerate&nbsp;the discovery of new things. Be more systematic. Make it more high throughput. More&nbsp;comprehensive. Then you might be able to make a moon hot without cutting corners. We might be able to break it down into an orderly series of steps. Can we think backwards from the goal and build technologies that systematically and comprehensively get to the ground truth underlying the mechanisms, and nail it. The big questions arise by considering hypothesis that alternatives to the classical ones. Why can't we through new technologies by mapping and controlling in a systematic way what's going on why can't we confront entire sets of hypothesis that we can broaden our horizons and not just focus on a single thing. The Tile Tree Method. The basic idea is can you have an&nbsp;idea of every possible way to solve a problem. That's how optogenetics was created. We went through all the laws of physics and try and decide which would be the best for controlling neurons. There's a short list of things you can deliver into a brain that convey energy and then from that you consider what kind of effect should the energy have. Will it be converted to electrical signals or chemical signals? If it gets converted into a electrical signal do you make the molecule that converts light into electricity or do you find it? If you think of the logical path described in the last several sentences, we're breaking down the space of all the possibilities as a tree diagram. The laws of physics, do you make or do you find, and so on. Very often that's how projects begin in our group. When you pick a discipline to approach a problem with do take a chemical approach, an electrical approach, or a computer science approach? Very often by systematically trying to break down the space of possible ideas intro an orderly structured pipelined approach that can be tested. It doesn't guarantee you are going to have a possible idea but it might reduce the risk of missing something really important or it might reduce the risk of getting stuck in a traditional way of thinking. This all points to the significance of making tools before anything else. First get the tools, then get the data, then you can make the theory. The tools that we design are designed to get to the ground truth. We want to design tools that allow us to understand a complex system in terms of building blocks and the interactions between them. Tools are now cool because they worked. After optogenetics people began making new kinds of tools, calcium imaging, new kinds of microscopes, and the question became how can you make more?&nbsp;</li>
<br />
<li>Must programmers be imprisoned in a boiler room to produce software? Or can remote async teams get the job done? Yes... using the right tools, right people, right culture, and right process. <a href="https://medium.com/cabify-product/on-site-friendly-fba1f9ba69dc">On-Site Friendly</a>: GitLab is a 100% remote company...The (GitLab) distributed system strives for weak consistency, freedom, then adjustment, on shorts loops...GitLab (and the remote culture) has a radically different approach. There you work trying to solve a somewhat defined business problem, in short iterations, delivering something, and then adjusting.</li>
<br />
<li>You can expect development to stall on all these apps as teams must turn their gaze inward as they pay the great multi-year integration tax. If you want to create a competitor now is the time.&nbsp;<a href="https://www.bbc.com/news/technology-47001460">Facebook to integrate WhatsApp, Instagram and Messenger</a>.&nbsp;</li>
<br />
<li>Uber on <a href="https://eng.uber.com/machine-learning-capacity-safety/">Using Machine Learning to Ensure the Capacity Safety of Individual Microservices</a>: to help prevent these outages, our reliability engineers abide by a concept called capacity safety, in other words, the ability to support historical peaks or a 90-day forecast of concurrent riders-on-trip from a single data center without causing significant CPU, memory, and general resource starvation. On the Maps Reliability Engineering team, we built in-house machine learning tooling that forecasts core service metrics&mdash;requests per second, latency, and CPU usage&mdash;to provide an idea of how these metrics will change throughout the course of a week or month. Using these forecasts, teams can perform accurate capacity safety tests that capture the nuances of each microservice...At a high level, each service in production at Uber is instrumented to emit metrics, some of which are resource and capacity-related. These metrics are stored in M3 and can be queried via API...The data we use, such as information on CPU and memory usage, comes from reliable sources, such as server logs, event logs, and data center reports, giving us a robust training set for forecasting...For time series forecasting, we leverage an internal forecasting API that uses an ensemble method containing ARIMA, Holt-Winters, and Theta models.&nbsp;</li>
<br />
<li>Improving performance by tracking down bottlenecks.&nbsp;<a href="Achieving 100k connections per second with Elixir">Achieving 100k connections per second with Elixir</a>. Even though they hold the connection open for a second during the test, when you start doing real work over a connection everything changes. You're causing interrupts, potentially saturating the network, creating lock contention, using CPU, triggering garbage collection pauses, live locking other code, etc., so just handling a lot of connections isn't the whole story. Also,&nbsp;<a href="http://highscalability.com/blog/2014/2/26/the-whatsapp-architecture-facebook-bought-for-19-billion.html">The WhatsApp Architecture Facebook Bought For $19 Billion</a></li>
<br />
<li><a href="https://www.potaroo.net/ispcol/2019-03/quic.html">A quick look at QUIC</a>:&nbsp;QUIC is a rather forceful assertion that the Internet infrastructure is now heavily ossified and more highly constrained than ever. There is no room left for new transport protocols in today&rsquo;s network. If what you want to do can&rsquo;t be achieved within TCP, then all that&rsquo;s left is UDP...There is a price to pay for this new-found agility, and that price is broad interoperability. Browsers that support QUIC can open up UDP connections to certain servers and run QUIC, but browsers cannot assume, as they do with TCP, that QUIC is a universal and interoperable lingua franca of the Internet. While QUIC is a fascinating adaptation, with some very novel concepts, it is still an optional adaptation. For those clients and servers who do not support QUIC, or for network paths where UDP port 443 is not supports the common fallback is TCP. The expansion of the Internet is inevitably accompanied by inertial bloat, and as we&rsquo;ve seen with the extended saga of IPv6 deployment, it is a formidable expectation to think that the entire Internet will embrace a new technical innovation in a timeframe of months, years or possibly even decades! That does not mean that we can&rsquo;t think new thoughts, and that we can&rsquo;t realize these new ideas into new services on the Internet. We certainly can, and QUIC is an eloquent demonstration of exactly how to craft innovation into a rather stolid and resistant underlying space.</li>
<br />
<li><a href="https://blog.exxactcorp.com/deep-compression-optimization-techniques/">Deep Compression for Improved Inference Efficiency, Mobile Applications, and Regularization</a>:&nbsp;The main power sink in modern high performance computing including machine learning at scale isn&rsquo;t computation, it&rsquo;s communication. Performing a multiply operation on 32 bits of data typically requires less than 4 pJ, while fetching that same amount of data from DRAM requires about 640 pJ, making off-chip memory reads about 160 times more energy-expensive than commonly used mathematical operators. That lopsided power consumption gets even worse when we consider sending data more than a few centimeters (leading data-centers to replace mid-length data communication wires with optical fibers)...Luckily there&rsquo;s a biological analogue in the way human brains develop. Using synaptic pruning, the human brain becomes more efficient as people progress from childhood into adulthood...Not only does deep compression result in model sizes that are 35-50 times smaller, run faster, and require less energy (great for deployment in battery-powered applications), but the models often achieve better performance than the original, uncompressed model...Iteratively pruning and re-training the model in what&rsquo;s called dense-sparse-dense training can remove up to 90% of parameters with no loss in test accuracy...By quantizing the remaining parameters, we can take advantage of efficiency and speedup from features such as Nvidia&rsquo;s INT8 inference precision and further reduce the model size...Stopping after dense-sparse-dense training and parameter quantization is already enough to reduce storage requirements for the iconic AlexNet by more than 26 times without any significant loss of performance. There is one more step to achieving the full depth of benefits from deep compression, and that&rsquo;s weight sharing.</li>
<br />
<li><a href="https://github.com/facebook/folly/tree/master/folly/experimental/crypto">facebook/folly</a>&nbsp;(<a href="https://code.fb.com/security/homomorphic-hashing/">article</a>):&nbsp;Maintaining scalability and infrastructure reliability are important considerations for any large-scale network. Ensuring consistency when propagating updates across a large network of peers is a problem that has been extensively studied, but enforcing the integrity of those updates is a separate challenge. Traditional methods for update integrity can introduce compromises with respect to efficiency and scalability. To address these concerns, we&rsquo;ve employed homomorphic hashing, a cryptographic primitive that has been used in other applications, including efficient file distribution and memory integrity checking.</li>
<br />
<li><a href="https://github.com/BrighterCommand/Brighter">BrighterCommand/Brighter</a>:&nbsp;&nbsp;a command dispatcher, processor, and task queue. It can be used to implement the Command Invoker pattern. It can be used for interoperability in a microservices architecture as well.</li>
<br />
<li><a href="  https://github.com/CraneStation/wasmtime">CraneStation/wasmtime</a>: a standalone wasm-only runtime for WebAssembly, using the Cranelift JIT. It runs WebAssembly code outside of the Web, and can be used both as a command-line utility or as a library embedded in a larger application</li>
<br />
<li><a href="https://github.com/uber/kraken">uber/kraken</a>: a P2P-powered docker registry that focuses on scalability and availability. It is designed for docker image management, replication and distribution in a hybrid cloud environment. With pluggable backend support, Kraken can easily integrate into existing docker registry setups as the distribution layer. Kraken has been in production at Uber since early 2018. In our busiest cluster, Kraken distributes more than 1 million blobs per day, including 100k 1G+ blobs. At its peak production load, Kraken distributes 20K 100MB-1G blobs in under 30 sec.</li>
<br />
<li><a href="https://github.com/awslabs/route53-infima">awslabs/route53-infima</a>:&nbsp;a library for managing service-level fault isolation using Amazon Route 53. Infima provides a Lattice container framework that allows you to categorize each endpoint along one or more fault-isolation dimensions such as availability-zone, software implementation, underlying datastore or any other common point of dependency endpoints may share. Infima also introduces a new ShuffleShard sharding type that can exponentially increase the endpoint-level isolation between customer/object access patterns or any other identifier you choose to shard on.</li>
<br />
<li><a href="https://github.com/Azure/mmlspark">Azure/mmlspark</a>:&nbsp;an ecosystem of tools aimed towards expanding the distributed computing framework Apache Spark in several new directions. MMLSpark adds many deep learning and data science tools to the Spark ecosystem, including seamless integration of Spark Machine Learning pipelines with Microsoft Cognitive Toolkit (CNTK), LightGBM and OpenCV. These tools enable powerful and highly-scalable predictive and analytical models for a variety of datasources.</li>
<br />
<li><a href="https://github.com/openai/neural-mmo">openai/neural-mmo</a>:&nbsp;This environment is the first neural MMO; it attempts to create agents that scale to real world complexity. Simulating evolution on Earth is computationally infeasible, but we can construct a reasonable and efficient facsimile. We consider MMORPGs (Massive Multiplayer Online Role Playing Games) the best proxy for the real world among human games: they are complete macrocosms featuring thousands of agents per persistent world, diverse skilling systems, global economies, and ad-hoc high stakes single and team based conflict. </li>
<br />
<li><a href="https://www.biorxiv.org/content/10.1101/511725v1">Distributed DNA-based Communication in Populations of Synthetic Protocells</a>:&nbsp;Encapsulating DNA strand-displacement circuits further allows their use in concentrated serum where non-compartmentalized DNA circuits cannot operate. BIO-PC enables reliable execution of distributed DNA-based molecular programs in biologically relevant environments and opens new directions in DNA computing and minimal cell technology.</li>
<br />
<li><a href="https://code.fb.com/wp-content/uploads/2019/03/OFC-2019-Herve-Fevrier.pdf">Facebook Perspective on Submarine Wet Plant Evolution</a>: From TAT-12/13 and TPC-5 cable systems [1,2] to today, we have seen, first, the development of optically amplified submarine systems and the corresponding technologies (EDFA, line fiber, WDM, DWDM,&hellip;), and then, the fastpaced revolution of coherent communications during approximately the last 10 years [3,4]. We went from 5 Gbit/s per fiber pair to more than 20 Tbit/s per fiber pair. Because we are now approaching the limits of capacity per fiber pair, a paradigm shift from an optical system design point of view is happening and we are moving towards cable systems having a much higher number of fiber pairs.</li>
<br />
<li><a href="https://songlh.github.io/paper/go-study.pdf">Understanding Real-World Concurrency Bugs in Go</a>: We studied six popular Go software including Docker, Kubernetes, and gRPC. We analyzed 171 concurrency bugs in total, with more than half of them caused by non-traditional, Go-specific problems. Apart from root causes of these bugs, we also studied their fixes, performed experiments to reproduce them, and evaluated them with two publicly-available Go bug detectors</li>
<br />
<li><a href="https://arxiv.org/abs/1902.10730">Degenerate Feedback Loops in Recommender Systems</a>:&nbsp;In this paper, we provide a novel theoretical analysis that examines both the role of user dynamics and the behavior of recommender systems, disentangling the echo chamber from the filter bubble effect. In addition, we offer practical solutions to slow down system degeneracy. Our study contributes toward understanding and developing solutions to commonly cited issues in the complex temporal scenario, an area that is still largely unexplored.</li>
<br />
<li><a href="https://net.cs.uni-bonn.de/fileadmin/user_upload/naiakshi/Naiakshina_Password_Study.pdf">"If you want, I can store the encrypted password." A Password-Storage Field Study with Freelance Developers</a>: &nbsp;From our research, we offer twocontributions. First of all, we reveal that, similar to the students, freelancers do not store passwords securely unless prompted, they have misconceptions about secure password storage, and they use outdated methods. Secondly, we discuss the methodological implications of using freelancers and students in developer studies</li>
<br />
<li><a href="https://blog.acolyer.org/2019/03/06/keeping-calm-when-distributed-consistency-is-easy/">Keeping CALM: when distributed consistency is easy</a>:&nbsp;When it comes to high performing scalable distributed systems, coordination is a killer. It&rsquo;s the dominant term in the Universal Scalability Law. When we can avoid or reduce the need for coordination things tend to get simpler and faster. See for example Coordination avoidance in database systems, and more recently the amazing performance of Anna which gives a two-orders-of-magnitude speed-up through coordination elimination. So we should avoid coordination whenever we can.</li>
</ul>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2019/3/8/stuff-the-internet-says-on-scalability-for-march-8th-2019.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />Post a Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2019/3/8/stuff-the-internet-says-on-scalability-for-march-8th-2019.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2019%2F3%2F8%2Fstuff-the-internet-says-on-scalability-for-march-8th-2019.html','Stuff%20The%20Internet%20Says%20On%20Scalability%20For%20March%208th%2C%202019');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2019/3/8/stuff-the-internet-says-on-scalability-for-march-8th-2019.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/36162863"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/hot-links"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />hot links</a></span></span>  <span class="post-snippet-1"><iframe src="//www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2019/3/8/stuff-the-internet-says-on-scalability-for-march-8th-2019.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="//twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2019/3/8/stuff-the-internet-says-on-scalability-for-march-8th-2019.html" data-text="Stuff The Internet Says On Scalability For March 8th,&nbsp;2019" data-count="horizontal">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments </h3>

      
        
          <div class="text">There are no comments for this journal entry.  To create a new comment, use the form below.</div>

        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=36162863"> 

    
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2018, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>