<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1552578797277&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://www.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Stuff The Internet Says On Scalability For August 2nd,&nbsp;2019 - High Scalability - </title>
    <meta property="og:title" content="Stuff The Internet Says On Scalability For August 2nd,&nbsp;2019 - High Scalability - " /> 
  

      <meta property="og:description" content=" Wake up! It's HighScalability time&amp;mdash;once again: 

 
  

 
  That's pretty good. ( @shruti..." />
  

  
      <meta property="og:image" content="https://live.staticflickr.com/65535/48433108471_6923110daf.jpg" />
  

  <!-- End Heading -->

  

  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId36205443"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2019%2F8%2F2%2Fstuff-the-internet-says-on-scalability-for-august-2nd-2019.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19697312">

    <div id="navigationTop-moduleContent19697312">

              <a id="navigationTop-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19700860">

    <div id="navigationTop-moduleContent19700860">

              <a id="navigationTop-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19697312">

    <div id="navigationBottom-moduleContent19697312">

              <a id="navigationBottom-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19700860">

    <div id="navigationBottom-moduleContent19700860">

              <a id="navigationBottom-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19697312">

    <div id="moduleContent19697312">

              <a id="moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19700860">

    <div id="moduleContent19700860">

              <a id="moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html">Stuff The Internet Says On Scalability For August 2nd, 2019</a></li>  <li><a href="/blog/2019/7/26/stuff-the-internet-says-on-scalability-for-july-26th-2019.html">Stuff The Internet Says On Scalability For July 26th, 2019</a></li>  <li><a href="/blog/2019/7/19/sponsored-post-educative-pa-file-sight-etleap-perfops-inmemo.html">Sponsored Post: Educative, PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/7/19/stuff-the-internet-says-on-scalability-for-july-19th-2019.html">Stuff The Internet Says On Scalability For July 19th, 2019</a></li>  <li><a href="/blog/2019/7/10/sponsored-post-pa-file-sight-etleap-perfops-inmemorynet-trip.html">Sponsored Post: PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/6/27/sponsored-post-pa-file-sight-etleap-perfops-inmemorynet-trip.html">Sponsored Post: PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/6/27/2019-open-source-database-report-top-databases-public-cloud.html">2019 Open Source Database Report: Top Databases, Public Cloud vs. On-Premise, Polyglot Persistence</a></li>  <li><a href="/blog/2019/6/4/sponsored-post-etleap-perfops-inmemorynet-triplebyte-stream.html">Sponsored Post: Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/5/17/gone-fishin.html">Gone Fishin'</a></li>  <li><a href="/blog/2019/5/14/sponsored-post-perfops-inmemorynet-triplebyte-etleap-stream.html">Sponsored Post: PerfOps, InMemory.Net, Triplebyte, Etleap, Stream, Scalyr</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <center>
  
  <a href="https://www.educative.io/collection/5668639101419520/5649050225344512 ">
     <img src="/storage/grokking-sdi-highscalability.png">
  </a>
  
  <a href="https://www.poweradmin.com/products/file-sight/product-information/landing/?ref=highscalability&utm_source=highscalability">
     <img src="/storage/file-sight-ransomware-protection.png">
  </a>
  
  <a href="https://fauna.com?utm_medium=referral&utm_source=HighScalabilityBlog">
     <img src="/storage/FaunaDB_125x12505x.png">
  </a>
  
  <a href="https://perfops.net?utm_source=highscalability&utm_medium=banner_125_125&utm_campaign=global_flexible_load_balancers">
     <img src="/storage/125x125-2.png">
  </a>
  
  <a href="https://getstream.io/chat/">
     <img width="125" height="125" src="/storage/stream.png">
  </a>
  
  <a href="https://triplebyte.com/?ref=hs_apr18_c1">
    <img src="/storage/triplebyte125.png">
  </a>
  
  
  <a href="/advertising">advertise</A>
  </center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2019%2F8%2F2%2Fstuff-the-internet-says-on-scalability-for-august-2nd-2019.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2019/7/26/stuff-the-internet-says-on-scalability-for-july-26th-2019.html">Stuff The Internet Says On Scalability For July 26th, 2019 &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-highscalability category-hot-links">
<div id="item36205443" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Friday</span></div><div class="journal-entry-float-date"><span class="month">Aug</span><span class="date">02</span><span class="year">2019</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html">Stuff The Internet Says On Scalability For August 2nd,&nbsp;2019</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Friday, August 2, 2019 at 9:19AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p><span>Wake up! It's <span><span><span>HighScalability</span></span></span> time&mdash;once again:</span></p>
<div align="center"><img src="https://live.staticflickr.com/65535/48433108471_6923110daf.jpg" alt="" />
<p>&nbsp;</p>
</div>
<div align="center"><span style="text-align: left;">&nbsp;That's pretty good. (<a href="https://twitter.com/shrutikapoor08/status/1156738943469015040?s=12">@shrutikapoor08</a>)</span></div>
<p style="text-align: center;">&nbsp;</p>
<p style="text-align: center;">Do you like this sort of Stuff? I'd greatly appreciate your <a href="https://www.patreon.com/toddhoff"><span>support on <span><span><span>Patreon</span></span></span></span></a>. I wrote <a href="https://www.amazon.com/dp/B0765C4SNR">Explain the Cloud Like I'm 10</a><span>&nbsp;for people who need to understand the cloud. And who doesn't these days? On Amazon it has 52 mostly 5 star reviews (121 on <span><span><span>Goodreads</span></span></span>). They'll learn a lot and hold you in even greater awe.</span></p>
<p style="text-align: center;"><span><br /></span></p>
<h2>Number Stuff:</h2>
<ul>
<li><a href="https://www.gamasutra.com/blogs/TimMerel/20190712/346377/Record_96B_games_investment_in_last_18_months_but_games_MAIPO_drop.php">$9.6B</a>: games investment in last 18 months,&nbsp;equal to the previous five years combined.</li>
<li><a href="https://www.fastcompany.com/90382831/a-teenager-just-made-3-million-by-playing-fortnight">$3 million</a>: won by a teenager in the Fortnite World Cup. &nbsp;</li>
<li><a href="https://cacm.acm.org/magazines/2019/8/238344-scaling-static-analyses-at-facebook/fulltext">100,000</a><span>: issues in <span>Facebook's</span> <span>codebase</span> fixed from bugs found by static analysis.&nbsp;</span></li>
<li><a href="https://www.bloomberg.com/news/articles/2019-07-29/capital-one-data-systems-breached-by-seattle-woman-u-s-says">106 million</a>: Capital 1 <span>IDs</span> stolen by a former Amazon employee. <a href="https://www.justice.gov/usao-wdwa/press-release/file/1188626/download">(complaint</a>)</li>
<li><a href="https://armis.com/urgent11/">2 billion</a><span>: <span>IoT</span> devices at risk because of 11 <span>VXWorks</span> zero day vulnerabilities.</span></li>
<li><a href="https://micromobility.io/podcast/22-micromobility-standards-what-are-they-and-why-do-they-matter-zn33n-gpye5">2.1 billion</a><span>: parking spots in the US, taking 30% of city real estate, totaling&nbsp;34 billion square meters, the size of West Virginia, valued at 60 trillion dollars.</span></li>
<li><a href="https://thetechnologygeek.org/mobile-advertising-represents-94-percent-of-facebook-revenues/">2.1 billion</a>: people use Facebook, Instagram, WhatsApp, or Messenger every day on average.&nbsp;</li>
<li><span><a href="https://www.bbc.com/news/technology-49165713">100</a>: words per minute from Facebook's machine-learning algorithms capable of turning brain activity into speech.&nbsp;</span></li>
<li><a href="https://thetechnologygeek.org/mobile-advertising-represents-94-percent-of-facebook-revenues/">51%</a>: Facebook and Google's ownership of the global digital ad market space on the internet.</li>
<li><a href="https://orange.hosting.lsoft.com/trk/click?ref=znwrbbrs9_6-20dd6x31cfa2x097744&amp;">56.9%</a>:&nbsp;Raleigh, NC was the top U.S. city for tech job growth.</li>
<li><a href="https://perlancar.wordpress.com/2019/08/01/dwindling-cpan-releases/">20-30</a>: daily CPAN (Perl) uploads. 700-800 for Python.</li>
<li><a href="https://www.thethingsnetwork.org/article/lorawan-distance-world-record">476 miles</a>:&nbsp;LoRaWAN (Low Power, Wide Area (LPWA)) distance world record broken using 25mW transmission power.</li>
<li><a href="https://www.youtube.com/watch?v=YE4KahNwxTA">74%</a>: Skyscanner savings using spot instances and containers on the Kubernetes cluster.</li>
<li><a href="https://www.verint.com/research/research-paper/">49%</a>: say convenience is more important than price when selecting a provider.</li>
<li><a href="https://medium.com/airbnb-engineering/supporting-dynamic-type-at-airbnb-b47c68b0c998">30%</a>: Airbnb app users prefer a non-default font size.</li>
<li><a href="https://ir.aboutamazon.com/news-releases/news-release-details/amazoncom-announces-second-quarter-sales-20-634-billion">150,000</a>:&nbsp;number of databases migrated to AWS using the AWS Database Migration Service.</li>
<li><a href="https://twitter.com/mikeelgan/status/1154435124433281025?s=12">1 billion</a>: Google photos users, <a href="https://twitter.com/mikeelgan/status/1154435124433281025?s=12">@MikeElgan</a>: same size as Instagram but far larger than Twitter, Snapchat or Pinterest</li>
<li><a href="https://techcrunch.com/2019/08/01/pinterest-pops-after-delivering-impressive-second-quarter-earnings-report/">300M</a>: Pinterest monthly active users with evenue of $261 million, up 64% year-over-year, on losses of $26 million for the second-quarter of 2019.</li>
<li><a href="https://time.com/5638981/lying-on-dating-apps">7%</a>:&nbsp;of all dating app messages were rated as false.</li>
<li><a href="https://www.cnbc.com/2019/08/01/goldman-spending-100-million-to-shave-milliseconds-off-stock-trades.html">$100 million</a>:&nbsp;Goldman Sachs spend to improve stock trades from&nbsp;hundreds of milliseconds down to&nbsp;100 microseconds while handling more simultaneous&nbsp;trades. The article mentions using microservices and event sourcing, but it's not clear how that's related.</li>
</ul>
<h2>Quotable Stuff:</h2>
<ul>
<li><a href="https://www.wsj.com/articles/facebook-and-google-algorithms-are-secretbut-australia-plans-to-change-that-11564134106"><span>Josh <span>Frydenberg</span>, Australian Treasurer</span></a>:&nbsp;Make no mistake, these companies are among the most powerful and valuable in the world. They need to be held to account and their activities need to be more transparent.</li>
<li><a href="https://www.edge.org/conversation/neil_gershenfeld-morphogenesis-for-the-design-of-design">Neil Gershenfeld</a>: Fabrication merges with communication and computation. Most fundamentally, it leads to things like morphogenesis and self-reproducing an assembler. Most practically, it leads to almost anybody can make almost anything, which is one of the most disruptive things I know happening right now. Think about this range I talked about as for computing the thousand, million, billion, trillion now happening for the physical world, it's all here today but coming out on many different link scales.</li>
<li><a href="https://tinlizzie.org/tinkertoy/">Alan Kay</a>:&nbsp;Marvin and Seymour could see that most interesting systems were crossconnected in ways that allowed parts to be interdependent on each other&mdash;not hierarchical&mdash;and that the parts of the systems needed to be processes rather than just &ldquo;things&rdquo;</li>
<li><a href="https://www.bleepingcomputer.com/news/security/the-week-in-ransomware-july-26th-2019-state-of-emergency/">Lawrence Abrams</a>:&nbsp;Now that ransomware developers know that they can earn monstrous payouts from local cities and insurance policies, we see a new government agency, school district, or large company getting hit with a ransomware attack every day.</li>
<li><a href="https://twitter.com/tmclaughbos/status/1155175594025455617?s=12"><span>@<span>tmclaughbos</span></span></a><span>: A lot of <span>serverless</span> adoption wi<span>ll</span> fail because organizations wi<span>ll</span> push developers to assume more responsibility down the sta<span>ck</span> instead of forcing them to mo<span>ve</span> up the sta<span>ck</span> closer to the business.</span></li>
<li><a href="https://research.lightstep.com/reports/google-cloud-storage">Lightstep</a>: Google Cloud Functions&rsquo; reusable connection insertion makes the requests more than 4 times faster [than S3] both in region and cross region.</li>
<li><a href="https://www.theatlantic.com/magazine/archive/2019/08/henry-kissinger-the-metamorphosis-ai/592771/">HENRY A. KISSING, ERERIC SCHMIDT, DANIEL HUTTENLOCHER</a>: The evolution of the arms-control regime taught us that grand strategy requires an understanding of the capabilities and military deployments of potential adversaries. But if more and more intelligence becomes opaque, how will policy makers understand the views and abilities of their adversaries and perhaps even allies? Will many different internets emerge or, in the end, only one? What will be the implications for cooperation? For confrontation? As AI becomes ubiquitous, new concepts for its security need to emerge.&nbsp;The three of us differ in the extent to which we are optimists about AI. But we agree that it is changing human knowledge, perception, and reality&mdash;and, in so doing, changing the course of human history. We seek to understand it and its consequences, and encourage others across disciplines to do the same.</li>
<li><a href="https://minesafetydisclosures.com/blog/2019/7/23/part-ll-an-overview-of-visa">minesafetydisclosures</a>: Visa's business is all about scale. That's because the company's fixed costs are high, but the cost of processing a transaction is essentially zero. Said more simply, it takes a big upfront investment in computers, servers, personnel, marketing, and legal fees to run Visa. But those costs don't increase as volume increases; i.e., they're &ldquo;fixed&rdquo;. So as Visa processes more transactions through their network, profit swells. As a result, the company&rsquo;s operating margin has increased from 40% to 65%.&nbsp;And the total expense per transaction has dropped from a dime to a nickel; of which only half of a penny goes to the processing cost. Both trends are likely to continue.</li>
<li><a href="https://news.ycombinator.com/item?id=20535629">noobiemcfoob</a>: Summarizing my views: MQTT seems as opaque as WebSockets without the benefits of being built on a very common protocol (HTTP) and being used in industries beyond just IoT. The main benefits proponents of MQTT argue for (low bandwidth, small libraries) don't seem particularly true in comparison to HTTP and WebSockets.</li>
<li><a href="https://gist.github.com/erincandescent/8a10eeeea1918ee4f9d9982f7618ef68">erincandescent</a>: It is still my opinion that RISC-V could be much better designed; though I will also say that if I was building a 32 or 64-bit CPU today I'd likely implement the architecture to benefit from the existing tooling.</li>
<li><a href="https://techcrunch.com/2019/07/30/lion-king-behind-the-scenes/">Director Jon Favreau</a>~ &nbsp;the plan was to create a virtual Serengeti in the Unity game engine, then apply live action filmmaking techniques to create the film &mdash; the &ldquo;Lion King&rdquo; team described this as a &ldquo;virtual production process.&rdquo;</li>
<li><a href="https://www.theinformation.com/articles/facebook-secret-research-warned-of-tipping-point-threat-to-core-app">Alex Heath</a>:&nbsp;In confidential research Mr. Cunningham prepared for Facebook CEO Mark Zuckerberg, parts of which were obtained by The Information, he warned that if enough users started posting on Instagram or WhatsApp instead of Facebook, the blue app could enter a self-sustaining decline in usage that would be difficult to undo. Although such &ldquo;tipping points&rdquo; are difficult to predict, he wrote, they should be Facebook&rsquo;s biggest concern.&nbsp;</li>
<li><a href="https://news.ycombinator.com/item?id=20554289">jitbit</a>: Well, to be embarrassingly honest... We suck at pricing. We were offering "unlimited" plans to everyone until recently. And the "impressive names" like you mention, well, they mostly pay us around $250 a month - which used to be our "Enterprise" pricing plan with unlimited everything (users, storage, agents etc.) So I guess the real answer is - we suck at positioning and we suck at marketing. As the result - profits were REALLY low (Lesson learned - don't compete on pricing). P.S. Couple of years ago I met Thomas from "FE International" at some conference, really experienced guy, who told me "dude, this is crazy, dump the unlimited plan like right now" so we did. So I guess technically we can afford a PaaS now...</li>
<li><a href="https://news.ycombinator.com/item?id=20591443">1e-9</a>:&nbsp;The markets are kind of like a massive, distributed, realtime, ensemble, recursive predictor that performs much better than any one of its individual component algorithms could. The reason why shaving a few milliseconds (or even microseconds) can be beneficial is because the price discovery feedback loops get faster, which allows the system to determine a giant pricing vector that is more self-consistent, stable, and beneficial to the economy. It's similar to how increasing the sample rate of a feedback control system improves performance and stability. Providers of such benefits to the markets get rewarded through profit.</li>
<li><a href="https://twitter.com/quinnypig/status/1156384668452655104?s=12">@QuinnyPig</a>:&nbsp;There&rsquo;s something else afoot too. I fix cloud bills. If I offer $10k to save $100k people sign off. If I offer $10 million to save $100 million people laugh me out of the room. Large numbers are psychologically scary.</li>
<li><a href="https://news.ycombinator.com/item?id=20576825">mrjn</a>: &nbsp;Is it worth paying $20K for any DB or DB support? If it would save you 1/10th of an engineer per year, it becomes immediately worth. That means, can you avoid 5 weeks of one SWE by using a DB designed to better suit your dataset? If the answer is yes (and most cases it is), then absolutely that price is worth. See my blog post about how much money it must be costing big companies building their graph layers. Second part is, is Dgraph worth paying for compared to Neo or others? Note that the price is for our enterprise features and support. Not for using the DB itself. Many companies run a 6-node or a 12-node distributed/replicated Dgraph cluster and we only learn that much later when they're close to pushing it into production and need support. They don't need to pay for it, the distributed/replicated/transactional architecture of Dgraph is all open source. How much would it cost if one were to run a distributed/replicated setup of another graph DB? Is it even possible, can it execute and perform well? And, when you add support to that, what's the cost?</li>
<li><a href="https://twitter.com/codemouse/status/1155144947483512833"><span>@<span>codemouse</span></span></a>: It&rsquo;s halfway to 2020. At this point, if any of your strategy is continued investment into your data centers you&rsquo;re doing it wrong. Yes migration may take years, but you&rsquo;re not going to be doing #cloud or #ops better than @awscloud </li>
<li><a href="https://news.ycombinator.com/item?id=20561859">hermitdev</a>:&nbsp;Not Citibank, but previously worked for a financial firm that sold a copy of it's back office fund administration stack. Large, on site deployment. It would take a month or two to make a simple DNS change so they could locate the services running on their internal network. The client was a US depository trust with trillions on deposit. No, I wont name any names. But getting our software installed and deployed was as much fun as extracting a tooth with a dull wood chisel and a mallet.</li>
<li><a href="https://www.recordedfuture.com/measuring-malware-popularity/">Insikt Group</a>: Approximately 50% of all activity concerning ransomware on underground forums are either requests for any generic ransomware or sales posts for generic ransomware from lower-level vendors. We believe this reflects a growing number of low-level actors developing and sharing generic ransomware on underground forums.</li>
<li><a href="https://cacm.acm.org/magazines/2019/8/238344-scaling-static-analyses-at-facebook/fulltext"><span> <span>Facebook</span></span></a>: For classes of bugs intended for all or a wide variety of engineers on a given platform, we have gravitated toward a "diff time" deployment, where analyzers participate as bots in code review, making automatic comments when an engineer submits a code modification. Later, we recount a striking situation where the diff time deployment saw a 70% fix rate, where a more traditional "offline" or "batch" deployment (where bug lists are presented to engineers, outside their workflow) saw a 0% fix rate. </li>
<li><a href="http://www.startuplessonslearned.com/2019/06/lean-startup-conference-speaker-andy.html?m=1">Andy Rachleff</a>: Venture capitalists know that the thing that causes their companies to go out of business is lack of a market, not poor execution. So it's a fool's errand to back a company that proposes to do a ride-hailing service or renting a room or something as crazy as that. Again--how would you know if it&rsquo;s going to work? So the venture industry outsourced that market risk to the angel community. The angel community thinks they won it away from the venture community, but nothing could be further from the truth, because it's a sucker bet. It's a horrible risk/reward. The venture capitalists said, "Okay, let the angels invest at a $5 million valuation and take all of that market risk. We'll invest at a $50 million valuation. We have to pay up if it works." Now they hope the company will be worth $5 billion to make the same return as they would have in the old model. Interestingly, there now are as many companies worth $5 billion today as there were companies worth $500 million 20 years ago, which is why the returns of the premier venture capital firms have stayed the same or even gone up.</li>
<li><a href="https://news.ycombinator.com/item?id=20544943">imagetic</a>: I dealt with a lot of high traffic live streaming video on Facebook for several years. We saw interaction rates decline almost 20x in a 3 year period but views kept increasing. Things just didn't add up when the dust settled and we'd look at the stats. It wouldn't be the least bit surprised if every stat FB has fed me was blown extremely out of proportion.</li>
<li><a href="https://www.reddit.com/r/programming/comments/cixatj/an_exarm_engineer_critiques_riscv/evb9e4m/">prism1234</a>:&nbsp;If you are designing a small embedded system, and not a high performance general computing device, then you already know what operations your software will need and can pick what extensions your core will have. So not including a multiply by default doesn't matter in this case, and may be preferred if your use case doesn't involve a multiply. That's a large use case for risc-v, as this is where the cost of an arm license actually becomes an issue. They don't need to compete with a cell phone or laptop level cpu to still be a good choice for lots of devices.</li>
<li>
<div id="_mcePaste"><span> </span></div>
<div id="_mcePaste"><a href="https://news.ycombinator.com/item?id=20568708">oppositelock</a>: You don't have time to implement everything yourself, so you delegate. Some people now have credentials to the production systems, and to ease their own debugging, or deployment, spin up little helper bastion instances, so they don't have to use 2FA each time to use SSH or don't have to deal with limited-time SSH cert authorities, or whatever. They roll out your fairly secure design, and forget about the little bastion they've left hanging around, open to 0.0.0.0 with the default SSH private key every dev checks into git. So, any former employee can get into the bastion.</div>
</li>
<li><a href="https://eng.lyft.com/lyft-marketing-automation-b43b7b7537cc">Lyft</a>: Our tech stack comprises Apache Hive, Presto, an internal machine learning (ML) platform, Airflow, and third-party APIs.</li>
<li><a href="https://www.verica.io/top-seven-myths-of-robust-systems/">Casey Rosenthal</a>: It turns out that redundancy is often orthogonal to robustness, and in many cases it is absolutely a contributing factor to catastrophic failure. The problem is, you can&rsquo;t really tell which of those it is until after an incident definitively proves it&rsquo;s the latter.</li>
<li><a href="https://www.infoq.com/presentations/pid-loops/"><span><span>Colm</span> <span>MacC&aacute;rthaigh</span></span></a>:&nbsp;There are two complementary tools in the chest that we all have these days, that really help combat Open Loops. The first is Chaos Engineering. If you actually deliberately go break things a lot, that tends to find a lot of Open Loops and make it obvious that they have to be fixed.</li>
<li><a href="https://twitter.com/eeyitemi/status/1156005500921638915?s=12"><span>@<span>eeyitemi</span></span></a><span>: I'm <span>gonna</span> constantly remind myself of this everyday. "You can <span>outsource</span> the work, but you can't <span>outsource</span> the risk." @<span>Viss</span> 2019</span></li>
<li><a href="https://techcrunch.com/2019/07/30/lion-king-behind-the-scenes/">Ben Grossman</a>~ this could lead to a situation where filmmaking is less about traditional &ldquo;filmmaking or storytelling,&rdquo; and more about &ldquo;world-building&rdquo;: &ldquo;You create a world where characters have personalities and they have motivations to do different things and then essentially, you can throw them all out there like a simulation and then you can put real people in there and see what happens.&rdquo;</li>
<li><a href="https://news.ycombinator.com/item?id=20588257">cheeze</a>:&nbsp;I'm a professional dev and we own a decent amount of perl. That codebase is by far the most difficult to work in out of anything we own. New hires have trouble with it (nobody learns perl these days). Lots of it is next to unreadable.</li>
<li><a href="https://www.theatlantic.com/ideas/archive/2019/07/whatever-happened-tech-bubble/594856/">Annie Lowrey</a>:&nbsp;All that capital from institutional investors, sovereign wealth funds, and the like has enabled start-ups to remain private for far longer than they previously did, raising bigger and bigger rounds. (Hence the rise of the &ldquo;unicorn,&rdquo; a term coined by the investor Aileen Lee to describe start-ups worth more than $1 billion, of which there are now 376.) Such financial resources &ldquo;never existed at scale before&rdquo; in Silicon Valley, says Steve Blank, a founder and investor. &ldquo;Investors said this: &lsquo;If we could pull back our start-ups from the public market and let them appreciate longer privately, we, the investors, could take that appreciation rather than give it to the public market.&rsquo; That&rsquo;s it.&rdquo;</li>
<li><a href="https://news.ycombinator.com/item?id=20540925"><span><span>alexis</span>_<span>fr</span></span></a><span>: I wonder if the human life calculation worked we<span>ll</span> this time. As far as I see, Boeing lost more than the sum of the human lives; they also lost reputation for everything new they&rsquo;<span>ve</span> designed in the last 7 years being corrupted, and they also engulfed the reputation of FAA with them, whose agents would fit the definition of &ldquo;corrupted&rdquo; by any people&rsquo;s definition (I know, they are not, they just used agents of Boeing to inspect Boeing because they were understaffed), and the FAA showed the last step of failure by not admitting that the plane had to be stopped until a few days after the European agencies. In other words, even in financial terms, it cost more than damages. It may ha<span>ve</span> cost the entire company. They &ldquo;<span>DeHavailland</span>&rdquo;&rsquo;ed their company. Ever heard of <span>DeHavailland</span>? No? That&rsquo;s probably to do with their 4 successi<span>ve</span> <span>deintegrating</span> planes that &ldquo;<span>CEOs</span> ha<span>ve</span> complete trust in.&rdquo; It just died, as a name. The risk is high.</span></li>
<li><a href="https://www.edge.org/conversation/neil_gershenfeld-morphogenesis-for-the-design-of-design">Neil Gershenfeld</a>: computer science was one of the worst things ever to happen to computers or science, why I believe that, and what that leads me to. I believe that because it&rsquo;s fundamentally unphysical. It&rsquo;s based on maintaining a fiction that digital isn&rsquo;t physical and happens in a disconnected virtual world.</li>
<li><a href="https://twitter.com/benedictevans/status/1156739698867314688?s=12"><span>@<span>benedictevans</span></span></a><span>: <span>Netflix</span> and Sky both realised that a new technology meant you could pay vastly more for content than anyone expected, and take it to market in a new way. The new tech (satellite, broadband) is a crowbar for breaking into TV. But the questions that matter are a<span>ll</span> TV questions</span></li>
<li><a href="https://twitter.com/iamdevloper/status/1156151468744818688?s=12"><span>@<span>iamdevloper</span></span></a>: Therapist: And what do we do when we feel like this? Me: buy a domain name for the side project idea we've had for 15 seconds. Therapist: No</li>
<li><a href="https://twitter.com/dvassallo/status/1154516910265884672?s=12&amp;ck_subscriber_id=512839864">@dvassallo</a>: Step 1: Forget that all these things exist: Microservices, Lambda, API Gateway, Containers, Kubernetes, Docker. Anything whose main value proposition is about &ldquo;ability to scale&rdquo; will likely trade off your &ldquo;ability to be agile &amp; survive&rdquo;. That&rsquo;s rarely a good trade off. 4/25 Start with a t3.nano EC2 instance, and do all your testing &amp; staging on it. It only costs $3.80/mo. Then before you launch, use something bigger for prod, maybe an m5.large (2 vCPU &amp; 8 GB mem). It&rsquo;s $70/mo and can easily serve 1 million page views per day.</li>
<li><a href="https://feedly.com/i/subscription/feed%2Fhttp%3A%2F%2Fpetewarden.typepad.com%2Fsearchbrowser%2Fatom.xml"><span><span>PeteSearch</span></span></a><span>: I belie<span>ve</span> we ha<span>ve</span> an opportunity right now to engineer-in privacy at a hardware level, and set the technical expectation that we should design our systems to be resistant to abuse from the very start. The nice thing about bundling the audio and image sensors together with the machine learning logic into a single component is that we ha<span>ve</span> the ability to constrain the interface. If we truly do just ha<span>ve</span> a single pin output that indicates if a person is present, and there&rsquo;s no other way (like <span>Bluetooth</span> or <span>WiFi</span>) to smuggle information out, then we should be able to offer strong promises that it&rsquo;s just not possible to leak pictures. The same for speech interfaces, if it&rsquo;s only able to recognize certain commands then we should be able to guarantee that it can&rsquo;t be used to record conversations.</span></li>
<li><a href="http://muratbuffalo.blogspot.com/2019/07/corfu-shared-log-design-for-flash.html"><span><span>Murat</span></span></a><span>:&nbsp;As I ha<span>ve</span> mentioned in the previous blog post, MAD questions, Cosmos DB has <span>operationalized</span> a fault-masking streamlined version of replication via nested replica-sets deployed in fan-out topology. Rather than doing offline updates from a log, Cosmos DB updates database at the replicas online, in place, to provide strong consistent and bounded-staleness consistency reads among other read levels. On the other hand, Cosmos DB also maintains a change log by way of a witness replica, which serves several useful purposes, including fault-tolerance, remote storage, and snapshots for analytic workload.</span></li>
<li><a href="https://www.reddit.com/r/programming/comments/cjeuvv/the_fallacy_of_premature_optimization/evdomqf/">grauenwolf</a>: That's where I get so frustrated. Far too often I hear "premature optimization" as a justification for inefficient code when doing it the right way would actually require the same or less effort and be more readable.</li>
<li><a href="http://muratbuffalo.blogspot.com/2019/07/paxos-jokes.html"><span><span>Murat</span></span></a><span>: Leader - I te<span>ll</span> you <span>Paxos</span> joke, if you accept me as leader. Quorum - Ok comrade. Leader - Here is joke! (*Transmits joke*) Quorum - <span>Oookay</span>... Leader - (*Laughs* <span>hahaha</span>). Now you laugh!! Quorum - <span>Hahaha</span>, <span>hahaha</span>.</span></li>
<li><a href="https://arstechnica.com/information-technology/2019/07/feds-former-cloud-worker-hacks-into-capital-one-and-takes-data-for-106-million-people/?comments=1&amp;post=37724659"><span>Manmax75</span></a><span>:&nbsp;The amount of stories I'<span>ve</span> heard from <span>SysAdmins</span> who jokingly try to access a former employers network with their old credentials only to be shocked they sti<span>ll</span> ha<span>ve</span> admin access is a scary and boggling thought.</span></li>
<li><a href="https://twitter.com/dougtoppin/status/1156170855929528321"><span>@<span>dougtoppin</span></span></a><span>: <span>Fargate</span> brings significant opportunity for cost savings and to get the maximum benefit the minimal possible number of tasks must be running to handle your capacity needs. This means quickly detecting request traffic, responding just as quickly and then scaling ba<span>ck</span> down.</span></li>
<li><a href="https://twitter.com/evolvable/status/1155596629203795968?s=12">@evolvable</a><span>:&nbsp;At a startup bank we got management <span>pushback</span> when revealing we planned to start testing in production - concerns around regulation and employees accessing prod. We changed the name to &ldquo;Production Verification&rdquo;. The discussion changed to why we hadn&rsquo;t been doing it until now.&nbsp;</span></li>
<li><a href="https://twitter.com/quinnypig/status/1155838435065655296?s=12"><span>@<span>QuinnyPig</span></span></a>: I&rsquo;m saying it a bit louder every time: @awscloud&rsquo;s data transfer pricing is predatory garbage.&nbsp;I have made hundreds of thousands of consulting dollars straightening these messes out. It&rsquo;s unconscionable. I don&rsquo;t want to have to do this for a living.&nbsp;To be very clear, it's not that the data transfer pricing is too expensive, it's that it's freaking inscrutable to understand. If I can cut someone's bill significantly with a trivial routing change, that's not the customer's fault.</li>
<li><a href="https://twitter.com/ppathole/status/1155464941177987072?s=12"><span>@<span>PPathole</span></span></a><span>: Alternati<span>ve</span> Big O notations: O(1) = O(yeah) O(log n) = O(nice) O(<span>nlogn</span>) = O(k-<span>ish</span>) O(n) = O(ok) O(n&sup2;) = O(my) O(2ⁿ) = O(no) O(n^n) = O(f*<span>ck</span>) O(n!) = O(mg!)</span></li>
<li><a href="https://reading.supply/post/432f6903-c7cd-4cb0-a894-c09155a8ca8b">Brewster Kahle</a>: There's only a few hackers I've known like Richard Stallman, he'd write flawless code at typing speed. He worked himself to the bone trying to keep up with really smart former colleagues who had been poached from MIT. Carpal tunnel, sleeping under the desk, really trying hard for a few years and it was killing him. So he basically says I give up, we're going to lose the Lisp machine. It was going into this company that was flying high, it was going to own the world, and he said it was going to die, and with it the Lisp machine. He said all that work is going to be lost, we need a way to deal with the violence of forking. And he came up with the GNU public license. The GPL is a really elegant hack in the classic sense of a hack. His idea of the GPL was to allow people to use code but to let people put it back into things. Share and share alike.</li>
</ul>
<h2>Useful Stuff:</h2>
<ul>
<li>It's probably not a good idea to start a Facebook poll on the advisability of your pending nuptials a day before the wedding. But it is very funny and disturbingly plausible.&nbsp;<a href="https://www.youtube.com/watch?v=nm6eTYg3xZs">Made Public</a>. Another funny/sad one is using a ML bot to "deal with" <a href="https://www.youtube.com/watch?v=ndvYa3X6hU0">phone scams</a>. The sad part will be when both sides are just AIs trying to socially engineer each other&nbsp;and half the world's resources become dedicated to yet another form of digital masturbation. Perhaps we should just stop the MADness?</li>
<br />
<li><span><a href="https://armis.com/urgent11/">Urgent/1111 Zero Day Vulnerabilities Impacting <span>VxWorks</span>, the Most Widely Used Real-Time Operating System (<span>RTOS</span>)</a></span><span>. I read this with special interest because I'<span>ve</span> used <span>VxWorks</span> on several projects. Not once do I ever remember anyone saying "I wonder if the TCP/<span>IP</span> sta<span>ck</span> has security vulnerabilities?" We looked at licensing costs, board support packages, device driver support, tool chain support, <span>ISR</span> service latencies, priority inversion handling, task switch determinacy, etc. Why did we never think of these kind of potential vulnerabilities? One reason is social proof. Surely a<span>ll</span> these other companies use <span>VxWorks</span>, it must be good, right? Another reason is <span>VxWorks</span> is often used within a secure perimeter. None of the network interfaces are supposed to be exposed to the internet, so remote code execution is not part of your threat model. But in reality you ha<span>ve</span> no idea if a customer wi<span>ll</span> expose a device to the internet. And you ha<span>ve</span> no idea if later product enhancements wi<span>ll</span> place the device on the internet. Since it seems a<span>ll</span> network devices expand until they become a router, this seems a likely path to Armageddon. At that point nobody is going to <span>requalify</span> their entire <span>toolchain</span>. That just wouldn't be done in practice. <span>VxWorks</span> is dangerous because everything is compiled into a single image the boots and runs, much like a unikernel. At least when I used it that was the case. <span>VxWorks</span> is basically just a library you link into your application that provides OS functionality. Your write the boot code, device drivers, and other code to make your application work. So if there's a remote code execution bug it has&nbsp;access to everything. And a lot of these images are built into ROM, so they aren't <span>upgradeable</span>. And if even if the images are <span>upgradeable</span> in <span>EEPROM</span> or flash, how many people wi<span>ll</span> actually do that? Unless you pay a lot of money you do not get the source to <span>VxWorks</span>. You just get libraries and header files. So you ha<span>ve</span> no idea what's going on in the network sta<span>ck</span>. I'm surprised <span>VxWorks</span> never tested their sta<span>ck</span> against a <span>fuzzing</span> kind of atta<span>ck</span>. That's a great way to find bugs in protocols. Though nobody can define simplicity, many of the bugs were in the handling of the little used&nbsp;TCP Urgent Pointer feature. Anyone surprised that code around this is broke? Who uses it? It shouldn't be in the sta<span>ck</span> at a<span>ll</span>. Simple to say, harder to do.</span></li>
<br />
<li>JuliaCon 2019 videos are <a href="https://www.youtube.com/playlist?list=PLP8iPy9hna6StY9tIJIUN3F_co9A0zh0H">now available</a>. You might like&nbsp;<a href="https://www.youtube.com/watch?v=mSgXWpvQEHE">Keynote: Professor Steven G. Johnson</a>&nbsp;and&nbsp;<a href="https://www.youtube.com/watch?v=kc9HwsxE1OY">The Unreasonable Effectiveness of Multiple Dispatch</a>.&nbsp;</li>
<br />
<li>CERN is&nbsp;<a href="https://home.cern/news/news/computing/migrating-open-source-technologies">Migrating to open-source technologies</a>. Microsoft wants too much for their licenses so CERN is giving MS the finger.</li>
<br />
<li><span><a href="https://jakob.engbloms.se/archives/2997">Memory and Compute with <span>Onur</span> <span>Mutlu</span></a></span>:                                                  
<ul>
<li>The main problem is that DRAM latency is hardly improving at all. From 1999 to 2017, DRAM capacity has increased by 128x, bandwidth by 20x, but latency only by 1.3x! This means that more and more effort has to be spent tolerating memory latency. &nbsp;But what could be done to actually improve memory latency?</li>
<li>You could &ldquo;easily&rdquo; get a 30% latency improvement by having DRAM chips provide a bit more precise information to the memory controller about actual latencies and current temperatures.</li>
<li><span>Another concept to truly break the memory barrier is to mo<span>ve</span> the compute to the memory. Basically, why not put the compute operations in memory? &nbsp;One way is to use something like High-Bandwidth Memory (<span>HBM</span>) and shorten the distance to memory by stacking logic and memory.</span></li>
<li><span>Another rather cool (but also somewhat limited) approach is to actually use the DRAM cells themselves as a compute engine. It turns out that you can do copy, clear, and even logic ops on memory rows by using the existing way that <span>DRAMs</span> are built and adding a tiny amount of extra logic.</span></li>
</ul>
</li>
<br />
<li><span>Want to make something in hardware? Like Pebble, <span>Dropcam</span>, or Ring. Who you <span>gonna</span> ca<span>ll</span>? </span><a href="https://www.dragoninnovation.com/">Dragon Innovation</a><span>. Listen how on the AMP Hour <span>podcast</span> episode&nbsp;</span><a href="https://theamphour.com/451-an-interview-with-scott-miller-2nd/">#451 &ndash; An Interview with Scott Miller</a>.&nbsp;                                                      
<ul>
<li><span>Typical customers build between 5k and 1 million units, but wi<span>ll</span> talk with you at 100 units. Customers usually start sma<span>ll</span>. They'<span>ve</span> built a big toolbox for <span>IoT</span>, so they don't need to create the wheel every time, they ha<span>ve</span> designs for sensing, processing, electronics on the edge, radios, and a<span>ll</span> the different security layers. They can deploy quickly with little customizations.</span></li>
<li><span>Dragon is moving into doing the design, manufacturing, packaging, issue a<span>ll</span> <span>POs</span>, and installation support. They ca<span>ll</span> this Product as a Service (<span>PaaS</span>)&mdash;fu<span>ll</span> end-to-end provider. Say you ha<span>ve</span> a sensor to determine when avocados are ripe you would pay per sensor per month, or maybe per avocado, instead of a one time sale. Seeing more non-traditional getting into the <span>IoT</span> space, with different revenue models, Dragon has an opportunity to innovate on their business model.&nbsp;</span></li>
<li><strong>Consumer is dying and industrial is growing</strong>. A trend they are seeing in the US is a constriction of business to consumer startups in the hardware space, but an an expansion of industrial <span>IoT</span>. There ha<span>ve</span> been a bunch of high profile bankruptcies in the consumer space (<span>Anki</span>, <span>Jibo</span>).</li>
<li><strong>Europe is growing</strong>. Overall huge growth in industrial startups across Europe. Huge number of capable factories in the EU. They get feet on the ground to find and qualify factories.&nbsp;They have over 2000 factories in their database. 75% in China, increasingly more in the EU and the US.&nbsp;</li>
<li><span>Factories are going global. Seeing a lot of companies driven out of China by the 25%&nbsp;tariffs, moving into Asian pacific countries like Taiwan, Singapore, Vietnam, Indonesia, Malaysia. Coming up quickly, but not up to <span>China's</span> level yet. Dragon wi<span>ll</span> include <span>RFQs</span> on a global basis, including factories from the US, China, EU, Indonesia, Vietnam, to see what the landed cost is as a function of geography.&nbsp;</span></li>
<li><strong>Factories are different in different countries</strong>. In China factories are vertically integrated. Mold making, injection molding, final assembly and test and packaging, all under one roof. Which is very convenient. In the US and Europe factories are more horizontal. It takes a lot more effort to put together your supply chain. &nbsp;As an example of the degree they were vertically integrated this factory in China would make their own paint and cardboard.&nbsp;</li>
<li><strong>Automation is huge in China</strong>. Chinese labor rates are on average 5 to 6 dollars an hour, depending on region, factory, training. Focus is on automation.&nbsp;One factory they worked with had 100,000 workers now they have 30,000 because of automation.</li>
<li><strong>Automation is different in China</strong>. Automation in China is <span>bottom's</span> up. They'<span>ll</span> build a simple robot that attaches to a soldering iron and wi<span>ll</span> solder the leads. In the US is top down. Build a huge fu<span>ll</span> functioning worker that can do anything instead of a task specific robot. China is really good at building stuff so they build task specific robots to make their processes more efficient. Since products are always changing this allows them to stay nimble.&nbsp;</li>
<li>Also <a href="https://www.youtube.com/channel/UCO8DQrSp5yEP937qNqTooOw">Strange Parts</a>,&nbsp;<a href="https://blog.dragoninnovation.com/blog/tag/design-for-manufacturing-course">Design for Manufacturing Course</a>, <a href="https://www.youtube.com/watch?v=leFuF-zoVzA"><span>How I Made My Own <span>iPhone</span> - in China</span></a>.</li>
</ul>
</li>
<br />
<li><a href="https://cloud.google.com/bigquery/docs/best-practices-costs"><span><span>BigQuery</span> best practices: Controlling costs</span></a><span>:&nbsp;Query only the columns that you need;&nbsp;Don't run queries to explore or preview table data;&nbsp;Before running queries, preview them to estimate costs;&nbsp;Using the query <span>validator</span>;&nbsp;Use the maximum bytes billed setting to limit query costs;&nbsp;Do not use a LIMIT clause as a method of cost control;&nbsp;Create a dashboard to view your billing data so you can make adjustments to your <span>BigQuery</span> usage. Also consider streaming your audit logs to <span>BigQuery</span> so you can analyze usage patterns;&nbsp;Partition your tables by date;&nbsp;f possible, materialize your query results in stages;&nbsp;&nbsp;If you are writing large query results to a destination table, use the default table expiration time to remo<span>ve</span> the data when it's no longer needed;&nbsp;Use streaming inserts only if your data must be immediately available.</span></li>
<br />
<li><a href="https://www.bbc.com/news/business-49142761">Boeing</a> has changed a lot over the years. Once upon a time I worked on a project with&nbsp;Boeing and the people were excellent. This is something I heard: "The&nbsp;changes can be attributed to the influence of the McDonnel family who maintain extremely high influence through their stock shares resulting from the merger. It has been gradually getting better recently but still a problem for those inside who understand the real potential impact."</li>
<br />
<li>Maybe we are all just random matrices?&nbsp;<a href="https://www.youtube.com/watch?v=HrtJ3SRQF4E">What Is Universality?</a>&nbsp;It turns out there are deep patterns in&nbsp;complex correlated systems that lie somewhere between randomness and order. They arise from components that interact and repel one another. Do such patterns exist in software systems? Also,&nbsp;<a href="https://www.quantamagazine.org/bubble-experiment-finds-universal-laws-20190731/">Bubble Experiment Finds Universal Laws</a>.&nbsp;</li>
<br />
<li><a href="https://www.infoq.com/presentations/pid-loops/"><span><span>PID</span> Loops and the Art of Keeping Systems Stable</span></a>:&nbsp;                                            
<ul>
<li><span>I see a lot of places where control theory is directly applicable but rarely applied. Auto-scaling and placement are really obvious examples, we're going to walk through some, but another is fairness algorithms. A really common fairness algorithm is how TCP achieves fairness. You'<span>ve</span> got a<span>ll</span> these network users and you want to gi<span>ve</span> them a<span>ll</span> a fair slice. Turns out that a <span>PID</span> loop it&rsquo;s what's happening. In system stability, how do we absorb errors, recover from those errors?&nbsp;</span></li>
<li><span>Something we do in <span>CloudFront</span> is we run a control system. We're constantly measuring the utilization of each site and depending on that utilization, we figure out what's our error, how far are we from optimized? We change the mass or radius of effect of each site, so that at our really busy time of day, really close to peak, it's servicing everybody in that city, everybody directly around it drawing those in, but that at our quieter time of day can extend a little further and go out. It&rsquo;s a big system of dynamic springs a<span>ll</span> interconnected, a<span>ll</span> with <span>PID</span> loops. It's amazing how optimal a system like that can be, and how applying a system like that has increased our effectiveness as a <span>CDN</span> provider.&nbsp;</span></li>
<li><span>A surprising number of control systems are just like this, they're just Open Loops. I can't count the number of customers I'<span>ve</span> gone through control systems with and they told me, "We ha<span>ve</span> this system that pushes out some states, some configuration and sometimes it doesn't do it."&nbsp;I find that scary, because what it's saying is <span>nothing's</span> actually monitoring the system. <span>Nothing's</span> really checking that everything is as it should be.&nbsp;My classic favorite example of this as an Open Loop process, is certificate rotation. I happened to work on <span>TLS</span> a lot, it's something I spent a lot of my time on. Not a week goes by without some major website having a certificate outage.</span></li>
<li><span>We ha<span>ve</span> two <span>observability</span> systems at <span>AWS</span>, <span>CloudWatch</span>, and X-Ray. One of the things I didn't appreciate until I joined <span>AWS</span> - I was a bit going on like Charlie and the chocolate factory, and seeing the insides. I expected to see a<span>ll</span> sorts of cool algorithms and a<span>ll</span> sorts of fancy techniques and things that I just never imagined. It was a little bit of that, there was some of that once I got inside working, but mostly what I found was really mundane, people were just doing a lot of things at scale that I didn't realize. One of those things was just the sheer volume of monitoring. The number of metrics we keep on, every single host, every single system, I sti<span>ll</span> find staggering.</span></li>
<li><span>Exponential Ba<span>ck</span>-off is a really strong example. Exponential Ba<span>ck</span>-off is basically an integral, an error happens and we retry, a second later if that fails, then we wait.&nbsp;Rate limiters are like derivatives, they're just rate estimators and what's going on and deciding what's to let in and what to let out. We'<span>ve</span> built both of these into the <span>AWS</span> <span>SDKs</span>.&nbsp;We'<span>ve</span> got other ba<span>ck</span> pressure strategies too, we'<span>ve</span> got systems where servers can te<span>ll</span> clients, "Ba<span>ck</span> off, please, I'm a little busy right now," a<span>ll</span> those things working together. If I look at system design and it doesn't ha<span>ve</span> any of this, if it doesn't ha<span>ve</span> exponential ba<span>ck</span>-off, if it doesn't ha<span>ve</span> rate-limiters in some place, if it's not able to fight some power-law that I think might arise due to errors propagating, that tells me I need to be a bit more worried and start digging deeper.</span></li>
<li>I like to watch out for edge triggering in systems, it tends to be an anti-pattern. One reason is because edge triggering seems to imply a modal behavior. You cross the line, you kick into a new mode, that mode is probably rarely tested and it's now being kicked into at a time of high stress, that's really dangerous.&nbsp;Your system has to be idempotent, if you're going to build an idempotent system, you might as well make a level-triggered system in the first place, because generally, the only benefit of building an edge-triggered system is it doesn't have to be idempotent.</li>
<li><span>There is definitely tension between stability and optimality, and in general, the more finely-tuned you want to make a system to achie<span>ve</span> absolute optimality, the more risk you are of being able to dri<span>ve</span> it into an unstable state. There are people who do entire <span>PIDs</span> on nothing else then finding that balance for one system. Oil refineries are a good example, where the oil industry wi<span>ll</span> pay people a lot of money just to optimize that, even very slightly. Computer Science, in my opinion, and distributed systems, are nowhere near that level of advanced control theory practice yet. We ha<span>ve</span> a long way to go. We're sti<span>ll</span> down at the baby steps of, &ldquo;We&rsquo;<span>ll</span> at least measure it.&rdquo;</span></li>
</ul>
</li>
<br />
<li>Re:Inforce 2019 videos are <a href="https://aws.amazon.com/blogs/security/reinforce-2019-wrap-up-and-session-links/">now available</a>.</li>
<br />
<li><a href="https://www.verica.io/top-seven-myths-of-robust-systems/">Top Seven Myths of Robust Systems</a>:&nbsp;The number one myth we hear out in the field is that if a system is unreliable, we can fix that with redundancy; rather than trying to simplify or remove complexity, learn to live with it. Ride complexity like a wave. Navigate the complexity;&nbsp;The adaptive capacity to improvise well in the face of a potential system failure comes from frequent exposure to risk;&nbsp;Both sides &mdash; the procedure-makers and the procedure-not-followers &mdash; have the best of intentions, and yet neither is likely to believe that about the other;&nbsp;Unfortunately it turns out catastrophic failures in particular tend to be a unique confluence of contributing factors and circumstances, so protecting yourself from prior outages, while it shouldn&rsquo;t hurt, also doesn&rsquo;t help very much;&nbsp;Best practices aren&rsquo;t really a knowable thing;&nbsp;Don&rsquo;t blame individuals. That&rsquo;s the easy way out, but it doesn&rsquo;t fix the system. Change the system instead.&nbsp;                                          
<ul>
</ul>
</li>
<br />
<li>They grow up so slow.&nbsp;<a href="https://itnext.io/whats-new-in-javascript-google-i-o-2019-summary-d16bd2308412">What&rsquo;s new in JavaScript: Google I/O 2019 Summary</a>.&nbsp;</li>
<br />
<li><em>From a rough calculation we saw about 40% decrease in the amount of CPU resources used. Overall, we saw latency stabilize for both avg and max p99. Max p99 latency also decreased a bit.</em>&nbsp;<a href="https://engineering.mixpanel.com/2019/07/24/safely-rewriting-mixpanels-highest-throughput-service-in-golang/">Safely Rewriting Mixpanel&rsquo;s Highest Throughput Service in Golang</a>. Mixpanel moved from Python to Go for their data collection API. They has already migrated the Python API to use the Google Load Balancer to route messages to kubernetes pod on Google Cloud where an Envoy container load-balanced between eight Python API containers. The Python API containers then submitted the data to Google Pubsub queue via a pubsub sidecar container that had a kestrel interface.&nbsp;To enable testing against live traffic, we created a dedicated setup. The setup was a separate kubernetes pod running in the same namespace and cluster as the API deployments. The pod ran an open source API correctness tool, Diffy, along with copies of the old and new API services. Diffy is a service that accepts HTTP requests, and forwards them to two copies of an existing HTTP service and one copy of a candidate HTTP service.&nbsp;One huge improvement is we only need to run a single API container per pod.&nbsp;</li>
<br />
<li><a href="https://www.gamasutra.com/blogs/GafgarDavallius/20190718/346598/Satisfactory_Network_Optimizations.php">Satisfactory: Network Optimizations</a>:&nbsp;It would be a big gain to stop replicating the inventory when it&rsquo;s not viewed, which is essentially what we did, but the method of doing so was a bit complicated and required a lot of rework...Doing this also helps to reduce CPU time, as an inventory is a big state to compare, and look for changes in. If we can reduce that to a maximum of 4x the number of players it is a huge gain, compared to the hundreds, if not thousands, that would otherwise be present in a big base...There is, of course, a trade-off. As I mentioned there is a chance the inventory is not there when you first open to view it, as it has yet to arrive over the network...In this case the old system actually varied in size but landed around 48 bytes per delta, compared to the new system of just 3 bytes...On top of this, we also reduced how often a conveyor tries to send an update to just 3 times a second compared to the previous of over 20...the accuracy of item placements on the conveyors took a small hit, but we have added complicated systems in order to compensate for that...we&rsquo;ve noticed that the biggest issue for running smooth multiplayer in large factories is not the network traffic anymore, it&rsquo;s rather the general performance of the PC acting as a server.</li>
<br />
<li><a href="https://kinsta.com/blog/mariadb-vs-mysql/">MariaDB vs MySQL Differences</a>: MariaDB is fully GPL licensed while MySQL takes a dual-license approach. Each handle thread pools in a different way. MariaDB supports a lot of different storage engines. In many scenarios, MariaDB offers improved performance.</li>
<br />
<li><em>Our pySpark pipeline churns through tens of billions of rows on a daily basis.&nbsp;</em><a href="https://blog.mapbox.com/calculating-30-billion-speed-estimates-a-week-with-apache-spark-b7cd86ff10c">Calculating 30 billion speed estimates a week with Apache Spark</a>:&nbsp;Probes generated from the traces are matched against the entire world&rsquo;s road network. At the end of the matching process we are able to assign each trace an average speed, a 5 minute time bucket and a road segment. Matches on the same road that fall within the same 5 minute time bucket are aggregated to create a speed histogram. Finally, we estimate a speed for each aggregated histogram which represents our prediction of what a driver will experience on a road at a given time of the week...On a weekly basis, we match on average 2.2 billion traces to 2.3 billion roads to produce 5.4 billion matches. From the matches, we build 51 billion speed histograms to finally produce 30 billion speed estimates...The first thing we spent time on was designing the pipeline and schemas of all the different datasets it would produce. In our pipeline, each pySpark application produces a dataset persisted in a hive table readily available for a downstream application to use...Instead of having one pySpark application execute all the steps (map matching, aggregation, speed estimation, etc.) we isolated each step to its own application...We favored normalizing our tables as much as possible and getting to the final traffic profiles dataset through relationships between relevant tables...Partitioning makes querying part of the data faster and easier. We partition all the resulting datasets by both a temporal and spatial dimension.&nbsp;</li>
<br />
<li>Do not read this unless you can become comfortable with the feeling that everything you've done in your life is trivial and vainglorious.&nbsp;<a href="https://www.edge.org/conversation/neil_gershenfeld-morphogenesis-for-the-design-of-design">Morphogenesis for the Design of Design</a>:&nbsp;                                 
<ul>
<li>One of my students built and runs all the computers Facebook runs on, one of my students used to run all the computers Twitter runs on&mdash;this is because I taught them to not believe in computer science. In other words, their job is to take billions of dollars, hundreds of megawatts, and tons of mass, and make information while also not believing that the digital is abstracted from the physical. Some of the other things that have come out from this lineage were the first quantum computations, or microfluidic computing, or part of creating some of the first minimal cells.</li>
<li>The Turing machine was never meant to be an architecture. In fact, I'd argue it has a very fundamental mistake, which is that the head is distinct from the tape. And the notion that the head is distinct from the tape&mdash;meaning, persistence of tape is different from interaction&mdash;has persisted. The computer in front of Rod Brooks here is spending about half of its work just shuttling from the tape to the head and back again.</li>
<li>There&rsquo;s a whole parallel history of computing, from Maxwell to Boltzmann to Szilard to Landauer to Bennett, where you represent computation with physical resources. You don&rsquo;t pretend digital is separate from physical. Computation has physical resources. It has all sorts of opportunities, and getting that wrong leads to a number of false dichotomies that I want to talk through now. One false dichotomy is that in computer science you&rsquo;re taught many different models of computation and adherence, and there&rsquo;s a whole taxonomy of them. In physics there&rsquo;s only one model of computation: A patch of space occupies space, it takes time to transit, it stores state, and states interact&mdash;that&rsquo;s what the universe does. Anything other than that model of computation is physics and you need epicycles to maintain the fiction, and in many ways that fiction is now breaking.</li>
<li>We did a study for DARPA of what would happen if you rewrote from scratch a computer software and hardware so that you represented space and time physically.</li>
<li>One of the places that I&rsquo;ve been involved in pushing that is in exascale high-performance computing architecture, really just a fundamental do-over to make software look like hardware and not to be in an abstracted world.</li>
<li>Digital isn&rsquo;t ones and zeroes. One of the hearts of what Shannon did is threshold theorems. A threshold theorem says I can talk to you as a wave form or as a symbol. If I talk to you as a symbol, if the noise is above a threshold, you&rsquo;re guaranteed to decode it wrong; if the noise is below a threshold, for a linear increase in the physical resources representing the symbol there&rsquo;s an exponential reduction in the fidelity to decode it. That exponential scaling means unreliable devices can operate reliably.&nbsp;The real meaning of digital is that scaling property. But the scaling property isn&rsquo;t one and zero; it&rsquo;s the states in the system.&nbsp;</li>
<li>if you mix chemicals and make a chemical reaction, a yield of a part per 100 is good. When the ribosome&mdash;the molecular assembler that makes your proteins&mdash;elongates, it makes an error of one in 104. When DNA replicates, it adds one extra error-correction step, and that makes an error in 10-8, and that&rsquo;s exactly the scaling of threshold theorem. The exponential complexity that makes you possible is by error detection and correction in your construction. It&rsquo;s everything Shannon and von Neumann taught us about codes and reconstruction, but it&rsquo;s now doing it in physical systems.</li>
<li>One of the projects I&rsquo;m working on in my lab that I&rsquo;m most excited about is making an assembler that can assemble assemblers from the parts that it&rsquo;s assembling&mdash;a self-reproducing machine. What it's based on is us.&nbsp;</li>
<li>If you look at scaling coding construction by assembly, ribosomes are slow&mdash;they run at one hertz, one amino acid a second&mdash;but a cell can have a million, and you can have a trillion cells. As you were sitting here listening, you&rsquo;re placing 1018 parts a second, and it&rsquo;s because you can ring up this capacity of assembling assemblers. The heart of the project is the exponential scaling of self-reproducing assemblers.</li>
<li>As we work on the self-reproducing assembler, and writing software that looks like hardware that respects geometry, they meet in morphogenesis. This is the thing I&rsquo;m most excited about right now: the design of design. Your genome doesn&rsquo;t store anywhere that you have five fingers. It stores a developmental program, and when you run it, you get five fingers. It&rsquo;s one of the oldest parts of the genome. Hox genes are an example. It&rsquo;s essentially the only part of the genome where the spatial order matters. It gets read off as a program, and the program never represents the physical thing it&rsquo;s constructing. The morphogenes are a program that specifies morphogens that do things like climb gradients and symmetry break; it never represents the thing it&rsquo;s constructing, but the morphogens then following the morphogenes give rise to you.</li>
<li>What&rsquo;s going on in morphogenesis, in part, is compression. A billion bases can specify a trillion cells, but the more interesting thing that&rsquo;s going on is almost anything you perturb in the genome is either inconsequential or fatal. The morphogenes are a curated search space where rearranging them is interesting&mdash;you go from gills to wings to flippers. The heart of success in machine learning, however you represent it, is function representation. The real progress in machine learning is learning representation.&nbsp;</li>
<li>We're at an interesting point now where it makes as much sense to take seriously that scaling as it did to take Moore&rsquo;s law scaling in 1965 when he made his first graph. We started doing these FAB labs just as outreach for NSF, and then they went viral, and they let ordinary people go from consumers to producers. It&rsquo;s leading to very fundamental things about what is work, what is money, what is an economy, what is consumption.</li>
<li>Looking at exactly this question of how a code and a gene give rise to form. Turing and von Neumann both completely understood that the interesting place in computation is how computation becomes physical, how it becomes embodied and how you represent it. That&rsquo;s where they both ended their life. That&rsquo;s neglected in the canon of computing.</li>
<li>If I&rsquo;m doing morphogenesis with a self-reproducing system, I don&rsquo;t want to then just paste in some lines of code. The computation is part of the construction of the object. I need to represent the computation in the construction, so it forces you to be able to overlay geometry with construction.</li>
<li>Why align computer science and physical science? There are at least five reasons for me. Only lightly is it philosophical. It&rsquo;s the cracks in the matrix. The matrix is cracking. 1) The fact that whoever has their laptop open is spending about half of its resources shuttling information from memory transistors to processor transistors even though the memory transistors have the same computational power as the processor transistors is a bad legacy of the EDVAC. It&rsquo;s a bit annoying for the computer, but when you get to things like an exascale supercomputer, it breaks. You just can&rsquo;t maintain the fiction as you push the scaling. The resource in very largescale computing is maintaining the fiction so the programmers can pretend it&rsquo;s not true is getting just so painful you need to redo it. In fact, if you look down in the trenches, things like emerging ways to do very largescale GPU program are beginning to inch in that direction. So, it&rsquo;s breaking in performance.</li>
<li>&nbsp;What&rsquo;s interesting is a lot of the things that are hard&mdash;for example, in parallelization and synchronization&mdash;come for free. By representing time and space explicitly, you don&rsquo;t need to do the annoying things like thread synchronization and all the stuff that goes into parallel programming.</li>
<li>Communication degraded with distance. Along came Shannon. We now have the Internet. Computation degraded with time. The last great analog computer work was Vannevar Bush's differential analyzer. One of the students working on it was Shannon. He was so annoyed that he invented our modern digital notions in his Master&rsquo;s thesis to get over the experience of working on the differential analyzer.</li>
<li>When you merge communication with computation with fabrication, it&rsquo;s not there&rsquo;s a duopoly of communication and computation and then over here is manufacturing; they all belong together. The heart of how we work is this trinity of communication plus computation and fabrication, and for me the real point is merging them.</li>
<li>I almost took over running research at Intel. It ended up being a bad idea on both sides, but when I was talking to them about it, I was warned off. It was like the godfather: "You can do that other stuff, but don&rsquo;t you dare mess with the mainline architecture." We weren't allowed to even think about that. In defense of them, it&rsquo;s billions and billions of dollars investment. It was a good multi-decade reign. They just weren&rsquo;t able to do it.&nbsp;</li>
<li>Again, the embodiment of everything we&rsquo;re talking about, for me, is the morphogenes&mdash;the way evolution searches for design by coding for construction. And they&rsquo;re the oldest part of the genome. They were invented a very long time ago and nobody has messed with them since.</li>
<li>Get over digital and physical are separate; they can be united. Get over analog as separate from digital; there&rsquo;s a really profound place in between. We&rsquo;re at the beginning of fifty years of Moore&rsquo;s law but for the physical world. We didn&rsquo;t talk much about it, but it has the biggest impact of anything I know if anybody can make anything.</li>
</ul>
</li>
</ul>
<h2>Soft Stuff:</h2>
<ul>
<li><a href="https://github.com/paypal/hera?"><span><span>paypal</span>/<span>hera</span></span></a>&nbsp;(<a href="https://medium.com/paypal-engineering/scaling-database-access-for-100s-of-billions-of-queries-per-day-paypal-introducing-hera-e192adacda54">article</a><span>):&nbsp;Hera multiplexes connections for <span>MySQL</span> and Oracle databases. It supports <span>sharding</span> the databases for horizontal scaling. It</span>&nbsp;is a data access gateway that PayPal uses to scale database access for hundreds of billions of SQL queries per day. Additionally, HERA improves database availability through sophisticated protection mechanisms and provides application resiliency through transparent traffic failover.&nbsp;HERA is now available outside of PayPal as an Apache 2-licensed project.</li>
<li><a href="https://github.com/zerotier/lf">zerotier/lf</a>: a fully decentralized fully replicated key/value store.&nbsp;LF is built on a directed acyclic graph (DAG) data model that makes synchronization easy and allows many different security and conflict resolution strategies to be used. One way to think of LF's DAG is as a gigantic conflict-free replicated data type (CRDT).&nbsp;Proof of work is used to rate limit writes to the shared data store on public networks and as one thing that can be taken into consideration for conflict resolution.&nbsp; </li>
<li><a href="https://github.com/pahud/fargate-fast-autoscaling">pahud/fargate-fast-autoscaling</a>:&nbsp;This reference architecture demonstrates how to build AWS Fargate workload that can detect the spiky traffic in less than 10 seconds followed by an immediate horizontal autoscaling.</li>
<li><a href="https://github.com/ailidani/paxi">ailidani/paxi</a>:&nbsp;Paxi is the framework that implements WPaxos and other Paxos protocol variants. Paxi provides most of the elements that any Paxos implementation or replication protocol needs, including network communication, state machine of a key-value store, client API and multiple types of quorum systems.</li>
</ul>
<h2>Pub Stuff:</h2>
<ul>
<li>The original Libra (<a href="https://www.coindesk.com/mit-fellow-accuses-facebook-of-lifting-his-ideas-for-libra-cryptocurrency">MIT Fellow Says Facebook &lsquo;Lifted&rsquo; His Ideas for Libra Cryptocurrency</a>).&nbsp;<a href="https://royalsocietypublishing.org/doi/full/10.1098/rsos.180155">Digital trade coin: towards a more stable digital currency</a>.&nbsp;</li>
<li><a href="goo.gl/uEoAh4">Secure Firmware Development Best Practices</a>: This document was produced by the Cloud Security Industry Summit (CSIS). CSIS is a group of Cloud Service Providers, with a mission to align on a vision and approach to developing best-of-breed security solutions. The group includes members from top Cloud Service Providers, partnering as an industry team and evolving a coordinated approach for improving cloud security from component to system to solution. Intel facilitates the group.</li>
<li><a href="http://muratbuffalo.blogspot.com/2019/07/dissecting-performance-bottlenecks-of.html">Dissecting performance bottlenecks of strongly-consistent replication protocols</a>:&nbsp;In this work, we study the performance of Paxos protocols. We take a two-pronged approach, and provide both analytic and empirical evaluations which corroborate and complement each other. We then distill these results to give back-of-the-envelope formulas for estimating the throughput scalability of different Paxos protocols.</li>
</ul>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/highscalability"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Todd Hoff</a></span> |  <span class="post-comments"><a href="/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />Post a Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2019%2F8%2F2%2Fstuff-the-internet-says-on-scalability-for-august-2nd-2019.html','Stuff%20The%20Internet%20Says%20On%20Scalability%20For%20August%202nd%2C%202019');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/36205443"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/hot-links"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />hot links</a></span></span>  <span class="post-snippet-1"><iframe src="//www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="//twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html" data-text="Stuff The Internet Says On Scalability For August 2nd,&nbsp;2019" data-count="horizontal">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments </h3>

      
        
          <div class="text">There are no comments for this journal entry.  To create a new comment, use the form below.</div>

        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=36205443"> 

    
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2018, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>