<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- highscalability -->

  <link rel="shortcut icon" href="/favicon.png" type="image/png" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=512250&amp;RK=1552578797277&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://feeds.feedburner.com/HighScalability" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "High Scalability"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "4867632"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://highscalability.com/blog/2019/9/16/managing-high-availability-in-postgresql-part-iii-patroni.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://www.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "426227";

    

    

    

  // ]]>
  </script>

      <title>Managing High Availability in PostgreSQL – Part III:&nbsp;Patroni - High Scalability - </title>
    <meta property="og:title" content="Managing High Availability in PostgreSQL – Part III:&nbsp;Patroni - High Scalability - " /> 
  

      <meta property="og:description" content=" 

 In our previous blog posts, we discussed the capabilities and functioning of PostgreSQL Automat..." />
  

  
      <meta property="og:image" content="https://scalegrid.io/blog/wp-content/uploads/2019/08/Managing-High-Availability-in-PostgreSQL-Part-3-Patroni-ScaleGrid-Blog.png?__SQUARESPACE_CACHEVERSION=1566500919113" />
  

  <!-- End Heading -->

  

  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage4867632"   class="objectId36212513"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fblog%2F2019%2F9%2F16%2Fmanaging-high-availability-in-postgresql-part-iii-patroni.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper4867632">

    <div id="navigationTop-moduleContent4867632">

              <a id="navigationTop-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5498762">

    <div id="navigationTop-moduleContent5498762">

              <a id="navigationTop-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper15178301">

    <div id="navigationTop-moduleContent15178301">

              <a id="navigationTop-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850438">

    <div id="navigationTop-moduleContent4850438">

              <a id="navigationTop-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper10576114">

    <div id="navigationTop-moduleContent10576114">

              <a id="navigationTop-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19697312">

    <div id="navigationTop-moduleContent19697312">

              <a id="navigationTop-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850431">

    <div id="navigationTop-moduleContent4850431">

              <a id="navigationTop-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850400">

    <div id="navigationTop-moduleContent4850400">

              <a id="navigationTop-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4850388">

    <div id="navigationTop-moduleContent4850388">

              <a id="navigationTop-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper5861345">

    <div id="navigationTop-moduleContent5861345">

              <a id="navigationTop-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971493">

    <div id="navigationTop-moduleContent18971493">

              <a id="navigationTop-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper18971509">

    <div id="navigationTop-moduleContent18971509">

              <a id="navigationTop-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19028422">

    <div id="navigationTop-moduleContent19028422">

              <a id="navigationTop-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper4847294">

    <div id="navigationTop-moduleContent4847294">

              <a id="navigationTop-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper19700860">

    <div id="navigationTop-moduleContent19700860">

              <a id="navigationTop-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://highscalability.com/"><img id="banner" src="/storage/HSBannerTrebuchet.jpg" alt="High Scalability" title="High Scalability"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent2191792" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper4867632">

    <div id="navigationBottom-moduleContent4867632">

              <a id="navigationBottom-moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5498762">

    <div id="navigationBottom-moduleContent5498762">

              <a id="navigationBottom-moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper15178301">

    <div id="navigationBottom-moduleContent15178301">

              <a id="navigationBottom-moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850438">

    <div id="navigationBottom-moduleContent4850438">

              <a id="navigationBottom-moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper10576114">

    <div id="navigationBottom-moduleContent10576114">

              <a id="navigationBottom-moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19697312">

    <div id="navigationBottom-moduleContent19697312">

              <a id="navigationBottom-moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850431">

    <div id="navigationBottom-moduleContent4850431">

              <a id="navigationBottom-moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850400">

    <div id="navigationBottom-moduleContent4850400">

              <a id="navigationBottom-moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4850388">

    <div id="navigationBottom-moduleContent4850388">

              <a id="navigationBottom-moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper5861345">

    <div id="navigationBottom-moduleContent5861345">

              <a id="navigationBottom-moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971493">

    <div id="navigationBottom-moduleContent18971493">

              <a id="navigationBottom-moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper18971509">

    <div id="navigationBottom-moduleContent18971509">

              <a id="navigationBottom-moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19028422">

    <div id="navigationBottom-moduleContent19028422">

              <a id="navigationBottom-moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper4847294">

    <div id="navigationBottom-moduleContent4847294">

              <a id="navigationBottom-moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper19700860">

    <div id="navigationBottom-moduleContent19700860">

              <a id="navigationBottom-moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent2251797" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4876569" class="widget-wrapper  widget-type-search"><div id="moduleContent4876569">


<!-- <form method="get" action="/display/Search">
	<div class="search-form-pt-wrapper">
	  <div class="search-form-pt">
	    <span class="queryFieldWrapper"><input type="text" class="text queryField" name="searchQuery" value=""/></span>
	    <span class="queryButtonWrapper"><input type="submit" class="button queryButton" value="&raquo;"/></span>
	    <input type="hidden" name="moduleId" value="4876569"/>
	    <br class="clearer"/>
	  </div>
	</div>
</form> -->

<form method="get" action="/display/Search">
	<input type="hidden" name="moduleId" value="4876569"/>
	<table class="search-form-pt-wrapper search-form-table" border="0" cellpadding="0" cellspacing="0">
		<tr class="search-form-pt search-form-row">
			<td class="queryFieldCell search-form-cell">
				<span class="queryFieldWrapper">
					<input type="text" class="text queryField" name="searchQuery" value=""/>
				</span>
			</td>
			<td class="queryButtonCell search-form-cell">
				<span class="queryButtonWrapper">
					<input type="submit" class="button queryButton" value="&rarr;"/>
				</span>
			</td>
		</tr>
	</table> 
</form></div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191792" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Top</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper4867632">

    <div id="moduleContent4867632">

              <a id="moduleLink4867632" class=" " href="/" ><span>Home</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5498762">

    <div id="moduleContent5498762">

              <a id="moduleLink5498762" class="offsite-link " href="https://smile.amazon.com/Explain-Cloud-Like-Im-10-ebook/dp/B0765C4SNR" onclick="this.target='new';"><span>Explain the Cloud Like I&#39;m 10</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper15178301">

    <div id="moduleContent15178301">

              <a id="moduleLink15178301" class=" " href="/all-time-favorites/" ><span>All Time Favorites</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850438">

    <div id="moduleContent4850438">

              <a id="moduleLink4850438" class=" " href="/blog/category/example" ><span>Real Life Architectures</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper10576114">

    <div id="moduleContent10576114">

              <a id="moduleLink10576114" class=" " href="http://highscalability.squarespace.com/blog/category/strategy" ><span>Strategies</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19697312">

    <div id="moduleContent19697312">

              <a id="moduleLink19697312" class="offsite-link " href="https://www.patreon.com/toddhoff" onclick="this.target='new';"><span>Support in Patreon</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850431">

    <div id="moduleContent4850431">

              <a id="moduleLink4850431" class=" " href="/advertising/" ><span>Advertising</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850400">

    <div id="moduleContent4850400">

              <a id="moduleLink4850400" class=" " href="/start-here/" ><span>Start Here</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4850388">

    <div id="moduleContent4850388">

              <a id="moduleLink4850388" class=" " href="/contact/" ><span>contact</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper5861345">

    <div id="moduleContent5861345">

              <a id="moduleLink5861345" class=" " href="http://feeds.feedburner.com/HighScalability" ><span>RSS</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971493">

    <div id="moduleContent18971493">

              <a id="moduleLink18971493" class=" " href="https://twitter.com/highscal" ><span>Twitter</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper18971509">

    <div id="moduleContent18971509">

              <a id="moduleLink18971509" class=" " href="http://www.facebook.com/pages/Highscalability/441249225918692" ><span>Facebook</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19028422">

    <div id="moduleContent19028422">

              <a id="moduleLink19028422" class=" " href="https://plus.google.com/b/116966782604206517628/116966782604206517628/posts" ><span>G+</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4847294">

    <div id="moduleContent4847294">

              <a id="moduleLink4847294" class=" " href="/all-posts/" ><span>All Posts</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper19700860">

    <div id="moduleContent19700860">

              <a id="moduleLink19700860" class="offsite-link " href="https://www.amazon.com/shop/highscal" onclick="this.target='new';"><span>Amazon Store</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248744" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Recent Posts</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867742" class="widget-wrapper  widget-type-journalarchive"><div id="moduleContent4867742">







  <ul class="archive-item-list-pt">
     <li><a href="/blog/2019/9/17/sponsored-post-educative-pa-file-sight-etleap-perfops-inmemo.html">Sponsored Post: Educative, PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/9/16/managing-high-availability-in-postgresql-part-iii-patroni.html">Managing High Availability in PostgreSQL – Part III: Patroni</a></li>  <li><a href="/blog/2019/9/6/stuff-the-internet-says-on-scalability-for-september-6th-201.html">Stuff The Internet Says On Scalability For September 6th, 2019</a></li>  <li><a href="/blog/2019/9/3/top-redis-use-cases-by-core-data-structure-types.html">Top Redis Use Cases by Core Data Structure Types</a></li>  <li><a href="/blog/2019/9/3/sponsored-post-educative-pa-file-sight-etleap-perfops-inmemo.html">Sponsored Post: Educative, PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/8/23/stuff-the-internet-says-on-scalability-for-august-23rd-2019.html">Stuff The Internet Says On Scalability For August 23rd, 2019</a></li>  <li><a href="/blog/2019/8/20/sponsored-post-educative-pa-file-sight-etleap-perfops-inmemo.html">Sponsored Post: Educative, PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/8/16/stuff-the-internet-says-on-scalability-for-august-16th-2019.html">Stuff The Internet Says On Scalability For August 16th, 2019</a></li>  <li><a href="/blog/2019/8/6/sponsored-post-educative-pa-file-sight-etleap-perfops-inmemo.html">Sponsored Post: Educative, PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a></li>  <li><a href="/blog/2019/8/2/stuff-the-internet-says-on-scalability-for-august-2nd-2019.html">Stuff The Internet Says On Scalability For August 2nd, 2019</a></li> 
  </ul>



</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

    <div id="sectionContent2249261" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4869210" class="widget-wrapper  widget-type-page"><div id="moduleContent4869210">





  <center>
  
  <a href="https://www.educative.io/collection/5668639101419520/5649050225344512 ">
     <img src="/storage/grokking-sdi-highscalability.png">
  </a>
  
  
  <a href="https://jobs.lever.co/close.io/38d0c4ac-c3eb-47e9-a49e-4611f96eef8d?lever-origin=applied&lever-source%5B%5D=highscalability">
     <img src="/storage/close-sre.png">
  </a>
  
  <a href="https://www.poweradmin.com/products/file-sight/product-information/landing/?ref=highscalability&utm_source=highscalability">
     <img src="/storage/file-sight-ransomware-protection.png">
  </a>
  
  <a href="https://fauna.com?utm_medium=referral&utm_source=HighScalabilityBlog">
     <img src="/storage/FaunaDB_125x12505x.png">
  </a>
  
  <a href="https://perfops.net?utm_source=highscalability&utm_medium=banner_125_125&utm_campaign=global_flexible_load_balancers">
     <img src="/storage/125x125-2.png">
  </a>
  
  <a href="https://getstream.io/chat/">
     <img width="125" height="125" src="/storage/stream.png">
  </a>
  
  <a href="https://triplebyte.com/?ref=hs_apr18_c1">
    <img src="/storage/triplebyte125.png">
  </a>
  
  
  <a href="/advertising">advertise</A>
  </center>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2191793" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <ul class="content-navigation">
  <li class="module   " id="moduleContentWrapper4708561">

    <div id="moduleContent4708561">

              <a id="moduleLink4708561" class=" " href="/login/?returnUrl=%2Fblog%2F2019%2F9%2F16%2Fmanaging-high-availability-in-postgresql-part-iii-patroni.html%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%3A%20HighScalability%20%28High%20Scalability%29" ><span>Login</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper4869034">

    <div id="moduleContent4869034">

              <a id="moduleLink4869034" class=" " href="/register/" ><span>Register</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent2248734" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper4867711" class="widget-wrapper  widget-type-rss-syndicate"><div id="moduleContent4867711">



  <ul class="feed-list-inline">
    
          <li><a href="http://feeds.feedburner.com/HighScalability" class="feed-link">High Scalability RSS</a></li>
        
          <li><a href="http://highscalability.com/blog/rss-comments.xml" class="feed-link">High Scalability Comments RSS</a></li>
        
  </ul>

</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
      
  <div class="journal-entry-navigation">

    
       <a class="journal-entry-navigation-prev" href="/blog/2019/9/17/sponsored-post-educative-pa-file-sight-etleap-perfops-inmemo.html">&laquo; Sponsored Post: Educative, PA File Sight, Etleap, PerfOps, InMemory.Net, Triplebyte, Stream, Scalyr</a> | 
      <a class="journal-entry-navigation-main" href="/blog/">Main</a>
       | <a class="journal-entry-navigation-next" href="/blog/2019/9/6/stuff-the-internet-says-on-scalability-for-september-6th-201.html">Stuff The Internet Says On Scalability For September 6th, 2019 &raquo;</a> 

    

  </div>


  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-kristimke category-appliction-monitoring category-clustering category-devops">
<div id="item36212513" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Monday</span></div><div class="journal-entry-float-date"><span class="month">Sep</span><span class="date">16</span><span class="year">2019</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/blog/2019/9/16/managing-high-availability-in-postgresql-part-iii-patroni.html">Managing High Availability in PostgreSQL – Part III:&nbsp;Patroni</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="smalllight" src="/universal/images/transparent.png" />Monday, September 16, 2019 at 12:31PM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p><a href="https://scalegrid.io/blog/managing-high-availability-in-postgresql-part-3/"><img src="https://scalegrid.io/blog/wp-content/uploads/2019/08/Managing-High-Availability-in-PostgreSQL-Part-3-Patroni-ScaleGrid-Blog.png?__SQUARESPACE_CACHEVERSION=1566500919113" alt="Managing High Availability in PostgreSQL &ndash; Part III: Patroni - ScaleGrid Blog" width="100%" height="auto" /></a></p>
<p style="text-align: justify; padding-bottom: 15px;">In our previous blog posts, we discussed the capabilities and functioning of PostgreSQL Automatic Failover (PAF) by Cluster Labs and Replication Manager (repmgr) by 2ndQuadrant. In the final post of this series, we will review the last solution, Patroni by Zalando, and compare all three at the end so you can determine which high availability framework is best for your <a style="color: #2da964;" href="https://scalegrid.io/postgresql.html" target="_blank">PostgreSQL hosting</a> deployment.</p>
<ul>
<li style="padding-bottom: 10px;"><a style="color: #2da964;" href="https://scalegrid.io/blog/managing-high-availability-in-postgresql-part-1/" target="_blank">Managing High Availability in PostgreSQL &ndash; Part I: PostgreSQL Automatic Failover</a></li>
<li style="padding-bottom: 10px;"><a style="color: #2da964;" href="https://scalegrid.io/blog/managing-high-availability-in-postgresql-part-2/" target="_blank">Managing High Availability in PostgreSQL &ndash; Part II: Replication Manager</a></li>
<li><a style="color: #2da964;" href="https://scalegrid.io/blog/managing-high-availability-in-postgresql-part-3/" target="_blank">Managing High Availability in PostgreSQL &ndash; Part III: Patroni</a></li>
</ul>
<h2 style="padding-top: 15px;">Patroni for PostgreSQL</h2>
<p style="text-align: justify;"><a style="color: #2da964;" href="https://patroni.readthedocs.io/en/latest/" target="_blank">Patroni</a> originated as a fork of Governor, a project from Compose. It is an open-source tool suite, written in Python, for managing high availability of PostgreSQL clusters. Instead of building its own consistency protocol, Patroni smartly leverages the consistency model provided by a <a style="color: #2da964;" href="https://patroni.readthedocs.io/en/latest/dynamic_configuration.html" target="_blank">Distributed Configuration Store</a> (DCS). It also supports other DCS solutions like Zookeeper, etcd, Consul and Kubernetes.</p>
<p style="text-align: justify;">Patroni ensures the end-to-end setup of PostgreSQL HA clusters, including streaming replication. It supports various ways for creating a standby node, and works like a template that can be customized&nbsp;to your needs.</p>
<p style="text-align: justify;">This feature-rich tool&nbsp;exposes its functionality via REST APIs and also via a command line utility called <a style="color: #2da964;" href="https://github.com/zalando/patroni/blob/master/patronictl.py" target="_blank">patronictl</a>. It supports integration with HAProxy by using its health check APIs to handle load balancing.</p>
<p style="text-align: justify;">Patroni also&nbsp;supports event notification with the help of callbacks, which are scripts triggered by certain actions. It enables users to perform any maintenance actions by providing pause/resume functionality. The Watchdog support feature makes the framework even more robust.</p>
<h2 style="padding-top: 15px;">How it Works</h2>
<p style="text-align: justify;">Initially, PostgreSQL and Patroni binaries needs to be installed.&nbsp;Once this is done, you will also need to setup a HA DCS configuration. All the necessary configurations to bootstrap the cluster needs to be specified in the yaml configuration file and Patroni will use this file for initialization. On the first node, Patroni initializes the database, obtains the leader lock from DCS, and ensures the node is being run as the master.</p>
<p style="text-align: justify;">The next step is adding standby nodes, for which Patroni provides multiple options. By default, Patroni uses <a style="color: #2da964;" href="https://www.postgresql.org/docs/10/app-pgbasebackup.html" target="_blank">pg_basebackup</a> to create the standby node, and also supports custom methods like WAL-E, pgBackRest, Barman and others for the standby node creation. Patroni makes it very simple to add a standby node, and handles all the bootstrapping tasks and setting up of your streaming replication.</p>
<p style="text-align: justify;">Once&nbsp;your cluster setup is complete, Patroni will actively monitor the cluster and ensure it's in a healthy state. The master node renews the leader lock every ttl second(s) (default: 30 seconds). When the master node fails to renew the leader lock, Patroni triggers an election, and the node which will obtain the leader lock will be elected as the new master.</p>
<h3 style="padding-top: 15px;">How Does it Handle the Split Brain Scenario?</h3>
<p style="text-align: justify;">In a distributed system, consensus plays an important role in determining consistency, and Patroni uses DCS to attain consensus. Only the node that holds the leader lock can be the master and the leader lock is obtained via DCS. If the master node doesn&rsquo;t hold the leader lock, then it will be demoted immediately by Patroni to run as a standby. This way, at any point in time, there can only be one master running in the system.</p>
<h3 style="padding-top: 15px;">Are There Any Setup Requirements?</h3>
<ul>
<li>Patroni needs <a style="color: #2da964;" href="https://www.python.org/downloads/" target="_blank">python 2.7</a> and above.</li>
<li>The DCS and its specific python module must be installed. For test purposes, DCS can be installed on same nodes running PostgreSQL. However, in production, DCS must be installed on separate nodes.</li>
<li>The yaml configuration file must be present&nbsp;using these high level configuration settings:         
<table class="table table-bordered" style="height: auto; margin-top: 20px;" width="100%">
<tbody>
<tr>
<td style="padding: 20px 20px 10px; width: 100%; vertical-align: middle; background-color: #d9fce9;">
<p style="text-align: justify; padding-bottom: 6px;"><strong>Global/Universal</strong><br /> This includes configuration such as the name of the host (name) which needs to be unique for the cluster, the name of the cluster (scope) and path for storing config in DCS (namespace).</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>Log</strong><br /> Patroni-specific log settings including level, format, file_num, file_size etc.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>Bootstrap configuration</strong><br /> This is the global configuration for a cluster that will be written to DCS. These configuration parameters can be changed with the help of Patroni APIs or directly in DCS.The bootstrap configuration includes standby creation methods, initdb parameters, post initialization script etc. It also contains timeouts configuration, parameters to decide the usage of PostgreSQL features like replication slots, synchronous mode etc.This section will be written into /&lt;namespace&gt;/&lt;scope&gt;/config of a given configuration store after the initializing of new cluster.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>PostgreSQL</strong><br /> This section contains the PostgreSQL-specific parameters like authentication, directory paths for data, binary and config, listen ip address etc.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>REST API</strong><br /> This section includes the Patroni-specific configuration related to REST API's such as listen address, authentication, SSL etc.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>Consul</strong><br /> Settings specific to Consul DCS.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>Etcd</strong><br /> Settings specific to Etcd DCS.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>Exhibitor</strong><br /> Settings specific to Exhibitor DCS.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>Kubernetes</strong><br /> Settings specific to Kubernetes DCS.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>ZooKeeper</strong><br /> Settings specific to ZooKeeper DCS.</p>
<p style="text-align: justify; padding-bottom: 6px;"><strong>Watchdog</strong><br /> Settings specific to Watchdog.</p>
</td>
</tr>
</tbody>
</table>
</li>
</ul>
<h2 style="padding-top: 15px;">Patroni Pros</h2>
<ul>
<li>Patroni enables end-to-end setup up of the cluster.</li>
<li>Supports REST APIs and HAproxy integration.</li>
<li>Supports event notifications via callbacks scripts triggered by certain actions.</li>
<li>Leverages DCS for consensus.</li>
</ul>
<h2 style="padding-top: 15px;">Patroni Cons</h2>
<ul>
<li>Patroni will not detect the misconfiguration of a standby with an unknown or non-existent node in recovery configuration. The node will be shown as a slave even if the standby is running without connecting to the master/cascading standby node.</li>
<li>User needs to handle setup, management, and upgrade of the DCS software.</li>
<li>Requires multiple ports to be open for components communication:         
<ul>
<li>REST API port for Patroni</li>
<li>Minimum 2 ports for DCS</li>
</ul>
</li>
</ul>
<h2 style="padding-top: 15px;">High Availability Test Scenarios</h2>
<p style="text-align: justify;">We conducted a few tests on PostgreSQL HA management using Patroni. All of these tests were&nbsp;performed while the application was running and inserting data to the PostgreSQL database. The application was written using PostgreSQL Java <a style="color: #2da964;" href="https://jdbc.postgresql.org/" target="_blank">JDBC Driver</a> leveraging the connection failover capability.</p>
<h3 style="padding-top: 15px;">Standby Server Tests</h3>
<table class="table table-bordered">
<tbody>
<tr>
<th style="width: 5%; vertical-align: middle; background-color: #d9fce9;">Sl. No</th> <th style="width: 25%; vertical-align: middle; background-color: #d9fce9;">Test Scenario</th> <th style="width: 70%; vertical-align: middle; background-color: #d9fce9;">Observation</th>
</tr>
<tr>
<td style="vertical-align: middle;">1</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Kill the PostgreSQL process</td>
<td style="vertical-align: middle;">Patroni brought the PostgreSQL process back to running state.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle;">2</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Stop the PostgreSQL process</td>
<td style="vertical-align: middle;">Patroni brought the PostgreSQL process back to running state.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle;">3</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Reboot the server</td>
<td style="vertical-align: middle;">Patroni needs to be started after reboot, unless configured to not start on reboot. Once Patroni was started, it started the PostgreSQL process and setup the standby configuration.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle;">4</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Stop the Patroni process</td>
<td style="vertical-align: middle;">
<ul>
<li>It did not stop the PostgreSQL process.</li>
<li><em>patronictl list</em> did not display this server.</li>
<li>There was no disruption of the writer application.</li>
</ul>
So, essentially, you need to monitor the health of the Patroni process - otherwise it will lead to issues down the line.</td>
</tr>
</tbody>
</table>
<h3 style="padding-top: 15px;">Master/Primary Server Tests</h3>
<table class="table table-bordered">
<tbody>
<tr>
<td style="width: 5%; vertical-align: middle; background-color: #d9fce9;"><strong>Sl. No</strong></td>
<td style="width: 25%; vertical-align: middle; background-color: #d9fce9;"><strong>Test Scenario</strong></td>
<td style="width: 70%; vertical-align: middle; background-color: #d9fce9;"><strong>Observation</strong></td>
</tr>
<tr>
<td style="vertical-align: middle;">1</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Kill the PostgreSQL process</td>
<td style="vertical-align: middle;">Patroni brought the PostgreSQL process back to running state. Patroni running on that node had primary lock and so the election was not triggered.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle;">2</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Stop the PostgreSQL process and bring it back immediately after health check expiry</td>
<td style="vertical-align: middle;">Patroni brought the PostgreSQL process back to running state. Patroni running on that node had primary lock and so the election was not triggered.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle;">3</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Reboot the server</td>
<td style="vertical-align: middle;">Failover happened and one of the standby servers was elected as the new master after obtaining the lock. When Patroni was started on the old master, it brought back the old master up and performed pg_rewind and started following the new master.T         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle;">4</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Stop/Kill the Patroni process</td>
<td style="vertical-align: middle;">
<ul>
<li>One of the standby servers acquired the DCS lock and became the master by promoting itself.</li>
<li>The old master was still running and it led to multi-master scenario. The application was still writing to the old master.</li>
<li>Once Patroni was started on the old master, it rewound the old master (<strong>use_pg_rewind</strong> was set to true) to the new master timeline and lsn and started following the new master.</li>
</ul>
As you can see above, it is very important to monitor the health of the Patroni process on the master. Failure to do so can lead to a multi-master scenario and potential data loss.</td>
</tr>
</tbody>
</table>
<h3 style="padding-top: 15px;">Network Isolation Tests</h3>
<table class="table table-bordered">
<tbody>
<tr>
<td style="width: 5%; vertical-align: middle; background-color: #d9fce9;"><strong>Sl. No</strong></td>
<td style="width: 25%; vertical-align: middle; background-color: #d9fce9;"><strong>Test Scenario</strong></td>
<td style="width: 70%; vertical-align: middle; background-color: #d9fce9;"><strong>Observation</strong></td>
</tr>
<tr>
<td style="vertical-align: middle;">1</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Network-isolate the master server from other servers</td>
<td style="vertical-align: middle;">DCS communication was blocked for master node.         
<ul>
<li>PostgreSQL was demoted on the master server.</li>
<li>A new master was elected in the majority partition.</li>
<li>There was a downtime in the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle;">2</td>
<td style="vertical-align: middle; background-color: #f5f5f5;">Network-isolate the standby server from other servers</td>
<td style="vertical-align: middle;">DCS communication was blocked for the standby node.         
<ul>
<li>The PostgreSQL service was running, however, the node was not considered for elections.</li>
<li>There was no disruption in the writer application.</li>
</ul>
</td>
</tr>
</tbody>
</table>
<h2 style="padding-top: 15px;">What's the Best PostgreSQL HA Framework?</h2>
<p style="text-align: justify;">Patroni is a valuable tool for PostgreSQL database administrators (DBAs), as it performs end-to-end setup and monitoring of a PostgreSQL cluster. The flexibility of choosing DCS and standby creation is an advantage to the end user, as they can choose the method they are comfortable with.</p>
<p style="text-align: justify;">REST APIs, HaProxy integration, Watchdog support, callbacks and its feature-rich management makes Patroni the best solution for PostgreSQL HA management.</p>
<h2 style="padding-top: 15px;">PostgreSQL HA Framework Testing: PAF vs. repmgr vs. Patroni</h2>
<p style="text-align: justify;">Included below is a comprehensive table detailing the results of all the tests we have performed on all three frameworks - PostgreSQL Automatic Failover (PAF), Replication Manager (repmgr) and Patroni.</p>
<h3 style="padding-top: 15px;">Standby Server Tests</h3>
<table class="table table-bordered">
<tbody>
<tr>
<th style="width: 13%; vertical-align: middle; background-color: #d9fce9;">Test Scenario</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">PostgreSQL Automatic Failover (PAF)</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">Replication Manager (repmgr)</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">Patroni</th>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Kill the PostgreSQL process</td>
<td style="vertical-align: middle; font-size: 15px;">Pacemaker brought the PostgreSQL process back to running state.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Standby server was marked as failed. Manual intervention was required to start the PostgreSQL process again.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Patroni brought the PostgreSQL process back to running state.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Stop the PostgreSQL process</td>
<td style="vertical-align: middle; font-size: 15px;">Pacemaker brought the PostgreSQL process back to running state.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Standby server was marked as failed. Manual intervention was required to start the PostgreSQL process again.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Patroni brought the PostgreSQL process back to running state.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Reboot the server</td>
<td style="vertical-align: middle; font-size: 15px;">Standby server was marked offline initially. Once the server came up after reboot, PostgreSQL was started by Pacemaker and the server was marked as online. If fencing was enabled then node wouldn&rsquo;t have been added automatically to cluster.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Standby server was marked as failed. Once the server came up after reboot, PostgreSQL was started manually and server was marked as running.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Patroni needs to be started after reboot, unless configured to not start on reboot. Once Patroni was started, it started the PostgreSQL process and setup the standby configuration.         
<ul>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Stop the framework agent process</td>
<td style="vertical-align: middle; font-size: 15px;">Agent: pacemaker         
<ul>
<li>The PostgreSQL process was stopped and was marked offline.</li>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Agent: repmgrd         
<ul>
<li>The standby server will not be part of automated failover situation.</li>
<li>PostgreSQL service was found to be running.</li>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Agent: patroni         
<ul>
<li>It did not stop the PostgreSQL process.</li>
<li><em>patronictl list</em> did not display this server.</li>
<li>There was no disruption of the writer application.</li>
</ul>
</td>
</tr>
</tbody>
</table>
<h3 style="padding-top: 15px;">Master/Primary Server Tests</h3>
<table class="table table-bordered">
<tbody>
<tr>
<th style="width: 13%; vertical-align: middle; background-color: #d9fce9;">Test Scenario</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">PostgreSQL Automatic Failover (PAF)</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">Replication Manager (repmgr)</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">Patroni</th>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Kill the PostgreSQL process</td>
<td style="vertical-align: middle; font-size: 15px;">Pacemaker brought the PostgreSQL process back to running state. Primary got recovered within the threshold time and hence election was not triggered.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">repmgrd started health check for primary server connection on all standby servers for a fixed interval. When all retries failed, an election was triggered on all the standby servers. As a result of the election, the standby which had the latest received LSN got promoted. The standby servers which lost the election will wait for the notification from the new master node and will follow it once they receive the notification.Manual intervention was required to start the postgreSQL process again.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Patroni brought the PostgreSQL process back to running state. Patroni running on that node had primary lock and hence election was not triggered.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Stop the PostgreSQL process and bring it back immediately after health check expiry</td>
<td style="vertical-align: middle; font-size: 15px;">Pacemaker brought the PostgreSQL process back to running state. Primary got recovered within the threshold time and hence election was not triggered.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">repmgrd started health check for primary server connections on all standby servers for a fixed interval. When all the retries failed, an election was triggered on all the standby nodes. However, the newly elected master didn&rsquo;t notify the existing standby servers since the old master was back.Cluster was left in an indeterminate state and manual intervention was required.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Patroni brought the PostgreSQL process back to running state. Patroni running on that node had primary lock and hence election was not triggered.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Reboot the server</td>
<td style="vertical-align: middle; font-size: 15px;">Election was triggered by Pacemaker after the threshold time for which master was not available. The most eligible standby server was promoted as the new master. Once the old master came up after reboot, it was added back to the cluster as a standby. If fencing was enabled, then node wouldn&rsquo;t have been added automatically to cluster.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">repmgrd started election when master connection health check failed on all standby servers. The eligible standby was promoted. When this server came back, it didn&rsquo;t join the cluster and was marked failed. repmgr node rejoin command was run to add the server back to the cluster.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Failover happened and one of the standby servers was elected as the new master after obtaining the lock. When Patroni was started on the old master, it brought back the old master up and performed pg_rewind and started following the new master.         
<ul>
<li>There was downtime in the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Stop the framework agent process</td>
<td style="vertical-align: middle; font-size: 15px;">Agent: pacemaker         
<ul>
<li>The PostgreSQL process was stopped and it was marked offline.</li>
<li>Election was triggered and new master was elected.</li>
<li>There was downtime in writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Agent: repmgrd         
<ul>
<li>The primary server will not be part of the automated failover situation.</li>
<li>PostgreSQL service was found to be running.</li>
<li>There was no disruption in writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">Agent: patroni         
<ul>
<li>One of the standby servers acquired the DCS lock and became the master by promoting itself.</li>
<li>The old master was still running and it led to multi-master scenario. The application was still writing to the old master.</li>
<li>Once Patroni was started on the old master, it rewound the old master (<strong>use_pg_rewind</strong> was set to true) to the new master timeline and lsn and started following the new master.</li>
</ul>
</td>
</tr>
</tbody>
</table>
<h3 style="padding-top: 15px;">Network Isolation Tests</h3>
<table class="table table-bordered">
<tbody>
<tr>
<th style="width: 13%; vertical-align: middle; background-color: #d9fce9;">Test Scenario</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">PostgreSQL Automatic Failover (PAF)</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">Replication Manager (repmgr)</th> <th style="width: 29%; vertical-align: middle; background-color: #d9fce9;">Patroni</th>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Network isolate the master server from other servers (split brain scenario)</td>
<td style="vertical-align: middle; font-size: 15px;">Corosync traffic was blocked on the master server.         
<ul>
<li>PostgreSQL service was turned off and master server was marked offline due to quorum policy.</li>
<li>A new master was elected in the majority partition.</li>
<li>There was a downtime in the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">All servers have the same value for <em>location</em> in repmgr configuration:         
<ul>
<li>repmgrd started election when master connection health check failed on all standby servers.</li>
<li>The eligible standby was promoted, but the PostgreSQL process was still running on the old master node.</li>
<li>There were two nodes running as master. Manual intervention was required after the network isolation was corrected.</li>
</ul>
The standby servers have the same value for <em>location</em> but the primary had a different value for <em>location</em> in repmgr configuration:         
<ul>
<li>repmgrd started election when master connection health check failed on all standby servers.</li>
<li>But, there was no new master elected since the standby servers had <em>location</em> different from that of the primary.</li>
<li>repmgrd went into degrade monitoring mode. PostgreSQL was running on all the nodes and there was only one master in the cluster.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">DCS communication was blocked for master node.         
<ul>
<li>PostgreSQL was demoted on the master server.</li>
<li>A new master was elected in the majority partition.</li>
<li>There was a downtime in the writer application.</li>
</ul>
</td>
</tr>
<tr>
<td style="vertical-align: middle; background-color: #f5f5f5;">Network-isolate the standby server from other servers</td>
<td style="vertical-align: middle; font-size: 15px;">Corosync traffic was blocked on the standby server.         
<ul>
<li>The server was marked offline and PostgreSQL service was turned off due to quorum policy.</li>
<li>There was no disruption in the writer application.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">
<ul>
<li>repmgrd went into degrade monitoring mode.</li>
<li>The PostgreSQL process was still running on the standby node.</li>
<li>Manual intervention was required after the network isolation was corrected.</li>
</ul>
</td>
<td style="vertical-align: middle; font-size: 15px;">DCS communication was blocked for the standby node.         
<ul>
<li>The PostgreSQL service was running, however, the node was not considered for elections.</li>
<li>There was no disruption in the writer application.</li>
</ul>
</td>
</tr>
</tbody>
</table>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/blog/author/kristimke"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="smalllight" src="/universal/images/transparent.png" />Kristi Anderson</a></span> |  <span class="post-comments"><a href="/blog/2019/9/16/managing-high-availability-in-postgresql-part-iii-patroni.html#comments"> <img title="Comment" alt="Comment" class="inline-icon comment-icon" rel="smalllight" src="/universal/images/transparent.png" />Post a Comment</a></span> |  <span class="permalink-item"><a class="permalink" href="/blog/2019/9/16/managing-high-availability-in-postgresql-part-iii-patroni.html"> <img title="Permalink" alt="Permalink" class="inline-icon permalink-icon" rel="smalllight" src="/universal/images/transparent.png" />Permalink </a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fblog%2F2019%2F9%2F16%2Fmanaging-high-availability-in-postgresql-part-iii-patroni.html','Managing%20High%20Availability%20in%20PostgreSQL%20%E2%80%93%20Part%20III%3A%20Patroni');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="smalllight" src="/universal/images/transparent.png" />Share Article </a></span> <span class="print-item"><a href="/blog/2019/9/16/managing-high-availability-in-postgresql-part-iii-patroni.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="smalllight" src="/universal/images/transparent.png" />Print Article </a></span> <span class="email-item"><a href="/blog/recommend/36212513"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="smalllight" src="/universal/images/transparent.png" />Email Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"><span class="tagged-with">tagged <span class="tag-element"><a rel="tag" href="/blog/tag/dba"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />DBA</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/patroni"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />Patroni</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/postgresql-automatic-failover"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />PostgreSQL Automatic Failover</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/postgres"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />Postgres</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/rest-api"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />REST API</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/replication-manager"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />Replication Manager</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/database"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />database</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/developer"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />developer</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/high-availability"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />high availability</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/postgresql"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />postgresql</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/python"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />python</a></span>, <span class="tag-element"><a rel="tag" href="/blog/tag/sql"> <img title="Tag" alt="Tag" class="inline-icon tag-icon" rel="smalllight" src="/universal/images/transparent.png" />sql</a></span></span>  <span class="posted-in">in <span class="tag-element"><a rel="tag" href="/blog/category/appliction-monitoring"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />Appliction monitoring</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/clustering"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />Clustering</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/devops"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />DevOps</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/failure-analysis"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />Failure Analysis</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/geo-distributed-clusters"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />Geo-distributed Clusters</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/performance"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />Performance</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/postgres"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />Postgres</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/python"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />Python</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/administrator"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />administrator</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/best-platform"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />best platform</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/cloud"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />cloud</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/cluster"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />cluster</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/database-replication"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />database replication</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/deployment"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />deployment</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/enterprise-architecture"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />enterprise architecture</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/framework"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />framework</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/high-availability"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />high availability</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/infrastructure"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />infrastructure</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/master-slave"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />master-slave</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/open-source"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />open source</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/postgresql"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />postgresql</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/sql"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />sql</a></span>, <span class="tag-element"><a rel="tag" href="/blog/category/tutorial"> <img title="Category" alt="Category" class="inline-icon category-icon" rel="smalllight" src="/universal/images/transparent.png" />tutorial</a></span></span>  <span class="post-snippet-1"><iframe src="//www.facebook.com/plugins/like.php?href=http://highscalability.com/blog/2019/9/16/managing-high-availability-in-postgresql-part-iii-patroni.html&layout=standard&show_faces=true&width=450&action=like&colorscheme=light&height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe></span> <span class="post-snippet-2"><a href="//twitter.com/share" class="twitter-share-button" data-url="http://highscalability.com/blog/2019/9/16/managing-high-availability-in-postgresql-part-iii-patroni.html" data-text="Managing High Availability in PostgreSQL – Part III:&nbsp;Patroni" data-count="horizontal">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></span> </div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

  

  

  
    <div class="journal-comment-area-wrapper">
    <div id="comments" class="journal-comment-area">

      <h3 class="caption">Reader Comments </h3>

      
        
          <div class="text">There are no comments for this journal entry.  To create a new comment, use the form below.</div>

        

      

    </div>
    </div>

    
      <div class="journal-add-comment-area-wrapper">
  
          
            
            
  <script type="text/javascript">
  // <![CDATA[

    var isAddCommentsVisible = true;

    function toggleReferenceMode() {
      if (isAddCommentsVisible) {
        hideObject(document.getElementById("add-comment-area"));
        showObject(document.getElementById("add-reference-area"));
      } else {
        showObject(document.getElementById("add-comment-area"));
        hideObject(document.getElementById("add-reference-area"));
      }
      isAddCommentsVisible = !isAddCommentsVisible;
    }

    E.addListener("postform", "keydown", Squarespace.SessionAuthorizationKey.acquireAuthKey, '');

  // ]]>
  </script>

  <form method="post" style="margin: 0; padding: 0;" name="postform" id="postform" action="/process/CreateJournalEntryComment?moduleId=4867632&amp;entryId=36212513"> 

    
 
    <div class="notice-box" style="margin-top: 2em;" id="add-comment-area">

      
                              <h3 class="caption"><img title="Post" alt="Post" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/comment.png) top left no-repeat;"/>Post a New Comment</h3>
          
        

        <div class="caption-text">

          Enter your information below to add a new comment.

          

        </div>

        

        <script type="text/javascript" src="/universal/scripts/storable-fields.js?CE=75"></script>

        
          <div class="input-field">
            
            <div id="authorName_title" class="title">
               Author: 

              &nbsp;<a id="storedFieldControls" style="display: none; font-size: 9px;" href="javascript:forgetSavedFields();">(forget stored information)</a>
            </div>
            <input class="text" type="text" style="width: 200px;" name="authorName" id="authorName" value="" maxlength="50" tabindex="2"/>
          </div>

          <div class="input-field">
            
            <div id="authorEmail_title" class="title"> Author Email (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorEmail" id="authorEmail" value="" maxlength="255" tabindex="3"/>
          </div>

          <div class="input-field">
            
            <div id="authorUrl_title" class="title"> Author URL (optional): 
</div>
            <input class="text" type="text" style="width: 200px;" name="authorUrl" id="authorUrl" value="" maxlength="255" tabindex="4"/>
          </div>

          <script type="text/javascript">

            YAHOO.util.Event.addListener(window, "load", function() {

              document.getElementById("storedFieldControls").style.display = (Squarespace.StorableFields.isDataSaved("authorName", "authorEmail", "authorUrl") ? "inline" : "none");
              Squarespace.StorableFields.recall("authorName", "authorEmail", "authorUrl");

            });

            function forgetSavedFields() {

              Squarespace.StorableFields.forget("authorName", "authorEmail", "authorUrl");
              document.getElementById("storedFieldControls").style.display = "none";

            }

          </script>

        

        <script type="text/javascript">
          function expandBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight + 40) + "px"; }
          function shrinkBody() { b = document.getElementById("body"); b.style.height = (b.offsetHeight - 40) + "px"; }
        </script>

        
        <div id="body_title" style="padding-bottom: 5px; float: left;"> Post: 
</div>
        <div style="padding-bottom: 5px; float: right;"><a title="Increase the size of the comment area." href="javascript:expandBody();">&#8595;</a> | <a title="Decrease the size of the comment area." href="javascript:shrinkBody();">&#8593;</a></div>
        <div class="clearer">&nbsp;</div>
        <div style="padding-bottom: 5px;"><textarea rows="15" cols="60" name="body" id="body" tabindex="5"></textarea></div>
        <div style="padding-bottom: 5px;">Some HTML allowed: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;code&gt; &lt;em&gt; &lt;i&gt; &lt;strike&gt; &lt;strong&gt;</div>

        

        

        <div class="footer">

                      <div class="notice-box-alert">
              <div class="icon"><img title="Alert" alt="Alert" class="inline-icon" rel="smalllight" src="/universal/images/transparent.png" style="background:transparent url(/universal/images/core-resources/icons/smalllight/alert.png) top left no-repeat;"/></div>
              <div class="text">
                <strong>Comment Moderation Enabled</strong><br/>
                Your comment will not appear until it has been cleared by a website editor.
              </div>
            </div>
          

                    
            <p style="padding-bottom: 10px;"><input class="checkbox" type="checkbox" name="followOptIn" id="followOptIn" value="true"  tabindex="6"/>
              <span onclick="toggleNotify()" style="cursor: pointer; cursor: hand">Notify me of follow-up comments via email.</span>
            </p>
            <br/>

          

          <input type="hidden" id="authKey" name="authKey" value=""/>
          <input style="width: 150px;" tabindex="6" class="button" type="button" name="createPostButton"  id="createPostButton"  value="Create Post"  onclick="submitContent(true);"/> &nbsp;&nbsp;
          <input style="width: 150px;" tabindex="7" class="button" type="button" name="previewPostButton" id="previewPostButton" value="Preview Post" onclick="submitContent(false);"/>

        </div>

      

    </div>

  </form>

  <script type="text/javascript">
  // <![CDATA[

    function toggleNotify() {
      document.getElementById("followOptIn").click();
    }
              
    function submitContent(isFinal) {
      if (isFinal) {
        document.getElementById("postform").action += "&finalize=true";
        Squarespace.StorableFields.save("authorName", "authorEmail", "authorUrl");
      }
      Squarespace.Form.smartSubmit("postform");
    }

  // ]]>
  </script>

  


  
            
  
          
  
        
  
      </div>
        
    
  
  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              Copyright &copy; 2018, Todd Hoff.  All rights reserved.
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>